Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Emerge - nie da się instalować
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
calif
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2009
Posts: 101

PostPosted: Fri Jun 11, 2010 9:07 am    Post subject: [SOLVED] Emerge - nie da się instalować Reply with quote

Witam!

Pilnie potrzebuję pomocy.

Aktualizowałem programy, potem usunąłem zależności (polecenie: emerge --depclean), chciałem za pomocą polecenia "revdep-rebuild
" przebudować zależności (etc.), okazało się, że nie mam tego programu, zabieram się więc za intalację gentoolkit, włączam instalacje (do zainstalowania 2 programy). Przy emergowaniu 1 wyskakuje błąd (po czym przerywa się działanie emerge):
Code:
 * ERROR: app-misc/realpath-1.15 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line  54:  Called src_compile
 *   environment, line 2248:  Called die
 * The specific snippet of code:
 *       emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =app-misc/realpath-1.15',
 * the complete build log and the output of 'emerge -pqv =app-misc/realpath-1.15'.
 * The complete build log is located at '/var/tmp/portage/app-misc/realpath-1.15/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/realpath-1.15/temp/environment'.
 * S: '/var/tmp/portage/app-misc/realpath-1.15/work/realpath-1.15'

>>> Failed to emerge app-misc/realpath-1.15, Log file:

>>>  '/var/tmp/portage/app-misc/realpath-1.15/temp/build.log'

 * Messages for package app-misc/realpath-1.15:

 * ERROR: app-misc/realpath-1.15 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line  54:  Called src_compile
 *   environment, line 2248:  Called die
 * The specific snippet of code:
 *       emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =app-misc/realpath-1.15',
 * the complete build log and the output of 'emerge -pqv =app-misc/realpath-1.15'.
 * The complete build log is located at '/var/tmp/portage/app-misc/realpath-1.15/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/realpath-1.15/temp/environment'.
 * S: '/var/tmp/portage/app-misc/realpath-1.15/work/realpath-1.15'


Robi się tak przy każdym programie który chcę zainstalować.

Co robić?
Pomocy.

PS.
Zauważyłem, że jak wpisuję emerge --info, wyskakuje:

Emerge --info:
Code:

home calif # emerge --info
!!! No gcc found. You probably need to 'source /etc/profile'
!!! to update the environment of this terminal and possibly
!!! other terminals also.
Portage 2.1.8.3 (default/linux/x86/10.0/desktop, [unavailable], glibc-2.10.1-r1, 2.6.32-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.32-gentoo-r7-i686-Intel-R-_Atom-TM-_CPU_N270_@_1.60GHz-with-gentoo-1.12.13
Timestamp of tree: Sun, 06 Jun 2010 13:00:01 +0000
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.4-r1, 3.1.2-r3
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.2, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.vectranet.pl/gentoo/ "
LANG="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm hal iconv ipv6 jpeg kde lcms ldap libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3 qt3support qt4 readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Zrobiłem source /etc/profile i env-update ale nadal pokazuje, że nie ma gcc..

Może to przez update gcc?
Code:

home calif # gcc
gcc-config: error: could not run/locate 'gcc'


Code:
home calif # gcc-config -l
 * gcc-config: Active gcc profile is invalid!
 [1] i686-pc-linux-gnu-4.4.3



Problem rozwiązany -
Code:
http://www.gentoo.org/doc/pl/gcc-upgrading.xml
Back to top
View user's profile Send private message
canis_lupus
l33t
l33t


Joined: 22 Dec 2005
Posts: 769
Location: Kraków

PostPosted: Sat Jun 12, 2010 8:21 am    Post subject: Reply with quote

Miałem to samo - moje szczescie ze miałem 2 kompy i z jednego gcc przeniosłem na drugiego. Odpalenie z livecd nic Ci nie da. Jesli chcesz paczkę z gcc na x86 to masz linka: http://lupus.ap.krakow.pl/~lupus/gcc-4.3.4.tbz2

Trzeba to umiescic w /usr/portage/packages/sys-devel/
potem emerge -K =gcc-4.3.4


Cos chyba namieszali w portage. Nawet sie zastanawiałem czy nie napisac posta ostrzegawczego, ale stwierdziłem że to pewnie ja mam cos namieszane w systemie. Gentoo schodzi na psy.
_________________
"I love you cię" Różyczko...
Back to top
View user's profile Send private message
unK
l33t
l33t


Joined: 06 Feb 2007
Posts: 768

PostPosted: Sat Jun 12, 2010 10:26 am    Post subject: Reply with quote

Zdaje się, że on po prostu nie miał żadnego profilu gcc wybranego.
_________________
ncmpcpp - featureful ncurses based MPD client inspired by ncmpc
Back to top
View user's profile Send private message
dziadu
Guru
Guru


Joined: 04 May 2006
Posts: 448
Location: Kraków/Darmstadt/Munich

PostPosted: Sat Jun 12, 2010 11:41 am    Post subject: Reply with quote

canius_lupus, trochę za bardzo straszysz. unK ma rację, też to miałem gdy zrobiłem z 4.4.3 na 4.4.4. Najpierw:
Code:
# gcc-config -l

a kiedy pokaże się lista profili (najprawdopodobniej żaden nie będzie zaznaczony), trzeba wybrać odpowiedni profil, np u mnie jest tak:
Code:
# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.4.4
# gcc-config 1
 * Switching native-compiler to x86_64-pc-linux-gnu-4.4.4 ...                                            [ ok ]

Powinno zadziałać.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum