Joined: 12 May 2004
|Posted: Tue Jun 01, 2010 7:26 pm Post subject: [ GLSA 201006-04 ] xine-lib: User-assisted execution of arbi
|Gentoo Linux Security Advisory
Title: xine-lib: User-assisted execution of arbitrary code (GLSA 201006-04)
Date: June 01, 2010
Bug(s): #234777, #249041, #260069, #265250
Multiple vulnerabilities in xine-lib might result in the remote execution
of arbitrary code.
xine-lib is the core library package for the xine media player, and
other players such as Amarok, Codeine/Dragon Player and Kaffeine.
Vulnerable: < 188.8.131.52
Unaffected: >= 184.108.40.206
Architectures: All supported architectures
Multiple vulnerabilities have been reported in xine-lib. Please review
the CVE identifiers referenced below for details.
A remote attacker could entice a user to play a specially crafted video
file or stream with a player using xine-lib, potentially resulting in
the execution of arbitrary code with the privileges of the user running
There is no known workaround at this time.
All xine-lib users should upgrade to an unaffected version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/xine-lib-220.127.116.11"
NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since April 10, 2009. It is likely that your system is
already no longer affected by this issue.
Last edited by GLSA on Sat Jul 27, 2013 4:29 am; edited 3 times in total
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum