Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wired wpa_supplicant
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
baley
n00b
n00b


Joined: 05 Sep 2006
Posts: 42
Location: Udine

PostPosted: Thu May 27, 2010 12:18 pm    Post subject: wired wpa_supplicant Reply with quote

Ciao a tutti,
devo collegare il mio portatile ad una rete lan che richiede l'autorizzazione.
Quello che dice di fare l'amministratore e' creare il seguente file di configurazione per wpa_supplicant:
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=0

network={
                 key_mgmt=IEEE8021X
                 eap=PEAP
                 phase2="auth=MSCHAPV2"
                 identity="nomeutente"
                 password="la password"
                 eapol_flags=0
}

dopodiche' dice di lanciare wpa_supplicant:
Code:

wpa_supplicant -c/etc/file_di_conf -i eth0 -D wired -B

poi tramite wpa_cli verificare che ci sia scritto "wpa_state=ASSOCIATED" e infine lanciare:
Code:

ifup eth0


Ora vi spiego cosa succede a me. Una volta lanciato wpa_supplicant lancio status dentro wpa_cli
e mi viene effettivamente la dicitura "wpa_state=ASSOCIATED". Dopo un po' pero' mi compare
la scritta:
Code:

CTRL-EVENT-EAP-FAILURE EAP authentication failed

ma dalla guida dell'amministratore sembrerebbe che la cosa importante sia la presenza
di "wpa_state=ASSOCIATED". Il secondo problema e' che in gentoo non c'e' il comando ifup (che
comunque penso sia analogo a ifconfig eth0 up).

A questo punto non so che fare. Dove sto sbagliando? Dovrei forse lanciare dhcpcd prima di
wpa_supplicant in modo da avere un ip o non e' necessario? (ho comunque provato a lanciarlo prima
ma l'errore e' lo stesso).
Bisogna aggiungere qualche opzione al kernel quando si usa un'autorizzazione MSCHAPV2?
O e' tutto corretto ed effettivamente il sistema non riconosce il mio username e password? (anche se
mi suona strano).

Grazie e perdonatemi se ho scritto delle idiozie...
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu May 27, 2010 7:09 pm    Post subject: Reply with quote

qui un tizio consiglia di settare ap_scan=2.
buona fortuna.

tempo fa ho avuto un problema di natura diversa, ma con sintomi analoghi (sembrava connesso ma non andava).
ho trovato l'errore nei log di sistema anziché dai monitor dei tool per il wireless.
nel mio caso, ho capito da internet che dovevo passare al kernerl 2.6.33 .
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Thu May 27, 2010 7:41 pm    Post subject: Reply with quote

ifup eth0 in realtà non equivale solo a ifconfig eth0 up, ma dipende da come sia stata configurata l'interfaccia sulla distro (debian-based).
Nel caso generale equivale a ifconfig eth0 up; dhcpcd eth0
Back to top
View user's profile Send private message
baley
n00b
n00b


Joined: 05 Sep 2006
Posts: 42
Location: Udine

PostPosted: Fri May 28, 2010 7:34 am    Post subject: Reply with quote

In questo momento non ho la rete sotto mano. Appena ho l'occasione provo
con ap=scan=2 e se non dovesse funzionare con il kernel 2.6.33.
Speriamo bene...

Grazie per gli aiuti.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat May 29, 2010 10:28 am    Post subject: Reply with quote

anch'io ultimamente ho avuto problemi con l'autenticazione ad una rete con mschapv2, e ho risolto creando questo file di configurazione:
Code:
ap_scan=1
ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="xxx"
        scan_ssid=0
        key_mgmt=WPA-EAP
        eap=PEAP
        identity="******"
        password="*****"
        phase1="peaplabel=2"
        phase2="auth=MSCHAPV2"
}


una volta autenticato è bastato chiedere l'indirizzo ip con dhcpcd e tutto è andato a posto...

Vedi un po se ti può tornare utile..
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum