Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Webcam] Ne marche pas alors que pourtant ça devrait
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Damiatux
Apprentice
Apprentice


Joined: 23 Feb 2008
Posts: 194

PostPosted: Wed May 26, 2010 3:28 pm    Post subject: [Webcam] Ne marche pas alors que pourtant ça devrait Reply with quote

Plop,

Sur un PC portable (un Toshiba), j'ai une webcam de marque Chicony Electronics. J'ai suivis cette page et celle là pour installer les composants du kernel de la partie Device Drivers, Multimedia Devices. J'ai aussi installé media-plugins/gst-plugins-v4l2 sur ce même PC. Je redémarre le PC, je me dis c'est bon, ça va marcher ; eh ben non. Cheese ne reconnaît toujours pas la webcam... Pourquoi ?

Merci d'avance,
Damiatux
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Fri May 28, 2010 2:56 pm    Post subject: Reply with quote

Est-ce que tu aurais pas une combinaison de touches qui puisse la désactiver ? (Sur mon lenovo c'est Fn + Esc, mais je ne pense pas que ce soit la même sur les Toshiba) C'est assez con, mais j'ai cherché pendant 2 jours pourquoi la mienne ne fonctionnait pas, c'était ça.
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Fri May 28, 2010 6:43 pm    Post subject: Reply with quote

hello,

j'utilise ça comme webcam

Code:
046d:08ad Logitech, Inc. QuickCam Communicate STX


bien qu'elle ne fonctionne pas dans cheese, elle fonctionne parfaitement dans les autres applications ex: aMsn Skype Ekiga

tu as essayé dans une autre appli?
Back to top
View user's profile Send private message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Sat May 29, 2010 7:19 am    Post subject: Reply with quote

Arrives-tu à prendre des photos avec cheese, mais pas de videos ? Ou n'est-elle pas du tout détectée ?

Pour ma part, il me manquait media-plugins/gst-plugins-alsa pour pouvoir activer la webcam en vidéo (autrement cheese plantait).
Back to top
View user's profile Send private message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 863
Location: Switzerland

PostPosted: Sat May 29, 2010 8:12 am    Post subject: Reply with quote

tente de l'utiliser directement avec gstreamer

Code:
gst-launch-0.10 v4l2src ! autovideosink

ceci devrait t'activer la webcam et t'afficher une fenêtre avec ta petite frimousse.

Voici la liste des paquets que tu aurais besoin avec gstreamer pour que ça fonctionne.

Quote:
gstreamer gst-plugins-base gst-plugins-good gst-plugins-v4l2 gst-plugins-ffmpeg


Bonne chance
_________________
Macbook Pro Unibody 9.1 - Kernel 4.4.6 - Awesome 3.5
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum