Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[polices]lettres manquantes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue May 25, 2010 11:57 am    Post subject: [polices]lettres manquantes Reply with quote

Bonjour à tous,

Il m'arrive un drôle de problème que je ne sais pas comment résoudre. Certaines lettres apparaissent sous la forme d'un carré, pourtant les polices sont installées (en tout cas je pense). Mes quelques recherches n'ont pas beaucoup aidé... J'ai suivi le tuto pour passer en UTF-8 mais j'ai toujours des problèmes. Je ne vois pas ce qui manque... Les lettres manquantes semblent aléatoires. Aujourd'hui, il manque les "S" majuscules dans les barres de titre des fenêtres et les "a" minuscules dans la lecture des mails (Seamonkey) et dans Skype, mais ça semble varier selon les jours... Le pages web et l'écriture de mails sous Semonkey affichent toutes les lettres. Je ne sais vraiment pas dans quelle direction chercher. Au cas où, voici un emerge --info :

Code:
Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11.1-r0, 2.6.34-gentoo x86_64)
=================================================================
System uname: Linux-2.6.34-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.0.1
Timestamp of tree: Mon, 24 May 2010 11:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=5.0 --with-bdeps y"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/ rsync://de-mirror.org/gentoo/"
LANG="fr_FR.UTF8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr fr_FR"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync3.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa amd64 amr bash-completion berkdb bluetooth bzip2 cdda cdr cleartype cli consolekit corefonts cracklib crypt css cups cxx dbus djvu dri dvd dvdr encode ffmpeg fortran ftp gdbm gif gphoto2 gpm hal handbook iconv imap ipv6 jack java jpeg lcms mad mime mmx mng modules mozilla mp3 mpeg msn mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ogg opencore-amr opengl openmp pam pcre pdf perl php png pppd python readline reflection session smp source speex spell spl sql sse sse2 ssl svg symlink sysfs tcpd tiff truetype type1 unicode usb v4l v4l2 vcd videos webkit wifi xcomposite xorg xscreensaver xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" RUBY_TARGETS="ruby18" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Et mon world :
Code:
kevin@KevinPC ~ $ cat /var/lib/portage/world
app-admin/conky
app-admin/logrotate
app-admin/sudo
app-admin/syslog-ng
app-arch/xarchiver
app-cdr/xfburn
app-emulation/wine
app-office/openoffice
app-portage/eix
app-portage/gentoolkit
app-portage/layman
app-text/epdfview
dev-python/dbus-python
dev-util/ccache
dev-util/lafilefixer
lxde-base/lxappearance
media-fonts/corefonts
media-fonts/cronyx-fonts
media-fonts/font-xfree86-type1
media-fonts/freefonts
media-fonts/intlfonts
media-fonts/terminus-font
media-gfx/gimp
media-gfx/mirage
media-gfx/xsane
media-libs/libv4l
media-plugins/gmpc-discogs
media-plugins/gmpc-libnotify
media-plugins/gmpc-lyricwiki
media-plugins/gmpc-mdcover
media-sound/alsa-utils
media-sound/easytag
media-sound/gmpc
media-sound/mpd
media-video/mplayer
media-video/smplayer
media-video/vlc
net-firewall/iptables
net-im/amsn
net-im/skype
net-misc/dhcpcd
net-p2p/rtorrent
net-print/cnijfilter
net-wireless/bluez-utils
net-wireless/rt73-firmware
net-wireless/wpa_supplicant
sys-apps/dbus
sys-apps/lm_sensors
sys-apps/slocate
sys-block/gparted
sys-boot/grub
sys-fs/ntfs3g
sys-kernel/gentoo-sources
sys-libs/gpm
www-client/seamonkey
www-plugins/adobe-flash
x11-apps/mesa-progs
x11-base/xorg-server
x11-drivers/radeon-ucode
x11-misc/cairo-dock
x11-misc/cairo-dock-plugins
x11-misc/gmrun
x11-misc/nitrogen
x11-misc/obconf
x11-misc/obmenu
x11-misc/slim
x11-misc/xcompmgr
x11-terms/guake
x11-terms/rxvt-unicode
x11-themes/amsn-skins
x11-themes/slim-themes
x11-wm/openbox
xfce-base/thunar
xfce-extra/thunar-thumbnailers
xfce-extra/thunar-volman


J'espère que vous aurez une solution à me proposer...
Merci d'avance,

Kevin57
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Tue May 25, 2010 4:19 pm    Post subject: Reply with quote

salut,

eselect fontconfig list ça donne quoi?
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue May 25, 2010 5:58 pm    Post subject: Reply with quote

Désolé, j'avais oublié cette commande. Voici ce qu'elle donne :

Code:
kevin@KevinPC ~ $ eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-dejavu-sans.conf *
  [10]  20-unhint-small-dejavu-sans-mono.conf *
  [11]  20-unhint-small-dejavu-serif.conf *
  [12]  20-unhint-small-vera.conf *
  [13]  25-unhint-nonlatin.conf
  [14]  30-metric-aliases.conf *
  [15]  30-urw-aliases.conf *
  [16]  40-nonlatin.conf *
  [17]  45-latin.conf *
  [18]  49-sansserif.conf *
  [19]  50-user.conf *
  [20]  51-local.conf *
  [21]  57-dejavu-sans.conf *
  [22]  57-dejavu-sans-mono.conf *
  [23]  57-dejavu-serif.conf *
  [24]  60-latin.conf *
  [25]  60-liberation.conf *
  [26]  65-fonts-persian.conf *
  [27]  65-khmer.conf
  [28]  65-nonlatin.conf *
  [29]  69-unifont.conf *
  [30]  70-no-bitmaps.conf
  [31]  70-yes-bitmaps.conf
  [32]  80-delicious.conf *
  [33]  90-synthetic.conf *

_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Tue May 25, 2010 6:05 pm    Post subject: Reply with quote

Ben juste pour voir : sélectionne les toutes. On verra si le problème vient de là ou est plus profond. Et regarde dans Xorg.0.log si y a pas des petites erreurs en rapport avec ça.
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue May 25, 2010 6:40 pm    Post subject: Reply with quote

Alors, ça semble avoir résolu le problème de lettres manquantes (je peux pas tester en rebootant, j'ai un backup en cours), mais en tuant et relançant Seamonkey et Skype, ils ne semblent plus affectés par ce problème. Par contre, les polices de Seamonkey me semblent bien floues...

Edit : et Xorg donne les erreurs suivantes :

Code:
(WW) The directory "/usr/share/fonts/misc" does not exist
(WW) The directory "/usr/share/fonts/TTF" does not exist
(WW) The directory "/usr/share/fonts/OTF" does not exist
(WW) The directory "/usr/share/fonts/100dpi" does not exist
(WW) The directory "/usr/share/fonts/75dpi" does not exist

_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Tue May 25, 2010 7:21 pm    Post subject: Reply with quote

Ok, alors c'est des warnings, des alertes, donc normalement c'est pas trop grave. Sinon tu peux tjrs intaller media-fonts/font-adobe-75dpi et media-fonts/font-adobe-100dpi. Mais c'est pas génant, chez moi c'est pas installé et sa marche comme il faut. Sinon tu as bien installé toutes les polices pour l'UTF-8 comme indiqué dans le guide (si c'est bien lui que tu as suivi ... :oops: )
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue May 25, 2010 7:28 pm    Post subject: Reply with quote

Je viens de vérifier, j'ai bien installé toutes les polices indiquées dans le guide francophone de passage à l'UTF-8.
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Tue May 25, 2010 7:36 pm    Post subject: Reply with quote

Ok ... A vrai dire je sais pas trop. Si tu peux redémarre le serveur X et vois ce que ça donne, il devrais plus y avoir de problème.
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue May 25, 2010 7:38 pm    Post subject: Reply with quote

Je ne peux pas redémarrer X, j'ai un backup en cours sur un terminal lancé dans X... Mais le problème a changé, toutes les lettres apparaissent mais celles de Seamonkey semblent trop lissées, assez floues.
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Tue May 25, 2010 7:43 pm    Post subject: Reply with quote

Ouao ... ben le problème doit venir de SeaMonkey alors. Essaye de voir dans les préférences si tu peux pas changer la police.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum