Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Intel Pro/Wireless 5100 AGN keeps dropping connections
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
blamothe
Apprentice
Apprentice


Joined: 31 Jan 2003
Posts: 231
Location: Cambridge Mass

PostPosted: Thu May 20, 2010 11:01 am    Post subject: Intel Pro/Wireless 5100 AGN keeps dropping connections Reply with quote

my wireless connection keeps dropping out. it still has an ip address registered and is still connected to the access point, but i can't ping anything and cannot connect to any websites. when i boot up my machine, wireless works fine, but after a few minutes it drops out. i do net.wlan0 stop and net.wlan0 start, it works again for a few minutes, and then drops out again. is there anything i can do to fix this?
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1404
Location: Montréal

PostPosted: Thu May 20, 2010 11:48 am    Post subject: Reply with quote

I have been using for years free wireless access points in my city Montréal. A lot where open, some where secure with WEP or WPA. I noted sometimes I had to give the channel of the wireless access point I wanted to connect to my wireless card for it to get the connection. You can use the AP address of wireless access point instead of it's ESSID to associate with it. When I had trouble with the native Linux kernel driver, first I looked with modinfo if I can pass a usefull option to the wireless card module. Then I compared the performance of the Linux kernel driver with the Windows one using the ndiswrapper. Sometimes the Windows one where betters. I think it's better to configure manually a wireless card then use a boot script to do it, specially to make the connexion stable.

Generally, it's a matter of quality link. Under a certain purcentage, let's say 3/5 it become unstable. A close distance between your wireless card and the access point router wireless card can make a big difference. The quality of the link can be disturb with microwaves and cellulars phones. This is not exhaustive. The problem can come from both sides, Gentoo disconnect you, or the other side, I say the access point. If the DNS server address you've got from it are not stable, you've better to use named or openDNS free DNS server.
_________________
Paul
Back to top
View user's profile Send private message
blamothe
Apprentice
Apprentice


Joined: 31 Jan 2003
Posts: 231
Location: Cambridge Mass

PostPosted: Thu May 20, 2010 9:07 pm    Post subject: Reply with quote

it definitely isn't that. iwconfig says that i'm still connected to the ap, ifconfig still says that i have an ip address, but i can't ping anything, and i can't visit any web pages, use ssh, etc. the only way i know to fix it is to stop and restart net.wlan0 like this:
Code:


shameka blamothe # /etc/init.d/net.wlan0 stop
 * Stopping wlan0
 *   Bringing down wlan0
 *     Stopping dhcpcd on wlan0 ...                                                                      [ ok ]
 *     Shutting down wlan0 ...                                                                           [ ok ]
 *     Stopping wpa_cli on wlan0 ...                                                                     [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                                                              [ ok ]
shameka blamothe # /etc/init.d/net.wlan0 start
 * Starting wlan0
SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
 *   Starting wpa_supplicant on wlan0 ...                                                            [ ok ]
 *   Starting wpa_cli on wlan0 ...                                                                       [ ok ]
 *     Backgrounding ...
shameka blamothe #


i also don't know what that SIOCSIFFLAGS: Unknown error 132 means. could that have something to do with the problem? i don't think it's an issue with the machine being out of range because it always works when i restart, but it dies after a few minutes.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu May 20, 2010 9:09 pm    Post subject: Reply with quote

Hi, can you post this :

Code:

# cd /usr/src/linux
# cat .config | grep -i kill
Back to top
View user's profile Send private message
blamothe
Apprentice
Apprentice


Joined: 31 Jan 2003
Posts: 231
Location: Cambridge Mass

PostPosted: Fri May 21, 2010 10:39 am    Post subject: Reply with quote

this is what i got:
Code:

shameka linux # cat .config | grep -i kill
CONFIG_RFKILL=y
CONFIG_RFKILL_LEDS=y
CONFIG_RFKILL_INPUT=y

i disabled RFKILL and did the grep again and got:
Code:

# CONFIG_RFKILL is not set

on reboot, the thing still drops off after a few minutes, so i don't think that fixed it.
Back to top
View user's profile Send private message
FelixPetzold
n00b
n00b


Joined: 10 May 2010
Posts: 24
Location: Paderborn/Germany

PostPosted: Fri May 21, 2010 11:04 am    Post subject: Reply with quote

which version of iwl5000-ucode are you running? I have a stable system and the stable version works fine with my Intel 5100 AGN card
Back to top
View user's profile Send private message
blamothe
Apprentice
Apprentice


Joined: 31 Jan 2003
Posts: 231
Location: Cambridge Mass

PostPosted: Sat May 22, 2010 12:15 pm    Post subject: Reply with quote

actually, d2_racing, i think your suggestion worked. when i first rebooted the computer after disabling RFKILL, the connection dropped off like it did before. i restarted net.wlan0 and, since then, i have not had a lost connection. thanks a lot.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun May 23, 2010 1:23 am    Post subject: Reply with quote

Nice :P
Back to top
View user's profile Send private message
blamothe
Apprentice
Apprentice


Joined: 31 Jan 2003
Posts: 231
Location: Cambridge Mass

PostPosted: Mon Jun 07, 2010 7:32 pm    Post subject: Reply with quote

well, maybe i spoke too soon. i did not see any dropped connections for a while (about 2-3 days). i then tried to install and use cisco's vpn client so that i can connect to our colo from home. when i tried to start the vpn client, it continuously freezes my machine. i've (temporarily) given up on getting the vpn to work, but now i get consistent dropped connections. the vpn client's install script did need to know where my kernel sources were installed, but RFKILL is still disabled. i'm not sure if the vpn client stuff is a coincidence or not, but it seemed to be going strong before i did the vpn stuff, and now it isn't. has anyone else ever seen this?
Back to top
View user's profile Send private message
blamothe
Apprentice
Apprentice


Joined: 31 Jan 2003
Posts: 231
Location: Cambridge Mass

PostPosted: Thu Jun 10, 2010 7:19 pm    Post subject: Reply with quote

after an immense amount of googling, i've found that the issue is with the iwlagn driver, namely, the 802.11n code. after disabling 802.11n from the module, i don't seem to have a problem any more.
Code:
rmmod iwlagn
modprobe iwlagn 11n_disable50=1 11n_disable=1
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Jun 11, 2010 1:08 am    Post subject: Reply with quote

Nice :P
Back to top
View user's profile Send private message
cach0rr0
Bodhisattva
Bodhisattva


Joined: 13 Nov 2008
Posts: 4123
Location: Houston, Republic of Texas

PostPosted: Fri Jun 11, 2010 4:52 am    Post subject: Reply with quote

blamothe wrote:
after an immense amount of googling, i've found that the issue is with the iwlagn driver, namely, the 802.11n code. after disabling 802.11n from the module, i don't seem to have a problem any more.
Code:
rmmod iwlagn
modprobe iwlagn 11n_disable50=1 11n_disable=1


You happen to have the relevant link handy still?

I've had the same on my Atheros card for months, and have long suspected the issue goes deeper than the driver itself, but rather something buggered in the 80211 stack.
Whenever it connected to 802.11n networks, it would disconnect under load.
Whenever connected to 802.11g, no issues (though, the pipe itself was too small to really load it)
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Jun 11, 2010 10:50 am    Post subject: Reply with quote

Yeah, I would like to know the link too, because that one is pretty nasty.
Back to top
View user's profile Send private message
cach0rr0
Bodhisattva
Bodhisattva


Joined: 13 Nov 2008
Posts: 4123
Location: Houston, Republic of Texas

PostPosted: Fri Jun 11, 2010 7:51 pm    Post subject: Reply with quote

d2_racing wrote:
Yeah, I would like to know the link too, because that one is pretty nasty.


dunno, I did some extended reading on this last night, and a load of ath9k users are having this problem
however over on the Arch forums they said it was resolved for them with the latest compat-wireless (this was late April, so the latest at that time)

There's an ebuild for compat-wireless in the Pentoo overlay, so no need to try patching by hand. All sorts of other goodies in that overlay too ;)

Code:

layman -a pentoo


Those guys do some solid work, worth adding for sure.
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum