Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] CUPS non stampa:"pstoraster failed"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Tue Jun 15, 2010 9:27 am    Post subject: [RISOLTO] CUPS non stampa:"pstoraster failed" Reply with quote

Ho cercato molto su internet nonché su questo forum ma ancora non ho risolto. Fino a pochi giorni fa tutto funzionava alla meraviglia. Il non funzionamento si è verificato dopo alcuni aggiornamenti (kde-4.4.4, cambio di profilo e, forse, altro che non ricordo :( )

Questi sono, credo, i pacchetti responsabili del problema
Code:

[ebuild   R   ] net-print/cups-1.3.11-r1  USE="X acl dbus java jpeg ldap pam perl png ppds python ssl tiff -avahi -gnutls -kerberos -php -samba -slp -static -xinetd -zeroconf" LINGUAS="it -de -en -es -et -fr -he -id -ja -pl -sv -zh_TW" 0 kB                                                                           
[ebuild   R   ] app-text/ghostscript-gpl-8.71-r1  USE="X cairo cups djvu -bindist -gtk -jpeg2k" LINGUAS="-ja -ko -zh_CN -zh_TW" 0 kB
[ebuild   R   ] net-print/hplip-3.9.12-r1  USE="X hpcups libnotify qt4 -doc -fax -hpijs -minimal -parport -policykit -scanner -snmp -static-ppds -udev-acl" 0 kB


Queste sono le ultime righe del file /var/log/cups/error-log
Code:
E [15/Jun/2010:11:07:01 +0200] PID 29513 (/usr/libexec/cups/filter/pstoraster) stopped with status 1!
I [15/Jun/2010:11:07:01 +0200] Hint: Try setting the LogLevel to "debug" to find out more.
E [15/Jun/2010:11:07:01 +0200] PID 29514 (/usr/libexec/cups/filter/hpcups) stopped with status 1!
I [15/Jun/2010:11:07:01 +0200] Hint: Try setting the LogLevel to "debug" to find out more.
E [15/Jun/2010:11:07:01 +0200] [Job 355] Job stopped due to filter errors.
I [15/Jun/2010:11:07:01 +0200] Saving subscriptions.conf...
I [15/Jun/2010:11:07:01 +0200] Saving subscriptions.conf...
I [15/Jun/2010:11:07:03 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=29519)


Grazie a chiunque vorrà aiutarmi.

PS La stampante è una HP Deskjet 5550


Last edited by nearthesoul on Wed Jun 16, 2010 12:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Jun 15, 2010 11:55 am    Post subject: Reply with quote

hai già provato ad aggiungere la useflag hpijs ?

se l'aggiornamento è stato consistente (puoi usare genlop per ricostruire i passaggi compiuti), hai provato a lanciare un revdep-rebuild?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Tue Jun 15, 2010 12:40 pm    Post subject: Reply with quote

Ho seguito il tuo consiglio eseguendo il comando:

Code:
USE="hpijs" emerge -Du --newuse world


Purtroppo il problema persiste (nonostante avessi fatto anche vari revdep-rebuild) ma ora il messaggio di errore è "/usr/libexec/cups/filter/foomatic-rip failed"!

Questo è il nuovo log di cups:

Code:

I [15/Jun/2010:14:27:34 +0200] [Job 358] Started filter /usr/libexec/cups/filter/pstops (PID 5301)
I [15/Jun/2010:14:27:34 +0200] [Job 358] Started filter /usr/libexec/cups/filter/foomatic-rip (PID 5302)
I [15/Jun/2010:14:27:34 +0200] [Job 358] Started backend /usr/libexec/cups/backend/hp (PID 5303)
I [15/Jun/2010:14:27:34 +0200] Saving subscriptions.conf...
I [15/Jun/2010:14:27:36 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=5314)
E [15/Jun/2010:14:27:44 +0200] PID 5302 (/usr/libexec/cups/filter/foomatic-rip) stopped with status 3!
I [15/Jun/2010:14:27:44 +0200] Hint: Try setting the LogLevel to "debug" to find out more.
E [15/Jun/2010:14:27:44 +0200] [Job 358] Job stopped due to filter errors.
I [15/Jun/2010:14:27:44 +0200] Saving subscriptions.conf...
I [15/Jun/2010:14:27:44 +0200] Saving subscriptions.conf...
I [15/Jun/2010:14:27:46 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=5315)


La cosa strana è che la stampante non solo è riconosciuta ma riesco anche ad effettuare l'allineamento delle cartucce da hp-systray!

PS Non so usare genlop :(
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Jun 15, 2010 4:42 pm    Post subject: Reply with quote

nearthesoul wrote:

PS Non so usare genlop :(

Code:

 eix genlop
failed to source '/usr/portage/local/layman/make.conf'
[I] app-portage/genlop
...

ai tuoi scopi, lo uso così:
Code:

cloc3@aspi2 ~ $ genlop -l hplip|tail -n 5
     Thu May 13 02:24:19 2010 >>> gnome-extra/gnome-utils-2.28.3
     Thu May 13 02:25:11 2010 >>> net-analyzer/gnome-netstatus-2.28.1
     Thu May 13 06:16:05 2010 >>> sys-fs/udev-154
     Thu May 13 06:17:33 2010 >>> app-emulation/virtualbox-guest-additions-3.1.8-r1

il man per gli altri usi.

tornando al tuo problema, sembra comunque che la use flag abbia giovato (non era ovvio).
d'altra parte, sei in buona compagnia :cry: .

prova anche a fare un backup della cartella /etc/cups e ricrearla.
magari ti trova in automatico un ppd migliore del precedente.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Tue Jun 15, 2010 5:07 pm    Post subject: Reply with quote

Grazie per i consigli ma purtroppo non sono riuscito a risolvere
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Wed Jun 16, 2010 12:39 pm    Post subject: Reply with quote

Con un upgrade a cups-1.4.3 ho risolto ogni problema! Questi sono i programmi e le useflag che attualmente uso:

Code:
[ebuild   R   ] net-print/cups-1.4.3  USE="X acl dbus java jpeg ldap pam perl png python ssl tiff usb -debug -gnutls -kerberos -php -samba -slp -static -xinetd" LINGUAS="it -da -de -es -eu -fi -fr -id -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 0 kB
[ebuild   R   ] app-text/ghostscript-gpl-8.71-r1  USE="X cairo cups djvu -bindist -gtk -jpeg2k" LINGUAS="-ja -ko -zh_CN -zh_TW" 0 kB
[ebuild   R   ] net-print/hplip-3.9.12-r1  USE="X hpcups libnotify qt4 -doc -fax -hpijs -minimal -parport -policykit -scanner -snmp -static-ppds -udev-acl" 0 kB


A quano pare la useflag hpijs non è essenziale ed il problema stava soltanto nella versione precedente che usavo.
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Wed Jun 16, 2010 10:46 pm    Post subject: Reply with quote

Rettifico: il solo upgrade di cups non risolve tutti i problemi. Si deve fare un upgrade anche di hplip (con conseguente upgrade di ghostscript-glp). Attualmente ho questi versioni dei suddetti programmi:

Code:

[ebuild   R   ] net-print/cups-1.4.3  USE="X acl dbus java jpeg ldap pam perl png python ssl tiff usb -debug -gnutls -kerberos -php -samba -slp -static -xinetd" LINGUAS="it -da -de -es -eu -fi -fr -id -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 0 kB
[ebuild   R   ] app-text/ghostscript-gpl-8.71-r4  USE="X cairo cups djvu -bindist -gtk -jpeg2k" LINGUAS="-ja -ko -zh_CN -zh_TW" 0 kB
[ebuild   R   ] net-print/hplip-3.10.5  USE="X hpcups libnotify qt4 -doc -fax -hpijs -minimal -parport -policykit -scanner -snmp -static-ppds -udev-acl" 0 kB


Allo stato attuale tutto sembra tornato funzionante.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum