Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UNSOLVABLE]Xorg (1.7.6/1.8.0) su DELL E6500
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
inc0
n00b
n00b


Joined: 17 May 2010
Posts: 21

PostPosted: Mon May 17, 2010 2:48 pm    Post subject: [UNSOLVABLE]Xorg (1.7.6/1.8.0) su DELL E6500 Reply with quote

Ciao a tutti,

sto cercando di far partire Xorg (ho provato sia la versione 1.7.6 che la 1.8.0) sul portatile in oggetto, un dell E6500 con scheda video Intel GMA 4500 MHD (chipset G45).
Code:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
03:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] Network Connection


Code:

melchior / # emerge --info
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.32-22-generic x86_64)
=================================================================
System uname: Linux-2.6.32-22-generic-x86_64-with-gentoo-1.12.13
Timestamp of tree: Wed, 12 May 2010 19:30:20 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.4-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -msse4 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash_completion berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups curl cxx dbus dri dri2 dts dvd dvdr emboss encode exif fam firefox flac fontconfig fortran gd gdbm gif gnome gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline reflection sdl session smp spell spl sse sse2 sse4_1 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="*" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Qui l'output di lshw: http://pastebin.com/pR2Dx02i
I kernel che ho provato sono il 2.6.32-r7 (gentoo) e il 2.6.33.3 (vanilla) con gli stessi risultati.
.config kernel 2.6.32-r7: http://pastebin.com/zpT92Tpe
.config kernel 2.6.33.3: http://pastebin.com/2jUfWx4H
Ovviamente ho cercato su google, ho chiesto nel canale irc italiano e inglese ma nessuna risposta; prima di chiedere come posso risolvere vi domando: qualcuno di voi è riuscito a far andare Xorg su tale laptop?

Grazie


Last edited by inc0 on Mon Jun 28, 2010 12:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Mon May 17, 2010 2:56 pm    Post subject: Reply with quote

vedo un sacco di informazioni ma non l'errore riportato da xorg...
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon May 17, 2010 3:08 pm    Post subject: Re: Xorg (1.7.6/1.8.0) su DELL E6500 Reply with quote

inc0 wrote:
Ovviamente ho cercato su google, ho chiesto nel canale irc italiano e inglese ma nessuna risposta; prima di chiedere come posso risolvere vi domando: qualcuno di voi è riuscito a far andare Xorg su tale laptop?

Grazie


Ha ragione the extreamer, dovresti pastare il log di X, quindi
Code:
/var/log/Xorg.0.log

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
inc0
n00b
n00b


Joined: 17 May 2010
Posts: 21

PostPosted: Mon May 17, 2010 3:15 pm    Post subject: Reply with quote

Chiedo venia, ma prima di partire con l'epopea chiedevo se qualcuno fosse riuscito a far andare Xorg sul dell E6500 comunque, a grande richiesta, ecco qua:
Code:

cat Xorg.1.log

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-gentoo-r7 x86_64
Current Operating System: Linux localhost 2.6.32-gentoo-r7 #6 SMP PREEMPT Wed May 12 16:23:59 CEST 2010 x86_64
Kernel command line: BOOT_IMAGE=/boot/2.6.32-r7 /dev/sda9 i915.modeset=1
Build Date: 12 May 2010  07:37:17PM
 
Current version of pixman: 0.17.2
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu May 13 11:57:57 2010
(II) Loader magic: 0x7c20a0
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 6.0
   X.Org XInput driver : 7.0
   X.Org Server Extension : 2.0
(++) using VT number 8

(--) PCI:*(0:0:2:0) 8086:2a42:1028:024f Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller rev 7, Mem @ 0xf6c00000/4194304, 0xe0000000/268435456, I/O @ 0x0000ef98/8
(--) PCI: (0:0:2:1) 8086:2a43:1028:024f Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller rev 7, Mem @ 0xf6b00000/1048576
(==) Using default built-in configuration (30 lines)
(==) --- Start of built-in configuration ---
   Section "Device"
      Identifier   "Builtin Default intel Device 0"
      Driver   "intel"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default intel Screen 0"
      Device   "Builtin Default intel Device 0"
   EndSection
   Section "Device"
      Identifier   "Builtin Default vesa Device 0"
      Driver   "vesa"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default vesa Screen 0"
      Device   "Builtin Default vesa Device 0"
   EndSection
   Section "Device"
      Identifier   "Builtin Default fbdev Device 0"
      Driver   "fbdev"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default fbdev Screen 0"
      Device   "Builtin Default fbdev Device 0"
   EndSection
   Section "ServerLayout"
      Identifier   "Builtin Default Layout"
      Screen   "Builtin Default intel Screen 0"
      Screen   "Builtin Default vesa Screen 0"
      Screen   "Builtin Default fbdev Screen 0"
   EndSection
(==) --- End of built-in configuration ---
(==) ServerLayout "Builtin Default Layout"
(**) |-->Screen "Builtin Default intel Screen 0" (0)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default intel Device 0"
(==) No monitor specified for screen "Builtin Default intel Screen 0".
   Using a default monitor configuration.
(**) |-->Screen "Builtin Default vesa Screen 0" (1)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default vesa Device 0"
(==) No monitor specified for screen "Builtin Default vesa Screen 0".
   Using a default monitor configuration.
(**) |-->Screen "Builtin Default fbdev Screen 0" (2)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default fbdev Device 0"
(==) No monitor specified for screen "Builtin Default fbdev Screen 0".
   Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/TTF/" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/OTF" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/Type1/" does not exist.
   Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
   Entry deleted from font path.
   (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
   Entry deleted from font path.
   (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
(==) FontPath set to:
   /usr/share/fonts/misc/
(==) ModulePath set to "/usr/lib64/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
   If no devices become available, reconfigure HAL or disable AutoAddDevices.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.1.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "intel"
(II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 2.9.1
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 2.3.0
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "fbdev"
(II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 0.4.1
   ABI class: X.Org Video Driver, version 6.0
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, Clarkdale, Arrandale
(II) VESA: driver for VESA chipsets: vesa
(II) FBDEV: driver for framebuffer: fbdev
(II) Primary Device is: PCI 00@00:02:0
(WW) Falling back to old probe method for vesa
(WW) Falling back to old probe method for fbdev
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib64/xorg/modules/linux/libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 0.0.2
   ABI class: X.Org Video Driver, version 6.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: drmOpenMinor returns 8
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(II) intel(0): Creating default Display subsection in Screen section
   "Builtin Default intel Screen 0" for depth/fbbpp 24/32
(==) intel(0): Depth 24, (--) framebuffer bpp 32
(==) intel(0): RGB weight 888
(==) intel(0): Default visual is TrueColor
(II) intel(0): Integrated Graphics Chipset: Intel(R) GM45
(--) intel(0): Chipset: "GM45"
(II) intel(0): Output VGA1 has no monitor section
(II) intel(0): Output LVDS1 has no monitor section
(II) intel(0): found backlight control interface /sys/class/backlight/acpi_video0
(II) intel(0): Output HDMI1 has no monitor section
(II) intel(0): Output DP1 has no monitor section
(II) intel(0): Output HDMI2 has no monitor section
(II) intel(0): Output DP2 has no monitor section
(II) intel(0): Output DP3 has no monitor section
(II) intel(0): Output TV1 has no monitor section
(II) intel(0): Output VGA1 disconnected
(II) intel(0): Output LVDS1 connected
(II) intel(0): Output HDMI1 disconnected
(II) intel(0): Output DP1 disconnected
(II) intel(0): Output HDMI2 disconnected
(II) intel(0): Output DP2 disconnected
(II) intel(0): Output DP3 disconnected
(II) intel(0): Output TV1 disconnected
(II) intel(0): Using exact sizes for initial modes
(II) intel(0): Output LVDS1 using initial mode 1440x900
(II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
(==) intel(0): video overlay key set to 0x101fe
(==) intel(0): DPI set to (96, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib64/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) UnloadModule: "vesa"
(II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
(II) UnloadModule: "fbdev"
(II) Unloading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
(II) UnloadModule: "fbdevhw"
(II) Unloading /usr/lib64/xorg/modules/linux/libfbdevhw.so
(==) Depth 24 pixmap format is 32 bpp
(II) intel(0): [DRI2] Setup complete
(**) intel(0): Kernel mode setting active, disabling FBC.
(**) intel(0): Framebuffer compression disabled
(**) intel(0): Tiling enabled
(**) intel(0): SwapBuffers wait enabled
(==) intel(0): VideoRam: 262144 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(II) intel(0): Tiled allocation successful.
(II) UXA(0): Driver registered support for the following operations:
(II)         solid
(II)         copy
(II)         composite (RENDER acceleration)
(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(II) intel(0): No memory allocations
(II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(==) intel(0): DPMS enabled
(==) intel(0): Intel XvMC decoder disabled
(II) intel(0): Set up textured video
(II) intel(0): direct rendering: DRI2 Enabled
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
(II) AIGLX: Loaded and initialized /usr/lib64/dri/i965_dri.so
(II) GLX: Initialized DRI2 GL provider for screen 0
(II) intel(0): Setting screen physical size to 381 x 238
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"
(II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 2.3.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 7.0
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event3"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device AlpsPS/2 ALPS DualPoint TouchPad
(**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
(**) AlpsPS/2 ALPS DualPoint TouchPad: Device: "/dev/input/event5"
(II) AlpsPS/2 ALPS DualPoint TouchPad: Found 3 mouse buttons
(II) AlpsPS/2 ALPS DualPoint TouchPad: Found relative axes
(II) AlpsPS/2 ALPS DualPoint TouchPad: Found x and y relative axes
(II) AlpsPS/2 ALPS DualPoint TouchPad: Found absolute axes
(II) AlpsPS/2 ALPS DualPoint TouchPad: Found x and y absolute axes
(II) AlpsPS/2 ALPS DualPoint TouchPad: Found absolute touchpad.
(II) AlpsPS/2 ALPS DualPoint TouchPad: Configuring as touchpad
(**) AlpsPS/2 ALPS DualPoint TouchPad: YAxisMapping: buttons 4 and 5
(**) AlpsPS/2 ALPS DualPoint TouchPad: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint TouchPad" (type: TOUCHPAD)
(WW) AlpsPS/2 ALPS DualPoint TouchPad: touchpads, tablets and touchscreens ignore relative axes.
(**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) keeping acceleration scheme 1
(**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration profile 0
(II) AlpsPS/2 ALPS DualPoint TouchPad: initialized for absolute axes.
(II) config/hal: Adding input device DualPoint Stick
(**) DualPoint Stick: always reports core events
(**) DualPoint Stick: Device: "/dev/input/event4"
(II) DualPoint Stick: Found 3 mouse buttons
(II) DualPoint Stick: Found relative axes
(II) DualPoint Stick: Found x and y relative axes
(II) DualPoint Stick: Configuring as mouse
(**) DualPoint Stick: YAxisMapping: buttons 4 and 5
(**) DualPoint Stick: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "DualPoint Stick" (type: MOUSE)
(**) DualPoint Stick: (accel) keeping acceleration scheme 1
(**) DualPoint Stick: (accel) acceleration profile 0
(II) DualPoint Stick: initialized for relative axes.
(II) config/hal: Adding input device Logitech USB-PS/2 Optical Mouse
(**) Logitech USB-PS/2 Optical Mouse: always reports core events
(**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event7"
(II) Logitech USB-PS/2 Optical Mouse: Found 12 mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
(II) Logitech USB-PS/2 Optical Mouse: Found relative axes
(II) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
(**) Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
(**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
(**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration profile 0
(II) Logitech USB-PS/2 Optical Mouse: initialized for relative axes.
(II) config/hal: Adding input device Integrated_Webcam_2M
(**) Integrated_Webcam_2M: always reports core events
(**) Integrated_Webcam_2M: Device: "/dev/input/event6"
(II) Integrated_Webcam_2M: Found keys
(II) Integrated_Webcam_2M: Configuring as keyboard
(II) XINPUT: Adding extended input device "Integrated_Webcam_2M" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device HID 413c:8157
(**) HID 413c:8157: always reports core events
(**) HID 413c:8157: Device: "/dev/input/event10"
(II) HID 413c:8157: Found keys
(II) HID 413c:8157: Configuring as keyboard
(II) XINPUT: Adding extended input device "HID 413c:8157" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Sleep Button
(**) Sleep Button: always reports core events
(**) Sleep Button: Device: "/dev/input/event2"
(II) Sleep Button: Found keys
(II) Sleep Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event1"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event9"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event8"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) AT Translated Set 2 keyboard: Close
(II) UnloadModule: "evdev"
(II) AlpsPS/2 ALPS DualPoint TouchPad: Close
(II) UnloadModule: "evdev"
(II) DualPoint Stick: Close
(II) UnloadModule: "evdev"
(II) Logitech USB-PS/2 Optical Mouse: Close
(II) UnloadModule: "evdev"
(II) Integrated_Webcam_2M: Close
(II) UnloadModule: "evdev"
(II) HID 413c:8157: Close
(II) UnloadModule: "evdev"
(II) Sleep Button: Close
(II) UnloadModule: "evdev"
(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) Video Bus: Close
(II) UnloadModule: "evdev"
(II) Video Bus: Close
(II) UnloadModule: "evdev"
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon May 17, 2010 3:20 pm    Post subject: Reply with quote

ma il problema è che non riesci a vedere nulla dando startx?

se fosse cosi, la causa potrebbe essere quella di installare roba tipo twm che non è installato di default.

Il consiglio che ti do è di installare il tuo DE/WM e una volta terminato lanciare il servizio xdm, a quel punto vedi se funziona o meno..il log sembra ok!


P.S. non c'entra il tuo dell..se vuoi cercare problemi per malfunzionamenti di Xorg devi dare più un'occhiata a scheda video e driver ;)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
inc0
n00b
n00b


Joined: 17 May 2010
Posts: 21

PostPosted: Mon May 17, 2010 3:23 pm    Post subject: Reply with quote

Quello che vedo è un bella schermata nera indipendentemente dall'ambiante grafico (niente mouse, niente di niente): ho installati sia gnome che twm che blackbox ma il risultato non cambia.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon May 17, 2010 3:25 pm    Post subject: Reply with quote

prova a settare la variabile
Code:
DISPLAYMANAGER
in
Code:
/etc/conf.d/xdm
e successivamente starta il servizio (xdm)...posta errori in caso
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Mon May 17, 2010 8:58 pm    Post subject: Reply with quote

Intanto ne ho imparta una con voi...........
Per caso dopo startx se aspetti tipo 10 minuti, fa dei tentativi di ricerca con lo schermo se ti compare la schermata di loggin e non ti risponde ne il mause ne la tastera?
Provai pure io da Xorg server e non fu felice.......
Che non sia il kernel che non hai specificato il supporto della grafica oppure il driver della scheda, chissà delle volte.........
Back to top
View user's profile Send private message
inc0
n00b
n00b


Joined: 17 May 2010
Posts: 21

PostPosted: Tue May 18, 2010 1:28 pm    Post subject: Reply with quote

ago88 wrote:
prova a settare la variabile
Code:
DISPLAYMANAGER
in
Code:
/etc/conf.d/xdm
e successivamente starta il servizio (xdm)...posta errori in caso

C'è già impostato (ed ovviamente è installato) gdm ma il risultato è sempre lo stesso: schermata nera, niente puntatore.
Back to top
View user's profile Send private message
inc0
n00b
n00b


Joined: 17 May 2010
Posts: 21

PostPosted: Tue May 18, 2010 1:30 pm    Post subject: Reply with quote

bi-andrea wrote:
Intanto ne ho imparta una con voi...........
Per caso dopo startx se aspetti tipo 10 minuti, fa dei tentativi di ricerca con lo schermo se ti compare la schermata di loggin e non ti risponde ne il mause ne la tastera?
Provai pure io da Xorg server e non fu felice.......
Che non sia il kernel che non hai specificato il supporto della grafica oppure il driver della scheda, chissà delle volte.........

Indipendentemente dal tempo che lascio X attivo, il risultato non cambia. Con i kernel ho provato (penso) tutte le combinazioni e il miglior risultato che ho ottenuto è quello descritto in questo thread :S
Puoi vedere gli ultimi .config che usato nel primo post.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Tue May 18, 2010 6:30 pm    Post subject: Reply with quote

inc0 wrote:
C'è già impostato (ed ovviamente è installato) gdm ma il risultato è sempre lo stesso: schermata nera, niente puntatore.


Come avvi xdm? hai aggiunto anche ai runlevel hald e dbus?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
inc0
n00b
n00b


Joined: 17 May 2010
Posts: 21

PostPosted: Wed May 19, 2010 8:56 am    Post subject: Reply with quote

ago88 wrote:
inc0 wrote:
C'è già impostato (ed ovviamente è installato) gdm ma il risultato è sempre lo stesso: schermata nera, niente puntatore.


Come avvi xdm? hai aggiunto anche ai runlevel hald e dbus?

hal e dbus sono avviati, xdm lo avvio tramite l'apposito script in init.d/ (il sistema parte in testuale).
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Thu May 20, 2010 5:11 pm    Post subject: Reply with quote

bene..quindi nel momento in cui si blocca hai accesso ad un terminale per visualizzare il log di X ?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
inc0
n00b
n00b


Joined: 17 May 2010
Posts: 21

PostPosted: Thu Jun 10, 2010 11:41 am    Post subject: Reply with quote

ago88 wrote:
bene..quindi nel momento in cui si blocca hai accesso ad un terminale per visualizzare il log di X ?

no: è bloccato :? (alt+fx, ctrl+alt+fx ne altre combinazioni rispondono)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Thu Jun 10, 2010 4:21 pm    Post subject: Reply with quote

teoricamente la scheda dovrebbe funzionare tranquillamente con i915, dal log si evince che non ci sono particolari problemi ma noto:


Xorg.0.log wrote:
Current Operating System: Linux localhost 2.6.32-gentoo-r7 #6 SMP PREEMPT Wed May 12 16:23:59 CEST 2010 x86_64Kernel command line: BOOT_IMAGE=/boot/2.6.32-r7 /dev/sda9 i915.modeset=1


mentre in emerge --info:
emerge --info wrote:
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.32-22-generic x86_64)


è un po disordinata la cosa..un log fa riferimento ad un kernel, mentre un'altro fa riferimento ad un'altro kernel..che dalla nomenclatura sembra *buntu
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum