Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Aggiornato sane-backends e niente più scan per gli utenti
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Fri May 14, 2010 8:19 pm    Post subject: Aggiornato sane-backends e niente più scan per gli utenti Reply with quote

Salve gente,

di recente ho aggiornato sane-backends alla versione 1.0.21, e mi sono accorto che se lancio xsane da utente non mi rileva più lo scanner, mentre da root sì.
Probabilmente mi sono perso qualche messaggio di log da parte di sane-backends (non ritrovo il modo per recuperare i messaggi post-emerge :( ) ed ora mi trovo a non poter più fare scansioni, se non da root.
Qualcuno ha idea di quale possa essere il problema?

EDIT: l'unico messaggio che ottengo da xsane è questo:
Code:
xsane failed to open device `brother2:bus4;dev1': Error during device I/O

_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Fri May 14, 2010 8:45 pm    Post subject: Reply with quote

l'utente è nel gruppo scanner?
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Fri May 14, 2010 8:49 pm    Post subject: Reply with quote

Sì, "da sempre". Infatti non capisco. È la prima cosa che ho controllato.
L'unica cosa è che sane-backends che ho messo è marcato come ~. Però è strana questa cosa.
Inoltre ho notato che con l'aggiornamento si è "autocompilato" con tutte le use flag sane_backends_* attive!

EDIT: facendo il downgrade alla versione 1.0.19-r2, le cose sono tornate a funzionare. Dev'essere colpa di dispatch-conf o di qualche settaggio nuovo.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Sat May 15, 2010 9:57 am    Post subject: Reply with quote

Incuriosito dal problema ho provato ad installare "sane-backends-1.0.21" e "xsane-0.997".
Il tutto è avvenuto senza alcuna modifica a "make.conf" (per quanto riguarda la variabile "SANE_BACKENDS") e i file da aggiornare in /etc non avevano nulla a che fare con la configurazione dello scanner.
Settando correttamente "SANE_BACKENDS" viene installato solo quello specificato, al contrario della documentazione che copre ogni possibile backend.
Probabilmente il tuo problema è generato da una regola udev errata, di cui il changelog del pacchetto in questione è pieno: http://gentoo-portage.com/media-gfx/sane-backends/ChangeLog#ptabs.
Per quanto riguarda questo aspetto non posso verificare (o meglio per me sarebbe complesso) in quanto sane-backends è installato in una chroot e la regola di udev "39-libsane.rules" non ha alcun effetto sul sistema principale: nel mio caso è sufficiente essere nel gruppo usb e lp, ma è un discorso a parte.

EDIT: Ho riscontrato un effetto collaterale in sane-backends-1.0.21. In pratica non posso scannerizzare aree con un margine sinistro. Questo con una multifunzione "Canon Mp600R" e "pixma" come backend. La versione stabile 1.0.19-r2 non presenta lo stesso errore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum