Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Postfix don't compile with sasl!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
MoonWalker
Guru
Guru


Joined: 04 Jul 2002
Posts: 449

PostPosted: Mon Jul 15, 2002 11:43 pm    Post subject: Postfix don't compile with sasl! Reply with quote

Hi!
When emerging postfix with sasl in make.conf USE it errors out on compile. First this:

Code:
cc -DHAS_MYSQL -I/usr/include/mysql -DHAS_SSL -I/usr/include -DHAS_PCRE -DUSE_SASL_AUTH  -march=i586 -O3 -pipe -I. -I../../include -DLINUX2 -o master master.o master_conf.o master_ent.o master_sig.o master_avail.o master_spawn.o master_service.o master_status.o master_listen.o master_vars.o master_wakeup.o master_flow.o ../../lib/libglobal.a ../../lib/libutil.a -lmysqlclient -lm -lssl -lpam -L/usr/lib -lpcre -ldl -lcrypt -lsasl -ldb -lnsl -lresolv
/usr/i586-pc-linux-gnu/bin/ld: cannot find -lsasl
collect2: ld returned 1 exit status
make: *** [master] Error 1
make: *** [update] Error 1


but hangs on a few more turns ending up with this
Code:
cc -DHAS_MYSQL -I/usr/include/mysql -DHAS_SSL -I/usr/include -DHAS_PCRE -DUSE_SASL_AUTH  -march=i586 -O3 -pipe -I. -I../../include -DLINUX2 -o master master.o master_conf.o master_ent.o master_sig.o master_avail.o master_spawn.o master_service.o master_status.o master_listen.o master_vars.o master_wakeup.o master_flow.o ../../lib/libglobal.a ../../lib/libutil.a -lmysqlclient -lm -lssl -lpam -L/usr/lib -lpcre -ldl -lcrypt -lsasl -ldb -lnsl -lresolv
/usr/i586-pc-linux-gnu/bin/ld: cannot find -lsasl
collect2: ld returned 1 exit status
make: *** [master] Error 1
make: *** [update] Error 1

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 1, Exitcode 2
!!! compile problem

!!! emerge aborting on  /usr/portage/net-mail/postfix/postfix-1.1.11-r1.ebuild .


Same result with # emerge postfix and # emerge -e postfix

When removing 'sasl' from USE it compiles ok.

Can anyone confirm this or is it just on my box? shouldn't happen anyway.

/Joakim
_________________
/Joakim

Living on earth is expensive, but it includes a free trip around the sun
every year.
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Mon Jul 15, 2002 11:50 pm    Post subject: Reply with quote

Moving to Networking forum...
_________________
I don't believe in witty sigs.
Back to top
View user's profile Send private message
Nitro
Bodhisattva
Bodhisattva


Joined: 08 Apr 2002
Posts: 661
Location: San Francisco

PostPosted: Tue Jul 16, 2002 12:46 am    Post subject: Reply with quote

Yeah, this is a known issue. I just did:
Code:
emerge /usr/portage/net-mail/postfix/postfix-1.1.11-r3.ebuild
It worked, but it is currently masked.

For more information, I would recommend you check out the following bugs:
https://bugs.gentoo.org/show_bug.cgi?id=3730
https://bugs.gentoo.org/show_bug.cgi?id=4783
_________________
- Kyle Manna

Please, please SEARCH before posting.

There are three kinds of people in the world: those who can count, and those who can't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum