Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ssh] tunnel et grande évasion [resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed May 05, 2010 8:13 am    Post subject: [ssh] tunnel et grande évasion [resolu] Reply with quote

Bonjour,

Je suis dans une société derrière un proxy qui depuis peu bloque pas mal de site (facedebouc, deezer...)
Heureusement ssh configurer sur le port 443 fonctionne et me permet de maintenir ma gentoo quand je suis au boulot.
Utilisant putty sous Xp quand je suis au travail je me suis livré à un petit test de tunnel ssh pour surfer depuis le boulot sur les sites que je veux.

Pour se faire j'ai sous putty configurer la bête comme ça :
Connexion>>ssh>>tunnel>>destination = XXXXX.dyndns.org:80
Connexion>>ssh>>tunnel>>source port = 111 (au pif !)

Ensuite sous IE (désolé pas le choix) et je tape : http://localhost:111/
ça a presque fonctionné car dans le navigateur c'est afficher l'interface d'administration de ma neufbox !
demi déçu car ça peut être pratique !

J'en déduis que le tunnel fonctionne mais c'est pas encore gagné pour réussir à surfer sur le net.
Comment faut-il que je m'y prenne ?
mon serveur ssh écoute le port 443 et 22 il se trouve derrière la neufbox sur laquelle j'ai redirigé le port 443 sur le serveur.


Last edited by BENJI on Wed May 05, 2010 9:40 am; edited 1 time in total
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Wed May 05, 2010 8:32 am    Post subject: Reply with quote

Salut,

pour surfer a travers le tunnel normalement pas besoin de mettre d'adresse, juste un port source dans ton cas 111

une fois le tunnel ouvert tu configures ton navigateur pour qu'il utilise le proxy socks 127.0.0.1:111

et là si tout ce passe bien les requêtes sont envoyées à travers le tunnel.


EDIT: quand tu choisis ton port dans putty il faut indiquer l'option Dynamic
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed May 05, 2010 8:55 am    Post subject: Reply with quote

hmm !
:?
ça marche pas !
dans putty j'ai juste fait :
Connexion>>ssh>>tunnel>>source port = 111
je clique sur add et le message suivant apparait :
"you need to specify a destination address in the form host.name:port"
Je précise qu'il n'y a plus rien dans la liste forwarded port.

EDIT : J'ai fait la même chose en cochant dynamic, là pas de message d'erreur.
La configuration de firefox est la suivante :
Configuration manuelle du proxy>>Hôte SOCKS>>127.0.0.1>> Port 111
SOCKS v5 est coché

J'ouvre firefox ensuite et je tape www.google.fr mais la connexion n'aboutit pas !
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Wed May 05, 2010 9:25 am    Post subject: Reply with quote

je pense que ça doit être un problème de DNS.

dans la configuration de firefox about:config cherche ce paramètre :

Code:
network.proxy.socks_remote_dns


et modifie la valeur en true
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed May 05, 2010 9:40 am    Post subject: Reply with quote

ah bien vu :wink:
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Wed May 05, 2010 1:13 pm    Post subject: Reply with quote

j'aime SSH :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum