Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[samba] access en écriture si logué uniquement (Resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Sun Jun 06, 2010 11:46 am    Post subject: [samba] access en écriture si logué uniquement (Resolu) Reply with quote

Bonjours,
je cherche a faire en sorte de partager un répertoire depuis linux vers windows via samba, pour se faire actuelement j'ai mis:

Code:
[pandore]
comment = Pandore storage drive
path = /mnt/Pandore
public = yes
writable = no
create mask = 0750
browseable = yes


jusque la le fonctionement est "normal" cad que n'importe qui peut y acceder pour lire mais en aucun cas pour écrire, ce que je cherche a faire c'est que pour tout utilisateur "non identitfié" il soit impossible d"écrire mais que l'on puisse lire (donc la config actuelle) mais que pour l'utilisateur "sweety" (ma copine a qui le hdd monté sur /mnt/Pandore) puisse écrire et faire tout ce que bon lui semblera

;EDIT1

apres lecture de ce tuto: http://doc.ubuntu-fr.org/samba_smb.conf
j'en suis arrivé a ca:

Code:
[pandore]
comment = Pandore storage drive
path = /mnt/Pandore
public = yes
#writable = no
create mask = 0750
browseable = yes
read only = yes
write list = sweety


(le security est en mode "user" )

le probleme c'est que meme apres redemarage du serveur sweety n'a toujours pas les permissions en écriture, j'ai pourtant bien moddif son fstab avec:
user=sweety,password=*****
(j'utilise cifs)

l'utilisateur sweety existe bien sur ma machine,


Last edited by Chr0nos on Fri Jun 11, 2010 12:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Tue Jun 08, 2010 9:35 pm    Post subject: Reply with quote

personne ?
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Wed Jun 09, 2010 6:32 pm    Post subject: Reply with quote

Chr0nos wrote:
personne ?

Si moi lol

Essai sa :

sous une console tu tape :
smbpasswd

tu valide sa te demande ton user et tu mets : sweety
tu valide et ensuite sa te demande ton mots de passe 2X

ensuite tu corrige ton fichier /etc/samba/smb.conf comme cela

[pandore]
comment = Pandore storage drive
path = /mnt/Pandore
public = yes
browseable = yes
read only = yes
write list = sweety

et ensuite tu relance samba /etc/init.d/samba restart

sa devrais fonctionner, je viens de tester, tous le monde a acces a mon répertoire en lecture et pas en ecriture et mon user peux lire et ecrire.

Happy Share ;)
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Wed Jun 09, 2010 7:05 pm    Post subject: Reply with quote

j'ai fais un "smbpasswd -a sweety"
j'ai bien tappé le nom d'utilisateur deux fois,

[pandore]
comment = Pandore storage drive
path = /mnt/Pandore
public = yes
#writable = no
create mask = 0750
browseable = yes
read only = yes
write list = sweety


restarté le serveur samba



mais apparement ca ne marche toujours pas O_o
"systeme de fichier accessible en lecture seulement"
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Wed Jun 09, 2010 7:49 pm    Post subject: Reply with quote

Chr0nos wrote:
j'ai fais un "smbpasswd -a sweety"
j'ai bien tappé le nom d'utilisateur deux fois,

[pandore]
comment = Pandore storage drive
path = /mnt/Pandore
public = yes
#writable = no
create mask = 0750
browseable = yes
read only = yes
write list = sweety


restarté le serveur samba



mais apparement ca ne marche toujours pas O_o
"systeme de fichier accessible en lecture seulement"


Tu n'as pas modifier ton fichier smb.conf comme sur mon exemple ?
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Wed Jun 09, 2010 8:04 pm    Post subject: Reply with quote

j'ai juste le "create mask" en plus, ca peut un probleme tu pensse ?
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Wed Jun 09, 2010 9:01 pm    Post subject: Reply with quote

Je ne sais pas si "create mask" peut poser un probleme.
Moi je t'ai donne ma config comme elle est et qui fonctionne pour faire le test qui t'interesse (droit lecture pour tous sauf pour 1 user droit d'ecriture en plus).
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Jun 10, 2010 10:12 am    Post subject: Reply with quote

Au fait comment tu fais pour mapper ton lecteur reseau ?
J'imagine que ton poste distant c'est du windows !
dans une fentre DOS tu fais :
net use lettre_lecteur: \\nom_pc_linux\nom_dossier_partage Mots_de_passe_user_samba /user:user_samba

si tu fais ton mappage pas l'eplorateur windows en faisant un clique droit connecter un lecteur reseau ton mappage ce fera sans autentification et samba tu connectera en somple user et donc tu n'auras pas le droit d'ecriture.
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Thu Jun 10, 2010 7:50 pm    Post subject: Reply with quote

je fais aussi mon mappage sur du linux (elle es en dual boot) et j'utilise donc dans /etc/fstab:

\\Stark\pandore /mnt/Pandore cifs user=sweety,password=le_pass 0 0
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Jun 10, 2010 8:15 pm    Post subject: Reply with quote

J'ai pas teste sous linux.
Sinon sous Windows sa fonctionne ?
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Thu Jun 10, 2010 9:43 pm    Post subject: Reply with quote

je viens de test sous windows (via la ligne de commande) et effectivement ca marche au poil ^^, y'a une bidouille a faire pour que ca passe aussi sous linux ?
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Fri Jun 11, 2010 4:56 am    Post subject: Reply with quote

Je vais faire un test je te tiens au jus ce soir.
Il faut que je met un second linux
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8045
Location: ~Brussels - Belgique

PostPosted: Fri Jun 11, 2010 5:23 am    Post subject: Reply with quote

Sur linux, je monte sans souci :
- mount -t cifs -o user=user,pass=password //machine/share /mnt/samba

si la machine demande une authentification par LDAP, ajouter le domaine dans les options (dom=domain).
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Fri Jun 11, 2010 8:22 am    Post subject: Reply with quote

tu peux auusi le monter comme cela :

mount -t smbfs //ip_pc_linx/repertoire_partage /mnt/samba/ -o username=user,password=password

Mais le mieu sur cette premiere commande c'est d'utiliser le cifs comme l'exemple de Xavier (toujours là Xavier ;) )
(smbfs est obselete), mais il faut que le cifs soit compilé dans ton noyau

ou

smbmount //ip_pc_linx/repertoire_partage /mnt/samba/ -o username=user,password=password
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Fri Jun 11, 2010 12:31 pm    Post subject: Reply with quote

je viens de tester et ca marche !
en fait le probleme était le "password=" dans le /etc/fstab, il falais metre "pass="

merci pour votre aide a tout les deux :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum