Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gnome-2.28] calma con quelle USE !
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed May 05, 2010 4:36 pm    Post subject: [gnome-2.28] calma con quelle USE ! Reply with quote

Code:

s939 ~ # USE="gdu" emerge -uDpvN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=sys-auth/consolekit-0.4[policykit]".
!!! One of the following packages is required to complete your request:
- sys-auth/consolekit-0.4.1 (Change USE: +policykit)
(dependency required by "sys-auth/polkit-0.96-r1" [ebuild])
(dependency required by "sys-apps/devicekit-disks-009" [ebuild])
(dependency required by "sys-apps/gnome-disk-utility-2.28.1" [ebuild])
(dependency required by "gnome-base/gvfs-1.4.3" [ebuild])
(dependency required by "gnome-base/libgnome-2.28.0" [ebuild])
(dependency required by "x11-terms/gnome-terminal-2.28.2" [ebuild])
(dependency required by "@world" [argument])

s939 ~ # USE="gdu policykit" emerge -uDpvN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "x11-base/xorg-server[kdrive]".
!!! One of the following packages is required to complete your request:
- x11-base/xorg-server-1.8.0 (Change USE: +kdrive)
(dependency required by "app-admin/sabayon-2.28.1" [ebuild])
(dependency required by "gnome-base/gnome-2.28.2" [ebuild]
(dependency required by "@world" [argument])

8O scherziamo?
passi per estrorcere la useflag gdu, ma policykit e kdrive non le voglio proprio usare!
che faccio, cambio distro?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Wed May 05, 2010 5:02 pm    Post subject: Reply with quote

Ciao cloc3, kdrive (ti permette di compilare X per ambienti embedded) la puoi pure rimuovere tranquillamente da xorg-server.
Mentre policykit, credo che ti tocchi abilitarla almeno in alcuni pacchetti, la disabiliti globalmente e vedi quali ebuild la richiedono forzatamente.
Comunque l'aggiornamento a gnome-2.28 e X non mi ha dato particolari rotture 8)!

Ciao
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed May 05, 2010 7:04 pm    Post subject: Reply with quote

mack1 wrote:

Comunque l'aggiornamento a gnome-2.28 e X non mi ha dato particolari rotture 8)!

grazie.
non ho paura delle eventuali rotture.
solo mi seccava l'obbligo di usare quelle flag.
hai commentato tu, l'altro giorno, i miei bisticci con la polkit, e adesso mi costringono a riutilizzarla.
ho il terrore verde che, applicata ad un singolo pacchetto, comporti conseguenze inattese sull'intero sistema.
comunque, gnome-2.28 contempla la use -policikyt. non ha senso che le dipendenze di gnome-2.28 costringano l'utente ad aggiungere proprio quella use.

ma non mi è ben chiaro nemmeno il modo di evitare l'applicazione di kdrive, richiesto da quel misterioso app-admin/sabayon, che solo il nome mi domando cosa ci quaglia con la mia gentoo.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed May 05, 2010 7:26 pm    Post subject: Reply with quote

passa a gnome-light e lascia perdere sabayon
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed May 05, 2010 7:33 pm    Post subject: Reply with quote

strano:
Code:

s939 / # cat /etc/portage/package.use/autounmask-gnome

# ---
# BEGIN: gnome-base/gnome-2.28.2
# ---
=gnome-base/gvfs-1.4.3 gdu
=dev-lang/python-2.6.4-r1 sqlite
=x11-base/xorg-server-1.8.0 kdrive
# ---
# END: gnome-base/gnome-2.28.2
# ---

questo è un file generato da autounmask per una installazione x86, dove gnome-2.28.2 è ancora mascherato.
come si nota, la use polkit non viene imposta da portage, mentre kdrive sì.

intorno al tip di Onip (usare gnome-light) osservo che, su amd64, kdrive non risulta più obligatorio, ma policykit sì.

probabilmente, bisogna attendere qualche aggiustamento negli ebuild.
se capisco il problema, posto qualcosa su bugzilla.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Wed May 05, 2010 8:43 pm    Post subject: Reply with quote

Quote:

hai commentato tu, l'altro giorno, i miei bisticci con la polkit, e adesso mi costringono a riutilizzarla.
ho il terrore verde che, applicata ad un singolo pacchetto, comporti conseguenze inattese sull'intero sistema.
comunque, gnome-2.28 contempla la use -policikyt. non ha senso che le dipendenze di gnome-2.28 costringano l'utente ad aggiungere proprio quella use.


Sì, dopo il tuo tread, ho provato a fare alcuni esperimenti, attivando/disattivando la USE "policykit" e ricompilando il sistema e posso dire, che +/-policykit non comporta particolari problemi, quindi credo sia una questione di "gusti" se usare policykit o meno...
Credo solo che policykit/polkit sia poco intuitivo a livello di configurazione (tipo hal per intendersi :roll: ), però usando policykit-gnome (anche se è deprecato) si configurano le autorizzazioni del tuo user facilmente.

Ot:ho provato a nascondere i tread di consolekit attivando "Hidden=true" in /etc/ConsoleKit/seats.d/00-primary.seat dopo che avevo aggiornato a gnome-2.28 e consolekit si impallava e nei log ho trovato:

Code:


console-kit-dae[32662]: segfault at 18 ip 0000005e16a78b54 sp 000003c381962f90 error 4 in console-kit-daemon[5e16a6b000+1f000]

console-kit-daemon[32662]: GLib-GObject-WARNING: invalid (NULL) pointer instance
May  5 22:32:15 Hell_in_a_Shell console-kit-daemon[32662]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
May  5 22:32:15 Hell_in_a_Shell console-kit-daemon[32662]: GLib-GObject-WARNING: invalid (NULL) pointer instance
May  5 22:32:15 Hell_in_a_Shell console-kit-daemon[32662]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
May  5 22:32:15 Hell_in_a_Shell console-kit-daemon[32662]: GLib-GObject-WARNING: invalid (NULL) pointer instance


Succede anche ad altri?E' un bug che secondo voi devo segnalare in bugzilla?

Ciao
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu May 06, 2010 5:53 am    Post subject: Reply with quote

mack1 wrote:
però usando policykit-gnome (anche se è deprecato) si configurano le autorizzazioni del tuo user facilmente.

non lo metto in dubbio.
però a me, policykit non serviva affatto, e non mi è piaciuto di avere faticato a trovare i file di configurazione di policykit, dispersi nel file system e indipendenti da hal.
a mio parere, un tool che influisce sul comportamento di hal dovrebbe editare i file di configurazione di hal stesso. non impostare una configurazione stratificata a un livello superiore.

in ogni caso, lo spirito di gentoo dovrebbe essere quello di far scegliere l'utente.
e policikit non dovrebbe proprio essere imposta in nessun modo.

p.s.: il tuo ot, forse, andrebbe spostato in un thread autonomo, altrimenti nessuno ti risponde.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Thu May 06, 2010 8:26 am    Post subject: Reply with quote

Quote:

però a me, policykit non serviva affatto, e non mi è piaciuto di avere faticato a trovare i file di configurazione di policykit, dispersi nel file system e indipendenti da hal.
a mio parere, un tool che influisce sul comportamento di hal dovrebbe editare i file di configurazione di hal stesso. non impostare una configurazione stratificata a un livello superiore.

in ogni caso, lo spirito di gentoo dovrebbe essere quello di far scegliere l'utente.
e policikit non dovrebbe proprio essere imposta in nessun modo.


Sono d'accordo con te :D su "Gentoo is about choice"!, poi che policykit/polkit sia cervellotico come hal è sotto gli occhi di tutti, però, essendo un progetto abbastanza giovane, non è da escludere che in futuro venga reso più comprensibile (lato umano :D )ed usabile (immagino che altri utenti abbiano tratto le stesse conclusioni nostre).

Ciao
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu May 06, 2010 8:29 am    Post subject: Reply with quote

cloc3 wrote:
in ogni caso, lo spirito di gentoo dovrebbe essere quello di far scegliere l'utente.
In questo caso purtroppo la cosa dipende da come è sviluppato il software che è parte di gnome, gentoo c'entra poco.
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Thu May 06, 2010 9:14 am    Post subject: Reply with quote

Il segfault di consolekit è un bug già segnalato in bugzilla (dovrebbe essere stato già risolto in upstream):

https://bugs.gentoo.org/show_bug.cgi?id=318715

Scusate se vado in OT, ma potrebbe essere utile!

Ciao
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu May 06, 2010 2:35 pm    Post subject: Reply with quote

vorrei solo far notare che, mentre policykit è, effettivamente deprecato, polkit non lo è.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
n0t
n00b
n00b


Joined: 07 Aug 2007
Posts: 37
Location: Napoli

PostPosted: Thu May 06, 2010 4:00 pm    Post subject: Reply with quote

ma la use flag sabayon non dovrebbe essere collegata alla distribuzione (ahimè italiana)

ma dovrebbe riferirsi a questo http://www.redhat.com/magazine/008jun05/features/sabayon/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum