Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mutt segfaults
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
pi314
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2003
Posts: 136
Location: Germany

PostPosted: Thu Apr 29, 2010 9:03 pm    Post subject: mutt segfaults Reply with quote

Hi,

I have a problem connecting to an imaps server with mutt. Whenever I try to connect it segfaults.
This happens since mutt 1.5.20. Older versions work without any problem.
Some debug information is attached. Any Ideas?

Code:

Hole Nachrichten-Köpfe... 210/215 (97%)                                                                                                                           
Program received signal SIGSEGV, Segmentation fault.
mx_update_context (ctx=0x7a3650, new_messages=8332912) at mx.c:1651
1651    mx.c: Datei oder Verzeichnis nicht gefunden.
        in mx.c
(gdb) backtrace
#0  mx_update_context (ctx=0x7a3650, new_messages=8332912) at mx.c:1651
#1  0x000000000049700c in imap_read_headers (idata=0x7c87e0, msgbegin=-13968, msgend=214) at message.c:379
#2  0x0000000000493d9e in imap_open_mailbox (ctx=0x7a3650) at imap.c:756
#3  0x0000000000445e84 in mx_open_mailbox (path=0x41c540 "SH\201\354\360\004", flags=0, pctx=0x0) at mx.c:683
#4  0x000000000043b027 in main (argc=1, argv=0x7fffffffdfc8) at main.c:1023


Code:

[ebuild   R   ] mail-client/mutt-1.5.20-r14  USE="berkdb crypt gdbm gnutls idn imap nls smtp ssl debug -doc -gpg -mbox -nntp -pop -qdbm -sasl -sidebar -smime -tokyocabinet -vanilla"


muttrc
Code:

set folder=imaps://###/
set spoolfile="imaps://###/"
set header_cache = ~/.hcache

set hidden_host=yes
set hostname="###"
set use_domain                  # will qualify all local addresses
set imap_user="pi"

set realname="pi"
set from="###"





emerge -info
Code:

Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.3.2, glibc-2.10.1-r1, 2.6.33-gentoo x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 29 Apr 2010 11:15:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       3.3.6-r1, 4.3.2-r3, 4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -msse4 -msse4.1 -msse4.2 -march=core2 -mcx16 -msahf -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS=""
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news nostrip parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://mirror.jamit.de/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/keks-overlay /var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 bash-completion berkdb bzip2 cairo cli cracklib crypt cups curl cxx directfb dri exif fbcon fortran gdbm git gnutls gpm hal iconv idn ipv6 jpeg lcms maildir mmx modules mpi-threads mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre perl png pppd python readline reflection session smp spell spl sse sse2 ssl ssse3 subversion svg sysfs tcpd threads tiff truetype unicode vim-syntax xcb xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
erik258
Advocate
Advocate


Joined: 12 Apr 2005
Posts: 2650
Location: Twin Cities, Minnesota, USA

PostPosted: Mon May 03, 2010 11:28 pm    Post subject: Reply with quote

does emerge -avNDu mutt help? typically segfaults indicate either bad memory, a bad build, an error in the code (can't rule this out), or a mismatched dependency.
_________________
Configuring a Firewall? Try my iptables configuration
LinuxCommando.com is my blog for linux-related scraps and tidbits. Stop by for a visit!
Back to top
View user's profile Send private message
pi314
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2003
Posts: 136
Location: Germany

PostPosted: Tue May 04, 2010 7:50 am    Post subject: Reply with quote

thx, but nope, this doesn't help.

I tried it now also with some different imaps server which is working without any problem.

So it seems to be a problem that occurs while communicating with the domino mail server here at work. Maybe some incompatibility or whatever. Maybe even a bug in the mail server. Anyway mutt should not segfault so there is definitely some problem with mutt as well.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue May 04, 2010 8:15 am    Post subject: Reply with quote

Try disabling/clearing the header cache, I've seen that cause segfaults before.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
pi314
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2003
Posts: 136
Location: Germany

PostPosted: Tue May 04, 2010 12:51 pm    Post subject: Reply with quote

I already tried to disable the header cache. Also most of the other options that are not needed in the config. It doesn't help.

The last try was on an recent openSuSE with the same result. Probably I need to fill a but report for the mutt people as this seems to be some problem with mutt and certain mail servers. At least it is not gentoo specific and works with some other servers.

thx anyway.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum