Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Cant connect to network over wifi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
OWNSyouAll
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2010
Posts: 99

PostPosted: Fri Apr 23, 2010 11:11 pm    Post subject: [SOLVED]Cant connect to network over wifi Reply with quote

Using the "iwlist wlan0 scan" command it can find my network. But i can't find it in wicd-curses. Also wpa_gui keeps giving me a "could not get status from wpa_supplicant" error. The network is wpa2 encrypted. My hardware is a Broadcom BCM4318 [AirForce One 54g] 802.11g rev 02

Last edited by OWNSyouAll on Sun Apr 25, 2010 11:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Sven Vermeulen
Retired Dev
Retired Dev


Joined: 29 Aug 2002
Posts: 1345
Location: Mechelen, Belgium

PostPosted: Sat Apr 24, 2010 11:51 am    Post subject: Reply with quote

Did you configure wpa_supplicant for your network?
_________________
Please add "[solved]" to the initial topic title when it is solved. TIA.
Linux Sea (PDF), an online e-book on Gentoo Linux
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Apr 24, 2010 2:44 pm    Post subject: Reply with quote

Hi, can you post this :

Code:

# lspci -v
# ifconfig -a
# iwconfig
# iwlist scan
# dmesg | tail
Back to top
View user's profile Send private message
OWNSyouAll
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2010
Posts: 99

PostPosted: Sun Apr 25, 2010 11:54 pm    Post subject: my bad Reply with quote

Just got back from hunting a trip and tried running the following code and was able to connect my bad
[code]
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
followed by
dhcpcd wlan0



[/code]
[/code]
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Mon Apr 26, 2010 12:01 am    Post subject: Reply with quote

You should configure it inside your /etc/conf.d/net instead.
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Thu Apr 29, 2010 9:34 am    Post subject: Reply with quote

Doesn't wicd want to start wpa_supplicant on it's own? If you are running multiple instances, that could interfere...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum