Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[fglrx] probleme avec pilote ati [resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 8:10 am    Post subject: [fglrx] probleme avec pilote ati [resolu] Reply with quote

Bonjour à tous,

Voila j'ai downgrader ma version de xorg pour pouvoir installer ati-drivers.
Sans aucun probleme jusque là.
a present je n'ai plus les effets de bureau.
Ce que j'ai remargque dans mon Xorg.0.log c'est qu'il me charge pas les pilotes Ati mais Vesa, je n'ai pas de xorg.conf peut etre la mon erreur ?!
Voici les ligne en erreur :
Quote:
(EE) Failed to load module "dri2" (module does not exist, 0)
(EE) module ABI major version (6) doesn't match the server's version (5)
(EE) Failed to load module "ati" (module requirement mismatch, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)

J'ai comme carte graphique une ATI X550 en PCI Express.
Merci pour votre aide
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux


Last edited by KeNNys on Sun Apr 25, 2010 7:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Thu Apr 22, 2010 8:19 am    Post subject: Reply with quote

Essaye d'ajouter un xorg.conf, même minimal, pour voir si ça passe :
Code:

Section "Device"
    Identifier     "Card0"
    Driver         "fglrx"
EndSection

Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 9:25 am    Post subject: Reply with quote

jcTux wrote:
Essaye d'ajouter un xorg.conf, même minimal, pour voir si ça passe :
Code:

Section "Device"
    Identifier     "Card0"
    Driver         "fglrx"
EndSection



En ajoutant cela mon kde ce lance plus.
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 9:34 am    Post subject: Reply with quote

J'ai fais un Xorg -configure
copier dans le repertoire /etc/X11/xorg.conf
a present j'ai un ecran noir avec un curseur qui clignote en haut a gauche.
Quand je regarde le fichier Xorg.0.log voici l'erreur :
Quote:
(WW) Falling back to old probe method for fglrx
(EE) No supported AMD display adapters were found
(EE) No devices detected.

_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Thu Apr 22, 2010 9:35 am    Post subject: Reply with quote

[Edit]
LOL
Tu m'as devancé
[/Edit]

Oups !

Génère un xorg.conf avec
Code:
# Xorg -configure
Modifie la section driver si fglrx n'est pas déjà spécifié.
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Thu Apr 22, 2010 9:38 am    Post subject: Reply with quote

Tu es sûr que les modules des pilotes propriétaires AMD ont été correctement compilés ?
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Thu Apr 22, 2010 9:47 am    Post subject: Reply with quote

As-tu essayé l'utilitaire d'ATI ?

Code:
# aticonfig --initial --input=/etc/X11/xorg.conf


Code:
eselect opengl set ati
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 9:59 am    Post subject: Reply with quote

jcTux wrote:
Tu es sûr que les modules des pilotes propriétaires AMD ont été correctement compilés ?


Que veux tu dire par sa ?
Pour mon eselect oui il est bien sur ati

Et pour
Quote:
aticonfig --initial --input=/etc/X11/xorg.conf

j'ai une erreur
Quote:
bash: aticonfig : commande introuvable


Quand j'avais generer le xorg.conf oui j'avais modifier dans la section driver en mettant fglrx.
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Thu Apr 22, 2010 10:05 am    Post subject: Reply with quote

Je veux dire est-ce que le module est fglrx est présent et chargé.

Peux-tu poster le résultat de
Code:
# emerge --info
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Apr 22, 2010 11:54 am    Post subject: Reply with quote

Et ceci aussi :

Code:

# lsmod
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 12:27 pm    Post subject: Reply with quote

pour le emerge --info :
Quote:
Portage 2.1.8.3 (default/linux/x86/10.0/desktop/kde, gcc-4.3.4, glibc-2.10.1-r1, 2.6.32-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.32-gentoo-r7-i686-Intel-R-_Pentium-R-_D_CPU_2.80GHz-with-gentoo-1.12.13
Timestamp of tree: Wed, 21 Apr 2010 14:15:01 +0000
ccache version 2.4 [disabled]
app-shells/bash: 4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python: 2.6.4-r1
dev-python/pycrypto: 2.1.0_beta1
dev-util/ccache: 2.4-r7
dev-util/cmake: 2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox: 1.6-r2
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils: 2.18-r3
sys-devel/gcc: 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6b
virtual/os-headers: 2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA ut2003"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer "
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=3 --load-average=3.0 --with-bdeps=y"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirrors.linuxant.fr/distfiles.gentoo.org http://distfiles.gentoo.org"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j3 -l3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam fbcondecor firefox flac fortran gdbm gif gimp gnutls gpm hal iconv ipv6 java java6 javascript jpeg kde kerberos lcms ldap libnotify mad mikmod mng modules mp3 mp4 mpeg msn mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3 qt3support qt4 readline reflection sdl session spell spl sql ssl startup-notification svg symlink sysfs tcpd tiff truetype unicode usb userlocales vnc vorbis webkit winbind x264 x86 xcb xcomposite xml xorg xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa fglrx"
Unset: CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Et pour le lsmod :
Quote:
Module Size Used by
fuse 46450 2
snd_intel8x0 21876 1
snd_ac97_codec 88204 1 snd_intel8x0
ac97_bus 838 1 snd_ac97_codec
radeonfb 50065 0
fb_ddc 1151 1 radeonfb
i2c_algo_bit 3869 1 radeonfb

_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Thu Apr 22, 2010 12:51 pm    Post subject: Reply with quote

Effectivement, le module fglrx n'est pas chargé.
Tu as bien rajouté fglrx dans la section VIDEO_CARDS de make.conf. Je suppose alors que le paquet 11-drivers/ati-drivers est installé et le module fglrx compilé.
Pour avoir le cœur net, tu peux tout de même lancer un p'tit coup de :
Code:
emerge -uDNav world

Lance ensuite en root :
Code:
# modprobe fglrx

Déjà tu peux voir si le module peut être chargé. Si ça passe, rajoute alors fglrx dans la section driver de xorg.conf, et redémarre le serveur X. Si c'est ok, rajoute fglrx dans le fchier /etc/modules.autoload.d/kernel-2.6 pour charger le module à chaque démarrage du système.

Si ces opérations ne sont pas fructueuses, donne-nous la version de xorg-server que tu utilises actuellement.

JC
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 1:56 pm    Post subject: Reply with quote

Rien pour le emerge -uDNav world.
Deja à jour, j'ai réemerge ati-drivers.
Par contre pour le modeprobe fglrx erreur.
FATAL: Error insertiong fglrx (lib/modules/2.6.32-gentoo-r7/video/fglrx.ko) : No such device.

Il me manque quelque chose dans mon noyau ?
Quoi et ou ?
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Thu Apr 22, 2010 2:20 pm    Post subject: Reply with quote

Peut être qu'il manque quelque chose dans la configuration du noyau.
Si tu lis l'anglais, jette un coup d'œil ici : http://74.125.77.132/search?q=cache:m1MPgobdmM4J:en.gentoo-wiki.com/wiki/Fglrx+gentoo+ati+fglrx&hl=fr&gl=fr&strip=1

C'est une page cache Google du wiki non officiel de Gentoo qui a l'air d'être HS en ce moment.
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 2:45 pm    Post subject: Reply with quote

Je viens de lire le tuto qui est interessant.
Sa avance je pense a present quand je fais un modprobe fglrx j'ai une autre erreur :
Quote:
FATAL: Error inserting fglrx (/lib/modules/2.6.32-gentoo-r7/video/fglrx.ko): Unknown symbol in module, or unknown parameter (see dmes
g)
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Apr 22, 2010 3:43 pm    Post subject: Reply with quote

Pourrais-tu poster ceci :

Code:

# cd /usr/src && ls -la
# cat /boot/grub/grub.conf
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 4:03 pm    Post subject: Reply with quote

pour : cd /usr/src && ls -la
Quote:

total 16
drwxr-xr-x 4 root root 4096 8 avril 18:52 .
drwxr-xr-x 13 root root 4096 9 avril 23:22 ..
-rw-r--r-- 1 root root 0 16 févr. 13:19 .keep
lrwxrwxrwx 1 root root 22 8 avril 18:52 linux -> linux-2.6.32-gentoo-r7
drwxr-xr-x 20 root root 4096 8 avril 19:12 linux-2.6.31-gentoo-r10
drwxr-xr-x 24 root root 4096 22 avril 17:59 linux-2.6.32-gentoo-r7

le cat /boot/grub/grub.conf
Quote:
# This is a sample grub.conf for use with Genkernel, per the Gentoo handbook
# http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap2
# If you are not using Genkernel and you need help creating this file, you
# should consult the handbook. Alternatively, consult the grub.conf.sample that
# is included with the Grub documentation.

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Getnoo Linux 2.6.32-r7
kernel /boot/kernel-2.6.32-gentoo-r7 root=/dev/sda3
splash=verbose,theme:gentoo video=uvesafb:1024x768-32,mtrr:3,ywrap console=tty1
initrd (hd0,0)/boot/fbsplash-gentoo

title Gentoo Linux 2.6.31-r10
root (hd0,0)
kernel /boot/kernel-2.6.31-gentoo-r10 root=/dev/sda3

title Gentoo Linux 2.6.33-r1 unstable
root (hd2,0)
kernel /boot/kernel-2.6.33-gentoo-r1 root=/dev/sdb3

#initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5

# vim:ft=conf:

_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 4:24 pm    Post subject: Reply with quote

voila ce que me donne mon dernier dmesg enfin les dernieres ligne au lancement du modprobe fglrx
Quote:
[ 133.836239] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[ 133.836246] Disabling lock debugging due to kernel taint
[ 133.981292] [fglrx] Maximum main memory to use for locked dma buffers: 2392 MBytes.
[ 133.981785] [fglrx:firegl_init_device_list] *ERROR* No supported display adapters were found
[ 133.981789] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed
[ 430.807855] [fglrx] Maximum main memory to use for locked dma buffers: 2392 MBytes.
[ 430.808370] [fglrx:firegl_init_device_list] *ERROR* No supported display adapters were found
[ 430.808376] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed


Ne me dites pas que ma carte n'est pas compatible ! je viens de lire sa et sa me dis bien qu'elle l'est !
:cry:
http://odin.prohosting.com/wedge01/gentoo-radeon-faq.html

J'ai emerge les dernier pilotes ati-drivers-10.3 pour voire si sa changeait mais non.
Et pourquoi je ne peux pas installer les pilotes linux fournis directement par amd/ati le fichier at.run ?
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu Apr 22, 2010 4:33 pm    Post subject: Reply with quote

Vérifies que toutes les dépendances à xorg-1.6 sont bonnes, et surtout re-emerge les toutes.
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 5:16 pm    Post subject: Reply with quote

J'ai recompiler completement xorg-x11 mais toujours idem.
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
peapa
n00b
n00b


Joined: 26 Nov 2008
Posts: 33

PostPosted: Thu Apr 22, 2010 6:06 pm    Post subject: Reply with quote

KeNNys wrote:
Ne me dites pas que ma carte n'est pas compatible ! je viens de lire sa et sa me dis bien qu'elle l'est !
:cry:
http://odin.prohosting.com/wedge01/gentoo-radeon-faq.html


En fait, je viens de voir ici que ta carte est basée sur le r300, donc elle n'est plus supportée par fglrx depuis un certain temps déjà (un peu plus d'un an me semble-t-il).

A partir de là, deux solutions : Utiliser les pilotes libres qui fonctionnent normalement bien ou installer le dernier fglrx qui supporte ta carte, sachant qu'il va falloir également installer des (très) vieilles versions du noyau et du serveur X, avec tous les problèmes de dépendances qui peuvent en découler.
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Apr 22, 2010 6:10 pm    Post subject: Reply with quote

Merci peapa,

Je me doutais de cela.
je vais change de carte.
Pouve vous me donner une liste de carte ati supportant fglrx ?
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Thu Apr 22, 2010 7:20 pm    Post subject: Reply with quote

peapa wrote:
KeNNys wrote:
Ne me dites pas que ma carte n'est pas compatible ! je viens de lire sa et sa me dis bien qu'elle l'est !
:cry:
http://odin.prohosting.com/wedge01/gentoo-radeon-faq.html


En fait, je viens de voir ici que ta carte est basée sur le r300, donc elle n'est plus supportée par fglrx depuis un certain temps déjà (un peu plus d'un an me semble-t-il).

A partir de là, deux solutions : Utiliser les pilotes libres qui fonctionnent normalement bien ou installer le dernier fglrx qui supporte ta carte, sachant qu'il va falloir également installer des (très) vieilles versions du noyau et du serveur X, avec tous les problèmes de dépendances qui peuvent en découler.


Alors là pas de bol :(
Tu n'as pas d'autres choix que les pilotes libres.
Back to top
View user's profile Send private message
peapa
n00b
n00b


Joined: 26 Nov 2008
Posts: 33

PostPosted: Thu Apr 22, 2010 8:43 pm    Post subject: Reply with quote

KeNNys wrote:
je vais change de carte.
Pouve vous me donner une liste de carte ati supportant fglrx ?


Tu n'est pas obligé de changer de carte, le pilote libre fonctionne très bien, même mieux que fglrx pour la 2D et la vidéo. En 3D, il est suffisament performant pour les effets de bureau ou même pour jouer à des jeux assez légers. En plus de ça, un nouveau pilote libre plutôt prometteur est actuellement en développement et est en passe de dépasser l'actuel au niveau des performances :wink:

Sinon, les cartes supportées aujourd'hui par fglrx sont celles de la série HD2000 et supérieures, en sachant que comme ta carte actuelle, elles pourront un jour ne plus être supportées.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum