Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Wake-On-LAN] La diode LAN reste éteinte...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Tue Apr 20, 2010 2:46 pm    Post subject: [Wake-On-LAN] La diode LAN reste éteinte... Reply with quote

Hello :)

Ca fait 2 jours que je m'évertue à faire marcher ce p*** de Wake On LAN sur mon serveur. C'est un serveur qui est hébergé chez mes parents, et le Wake-on-lan m'évitera à avoir à les appeler pour qu'ils rallument le serveur quand il y a une coupure ou jenesaisquoi.

Les infos :

- carte réseau intégrée à la carte mère Matsonic
- Bios AMIBIOS, le Wake-On-Lan est bel et bien activé dedans
- niveau configuration, j'ai tout configuré avec ethtool, et :

Code:

servbwa: /home/saimoun # ethtool eth0
Settings for eth0:
   Supported ports: [ TP MII ]
   Supported link modes:   10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
   Supports auto-negotiation: Yes
   Advertised link modes:  10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
   Advertised auto-negotiation: Yes
   Speed: 100Mb/s
   Duplex: Full
   Port: MII
   PHYAD: 1
   Transceiver: internal
   Auto-negotiation: on
   Supports Wake-on: pg
   Wake-on: g
   Current message level: 0x000000c5 (197)
   Link detected: yes


- un lspci donne ça :
Code:

00:01.1 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 82)
   Subsystem: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet Adapter onboard [Asus P4SC-EA]
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 64 (13000ns min, 2750ns max)
   Interrupt: pin C routed to IRQ 10
   Region 0: I/O ports at dc00 [size=256]
   Region 1: Memory at cfffb000 (32-bit, non-prefetchable) [size=4K]
   Expansion ROM at cffc0000 [disabled] [size=128K]
   Capabilities: [40] Power Management version 2
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=160mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
      Status: D0 PME-Enable+ DSel=0 DScale=0 PME-
   Kernel driver in use: sis900
   Kernel modules: sis900


- j'ai branché une diode sur un Pin de la carte mère qui, selon la Doc, représente la diode LAN, j'ai vérifié, c'est bien le cas : elle s'allume quand l'ordi est allumé et elle s'éteint si jamais le débranche le cable RJ45.

Donc, après tout ça, j'éteint l'ordi, et là : la diode s'éteint alors qu'elle ne devrait pas !
Bien sûr, j'ai quand même essayer de faire, depuis un autre ordi connecté en local, un wakeonlan/etherwake xx:xx:xx:xx:xx en mettant l'adresse MAC de ma carte réseau (j'ai vérifié au moins 15 fois c'est la bonne !), j'ai même essayé un wakeonlan -i 192.168.0.12 xx:xx:xx:xx (192.168.0.12 est l'adresse locale de mon serveur) et ça ne marche pas non plus.
Enfin à mon avis c'est tout simplement le Wake-On-Lan de la carte réseau qui foire puisque la diode s'éteint alors qu'elle devrait rester allumé... Pourtant là aussi j'ai vérifié plein de fois : ma carte supporte bien le WOL et il est activé...

Bref, après avoir cherché partout où je pouvais, j'en revient donc à votre aide :)

Merci d'avance !

Saimoun

PS : si vous voulez d'autres informations n'hésitez pas à demander !
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Wed Apr 21, 2010 9:02 am    Post subject: Reply with quote

Ca pourra peut-être aider : la Documentation de la carte mère.

J'ai lu quelque part que n'importe-quelle carte Ethernet qui supporte le Wake-On-Lan doit garder sa diode allumée lorsqu'on éteint l'ordi, et ce quelle que soit la configuration du bios... C'est vrai ? Si oui, c'est rappé pour moi... :( Mais Franchement ça me paraîtrai bizarre et peu économique, vu que la carte réseau doit pomper sur la pile de la carte mère lorsqu'elle reste allumée.

Vous en savez quelque chose ?
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed Apr 21, 2010 9:07 am    Post subject: Reply with quote

Saimoun wrote:
Mais Franchement ça me paraîtrai bizarre et peu économique, vu que la carte réseau doit pomper sur la pile de la carte mère lorsqu'elle reste allumée.

Vous en savez quelque chose ?

Non ta cm elle pompe sur le courant. Si tu veux un pc branché sur le courant, même éteint consomme un peu. La pile c'est juste pour l'horloge et le bout d'eprom bios qui garde la config courante.

Enfin il me semble, quelqu'un pour confirmer? (parce qu'une pile pour alimenter la carte réseau, la led, le bios et l'horloge ça fait sacrément mince!)
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Wed Apr 21, 2010 9:42 am    Post subject: Reply with quote

La pile pour garder la carte réseau sous tension, ça me paraît très improbable. Pour gérer les "Wake On" (clavier, souris, carte réseau, etc.) les carte-mères restent un minimum alimentées.

Sinon pour vérifier que ta carte réseau supporte le WOL, tu peux tester ethtool eth0:
Code:
# ethtool eth0
Settings for eth0:
...
   Supports Wake-on: g
   Wake-on: g
...

Si il y a un "g" c'est bon signe ;)
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed Apr 21, 2010 9:56 am    Post subject: Reply with quote

Leander256 wrote:

Si il y a un "g" c'est bon signe ;)

Cf son premier post. C'est justement ça le problème: il a le bon flag, mais ça ne semble pas fonctionner pour autant.

par contre il a:
Code:

Supports Wake-on: pg

c'est quoi 'p'?
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Wed Apr 21, 2010 11:29 am    Post subject: Reply with quote

Merci pour vos réponses.
Ok pour l'histoire de la pile, j'avoue c'était con comme idée ^^

A ce que j'ai compris, la ligne "Supports Wake-on" indique plus ou moins le driver qui gère le Wake-on-LAN. J'ai vu sur Internet différents sujets avec des "Supports Wake-on" très variés.

Sinon j'ai fait quelques tests avec la séries des "Wake-on" (cf la doc de ma carte mère) :

- le Wake on keyboard marche, à condition de bouger un pin sur la carte mère (c'est expliqué dans la Doc)
- pas moyen de faire marcher le Wake on Alarm, j'ai essayé 15 fois ça ne marchait pas
- le Wake-On-Lan ne mache toujours pas (la diode reste éteinte).

A noter que j'ai bien mis NETDOWN="yes" à la fin du fichier /etc/default/halt
(j'ai aussi essayé avec NETDOWN="no", ça ne change rien).

Bref, à mon avis y'a un problème au niveau de la carte mère, c'est pas normal que le Wake on Alarm ne marche pas, alors qu'il n'y a rien à activer pour le faire marcher (mais peut-être me trompe-je...).

J'ai envoyé un mail à la personne qui m'a vendue la carte pour avoir plus d'info et de l'aide.
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed Apr 21, 2010 12:52 pm    Post subject: Reply with quote

Ton diagnostique est bon je trouve. C'est clairement le BIOS qui fait pas son boulot (un pb hardware ce serait plus étonnant.)

T'as pas moyen de le mettre à jour d'ailleurs ce BIOS?

Essais voir un reset complet du BIOS aussi, parfois certains bugs de settings se virent de cette manière.
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Wed Apr 21, 2010 1:04 pm    Post subject: Reply with quote

kwenspc wrote:
Cf son premier post. C'est justement ça le problème: il a le bon flag, mais ça ne semble pas fonctionner pour autant.

par contre il a:
Code:

Supports Wake-on: pg

c'est quoi 'p'?


Ça m'apprendra à lire un truc tard le soir et ne répondre que le lendemain matin... :oops: D'après le man (oui je me suis pas foulé):
Code:
              p  Wake on phy activity


Si j'en crois les diverses sources trouvées en cherchant un peu, certains BIOS nécessitent plusieurs options au nom cryptique d'activées, peut-être un truc obscur dans la gestion de l'énergie avec ACPI ? Et juste au cas où, je vois que c'est une carte-mère relativement ancienne mais est-ce que tu as la dernière version du BIOS disponible?
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Wed Apr 21, 2010 2:30 pm    Post subject: Reply with quote

En ce qui concerne la remise à zéro j'ai fait un Clear CMOS et j'ai changé la Pile de la carte mère il y a peu.

Pour la mise à jour du BIOS justement je me disais que le problème venait peut-être de là... Sauf que je ne sais pas où trouver une nouvelle version du bios ni même comment faire pour la mettre à jour.
Mon BIOS est un AMIBIOS.

D'ailleurs j'ai une erreur au lancement du kernel :

Code:
ACPI: BIOS age (1997) fails cutoff (2000), acpi=force is required to enable ACPI


et j'ai doc mis acpi=force dans les options de grub, et depuis j'ai toujours l'erreur mais avec ça juste après :

Code:
ACPI: acpi=force override


Pourtant quand je vais voir dans les infos du BIOS, il me dit 2002... o_O
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed Apr 21, 2010 2:57 pm    Post subject: Reply with quote

un vieux bouzin comme ça il doit mieux tourner sur APM que sur ACPI. Faut tester.

Sinon l'OS n'a rien à voir avec le Wake On Lan . Cela dis: désactive l'acpi si tu peux dans le BIOS (il doit gérer l'APM).

Un amibios ça doit se mettre à jour via une disquette et un ptit soft sous dos, donc il doit y avoir moyen via freedos sur une partition.

[edit] l'acpi et le bios c'est un peu différent. Même si le bios date de 2002 il est probable que la table acpi dsdt date d'avant. D'où la date donné par acpi[/edit]
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Thu Apr 22, 2010 5:53 pm    Post subject: Reply with quote

La parsonne qui m'a vendue la carte mère n'a pas vraiment pu m'aider.

Je vais encore faire quelques tests avec APM (par exemple), et pis arpès tant pis, abandon :(

En tout cas merci à tous de l'intérêt que vous avez porté à mon problème ^^
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Fri Apr 23, 2010 5:20 am    Post subject: Reply with quote

Salut,

Je ne pense pas qu'il faille regarder par l'OS. Si le BIOS ne réveille pas la carte-mère, c'est cuit.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum