Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[réseau] Conflit eth et wifi ? (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Mon Apr 19, 2010 7:55 pm    Post subject: [réseau] Conflit eth et wifi ? (résolu) Reply with quote

Salut,

J'étais tranquille un moment avec mes Gentoo, voilà que les beaux jours me ramènent aussi des soucis :lol:

Sur un de mes pc, j'ai tenté d'installer une clé USB wifi (type rt2500usb), drivers inclus dans le kernel, activation des options fait, la clé est détectée, iwconfig la reconnaît en wlan0, aucun problème de ce côté là. Sauf que depuis que j'ai installé la clé, ma connexion ethernet eth0 ne fonctionne plus, ou plutôt mal. En effet, le pc est connecté à mon routeur adsl Netgear, mais je ne peux plus accéder à internet. Le script de démarrage (net.eth0) démarre bien, l'IP est bien attribué par le routeur qui détecte correctement le PC. Je peux accéder à l'interface de mon routeur en tapant son adresse IP. Donc seule la connexion Internet n'est pas accessible. Comment régler le problème ?

J'utilise pour mon interface eth0 dhcpcd. Je n'ai pas de proxy, je n'utilise pas iptables.
Lorsque je retire la clé wifi et prend soin de retirer les modules (rmmod), cela ne règle pas le problème.

Voici mon /etc/init.d/net :

Code:

config_eth0=( "dhcp" )
dhcp_eth0="nodns nontp nonis"


Last edited by Fenril on Tue Apr 20, 2010 2:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Apr 20, 2010 1:56 am    Post subject: Reply with quote

Peux-tu poster ceci :

Code:

# cat /etc/udev/rules.d/70-persistent-net.rules
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Tue Apr 20, 2010 7:04 am    Post subject: Reply with quote

Voilà mon 70-persistent-net.rules :

Code:

# This file was automatically generated by the /lib/udev/write_net_rules
# program run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.

# PCI device 0x10de:0x0066 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:0e:a6:6d:44:11", KERNEL=="eth*", NAME="eth0"

# USB device 0x0b05:0x1706 (usb)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:11:2f:6b:e5:60", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Tue Apr 20, 2010 10:53 am    Post subject: Reply with quote

Salut

vérifie tes dns ds /etc/resolv.conf
_________________
Get Up and Go !
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Apr 20, 2010 11:55 am    Post subject: Reply with quote

Pourrais-tu poster ton fichier /etc/resolv.conf ?
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Tue Apr 20, 2010 1:11 pm    Post subject: Reply with quote

C'est bien simple : mon resolv.conf est vide.
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Tue Apr 20, 2010 1:27 pm    Post subject: Reply with quote

Fenril wrote:
C'est bien simple : mon resolv.conf est vide.

Effectivement pas de dns, pas d'internet.

Essaye un serveur dns tiers, Google par ex :

Code:
# nano -w /etc/resolv.conf.head


Ajoute ces deux lignes :
Code:
nameserver 8.8.8.8
nameserver 8.8.4.4


Dis-nous s'il y a une différence.
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Tue Apr 20, 2010 2:18 pm    Post subject: Reply with quote

Effectivement, c'était là le souci. J'ai ajouté l'adresse de mon routeur. Résolu.
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Tue Apr 20, 2010 3:03 pm    Post subject: Re: [réseau] Conflit eth et wifi ? (résolu) Reply with quote

Fenril wrote:
Voici mon /etc/init.d/net :

Code:

config_eth0=( "dhcp" )
dhcp_eth0="nodns nontp nonis"


Au passage, c'est parce que tu as mis l'option "nodns" que le fichier /etc/resolv.conf n'est pas rempli par dhcpcd lorsqu'il se connecte à ton routeur.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Tue Apr 20, 2010 3:06 pm    Post subject: Reply with quote

et en enlevant nodns des options dhcp?
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Apr 20, 2010 3:16 pm    Post subject: Reply with quote

Poussin wrote:
et en enlevant nodns des options dhcp?


Ben ton fichier resolv.conf sera renseigné par dhcpcd (à condition que le serveur dhcp lui fournisse les infos)
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Tue Apr 20, 2010 3:32 pm    Post subject: Re: [réseau] Conflit eth et wifi ? (résolu) Reply with quote

Leander256 wrote:
Fenril wrote:
Voici mon /etc/init.d/net :

Code:

config_eth0=( "dhcp" )
dhcp_eth0="nodns nontp nonis"


Au passage, c'est parce que tu as mis l'option "nodns" que le fichier /etc/resolv.conf n'est pas rempli par dhcpcd lorsqu'il se connecte à ton routeur.


Effectivement, sur un autre pc je n'ai pas mis nodns et il n'y a eu aucun problème. Je vais enlever cette option (je ne sais même pas pourquoi je l'ai mis).
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Wed Apr 21, 2010 2:43 pm    Post subject: Reply with quote

Bon, je remonte, car j'ai besoin encore d'un petit coup de main qui a un peu en rapport avec tout ça.
Si j'installe le wifi sur le pc, c'est pour ne pas à être obligé de se connecter par ethernet, donc je débranche le cable. J'ai une clé wifi usb Asus WL-167g basé sur une puce Ralink, j'ai un peu galéré pour la faire fonctionner correctement, mais j'ai compris comment le faire. Voici les étapes :

Code:

wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -Dwext -B <----- pour me connecter en Wpa-psk
iwconfig wlan0 rate 54M <----- Bug du driver qui ne se met pas automatiquement en 54 Mbps
dhcpcd wlan0 <----- Attribution de l'IP par le routeur


Alors ma question est la suivante : dois-je renseigner /etc/conf.d/net et comment ? Voici pour l'instant comment je l'ai renseigné :
Code:

config_eth0=( "dhcp" )
dhcp_eth0="nontp nonis"

modules=( "wpa_supplicant iwconfig" )
wpa_supplicant_wlan0="-Dwext -c /etc/wpa_supplicant/wpa_supplicant.conf"
iwconfig_wlan0="rate 54M mode Managed"
config_wlan0=( "dhcp" )


Dois-je passer par ce fichier ou créer moi-même un script ?
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Apr 22, 2010 1:18 am    Post subject: Reply with quote

Salut, ça te prend juste ça pour le wifi :

Code:

modules=( "wpa_supplicant " )
wpa_supplicant_wlan0="-Dwext"
config_wlan0=( "dhcp" )


Ensuite, as-tu un fichier /etc/wpa_supplicant/wpa_supplicant.conf
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Thu Apr 22, 2010 2:27 pm    Post subject: Reply with quote

En fonction de l'utilisation de la machine, si c'est une station de travail ou un portable et que le config réseau risque de changer beaucoup, regarde du côté de wicd, c'est très facile (et graphique).
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Thu Apr 22, 2010 7:07 pm    Post subject: Reply with quote

J'ai bien sûr renseigné mon wpa_supplicant.conf puisque mon réseau est protégé en wpa-psk. Ca marche bien, il y a aucun problème, je veux juste que ça soit fait proprement, que ma connexion est reconnue au démarrage. Il s'agit d'un pc fixe qui sera dans le salon, et donc pas de connexion Ethernet, juste wifi. J'ai essayé ce que tu conseille d2_racing, tout en créant un lien net.wlan0 vers net.lo, Gentoo reste bloqué aux scripts rc ! Je n'ai pas compris pourquoi. C'est pourquoi je me pose la question si je ne dois pas faire un script à part. Mais il me le faut dès le démarrage pour bénéficier des partages réseau immédiatement.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum