Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fusion-icon problem on a fresh install (solved)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Sun Apr 18, 2010 3:33 pm    Post subject: Fusion-icon problem on a fresh install (solved) Reply with quote

hi ,

i just finished a fresh ~amd64 install.

usually i install fusion-icon in x86 from Desktop-effects overlay, it looks like that' s not possible yet in ~amd64 due to some missing keyword, so iused the portage version.

vesta ~ # equery l fusion-icon
 * Searching for fusionicon ...
[IP-] [  ] x11-apps/fusion-icon-0.1-r1:0
vesta ~ # equery l compiz     
 * Searching for compiz ...
[IP-] [  ] x11-wm/compiz-0.8.6:0

my problem is that when i launch fusion-icon, emerald doesn't start, none of the plugins are working and i cannot switch from a desktop to another using the shortcuts.

when i try to run compiz-manger in a terminal it returns that :

vesta ~ # compiz-manager
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA: 01:00.0 0300: 10de:0392 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1920x1080) to maximum 3D texture size (4096): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting emerald

emerge --info

vesta ~ # emerge --info
Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.3.3, glibc-2.11-r1, 2.6.33-gentoo-r1 x86_64)
System uname: Linux-2.6.33-gentoo-r1-x86_64-Intel-R-_Core-TM-2_CPU_6300_@_1.86GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 17 Apr 2010 08:45:01 +0000
app-shells/bash:     4.1_p5
dev-lang/python:     2.6.5-r1, 3.1.2-r2
dev-util/cmake:      2.8.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.3.3-r2, 4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups custom-optimization cxx dbus dhcpcd dri dts dvd dvdr eds emboss encode evo exif extras fam firefox flac fortran gdbm gdu gif git gnome gnome-keyring gpm gstreamer gtk hal iconv ipv6 jpeg lcms ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt qt3support qt4 readline reflection samba sdl session spell spl sqlite sse sse2 ssl startup-notification svg symlink sysfs tcpd threads tiff truetype unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" RUBY_TARGETS="ruby18" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="nvidia"

is there a way to get through this ?


Last edited by gregool on Mon Apr 19, 2010 4:16 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Mon Apr 19, 2010 5:27 am    Post subject: Reply with quote

well i finally managed to install fusion-icon from desktop overlay, the right thing to do was to use ** as a keyword.

Now every plugins seem to work properly though i didn't try them all.

the problem that remains is Emerald, for an unknown reason it's still not doing the job...

From a terminal if i type emerald --replace it returns: OK

but nothing happens.

thnx for your help :)
Back to top
View user's profile Send private message

Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Mon Apr 19, 2010 4:16 pm    Post subject: Reply with quote

Fixed !

the problem was the decoration window plugin, it was not set properly !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum