Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi stadi di sleep!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Slayer86
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2007
Posts: 98

PostPosted: Thu Apr 15, 2010 7:17 pm    Post subject: Problemi stadi di sleep! Reply with quote

Ciao ragazzi ho bisogno di una mano per rendere il mio sistema perfetto (almeno fino a quando non metteranno in portage gnome-2.30 e sminchierò tutto di nuovo!!!)
In pratica è da quando sono passato al kernel-2.6.32 (ancora in ~x86 al tempo) che non riesco più a completare una sospensione su ram...
L'hybernate funziona che è una meraviglia... invece la sospensione (che mi sarebbe comodissima sul portatile...) dal kernel 2.6.32 in avanti non c'è più stato verso!

Qui di seguito vi posto il contenuto pm-suspend.log di una sospensione andata "male", tra virgolette perchè non viene riportato nessun errore... in pratica io sospendo sembrerebbe andare tutto per il veso giusto ma subito ricompare il desktop e tutto torna come prima che tenteassi di sospendere... in pratica sembra si risvegli subito!!!
Cmq:
Quote:
Initial commandline parameters:
Blacklisting 01grub.
Thu Apr 15 15:06:07 CEST 2010: Running hooks for suspend.
/usr/lib/pm-utils/sleep.d/00logging suspend suspend:Linux michele 2.6.33-gentoo-r1 #3 SMP Thu Apr 15 15:01:13 CEST 2010 i686 Genuine Intel(R) CPU T2300 @ 1.66GHz GenuineIntel GNU/Linux
Module Size Used by
radeon 506783 2
ttm 38149 1 radeon
drm_kms_helper 21618 1 radeon
cfbcopyarea 3117 1 radeon
cfbimgblt 2006 1 radeon
cfbfillrect 2517 1 radeon
total used free shared buffers cached
Mem: 1030196 467160 563036 0 22320 287024
-/+ buffers/cache: 157816 872380
Swap: 1052216 0 1052216
success.
/usr/lib/pm-utils/sleep.d/00powersave suspend suspend:success.
/usr/lib/pm-utils/sleep.d/01grub suspend suspend:disabled.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend:not applicable.
/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend:success.
/usr/lib/pm-utils/sleep.d/75modules suspend suspend:success.
/usr/lib/pm-utils/sleep.d/90clock suspend suspend:not applicable.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend:success.
/usr/lib/pm-utils/sleep.d/95led suspend suspend:not applicable.
/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:success.
/usr/lib/pm-utils/sleep.d/99video suspend suspend:kernel.acpi_video_flags = 0
success.
Thu Apr 15 15:06:07 CEST 2010: performing suspend
/usr/lib/pm-utils/pm-functions: line 295: echo: write error: Device or resource busy
Thu Apr 15 15:06:09 CEST 2010: Awake.
Thu Apr 15 15:06:09 CEST 2010: Running hooks for resume
/usr/lib/pm-utils/sleep.d/99video resume suspend:success.
/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler resume suspend:success.
/usr/lib/pm-utils/sleep.d/95led resume suspend:not applicable.
/usr/lib/pm-utils/sleep.d/94cpufreq resume suspend:success.
/usr/lib/pm-utils/sleep.d/90clock resume suspend:not applicable.
/usr/lib/pm-utils/sleep.d/75modules resume suspend:success.
/usr/lib/pm-utils/sleep.d/55NetworkManager resume suspend:success.
/usr/lib/pm-utils/sleep.d/49bluetooth resume suspend:not applicable.
/usr/lib/pm-utils/sleep.d/01grub resume suspend:disabled.
/usr/lib/pm-utils/sleep.d/00powersave resume suspend:success.
/usr/lib/pm-utils/sleep.d/00logging resume suspend:success.
Thu Apr 15 15:06:34 CEST 2010: Finished.


La riga evidenziata è l'unica cosa anomala... non riesco a capire a cosa si riferisca però!!!

Ho ovviamente provato diversi kernel... ora sto scrivendo dal TuxOnIce 2.6.32-r7 ed anche qui la storia è la stessa!!!
Ed anche con il 2.6.33 tutto uguale!

Cose che possono essere rilevanti non me ne vengono in mente... anche perchè come ho detto con il kernel 2.6.31 funzionava tutto bene!!!
Back to top
View user's profile Send private message
Slayer86
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2007
Posts: 98

PostPosted: Fri Apr 16, 2010 10:18 am    Post subject: Reply with quote

Nessuno?

Converrebbe forse segnalarlo come bug?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum