Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Global update attempt failed with slot conflicts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Mon May 11, 2015 8:37 pm    Post subject: [Solved] Global update attempt failed with slot conflicts Reply with quote

Hello!

Since a couple of months ago, I tried today to perform a global update to my Gentoo box. After emerge --sync, I ran "emerge -DuNav world", getting the following conflicts that I can't resolve:

Code:
# emerge -DuNav world

 * IMPORTANT: 8 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Digest-MD5-2.530.0-r2:0/0::ge                                                                                                                                                                                      ntoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

  (dev-lang/perl-5.18.2-r1:0/5.18::gentoo, installed) pulled in by
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r                                                                                                                                                                                      1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                                                                                                                                                                                                         
    (and 28 more with the same problem)

dev-lang/python-exec:2

  (dev-lang/python-exec-2.9999:2/2::gentoo, ebuild scheduled for merge) pulled i                                                                                                                                                                                      n by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/python-exec-2.9999:2/2::gentoo, installed) pulled in by
    dev-lang/python-exec:2[python_targets_jython2_5(-),python_targets_jython2_7(                                                                                                                                                                                      -),python_targets_pypy(-),python_targets_python3_2(-),python_targets_python3_3(-                                                                                                                                                                                      ),python_targets_python2_7(-),-python_single_target_jython2_5(-),-python_single_                                                                                                                                                                                      target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_python3_                                                                                                                                                                                      2(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-pyth                                                                                                                                                                                      on_single_target_python2_7(-)] required by (dev-python/python-exec-10000.2:2/2::                                                                                                                                                                                      gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

dev-libs/icu:0

  (dev-libs/icu-54.1-r1:0/54a::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-53.1:0/53::gentoo, installed) pulled in by
    dev-libs/icu:0/53= required by (net-nds/openldap-2.4.38-r2:0/0::gentoo, inst                                                                                                                                                                                      alled)
                ^^^^^^                                                                                                                                                                                                                                                                                         
    (and 7 more with the same problem)

media-video/vlc:0

  (media-video/vlc-2.2.1:0/5-8::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-video/vlc-2.1.5-r1:0/5-7::gentoo, ebuild scheduled for merge) pulled in                                                                                                                                                                                       by
    >=media-video/vlc-2.0.1:0/5-7=[dbus,ogg,vorbis] required by (media-libs/phon                                                                                                                                                                                      on-vlc-0.7.2:0/0::gentoo, installed)
                           ^^^^^^^                                                                                                                                                                                                                                                                                                           

media-libs/cogl:1.0

  (media-libs/cogl-1.18.2-r1:1.0/20::gentoo, ebuild scheduled for merge) pulled                                                                                                                                                                                       in by
    >=media-libs/cogl-1.17.5:1.0=[introspection?,pango,wayland?] required by (me                                                                                                                                                                                      dia-libs/clutter-1.20.0:1.0/1.0::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         

  (media-libs/cogl-1.16.2:1.0/15::gentoo, installed) pulled in by
    media-libs/cogl:1.0/15= required by (x11-libs/mx-1.4.7-r1:1.0/1.0::gentoo, i                                                                                                                                                                                      nstalled)
                   ^^^^^^^^                                                                                                                                                                                                                                                                                       


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-video/totem-3.14.2::gentoo
# required by dev-python/totem-python-2.32.0::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
##=net-im/skype-4.3.0.37
=media-plugins/grilo-plugins-0.2.13
# required by media-plugins/grilo-plugins-0.2.13::gentoo[youtube]
# required by media-video/totem-3.14.2::gentoo
# required by dev-python/totem-python-2.32.0::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
##=net-im/skype-4.3.0.37
=dev-libs/libgdata-0.16.1
# required by dev-python/totem-python-2.32.0::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
##=net-im/skype-4.3.0.37
=media-video/totem-3.14.2

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-sound/pulseaudio-6.0::gentoo[alsa-plugin,alsa]
# required by media-video/vlc-2.1.5-r1::gentoo[pulseaudio]
# required by @selected
# required by @world (argument)
>=media-plugins/alsa-plugins-1.0.28 pulseaudio
# required by media-video/totem-3.14.2::gentoo
# required by dev-python/totem-python-2.32.0::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/grilo-0.2.11 playlist

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Would you like to add these changes to your config files? [Yes/No] Yes

Autounmask changes successfully written.

 * IMPORTANT: 10 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

emerge: there are no ebuilds built with USE flags to satisfy "net-misc/curl[ssl,                                                                                                                                                                                      curl_ssl_nss]".
!!! One of the following packages is required to complete your request:
- net-misc/curl-7.42.1::gentoo (Change USE: +curl_ssl_nss, this change violates                                                                                                                                                                                       use flag constraints defined by net-misc/curl-7.42.1: 'curl_ssl_winssl? ( elibc_                                                                                                                                                                                      Winnt ) threads? ( !adns ) ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_gnutl                                                                                                                                                                                      s curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl curl_ssl_winssl ) )')
(dependency required by "net-libs/liboauth-1.0.1::gentoo[curl,nss]" [ebuild])
(dependency required by "dev-libs/libgdata-0.16.1::gentoo" [ebuild])
(dependency required by "media-plugins/grilo-plugins-0.2.13::gentoo[youtube]" [e                                                                                                                                                                                      build])
(dependency required by "media-video/totem-3.14.2::gentoo" [ebuild])
(dependency required by "dev-python/totem-python-2.32.0::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Here is my make.conf:
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.

#ACCEPT_KEYWORDS="~amd64"
CFLAGS="-march=core2 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j5"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="-libav icu xine openal networking sse3 vim-syntax dbus consolekit python threads aalib httpd bluray cpudetection ssse3 libmpeg2 a52 dts skins truetype vcdx vlm wma-fixed ieee1394 libv4l libv4l2 mpeg v4l2 win32codecs xv multilib mmx sse sse2 gtk -gnome dvd alsa cdr lirc id3tag mp3 mp2 mp4 twolame libsamplerate jack classic qt4 qt3 asf ssse2 ogg ncurses ffmpeg 3dnow X gtk soundtouch mac mms modplug musepack speex vocoder wavpack ffmpeg aac svg xml curl fltk libnotify java gnutls v4l tga truetype newmouse screenshot mmx gif cddb lv2 cairo tiff glade jpeg2k sndfile jackmidi midi portaudio ladspa lame lash alsa unicode jpeg png bzip2 gpm ipv6 ssl nls qt3-support cdda xinerama newmousefocus opengl flac audiofile vorbis fluidsynth gdu extras qt3support device-mapper policykit sqlite theora apng x264 mod sip sipim wav gflags"

VIDEO_CARDS="nvidia"
ALSA_CARDS="hdsp hdspm"
#SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
#SYNC=rsync://ftp.df.lth.se/pub/gentoo/
PORT_LOGDIR=/var/log/portage/
#ACCEPT_LICENSE="AdobeFlash-10.1 AdobeFlash-11.x"
#ACCEPT_LICENSE="skype-4.0.0.7-copyright"
#ACCEPT_LICENSE="skype-eula"
ACCEPT_LICENSE="dev-java/sun-jdk-1.6.0.37 Oracle-BCLA-JavaSE"
source /var/lib/layman/make.conf
PORTDIR_OVERLAY="/root/overlays/rt-nvidia"
PORTDIR_OVERLAY="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_ELOG_CLASSES="warn error info log qa"
PYTHON_SINGLE_TARGET="python2_7 python3_2" ## python3_3"
PYTHON_TARGETS="python2_7 python3_3"

# Set PORTDIR for backward compatibility with various tools:
#   gentoo-bashcomp - bug #478444
#   euse - bug #474574
#   euses and ufed - bug #478318
PORTDIR="/usr/portage"

#GENTOO_MIRRORS="rsync://trumpetti.atm.tut.fi/gentoo/ http://ftp.df.lth.se/pub/gentoo/ rsync://ftp.df.lth.se/pub/gentoo/ ftp://ftp.df.lth.se/pub/gentoo/ ftp://mirror.mdfnet.se/gentoo http://mirror.mdfnet.se/gentoo"
#GENTOO_MIRRORS="rsync://ftp.df.lth.se/pub/gentoo/ ftp://ftp.df.lth.se/pub/gentoo/ rsync://ftp.snt.utwente.nl/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"



I have also rebuilt the kernel, now it's '3.18.11-gentoo'.


Thank you for the help! :)

/K.
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine


Last edited by muadib25 on Fri Jun 19, 2015 2:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon May 11, 2015 9:25 pm    Post subject: Reply with quote

There's a bit of mess on your system.

First of all, elaborate on the reason of your masks.
Second, check which of your packages are listed as depending on dev-python/python-exec and reemerge them - that should drop the dep, as for quite awhile only dev-lang/python-exec:2 should be necessary.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Mon May 11, 2015 9:46 pm    Post subject: Reply with quote

Thanks for the reply VoidMage!

First, the bulk of masks was for preventing GNOME 3 from emerging. However, later today I unistalled GNOME completely. Here is, btw, my package.mask file:
Code:
# Atoms that makes me miserable :)

=x11-libs/fltk-2.0_pre6970
=dev-libs/boost-1.42.0-r2
=net-irc/xchat-gnome-0.26.1-r2
=dev-games/physfs-2.0.2-r1
=dev-qt/qtscript-4.8.2-r9999
media-libs/lv2core
=app-pda/libimobiledevice-1.1.4-r4
=media-sound/ardour-3.3-r1
=app-emulation/emul-linux-x86-baselibs-20131008-r2
=app-emulation/emul-linux-x86-baselibs-20131008
=app-emulation/wine-1.7.4
=app-emulation/wine-1.7.3
##=dev-qt/qtcore-4.8.4-r5
##=dev-qt/qt3support-4.8.5
##=dev-qt/qtgui-4.8.5-r1
##=dev-qt/designer-4.8.5
##=net-p2p/retroshare-0.5.5b

##GNOME 3.8 block
>=dev-libs/libgweather-3.0
>=gnome-base/libgnomekbd-3.0
=media-libs/libcanberra-0.28-r4
# Core Applications
>=app-accessibility/orca-3.0
>=gnome-base/gdm-3.0
>=gnome-base/gnome-applets-3.0
>=gnome-base/gnome-keyring-3.0
>=gnome-base/gnome-menus-3.0
>=gnome-base/gnome-panel-3.0
>=gnome-base/gnome-session-3.0
>=gnome-base/gnome-settings-daemon-3.0
>=gnome-base/gnome-control-center-3.0
>=gnome-base/gnome-shell-3.0
>=gnome-base/libgnome-keyring-3.0
>=gnome-base/nautilus-3.0
>=x11-wm/metacity-2.34
>=x11-wm/mutter-3.0
# Extra Applications
>=app-arch/file-roller-3.0
>=app-cdr/brasero-3.0
>=app-crypt/seahorse-3.0
>=app-editors/gedit-3.0
>=app-editors/gedit-plugins-3.0
>=app-text/gtranslator-2.90
>=app-text/evince-3.0
>=dev-util/anjuta-3.0
>=app-pda/gtkpod-2.1.0
>=dev-util/devhelp-3.0
>=gnome-extra/drwright-3.0
>=gnome-extra/evolution-data-server-3.0
>=gnome-extra/evolution-exchange-3.0
>=gnome-extra/gcalctool-6.0
>=gnome-extra/gconf-editor-3.0
>=gnome-extra/gnome-color-manager-3.0
>=gnome-extra/gnome-games-3.0
>=gnome-extra/gnome-games-extra-data-3.0
>=gnome-extra/gnome-media-2.32.0-r300
>=gnome-extra/gnome-packagekit-3.0
>=gnome-extra/gnome-power-manager-3.0
>=gnome-extra/gnome-screensaver-3.0
>=gnome-extra/gnome-system-monitor-3.0
>=gnome-extra/gnome-tweak-tool-3.0
>=gnome-extra/gnome-user-share-3.0
>=gnome-extra/gnome-utils-3.0

>=gnome-extra/mousetweaks-3.0
>=gnome-extra/nautilus-sendto-3.0
gnome-extra/office-runner
>=gnome-extra/zenity-3.0
>=mail-client/evolution-3.0
>=media-gfx/eog-3.0
>=media-sound/rhythmbox-2.90
>=media-sound/sound-juicer-2.99
>=media-video/cheese-3.0

>=net-analyzer/gnome-nettool-3.0
>=net-im/empathy-3.0
>=net-misc/vinagre-3.0
>=net-misc/vino-3.0
>=net-wireless/gnome-bluetooth-3.0
>=sys-apps/gnome-disk-utility-3.0.2-r300
>=www-client/epiphany-3.0
>=www-client/epiphany-extensions-3.0
>=x11-terms/gnome-terminal-3.0
# Documentation
>=gnome-extra/yelp-3.0
>=dev-util/gnome-devel-docs-3.0
>=gnome-extra/gnome-user-docs-3.0
# NetworkManager
>=net-misc/networkmanager-0.8.99
>=net-misc/networkmanager-pptp-0.8.99
>=net-misc/networkmanager-openconnect-0.8.99
>=net-misc/networkmanager-openvpn-0.8.99
>=net-misc/networkmanager-openswan-0.8.99
>=net-misc/networkmanager-vpnc-0.8.99
>=gnome-extra/nm-applet-0.8.99
# Meta packages
>=gnome-base/gnome-core-apps-3.0
>=gnome-base/gnome-extra-apps-3.0
>=gnome-base/gnome-core-libs-3.0
>=gnome-base/gnome-fallback-3.0
>=gnome-base/gnome-light-3.0
>=gnome-base/gnome-3.0
# Misc applications
>=gnome-extra/nautilus-open-terminal-0.19
>=app-mobilephone/gnome-phone-manager-0.67
>=app-accessibility/caribou-0.4
app-admin/eselect-gnome-shell-extensions
>=app-misc/tracker-0.12
>=dev-libs/folks-0.6
>=dev-libs/libgdata-0.9
>=dev-python/pyatspi-2.2
>=gnome-base/gconf-3.2
>=gnome-extra/at-spi-2.2
gnome-extra/gnome-contacts
gnome-extra/gnome-documents
gnome-extra/gnome-shell-extensions
>=gnome-extra/nautilus-tracker-tags-0.12
gnome-extra/sushi

>=net-libs/gnome-online-accounts-3
>=x11-libs/libcryptui-3
>=x11-misc/alacarte-0.13.2-r50
>=app-accessibility/accerciser-3.2

>gnome-extra/sensors-applet-2.99
>=gnome-base/gsettings-desktop-schemas-3.10.1

=gnome-base/gvfs-1.18.3

=net-libs/webkit-gtk-2.2.6-r200
=net-libs/opal-3.10.10
=media-video/x264-encoder-0.0.20111220


>=gnome-base/gnome-control-center-3.12.1-r1
>=net-libs/gnome-online-accounts-3.12.4
>=dev-libs/libgdata-0.14.3
>=media-plugins/grilo-plugins-0.2.12
>=media-video/totem-2.32.0-r2

=dev-libs/totem-pl-parser-3.10.1

>=x11-drivers/nvidia-drivers-341.0.0

>=sys-apps/openrc-0.13.8
=sys-fs/udev-init-scripts-27
dev-qt/qtchooser

=x11-base/xorg-server-1.16.4


Second, 'Equery depends dev-python/python-exec' gives me nothing:
Code:
# equery depends dev-python/python-exec
 * These packages depend on dev-python/python-exec:
#


...unless I understood wrong?

Thank you! :)
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon May 11, 2015 11:12 pm    Post subject: Reply with quote

If 'equery depends dev-python/python-exec ' is empty, 'emerge -c' it and slot 1 of dev-lang/python-exec (if it's installed.)

muadib25 wrote:
Code:
>=sys-apps/openrc-0.13.8
=sys-fs/udev-init-scripts-27
dev-qt/qtchooser

The point of these masks is ?
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Tue May 12, 2015 1:02 pm    Post subject: Reply with quote

VoidMage wrote:
If 'equery depends dev-python/python-exec ' is empty, 'emerge -c' it and slot 1 of dev-lang/python-exec (if it's installed.)
Done, 'dev-python/python-exec' unmerged 10000.1 and 10000.2 versions (?).
'Dev-lang/python-exec' version is 0.3.1-r1, I don't understand 'slot'... :oops: Should there be several versions? 'Emerge -cp dev-lang/python-exec' gives 1 package for deletion and 1 omitted:
Code:
>>> These are the packages that would be unmerged:

 dev-lang/python-exec
    selected: 0.3.1-r1
   protected: none
     omitted: 2.9999

All selected packages: =dev-lang/python-exec-0.3.1-r1


Quote:
muadib25 wrote:
Code:
>=sys-apps/openrc-0.13.8
=sys-fs/udev-init-scripts-27
dev-qt/qtchooser

The point of these masks is ?


I dont remember, actually. Must have been old update conflicts. Should I comment them?
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue May 12, 2015 4:30 pm    Post subject: Reply with quote

Actually, you most likely shouldn't have emerged the live version, just the currently stable slot 2 (likely yet another case of misunderstanding a message from portage).
As for the explanation of slots, :sigh: for example, 'man 5 ebuild'.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Tue May 12, 2015 4:48 pm    Post subject: Reply with quote

You lost me in semantics there...

Live version of what package?
And what should I do with 'man 5 ebuild'?

UPDATE: I see that 'man 5 ebuild' you typed has a description of slots, yet I can't understand to which package you are refering, since I had only one version installed... I guess you can 'realize' more than me from the logs... Sorry, I'm a bit slow on understanding all this...
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue May 12, 2015 5:58 pm    Post subject: Reply with quote

:sigh: At ca. 100 post count I thought I wasn't talking to a complete newbie.

Slots: some of the packages are allowed to be installed in more than one version; in the ebuild, that's called a slot; in this instance dev-lang/python-exec-0.3.1-r1 has a different slot that the other installed version; in 'equery l' output, slot is the number after version number and ':' (if that string has '/' in it, the part after it is a subslot and is a bit more complicated matter).

live ebuild: some of the packages have ebuilds that pull the sources from upstream repos; that's usually denoted by '9999' in the version number; almost always those versions aren't meant to be used by average users, they're usually there for the convenience of the maintainers and some overly brave minefield testers; live packages are usually keywordless, so the user needs to add explicit '**' entry for them in package.accept_keywords.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Tue May 12, 2015 7:59 pm    Post subject: Reply with quote

:sigh: Sorry, RL obligations have been keeping me from immersing more into Gentoo... I'll try to make up for it.
Thanks for the explanation, really appreciated!

Ok, let's see now, slot 1 of dev-lang/python-exec was 0.3.1-r1, just did 'emerge -c' as you told me to! However, 'equery l' reports no 'dev-lang/python-exec' packages...

What do I do now?
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Wed May 13, 2015 1:35 am    Post subject: Reply with quote

What's the output of 'emerge -1pv dev-lang/python-exec:2' ?
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Wed May 13, 2015 2:08 pm    Post subject: Reply with quote

Here it is:

Code:
# emerge -1pv dev-lang/python-exec:2

 * IMPORTANT: 12 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] dev-lang/python-exec-2.9999:2::gentoo  PYTHON_TARGETS="(jython2                                       
_5) (jython2_7) (pypy) (pypy3%*) (python2_7) (python3_3) (python3_4) (-python3_2                                       
%*)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

!!! The following installed packages are masked:
- virtual/perl-File-Spec-3.400.0-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (29 Mar 2015)
# Mask Perl 5.18 for removal. Please upgrade to Perl 5.20

- virtual/perl-IO-1.280.0-r1::gentoo (masked by: package.mask)
- virtual/perl-Storable-2.410.0-r1::gentoo (masked by: package.mask)
- virtual/perl-IO-Compress-2.60.0-r1::gentoo (masked by: package.mask)
- virtual/perl-Digest-MD5-2.520.0-r2::gentoo (masked by: package.mask)
- virtual/perl-Scalar-List-Utils-1.270.0-r2::gentoo (masked by: package.mask)
- app-emulation/emul-linux-x86-sdl-20140508-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (28 Mar 2015)
# on behalf of gx86-multilib project <multilib@gentoo.org>
# Mask emul-linux-x86 packages along with unported old versions
# of reverse dependencies for removal in 60 days, bug #544876.
# Please use multilib ebuilds with abi_x86_32 instead.

- virtual/perl-Encode-2.490.0-r2::gentoo (masked by: package.mask)
- media-libs/sk1libs-0.9.1-r3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (11 Apr 2015)
# media-libs/lcms:0 has serious security issues, is unmaintained
# and will be removed soon, see bug 526642
# Here we remove its last unconditional/unported reverse dependencies,
# media-libs/sk1libs media-gfx/uniconvw sci-libs/libecwj2
# (removal in 30 days).

- virtual/perl-Compress-Raw-Zlib-2.60.0-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

#

_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Wed May 13, 2015 7:52 pm    Post subject: Reply with quote

Remove that entry from package.accept_keywords, as I've said, there's no reason for the live ebuild.

Then, post the refreshed block list. Though unlses you're planning to remove totem, that entry in your package.mask is kind of pointless.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Wed May 13, 2015 11:11 pm    Post subject: Reply with quote

Entry '=dev-lang/python-exec-2.9999 **' removed.

Ok, the refreshed block list (package.mask):
Code:
# Atoms that makes me miserable :)

=x11-libs/fltk-2.0_pre6970
=dev-libs/boost-1.42.0-r2
=net-irc/xchat-gnome-0.26.1-r2
=dev-games/physfs-2.0.2-r1
=dev-qt/qtscript-4.8.2-r9999
media-libs/lv2core
=app-pda/libimobiledevice-1.1.4-r4
=media-sound/ardour-3.3-r1
=app-emulation/emul-linux-x86-baselibs-20131008-r2
=app-emulation/emul-linux-x86-baselibs-20131008
=app-emulation/wine-1.7.4
=app-emulation/wine-1.7.3

##GNOME 3.8 block
>=dev-libs/libgweather-3.0
>=gnome-base/libgnomekbd-3.0
=media-libs/libcanberra-0.28-r4
# Core Applications
>=app-accessibility/orca-3.0
>=gnome-base/gdm-3.0
>=gnome-base/gnome-applets-3.0
>=gnome-base/gnome-keyring-3.0
>=gnome-base/gnome-menus-3.0
>=gnome-base/gnome-panel-3.0
>=gnome-base/gnome-session-3.0
>=gnome-base/gnome-settings-daemon-3.0
>=gnome-base/gnome-control-center-3.0
>=gnome-base/gnome-shell-3.0
>=gnome-base/libgnome-keyring-3.0
>=gnome-base/nautilus-3.0
>=x11-wm/metacity-2.34
>=x11-wm/mutter-3.0
# Extra Applications
>=app-arch/file-roller-3.0
>=app-cdr/brasero-3.0
>=app-crypt/seahorse-3.0
>=app-editors/gedit-3.0
>=app-editors/gedit-plugins-3.0
>=app-text/gtranslator-2.90
>=app-text/evince-3.0
>=dev-util/anjuta-3.0
>=app-pda/gtkpod-2.1.0
>=dev-util/devhelp-3.0
>=gnome-extra/drwright-3.0
>=gnome-extra/evolution-data-server-3.0
>=gnome-extra/evolution-exchange-3.0
>=gnome-extra/gcalctool-6.0
>=gnome-extra/gconf-editor-3.0
>=gnome-extra/gnome-color-manager-3.0
>=gnome-extra/gnome-games-3.0
>=gnome-extra/gnome-games-extra-data-3.0
>=gnome-extra/gnome-media-2.32.0-r300
>=gnome-extra/gnome-packagekit-3.0
>=gnome-extra/gnome-power-manager-3.0
>=gnome-extra/gnome-screensaver-3.0
>=gnome-extra/gnome-system-monitor-3.0
>=gnome-extra/gnome-tweak-tool-3.0
>=gnome-extra/gnome-user-share-3.0
>=gnome-extra/gnome-utils-3.0

>=gnome-extra/mousetweaks-3.0
>=gnome-extra/nautilus-sendto-3.0
gnome-extra/office-runner
>=gnome-extra/zenity-3.0
>=mail-client/evolution-3.0
>=media-gfx/eog-3.0
>=media-sound/rhythmbox-2.90
>=media-sound/sound-juicer-2.99
>=media-video/cheese-3.0

>=net-analyzer/gnome-nettool-3.0
>=net-im/empathy-3.0
>=net-misc/vinagre-3.0
>=net-misc/vino-3.0
>=net-wireless/gnome-bluetooth-3.0>=sys-apps/gnome-disk-utility-3.0.2-r300
>=www-client/epiphany-3.0
>=www-client/epiphany-extensions-3.0
>=x11-terms/gnome-terminal-3.0
# Documentation
>=gnome-extra/yelp-3.0
>=dev-util/gnome-devel-docs-3.0
>=gnome-extra/gnome-user-docs-3.0
# NetworkManager
>=net-misc/networkmanager-0.8.99
>=net-misc/networkmanager-pptp-0.8.99
>=net-misc/networkmanager-openconnect-0.8.99
>=net-misc/networkmanager-openvpn-0.8.99
>=net-misc/networkmanager-openswan-0.8.99
>=net-misc/networkmanager-vpnc-0.8.99
>=gnome-extra/nm-applet-0.8.99
# Meta packages
>=gnome-base/gnome-core-apps-3.0
>=gnome-base/gnome-extra-apps-3.0
>=gnome-base/gnome-core-libs-3.0
>=gnome-base/gnome-fallback-3.0
>=gnome-base/gnome-light-3.0
>=gnome-base/gnome-3.0
# Misc applications
>=gnome-extra/nautilus-open-terminal-0.19
>=app-mobilephone/gnome-phone-manager-0.67
>=app-accessibility/caribou-0.4
app-admin/eselect-gnome-shell-extensions
>=app-misc/tracker-0.12
>=dev-libs/folks-0.6
>=dev-libs/libgdata-0.9
>=dev-python/pyatspi-2.2
>=gnome-base/gconf-3.2
>=gnome-extra/at-spi-2.2
gnome-extra/gnome-contacts
gnome-extra/gnome-documents
gnome-extra/gnome-shell-extensions
>=gnome-extra/nautilus-tracker-tags-0.12
gnome-extra/sushi

>=net-libs/gnome-online-accounts-3
>=x11-libs/libcryptui-3
>=x11-misc/alacarte-0.13.2-r50
>=app-accessibility/accerciser-3.2

>gnome-extra/sensors-applet-2.99
>=gnome-base/gsettings-desktop-schemas-3.10.1
=gnome-base/gvfs-1.18.3

=net-libs/webkit-gtk-2.2.6-r200
=net-libs/opal-3.10.10
=media-video/x264-encoder-0.0.20111220


>=gnome-base/gnome-control-center-3.12.1-r1
>=net-libs/gnome-online-accounts-3.12.4
>=dev-libs/libgdata-0.14.3
>=media-plugins/grilo-plugins-0.2.12

=dev-libs/totem-pl-parser-3.10.1
>=x11-drivers/nvidia-drivers-341.0.0

>=sys-apps/openrc-0.13.8
=sys-fs/udev-init-scripts-27
dev-qt/qtchooser
=x11-base/xorg-server-1.16.4

_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Lars
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 151
Location: Germany, near baltic sea

PostPosted: Thu May 14, 2015 9:05 am    Post subject: Reply with quote

Hi,

IMHO Paweł Hajdan has written a very helpful trick list to solve such dependency problems.

http://phajdan-jr.blogspot.de/2015/04/tricks-for-resolving-slot-conflicts-and.html

Regards
Lars
_________________
Quote:
Alles was nicht einfach ist, ist entweder falsch oder zu kompliziert.

V.Glazounov
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Thu May 14, 2015 10:00 am    Post subject: Reply with quote

...:sigh:...
By "refreshed block list", I've meant output of portage.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Thu May 14, 2015 2:50 pm    Post subject: Reply with quote

@ Lars: Bookmarked, will check them out. Thank you! :)

@ VoidMage: Oh... here:

Code:
 # emerge -DuNav world

 * IMPORTANT: 12 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Digest-MD5-2.530.0-r2:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                               

  (dev-lang/perl-5.18.2-r1:0/5.18::gentoo, installed) pulled in by
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    (and 28 more with the same problem)
                               
dev-libs/icu:0                 
                               
  (dev-libs/icu-54.1-r1:0/54a::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)
                               
  (dev-libs/icu-53.1:0/53::gentoo, installed) pulled in by
    dev-libs/icu:0/53= required by (net-nds/openldap-2.4.38-r2:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    (and 5 more with the same problem)
                               
media-video/vlc:0               
                               
  (media-video/vlc-2.2.1:0/5-8::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)
                               
  (media-video/vlc-2.1.5-r1:0/5-7::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/vlc-2.0.1:0/5-7=[dbus,ogg,vorbis] required by (media-libs/phonon-vlc-0.7.2:0/0::gentoo, installed)
                           ^^^^^^^                                                                                                                     
                               
media-libs/cogl:1.0             
                               
  (media-libs/cogl-1.18.2-r1:1.0/20::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/cogl-1.17.5:1.0=[introspection?,pango,wayland?] required by (media-libs/clutter-1.20.0:1.0/1.0::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^^^^^^                                                                                                                                                                                             
                               
  (media-libs/cogl-1.16.2:1.0/15::gentoo, installed) pulled in by
    media-libs/cogl:1.0/15= required by (x11-libs/mx-1.4.7-r1:1.0/1.0::gentoo, installed)
                   ^^^^^^^^                                                                                                 
                               
                               
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.
                               
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
                               
                               
The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-video/totem-3.14.2::gentoo
# required by dev-python/totem-python-2.32.0::gentoo
# required by @selected         
# required by @world (argument)
# /etc/portage/package.mask:   
##=net-im/skype-4.3.0.37       
=media-plugins/grilo-plugins-0.2.13
# required by media-plugins/grilo-plugins-0.2.13::gentoo[youtube]
# required by media-video/totem-3.14.2::gentoo
# required by dev-python/totem-python-2.32.0::gentoo
# required by @selected         
# required by @world (argument)
# /etc/portage/package.mask:   
##=net-im/skype-4.3.0.37       
=dev-libs/libgdata-0.16.1       
# required by dev-qt/qtscript-4.8.6-r2::gentoo
# required by app-cdr/k3b-2.0.3-r1::gentoo
# required by @selected         
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/qtchooser-0_p20150102

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-sound/pulseaudio-6.0::gentoo[alsa-plugin,alsa]
# required by media-video/vlc-2.1.5-r1::gentoo[pulseaudio]
# required by @selected
# required by @world (argument)
>=media-plugins/alsa-plugins-1.0.28 pulseaudio
# required by media-video/totem-3.14.2::gentoo
# required by dev-python/totem-python-2.32.0::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/grilo-0.2.11 playlist

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Would you like to add these changes to your config files? [Yes/No]

_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Sat May 23, 2015 11:04 am    Post subject: Reply with quote

Ok, I managed to install vlc, which was as easy as 'emerge vlc', which left me puzzled... Is this a portage bug/error?

Next was icu where it did not emerge, outputting this:
Code:
 # emerge -v icu

 * IMPORTANT: 14 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/icu-54.1-r1:0/54a::gentoo [53.1:0/53::gentoo] USE="-de                                                                                                                                                                                      bug -doc -examples -static-libs" ABI_X86="(64) -32 (-x32)" 24889 KiB

Total: 1 package (1 upgrade), Size of downloads: 24889 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-54.1-r1:0/54a::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu (Argument)

  (dev-libs/icu-53.1:0/53::gentoo, installed) pulled in by
    dev-libs/icu:0/53= required by (app-text/libmspub-0.1.2:0/0::gentoo, install                                                                                                                                                                                      ed)
                ^^^^^^                                                                                                                                                                                                                                                                                       
    (and 13 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- virtual/perl-File-Spec-3.400.0-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (29 Mar 2015)
# Mask Perl 5.18 for removal. Please upgrade to Perl 5.20

- virtual/perl-IO-1.280.0-r1::gentoo (masked by: package.mask)
- virtual/perl-Storable-2.410.0-r1::gentoo (masked by: package.mask)
- virtual/perl-IO-Compress-2.60.0-r1::gentoo (masked by: package.mask)
- virtual/perl-Digest-MD5-2.520.0-r2::gentoo (masked by: package.mask)
- virtual/perl-Scalar-List-Utils-1.270.0-r2::gentoo (masked by: package.mask)
- app-emulation/emul-linux-x86-sdl-20140508-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (28 Mar 2015)
# on behalf of gx86-multilib project <multilib@gentoo.org>
# Mask emul-linux-x86 packages along with unported old versions
# of reverse dependencies for removal in 60 days, bug #544876.
# Please use multilib ebuilds with abi_x86_32 instead.

- virtual/perl-Encode-2.490.0-r2::gentoo (masked by: package.mask)
- media-libs/sk1libs-0.9.1-r3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (11 Apr 2015)
# media-libs/lcms:0 has serious security issues, is unmaintained
# and will be removed soon, see bug 526642
# Here we remove its last unconditional/unported reverse dependencies,
# media-libs/sk1libs media-gfx/uniconvw sci-libs/libecwj2
# (removal in 30 days).

- virtual/perl-Compress-Raw-Zlib-2.60.0-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


What I really don't understand (and I would really appreciate some help here) is how to read these messages...

Thanks!
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Sat May 23, 2015 12:46 pm    Post subject: Reply with quote

So, in a semi-random order:
- you've got a silly locale (that is to say these days any non-utf8 is silly), though that most likely irrelevant here
- I'd say it would be better to clear up that perl upgrade first (there is a clear and simple solution described in many threads here)
- add '--verbose-conflicts' to that emerge line, so we could see if there really is a problem here or is that just misleading output
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Sat May 23, 2015 1:41 pm    Post subject: Reply with quote

-Excuse me? What silly locale? My system is UTF8!

-About perl: Should I mask it?

- Now, verbose-conflicts gives:
Code:
# emerge -v icu --verbose-conflicts
                               
 * IMPORTANT: 14 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
                               
These are the packages that would be merged, in order:
                               
Calculating dependencies... done!
[ebuild     U  ] dev-libs/icu-54.1-r1:0/54a::gentoo [53.1:0/53::gentoo] USE="-debug -doc -examples -static-libs" ABI_X86="(64) -32 (-x32)" 24889 KiB

Total: 1 package (1 upgrade), Size of downloads: 24889 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-54.1-r1:0/54a::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu (Argument)

  (dev-libs/icu-53.1:0/53::gentoo, installed) pulled in by
    dev-libs/icu:0/53= required by (net-nds/openldap-2.4.38-r2:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    dev-libs/icu:0/53= required by (app-text/libebook-0.1.2:0/0::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/53= required by (media-libs/libcdr-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/53= required by (media-libs/raptor-2.0.9:2/2::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/53=[abi_x86_64(-)] required by (dev-db/sqlite-3.8.6:3/3::gentoo, installed)
                ^^^^^^                                                                                                           
    >=dev-libs/icu-49:0/53= required by (dev-qt/qtcore-4.8.5-r2:4/4::gentoo, installed)
                     ^^^^^^                                                                                               
    >=dev-libs/icu-3.6:0/53=[abi_x86_64(-)] required by (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, installed)
                      ^^^^^^                                                                                                                     
    >=dev-libs/icu-51.2-r1:0/53=[abi_x86_64(-)] required by (dev-libs/libxml2-2.9.1-r4:2/2::gentoo, installed)
                          ^^^^^^                                                                                                                 
    >=dev-libs/icu-51.2-r1:0/53=[abi_x86_64(-)] required by (media-libs/harfbuzz-0.9.28:0/0.9.18::gentoo, installed)
                          ^^^^^^                                                                                                                       
    dev-libs/icu:0/53= required by (media-sound/mpd-0.19.6:0/0::gentoo, installed)
                ^^^^^^                                                                                               
    dev-libs/icu:0/53= required by (app-text/libmspub-0.1.2:0/0::gentoo, installed)
                ^^^^^^                                                                                                 
    >=dev-libs/icu-4.8.1.1:0/53= required by (app-office/libreoffice-4.3.5.2:0/0::gentoo, installed)
                          ^^^^^^                                                                                                       
    dev-libs/icu:0/53= required by (media-libs/libvisio-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    dev-libs/icu:0/53= required by (dev-qt/qtwebkit-4.8.5:4/4::gentoo, installed)
                ^^^^^^                                                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- virtual/perl-File-Spec-3.400.0-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (29 Mar 2015)
# Mask Perl 5.18 for removal. Please upgrade to Perl 5.20

- virtual/perl-IO-1.280.0-r1::gentoo (masked by: package.mask)
- virtual/perl-Storable-2.410.0-r1::gentoo (masked by: package.mask)
- virtual/perl-IO-Compress-2.60.0-r1::gentoo (masked by: package.mask)
- virtual/perl-Digest-MD5-2.520.0-r2::gentoo (masked by: package.mask)
- virtual/perl-Scalar-List-Utils-1.270.0-r2::gentoo (masked by: package.mask)
- app-emulation/emul-linux-x86-sdl-20140508-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (28 Mar 2015)
# on behalf of gx86-multilib project <multilib@gentoo.org>
# Mask emul-linux-x86 packages along with unported old versions
# of reverse dependencies for removal in 60 days, bug #544876.
# Please use multilib ebuilds with abi_x86_32 instead.

- virtual/perl-Encode-2.490.0-r2::gentoo (masked by: package.mask)
- media-libs/sk1libs-0.9.1-r3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (11 Apr 2015)
# media-libs/lcms:0 has serious security issues, is unmaintained
# and will be removed soon, see bug 526642
# Here we remove its last unconditional/unported reverse dependencies,
# media-libs/sk1libs media-gfx/uniconvw sci-libs/libecwj2
# (removal in 30 days).

- virtual/perl-Compress-Raw-Zlib-2.60.0-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Wed Jun 10, 2015 6:59 am    Post subject: Reply with quote

I managed to solve part of the problem by adding 'ABI_X86="64 32" to 'make.conf' and unmerging all emul-linux-x86-* packages.

Then doing some package.mask sorting did the trick.

Thanks!
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum