Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] - Bootsplash ... come averlo ???
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
matthew_s
n00b
n00b


Joined: 18 Feb 2010
Posts: 27

PostPosted: Tue Apr 13, 2010 5:15 pm    Post subject: [Risolto] - Bootsplash ... come averlo ??? Reply with quote

Ciao a tutti !!
Ho bisogno di aiuto :roll:

E' da un bel pò di tempo che cerco di mettere il bootsplash, sulla mia Gentoo, ma proprio non riesco...

Allora attualmente ho il kernel gentoo-sources 2.6.33-r1 con

Device Driver -> Graphics Support -> (M) Support for framebuffer devices dove :

(*)Enable video mode handling helper
(M)userspace vesa vga graphics support

Ho seguito anche la guida su uvesa che diceva di impostare:

(*)initial ram filesystem e ram disk (initrams/initrd) support
/usr/share/v86d/initrams


al Grub ho aggiunto questo ---> video=uvesafb:mtrr:3,ywrap,1024x768-24@60 e initrd (hd0,6)/boot/initramfs-bootsplash


Quando avvio questo kernel dopo i messaggi iniziali che si visualizzano , appare la schermata nera che non va via.... impedendomi di avviare il sistema, non appare kdm insomma, però il sistema non si blocca resta funzionante , difatti se clicco sul pulsante di accensione si spegne correttamente

Qualcuno di voi ha esperienza con il bootsplash ... riesce ad averlo ??? Io ho una Ati RADEON HD 3470 :?


Last edited by matthew_s on Thu Apr 22, 2010 8:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Tue Apr 13, 2010 8:43 pm    Post subject: Reply with quote

questi due li hai già visti?

http://en.gentoo-wiki.com/wiki/Framebuffer
http://en.gentoo-wiki.com/wiki/Fbsplash

hai provato anche con il framebuffer vesa generico?
Back to top
View user's profile Send private message
matthew_s
n00b
n00b


Joined: 18 Feb 2010
Posts: 27

PostPosted: Fri Apr 16, 2010 6:23 pm    Post subject: Reply with quote

Ho risolto una parte , la risoluzione sono riuscito ad attivarla, pero' la schermata poi mi resta nera... quando dovrebbe vedersi lo splash , e poi tutto ok arriva kdm. Avevo sbagliato impostando come modulo Uvesa

Ho seguito i due link , ma non riesco a capire il perchè dello schermo nero.

Ho usato splashutils per generare l'immagine ma non vede poi
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Fri Apr 16, 2010 7:24 pm    Post subject: Reply with quote

se il framebuffer è attivo ma non si vede il tema che hai scelto, probabilmente è un problema con quest'ultimo, magari hai digitato male le opzioni del kernel, o il nome del tema non è quello. prova anche con un altro tema
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Tue Apr 20, 2010 3:03 pm    Post subject: Reply with quote

Mi sembrava tempo fa di aver notato che il sistema andasse in cerca del tema "default" indipendentemente dal nome reale del tema scelto, io avevo risolto creando un link simbolico /etc/splash/default alla cartella del tema che volevo, poi avevo seguito tutti i passaggi delle guide indicate usando come nome del tema "default"...
Back to top
View user's profile Send private message
matthew_s
n00b
n00b


Joined: 18 Feb 2010
Posts: 27

PostPosted: Thu Apr 22, 2010 8:16 pm    Post subject: Reply with quote

Sono riuscito a sistemare , commettevo qualche errore nella generazione dell'immagine initrd, grazie per i link
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum