Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
scanning for wd7000, gentoo noload=pata_qdi [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 454
Location: Ljubljana, Slovenia

PostPosted: Tue Apr 13, 2010 1:59 pm    Post subject: scanning for wd7000, gentoo noload=pata_qdi [SOLVED] Reply with quote

I am attempting to install Gentoo for the first time
(for several days now, heh)

I have dell's latitude d500

I used install-x86-minimal-20100216.iso

when I inserted cd and wrote 'gentoo' computer freezed on scanning wd7000, or pata_qdi.
I 'solved' this problem with:
gentoo noload=pata_qdi
sugessted from these sites:
https://bugs.gentoo.org/288222
https://bugs.gentoo.org/252635

After several bumps , I believe I installed Gentoo.
I used genkernel (since these are my first attempts to install Gentoo),
and I made my GRUB.

When I start Genotoo, I choose the only one installation
and the lines start to scroll down the window, which I assume is ok.

Problem is, that computer freezes at:
scanning for wd7000

Again, no keyboard response, only shutdown while holding the power button for 5 seconds.


Is there a solution for this?
_________________
Kind regards, Goran Mitic

alive
while true
kick ass


Last edited by while true on Fri May 07, 2010 8:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Tue Apr 13, 2010 2:24 pm    Post subject: Reply with quote

Another solution would be to disable all other modules from loading and only load the modules you need.
You can find the modules you need by using a Ubuntu livecd and then do 'lspci -v' which will show which ones you need.
You can than add 'nodetect doload=<comma seperated list of modules you need>
I think your hardware doesn't deal so well with random probes all over the place.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7193
Location: almost Mile High in the USA

PostPosted: Tue Apr 13, 2010 2:28 pm    Post subject: Reply with quote

It looks like the cursed driver is pata_qdi, did you include this in your custom kernel (as a module or not?) Perhaps either not compiling it, or blacklisting it in /etc/modprobe.d/blacklist.conf ?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 454
Location: Ljubljana, Slovenia

PostPosted: Tue Apr 13, 2010 3:58 pm    Post subject: Reply with quote

Ola, I got help from another topic, and it work as charm:


[quote="Mike Hunt"]
while true wrote:

If using noload=pata_qdi works, then just append it to the end of the kernel line in grub.conf:
Code:
kernel /boot/kernel-genkernel-x86-2.6.31-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3 noload=pata_qdi


_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum