Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema dipendenze (libjpeg.so.7) [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Thu Apr 08, 2010 8:40 pm    Post subject: Problema dipendenze (libjpeg.so.7) [risolto] Reply with quote

Stavo facendo un po' di pulizia con revdep-rebuild e leggo diversi messaggi di problemi a diverse applicazioni che dipendono dalla libreria libjpeg.so.7.
Lancio un revdep-rebuild --library libjpeg.so.7 e attendo...13 pacchetti ricompilati e sembra tutto ok.
Rilancio un semplice revdep-rebuild per verificare che tutto è tornato a posto ed ecco che di nuovo
Code:
# revdep-rebuild
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 97% ]  *   broken /usr/qt/3/bin/assistant (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/designer (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/linguist (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/lrelease (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/lupdate (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/msg2qm (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/qembed (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/qm2ts (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/qtconfig (requires libjpeg.so.7)
 *   broken /usr/qt/3/bin/uic (requires libjpeg.so.7)
 *   broken /usr/qt/3/lib/libqt-mt.so.3.3.8 (requires libjpeg.so.7)
 *   broken /usr/qt/3/lib/libqui.so.1.0.0 (requires libjpeg.so.7)
 *   broken /usr/qt/3/plugins/designer/libcppeditor.so (requires libjpeg.so.7)
 *   broken /usr/qt/3/plugins/designer/libdlgplugin.so (requires libjpeg.so.7)
 *   broken /usr/qt/3/plugins/designer/libgladeplugin.so (requires libjpeg.so.7)
 *   broken /usr/qt/3/plugins/designer/libkdevdlgplugin.so (requires libjpeg.so.7)
 *   broken /usr/qt/3/plugins/designer/librcplugin.so (requires libjpeg.so.7)
 *   broken /usr/qt/3/plugins/designer/libwizards.so (requires libjpeg.so.7)
 *   broken /usr/qt/3/plugins/sqldrivers/libqsqlmysql.so (requires libjpeg.so.7)
[ 100% ]
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/qt/3/bin/assistant -> x11-libs/qt
 *   /usr/qt/3/bin/designer -> x11-libs/qt
 *   /usr/qt/3/bin/linguist -> x11-libs/qt
 *   /usr/qt/3/bin/lrelease -> x11-libs/qt
 *   /usr/qt/3/bin/lupdate -> x11-libs/qt
 *   /usr/qt/3/bin/msg2qm -> x11-libs/qt
 *   /usr/qt/3/bin/qembed -> x11-libs/qt
 *   /usr/qt/3/bin/qm2ts -> x11-libs/qt
 *   /usr/qt/3/bin/qtconfig -> x11-libs/qt
 *   /usr/qt/3/bin/uic -> x11-libs/qt
 *   /usr/qt/3/lib/libqt-mt.so.3.3.8 -> x11-libs/qt
 *   /usr/qt/3/lib/libqui.so.1.0.0 -> x11-libs/qt
 *   /usr/qt/3/plugins/designer/libcppeditor.so -> x11-libs/qt
 *   /usr/qt/3/plugins/designer/libdlgplugin.so -> x11-libs/qt
 *   /usr/qt/3/plugins/designer/libgladeplugin.so -> x11-libs/qt
 *   /usr/qt/3/plugins/designer/libkdevdlgplugin.so -> x11-libs/qt
 *   /usr/qt/3/plugins/designer/librcplugin.so -> x11-libs/qt
 *   /usr/qt/3/plugins/designer/libwizards.so -> x11-libs/qt
 *   /usr/qt/3/plugins/sqldrivers/libqsqlmysql.so -> x11-libs/qt
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Portage could not find any version of the following packages it could build:
 * x11-libs/qt:3
 * (Perhaps they are masked, blocked, or removed from portage.)
 * Try to emerge them manually.
 * Warning: Portage cannot rebuild any of the necessary packages.


Last edited by mrl4n on Fri Apr 09, 2010 3:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu Apr 08, 2010 8:48 pm    Post subject: Reply with quote

qt3 è stato rimosso da un pezzo da portage, ti conviene toglierlo e passare a nuove versioni (e\o alternative) dei programmi che te lo richiedono.
Ci sarebbe sempre l'overlay kde-sunset (o qualcosa del genere)
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Fri Apr 09, 2010 3:39 pm    Post subject: Reply with quote

@mrl4n: bastava leggere l'output:
Quote:
* Portage could not find any version of the following packages it could build:
* x11-libs/qt:3
* (Perhaps they are masked, blocked, or removed from portage.)

_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Apr 09, 2010 3:53 pm    Post subject: Reply with quote

!equilibrium wrote:
@mrl4n: bastava leggere l'output:
Quote:
* Portage could not find any version of the following packages it could build:
* x11-libs/qt:3
* (Perhaps they are masked, blocked, or removed from portage.)


...spesso sono troppo frettoloso... :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum