Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ελληνικά σε console [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Greek
View previous topic :: View next topic  
Author Message
atmosx
n00b
n00b


Joined: 17 Jul 2009
Posts: 37
Location: Brno

PostPosted: Thu May 12, 2011 10:10 am    Post subject: Ελληνικά σε console [SOLVED] Reply with quote

Καλησπέρα,

Έχω εγκαταστήσει gentoo κι ενώ έχω Ελληνικά σε X11 applications (browsers/abiword) δεν έχω στα terminals (Eterm/aterm) και σε console. Ακόμη και οι ημερομηνίες και ώρες δεν εμφανίζονται σωστά, είναι σαν «κινέζικα».

Όταν δίνω date από macosx Terminal (via ssh) που υποστηρίζει πλήρως UTF-8 διαβάζω κανονικά (Ελληνικά) τα αποτελέσματα. Όταν δίνω την ίδια εντολή από console όμως όχι.

Τα αρχεία μου:
Code:

amilo linux # cat /etc/locale.gen
[...]
en_US ISO-8859-1
en_US.UTF-8 UTF-8
en_US.utf8@euro UTF-8
el_GR.UTF-8 UTF-8
el_GR@euro ISO-8859-7
el_GR.UTF-8@euro UTF-8


amilo linux # cat /etc/env.d/02locale
LC_CTYPE="el_GR.utf8"
LC_NUMERIC="el_GR.utf8"
LC_TIME="el_GR.utf8"
LC_COLLATE="C"
LC_MONETARY="el_GR.utf8@euro"
LC_MESSAGES="en_US.utf8"
LC_PAPER="el_GR.utf8"
LC_NAME="el_GR.utf8"
LC_ADDRESS="el_GR.utf8"
LC_TELEPHONE="el_GR.utf8"
LC_MEASUREMENT="el_GR.utf8"
LC_IDENTIFICATION="el_GR.utf8"
#LC_ALL="el_GR.utf8@euro"
LANG="el_GR.utf8@euro"
LANGUAGE="el_GR:el:en_US:en"
LC_ALL=""


Έχω τρέξει, locale-gen στα USE flags έχω 'utf8' και στα Linguas='en el'. Αν έχετε κανένα hint, please share.

Ευχαριστώ,
_________________
Never argue with an idiot.


Last edited by atmosx on Tue May 17, 2011 10:06 am; edited 1 time in total
Back to top
View user's profile Send private message
g3om1s
n00b
n00b


Joined: 21 Feb 2010
Posts: 8

PostPosted: Fri May 13, 2011 9:18 am    Post subject: Reply with quote

έκανες env-update && source /etc/profile μέτα την δημιουργεία του /etc/env.d/02locale;
Back to top
View user's profile Send private message
atmosx
n00b
n00b


Joined: 17 Jul 2009
Posts: 37
Location: Brno

PostPosted: Fri May 13, 2011 7:28 pm    Post subject: Reply with quote

g3om1s wrote:
έκανες env-update && source /etc/profile μέτα την δημιουργεία του /etc/env.d/02locale;


Ναι τα έχω κάνει όλα αυτά πολλές φορές. Το πρόβλημα είναι ότι για κάποιο λόγο σε console αλλά και σε terminals (aterm/Eterm) δεν υποστηρίζει UTF-8 encoding τίποτα. Περιέργο γιατί έχω και utf8 στα use, kernel support build-in και όλα τα configurations είναι έτσι ώστε να παίζει το utf8.

Αναρωτιέμαι μήπως έχει δημιουργήσει προβλήματα το nls που έχω στα use flags.
_________________
Never argue with an idiot.
Back to top
View user's profile Send private message
g3om1s
n00b
n00b


Joined: 21 Feb 2010
Posts: 8

PostPosted: Fri May 13, 2011 9:00 pm    Post subject: Reply with quote

atmosx wrote:
g3om1s wrote:
έκανες env-update && source /etc/profile μέτα την δημιουργεία του /etc/env.d/02locale;


Ναι τα έχω κάνει όλα αυτά πολλές φορές. Το πρόβλημα είναι ότι για κάποιο λόγο σε console αλλά και σε terminals (aterm/Eterm) δεν υποστηρίζει UTF-8 encoding τίποτα. Περιέργο γιατί έχω και utf8 στα use, kernel support build-in και όλα τα configurations είναι έτσι ώστε να παίζει το utf8.

Αναρωτιέμαι μήπως έχει δημιουργήσει προβλήματα το nls που έχω στα use flags.


Απ' όσο γνωρίζω το aterm δεν υποστηρίζει unicode όσο για το eterm θα πρέπει να ενεργοποιήσεις την use flag unicode
θα σου συνιστούσα το rxvt-unicode σε σχέση με τα {a,e}term
Back to top
View user's profile Send private message
atmosx
n00b
n00b


Joined: 17 Jul 2009
Posts: 37
Location: Brno

PostPosted: Mon May 16, 2011 11:31 am    Post subject: Reply with quote

g3om1s wrote:
atmosx wrote:
g3om1s wrote:
έκανες env-update && source /etc/profile μέτα την δημιουργεία του /etc/env.d/02locale;


Ναι τα έχω κάνει όλα αυτά πολλές φορές. Το πρόβλημα είναι ότι για κάποιο λόγο σε console αλλά και σε terminals (aterm/Eterm) δεν υποστηρίζει UTF-8 encoding τίποτα. Περιέργο γιατί έχω και utf8 στα use, kernel support build-in και όλα τα configurations είναι έτσι ώστε να παίζει το utf8.

Αναρωτιέμαι μήπως έχει δημιουργήσει προβλήματα το nls που έχω στα use flags.


Απ' όσο γνωρίζω το aterm δεν υποστηρίζει unicode όσο για το eterm θα πρέπει να ενεργοποιήσεις την use flag unicode
θα σου συνιστούσα το rxvt-unicode σε σχέση με τα {a,e}term


Έχει γίνει compile το Eterm με +unicode.Το rxvt-unicode αν κι έχει γίνει install δεν βλέπω πουθενά το binary(!). Σε κάθε περίπτωση, όμως, έχω την εντύπωση ότι γενικότερα το σύστημα υποστηρίζει UTF-8 μόνοσε X-applications κι όχι σε console/terminal(s).

:-(
_________________
Never argue with an idiot.
Back to top
View user's profile Send private message
g3om1s
n00b
n00b


Joined: 21 Feb 2010
Posts: 8

PostPosted: Mon May 16, 2011 3:37 pm    Post subject: Reply with quote

atmosx wrote:
g3om1s wrote:
atmosx wrote:
g3om1s wrote:
έκανες env-update && source /etc/profile μέτα την δημιουργεία του /etc/env.d/02locale;


Ναι τα έχω κάνει όλα αυτά πολλές φορές. Το πρόβλημα είναι ότι για κάποιο λόγο σε console αλλά και σε terminals (aterm/Eterm) δεν υποστηρίζει UTF-8 encoding τίποτα. Περιέργο γιατί έχω και utf8 στα use, kernel support build-in και όλα τα configurations είναι έτσι ώστε να παίζει το utf8.

Αναρωτιέμαι μήπως έχει δημιουργήσει προβλήματα το nls που έχω στα use flags.


Απ' όσο γνωρίζω το aterm δεν υποστηρίζει unicode όσο για το eterm θα πρέπει να ενεργοποιήσεις την use flag unicode
θα σου συνιστούσα το rxvt-unicode σε σχέση με τα {a,e}term


Έχει γίνει compile το Eterm με +unicode.Το rxvt-unicode αν κι έχει γίνει install δεν βλέπω πουθενά το binary(!). Σε κάθε περίπτωση, όμως, έχω την εντύπωση ότι γενικότερα το σύστημα υποστηρίζει UTF-8 μόνοσε X-applications κι όχι σε console/terminal(s).

:-(


To rxvt-unicode το τρέχεις με urxvt ή /usr/bin/urxvt
σου παραθέτω το δικό μου /etc/env.d/02locale με το οποίο τρέχουν όλα κομπλέ
Code:

LANG="en_US.UTF-8"
LC_COLLATE="C"


μήπως πρέπει την μεταβλητή
Code:
LANG="el_GR.utf8@euro"
να διορθώσεις με
Code:
LANG="en_US.UTF-8"
ή με
Code:
LANG="el_GR.UTF-8"
?
ρίξε μια ματιά και σε αυτό http://forum.hellug.gr/index.php?topic=380.0
Back to top
View user's profile Send private message
atmosx
n00b
n00b


Joined: 17 Jul 2009
Posts: 37
Location: Brno

PostPosted: Tue May 17, 2011 10:05 am    Post subject: Reply with quote

Καλησπέρα,

Σε ευχαριστώ για την βοήθεια! Το rxvt-unicode αναγνωρίζει Ελληνικά κανονικότατα! Άλλαξα και τα locale κι όλα παίζουν! Ευχαριστώ πολύ για την βοήθεια!

Καλή συνέχεια!
_________________
Never argue with an idiot.
Back to top
View user's profile Send private message
g3om1s
n00b
n00b


Joined: 21 Feb 2010
Posts: 8

PostPosted: Tue May 17, 2011 10:44 am    Post subject: Reply with quote

Υπάρχει και το #gentoo-el στο freenode για οτιδήποτε χρειάζεσε..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Greek All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum