Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dns resolution fails, where IP layer is alive
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
das bletch
n00b
n00b


Joined: 17 Feb 2009
Posts: 44
Location: oakland

PostPosted: Sat Apr 03, 2010 12:09 pm    Post subject: dns resolution fails, where IP layer is alive Reply with quote

My laptop suddenly stopped being able to translate host names, though I can ping out and get responses, (i can also look up website via ip address), the dns won't allow anything above that level from happening.

Ive edited resolve.conf, hosts, host.conf, and been over them so many times I can't figure out what is going on.

I can post contents of those files, though at this point I think the problem lays elsewhere, where I haven't thought of looking.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sat Apr 03, 2010 12:32 pm    Post subject: Reply with quote

WRONG filename. It's /etc/resolv.conf

I always recommend using BIND for DNS.
Back to top
View user's profile Send private message
das bletch
n00b
n00b


Joined: 17 Feb 2009
Posts: 44
Location: oakland

PostPosted: Sat Apr 03, 2010 5:38 pm    Post subject: Reply with quote

correct, i was assuming /etc/resolve.conf

I've set the nameserver to 192.168.1.254, which should work since its the gateway, but still no luck. another gentoo machine has no problem being online, and I can't see any difference in how they are configured.

I just moved and was using the laptop to get wireless via wifoo ninja tricks, until i was wired. but ever since then, the dns thing keeps happening.

Is there any possiblity that poisoning the arp cache of ap's could have some strange side effect on my machine?
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 679

PostPosted: Sat Apr 03, 2010 5:56 pm    Post subject: Reply with quote

Try setting the nameserver to 8.8.8.8 (google's public dns server) and/or 4.2.2.2 (L3's (?) public dns server).

If it works, the problem is with your dns server.
Back to top
View user's profile Send private message
lindegur
Apprentice
Apprentice


Joined: 14 Aug 2004
Posts: 281
Location: Swiss mountains

PostPosted: Sun Apr 04, 2010 1:09 pm    Post subject: Reply with quote

Editing /etc/resolv.conf is not so wise, since it will be overwritten by programs as dhcp or even gentoo initscripts.
Code:
cat /etc/resolv.conf
should show you what is inside. A better place to add nameservers is /etc/coonf.d/net where you can add a long list of nameservers as:
Code:
dns_servers_eth0=( "192.168.1.1 78.159.101.37 217.79.186.148" )
I assume the first IP address is your router, the other two are OpenNIC nameservers, so you get also names as: http://www.opennic.glue
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum