Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Aggiornamento gnome
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Fri Apr 02, 2010 2:03 pm    Post subject: Aggiornamento gnome Reply with quote

Salve a tutti! Come ben sapete nella branca stabile di gentoo gnome è presente nella versione 2.26 mentre è uscita addirittura la versione 2.30! Ho provato a smascherare gnome tramite il comando
Code:
echo "gnome-base/gnome" >> /etc/portage/package.keywords

ma puntualmente mi installa gnome 2.26. Avete qualche suggerimento per questo niubbo?
Grazie infinite in anticipo.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Fri Apr 02, 2010 2:56 pm    Post subject: Reply with quote

aggiungendo quel pacchetto a package.keyword dovrebbe installarti la versione 2.28.2

POtresti postare un output più preciso?
Per quanto riguarda la versione 2.30 verrà a breve introdotta in portage
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Apr 02, 2010 4:25 pm    Post subject: Reply with quote

gnome-base/gnome è solamente un meta-pacchetto, utile per installare in un solo botto tutte quante le sue dipendenze. Ergo di per se non installa niente, nemmeno un file, ma si tira dietro tutto quanto è "gnome" secondo gli sviluppatori di gnome stesso.
Per fare un upgrade di gnome non basta smascherare quel pacchetto, ma anche tutti quanti i vari programmi e librerie ( gtk+, gedit, eccetera )

ATTENZIONE
Per pacchetti così grossi esiste app-portage/autounmask che fa più o meno tutto il lavoro sporco automaticamente. È caldamente consigliato esaminare l'output che produce prima di dare emerge. A questo proposito non pensi che sarebbe meglio se imparassi un po' come funziona gentoo prima di riempirti la macchina di pacchetti che, per il momento, sono ancora considerati instabili (cioè potenzialmente portatori di problemi) ? Io l'ho messo la settimana scorsa e funziona tutto abbastanza bene anche se non c'è poi un'apprezzabile differenza con il .26 per l'uso che ne faccio io.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Fri Apr 02, 2010 5:20 pm    Post subject: Reply with quote

Per quanto riguarda l'output non c'è molto da postare poichè io smascheravo quel pacchetto pensando che così facendo emerge mi avrebbe installato la versione 2.28 (non pretendo la 2.30 che è uscita 2 giorni fa se non erro) ma se mi dite che non basta capisco che l'errore è stato mio... diciamo c'è stata una incomprensione tra me e portage :D
Onip non hai tutti i torti quando mi consigli di non riempirmi l'hdd di pacchetti instabili e infatti cerco di mantenermi sempre sulla stabile ma vedendo che è uscita la versione 2.30 mi sono detto che ormai potevo aggiornare alla 2.28. A questo punto mi sa che convenga rimanere nelle mani del team di gentoo e aspettare che siano loro a dire che la versione 2.28 sia stabile. Per puro scopo didattico potresti dirmi come funziona autounmask?
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Fri Apr 02, 2010 5:23 pm    Post subject: Re: Aggiornamento gnome Reply with quote

davedeth wrote:
Salve a tutti! Come ben sapete nella branca stabile di gentoo gnome è presente nella versione 2.26 mentre è uscita addirittura la versione 2.30! Ho provato a smascherare gnome tramite il comando


a discapito di quanti asseriscono che Gentoo è una distro "bleeding edge", non lo è e non lo è mai stata, o meglio, non esiste distro (seria) al mondo che dopo poche ore dal rilascio di una nuova versione di un qualsiasi software questo sia giù presente nei repository stabile. E' già tanto se lo trovi nel branch ~arch a 48h dal rilascio, infatti Gnome 2.30 non c'è in portage: http://packages.gentoo.org/package/gnome-base/gnome

p.s.: rileggersi attentamente l'handbook :wink:
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Fri Apr 02, 2010 5:46 pm    Post subject: Reply with quote

Scusate ma ora rileggendo meglio il post ho capito di essermi spiegato veramente male. Io non pretendo gnome 2.30 sia ben chiaro :D Cercavo di averci la versione 2.28 poichè pensavo che ormai potesse essere abbastanza stabile. Non intendo dire che debba essere messa nel ramo stabile ma che potevo provare ad installare una versione un po' più nuova.
Comunque mi sa che alla fin fine mi conviene rimanere con il fidato gnome presente nel ramo stabile.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Fri Apr 02, 2010 10:52 pm    Post subject: Reply with quote

Onip wrote:
Per fare un upgrade di gnome non basta smascherare quel pacchetto, ma anche tutti quanti i vari programmi e librerie ( gtk+, gedit, eccetera )


Beh in effetti non avevo mai smascherato un metapacchetto...e mi sono accorto solo ora della boiata scritta sopra............ :oops:
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sat Apr 03, 2010 6:08 am    Post subject: Reply with quote

Quindi smascherando il metapacchetto teoricamente dovrebbe fare tutto lui? Se è così qualcosa non torna visto che mi installa sempre la versione stabile.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Sat Apr 03, 2010 7:11 am    Post subject: Reply with quote

@davedeth
La cosa più facile è che prendi l'ebuild di gnome e te lo leggi. Come puoi vedere è solamente un lungo elenco di pacchetti che, se controlli, sono per la maggiorparte ancora ~. emerge è abbastanza intelligente da controllare che tutte le dipendenze di un pacchetto siano installabili (cioè stabili o smascherate) prima di provvedere all'ugrade e, se non sbaglio, con l'ultima versione dovrebbe anche avvisarti del fatto che lascia indietro un upgrade per via di problemi del genere.

Per autounmask è abbastanza semplice.
Code:
# autounmask =gnome-base/gnome-2.28.2

e lui ti crea e riempie i file in /etc/portage/ in modo che sia tutto smascherato. Per le opzioni basta
Code:
# autounmask --help

_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sat Apr 03, 2010 7:31 am    Post subject: Reply with quote

E dove si trovano gli ebuild?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Apr 03, 2010 7:45 am    Post subject: Reply with quote

:roll:
in generale in
Code:
/usr/portage/$categoria/$nomepacchetto


nel tuo caso è:
Code:
/usr/portage/gnome-base/gnome/gnome-2.28.2.ebuild

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sat Apr 03, 2010 7:57 am    Post subject: Reply with quote

Grazie infinite per le risposte! Adesso mi sento spericolato e provo ad usare autounmask, vi farò sapere i risultati :D
Back to top
View user's profile Send private message
Slayer86
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2007
Posts: 98

PostPosted: Sat Apr 10, 2010 11:22 am    Post subject: Reply with quote

davedeth wrote:
Grazie infinite per le risposte! Adesso mi sento spericolato e provo ad usare autounmask, vi farò sapere i risultati :D


Io invece ti consiglio di aspettare un mesetto... poi gnome 2.28 verrà stabilizato e gnome 2.30 verra messo in portage come testing...
Se fai il passaggio ora avresti qualche problema per passare a 2.28 per poi averne tanti tra un mesetto per passare a 2.30...

Uso gnome unstable da sempre ma non so se conviene realmente questa cosa...


p.s. autounmask smaschera tutte le versioni unstable di gnome oppure solo la versione che indichi???
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Sat Apr 10, 2010 11:24 am    Post subject: Reply with quote

quella che indichi ;)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum