Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sendmail - Domain of sender address does not exist
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
v1pEr
n00b
n00b


Joined: 20 Apr 2009
Posts: 63

PostPosted: Mon Mar 29, 2010 7:56 pm    Post subject: Sendmail - Domain of sender address does not exist Reply with quote

I am running sendmail together with fetchmail to fetch mails ( :wink: ) from several accounts and deliver to a few home accounts.

Whenever i get an email from a domain which doesn't exist, it refuses to deliver it to my mailbox. I would however like these mails to be delivered too, as it's almost never spam (i got spamassassin running so spam is not really an issue here) but often from senders I want to receive email from.

An example of such an email in /var/log/fetchmail/current
Quote:

Mar 29 21:47:45 [fetchmail] reading message xxx@xxx.xxx:1 of 1 (25162 octets) (log message incomplete)_
Mar 29 21:47:45 [fetchmail] SMTP error: 553 5.1.8 <m-xsn77jna_a7bm8dnc09sczvvhzbl98wb_as44y3@bounce.linkedin.com>... Domain of sender address m-xsn77jna_a7bm8dnc09sczvvhzbl98wb_as44y3@bounce.linkedin.com does not exist_
Mar 29 21:47:45 [fetchmail] not flushed_


How can I configure sendmail to still allow these emails to be delivered? Right now the emails keep bouncing between my email provider and my mailserver untill either one get's too annoyed and drops it.

Thanks in advance!

(PS: I did search these forums and the internet but didn't find any clear posts that could help me with this (I'm not too advanced with linux :) )
Back to top
View user's profile Send private message
mimosinnet
l33t
l33t


Joined: 10 Aug 2006
Posts: 686
Location: Barcelona, Spain

PostPosted: Tue Mar 30, 2010 9:53 am    Post subject: Reply with quote

I use fetchmail and procmail to fetch mails from different accounts and deliver them locally. I get all the mails independently of the domains they are sent from. This is my .fechmailrc configuration:

Code:
set logfile /var/log/fetchmail.log
set no bouncemail
# poll pop.correo.yahoo.es protocol POP3 service 110 
#    user "user" password "password" fetchall
#    mda "/usr/bin/procmail -a YAHOO -d %T"

# Sembla que no funciona el password
# poll pop3.auna.com protocol POP3 service 110 
#    user "user" password "password" fetchall
#    mda "/usr/bin/procmail -a MENTA -d %T"

poll pop.gmail.com protocol POP3 service 995
   user "user" password "password" fetchall
   ssl
   mda "/usr/bin/procmail -a GMAIL -d %T"
poll imap.uab.es protocol IMAP service 143
   user "user" password "password" fetchall
   mda "/usr/bin/procmail -a UAB -d %T"

# poll imap.uab.es protocol IMAP service 143
#    user "user" password "password" fetchall keep
#    mda "/usr/bin/procmail -a FIC -d %T"

# This one is for wrongly recognised spam
poll localhost protocol IMAP
   user user password password
   fetchall
   no rewrite
   folder IN.Spam_Fallat
   mda "/usr/bin/sa-learn --spam"

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum