Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
resolved
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Sat Mar 27, 2010 7:46 pm    Post subject: resolved Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:24 pm; edited 2 times in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Sat Mar 27, 2010 8:02 pm    Post subject: Reply with quote

hai provato anche a installare i driver in testing? ( 195.36.15 )
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Mar 27, 2010 8:03 pm    Post subject: Reply with quote

Hai provato ad aggiornare i driver all'ultima versione?
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Sat Mar 27, 2010 8:07 pm    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Sat Mar 27, 2010 8:11 pm    Post subject: Reply with quote

sky.return wrote:
come posso fare per installlare l'ultima versione?

Code:
echo "x11-drivers/nvidia-drivers" >> /etc/portage/package.keywords
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Sat Mar 27, 2010 8:16 pm    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Mar 27, 2010 9:25 pm    Post subject: Reply with quote

avrai sbagliato a digitare qualcosa, controlla che /etc/portage/package.keywords esista e che il suo contenuto sia corretto
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Sat Mar 27, 2010 11:30 pm    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Sun Mar 28, 2010 1:44 am    Post subject: Reply with quote

nel file package.keywords devi avere solo categoria/nomepacchetto (nel tuo caso)

quind togli apici virgolette e roba varia

sky.return wrote:
PS: che differenza c'è tra .keyword & .unmask?

man portage :D

ma per farla breve in .keyword smascheri i pacchetti, quindi usi i testing (~)
mentre in .unmask smascheri i cosiddetti hardmasked (M)
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Sun Mar 28, 2010 9:13 am    Post subject: Reply with quote

ago88 wrote:
nel file package.keywords devi avere solo categoria/nomepacchetto (nel tuo caso)

quind togli apici virgolette e roba varia

sky.return wrote:
PS: che differenza c'è tra .keyword & .unmask?

man portage :D

ma per farla breve in .keyword smascheri i pacchetti, quindi usi i testing (~)
mentre in .unmask smascheri i cosiddetti hardmasked (M)
ieri ho avuto lo stesso problema, poi ho provato
Code:
lafilefixer --justfixit

ed ho riavviato la compilazione, che finalmente è riuscita... Spero non sia stato un caso e possa risolvere anche a te.
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Sun Mar 28, 2010 9:19 am    Post subject: Reply with quote

spillo wrote:
ieri ho avuto lo stesso problema, poi ho provato
Code:
lafilefixer --justfixit


teoricamente non dovrebbe essere quello il problema...ma dopo ogni aggiornamento lanciare quei tool sarebbe una buona cosa, quindi è consigliabile:
Code:
emerge --sync; emerge -DuNav world; revdep-rebuild; lafilefixer --justfixit


oppure usare il mitico GLAU!
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Sun Mar 28, 2010 12:06 pm    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Sun Mar 28, 2010 12:48 pm    Post subject: Reply with quote

sky.return wrote:
GLAU cosa sarebbe?

dai un'occhiata qui
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Sun Mar 28, 2010 6:43 pm    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Sun Mar 28, 2010 9:01 pm    Post subject: Reply with quote

hai creato la cartella portage?
Code:
mkdir /etc/portage

poi entraci dentro e crea il file package.keywords e ci scrivi
Code:
x11-drivers/nvidia-drivers
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Sun Mar 28, 2010 9:20 pm    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Sun Mar 28, 2010 9:26 pm    Post subject: Reply with quote

sicuramente hai sbagliato qualche carattere...perchè altrimenti è materialmente impossibile...
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Sun Mar 28, 2010 9:29 pm    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 837
Location: Villach, Austria

PostPosted: Mon Mar 29, 2010 9:18 am    Post subject: Reply with quote

è cambiata la posizione di un header nei sorgenti del kernel quindi bisogna patchare 2 files dei driver
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Mon Mar 29, 2010 11:00 am    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
sky.return
n00b
n00b


Joined: 06 Mar 2010
Posts: 17

PostPosted: Tue Mar 30, 2010 1:46 am    Post subject: Reply with quote

----

Last edited by sky.return on Sun Apr 04, 2010 2:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 837
Location: Villach, Austria

PostPosted: Tue Mar 30, 2010 9:51 am    Post subject: Reply with quote

sky.return wrote:
devilheart wrote:
è cambiata la posizione di un header nei sorgenti del kernel quindi bisogna patchare 2 files dei driver


quali sono i files da patchare ? la procedura?

è da cambiare conftest.sh e nv-linux.h
Code:
--- usr/src/nv/conftest.sh 2010-03-30 11:47:45.000000000 +0200
+++ usr/src/nv/conftest.sh 2010-03-30 11:46:47.000000000 +0200
@@ -111,7 +111,7 @@
     fi
 }

-CONFTEST_PREAMBLE="#include <linux/autoconf.h>
+CONFTEST_PREAMBLE="#include <generated/autoconf.h>
     #if defined(CONFIG_XEN) && \
         defined(CONFIG_XEN_INTERFACE_VERSION) &&  !defined(__XEN_INTERFACE_VERSION__)
     #define __XEN_INTERFACE_VERSION__ CONFIG_XEN_INTERFACE_VERSION
--- usr/src/nv/nv-linux.h  2010-03-30 11:47:52.000000000 +0200
+++ usr/src/nv/nv-linux.h  2010-03-30 11:47:13.000000000 +0200
@@ -14,7 +14,7 @@

 #include "nv.h"

-#include <linux/autoconf.h>
+#include <generated/autoconf.h>
 #include <linux/version.h>
 #include <linux/utsname.h>

nell'albero c'è già una patch ma si applica solo alla versione 190.53-r1 del driver
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum