Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iwlagn and Wireless N
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Cyberwizzard
Apprentice
Apprentice


Joined: 02 Apr 2004
Posts: 244
Location: Norway

PostPosted: Sat Mar 27, 2010 6:31 pm    Post subject: iwlagn and Wireless N Reply with quote

I have a iwlagn compatible Intel 4965 wifi controller in my XPS 1530. For years now I've been waiting for proper wireless N support for this driver but I was told that this should be working for ages now.

I have tested with a Linksys WRT160N router and a Conceptronic C300BRS4 (and tested with 2 wireless N routers at friends, don't now their brands) but I can't get the iwlagn driver to go into the wireless N mode. Rates never go over 54Mbit/s, not even if I put the router on top of my laptop. I live at the country side so the only wireless networks in the air are my own plus one of the neighbors.

I've been trying with each kernel upgrade to see if I can get it to go super sonic but every time I wind up with G speeds again. 'iwconfig' always shows that the 2.4GHz band is used, which means it can't use N without using the high speeds since N requires 5GHz (or am I mistaken?).

I am currently compiling kernel 2.6.34-rc2 (vanilla) and I am currently using 2.6.33 (gentoo sources). Any other iwlagn users out there know how to solve this?

Code:
lshw -c network
  *-network               
       description: Ethernet interface
       product: 88E8040 PCI-E Fast Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 12
       serial: 00:21:9b:cd:4b:fd
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.26 duplex=full firmware=N/A latency=0 link=no multicast=yes port=twisted pair speed=100MB/s
       resources: irq:29 memory:f1ffc000-f1ffffff ioport:de00(size=256)
  *-network
       description: Wireless interface
       product: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0b:00.0
       logical name: wlan0
       version: 61
       serial: 00:21:5c:5a:46:fb
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=2.6.33-gentoo firmware=228.61.2.24 ip=192.168.23.73 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:31 memory:f1efe000-f1efffff

_________________
More ramblings of a linux junky...
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Mar 28, 2010 10:51 am    Post subject: Reply with quote

I have seen posts from some people that setting the regulatory domain to their own country enables Wireless N mode:

Code:
sudo iw reg set FR


Will that help?
Back to top
View user's profile Send private message
Cyberwizzard
Apprentice
Apprentice


Joined: 02 Apr 2004
Posts: 244
Location: Norway

PostPosted: Sun Mar 28, 2010 11:53 am    Post subject: Reply with quote

Unfortunately not, when I insert the module in my kernel I get this:
Code:
iwlagn 0000:0b:00.0: PCI INT A disabled
iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:d
iwlagn: Copyright(c) 2003-2010 Intel Corporation
iwlagn 0000:0b:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn 0000:0b:00.0: setting latency timer to 64
iwlagn 0000:0b:00.0: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
iwlagn 0000:0b:00.0: Tunable channels: 13 802.11bg, 19 802.11a channels
iwlagn 0000:0b:00.0: irq 31 for MSI/MSI-X
iwlagn 0000:0b:00.0: firmware: requesting iwlwifi-4965-2.ucode
iwlagn 0000:0b:00.0: loaded firmware version 228.61.2.24
phy1: Selected rate control algorithm 'iwl-agn-rs'


So the driver does not even advertise the wireless N channels.

I have CRDA installed for the regulatory stuff (so I get the same frequency pre-selection as with your command) which shows as:
Code:
cfg80211: Calling CRDA to update world regulatory domain
cfg80211: World regulatory domain updated:
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)


I tried setting it by hand to France or the Netherlands but still no luck...
_________________
More ramblings of a linux junky...
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Mar 28, 2010 12:19 pm    Post subject: Reply with quote

Balen :) .

Try enabling CONFIG_WIRELESS_OLD_REGULATORY=y according to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/331092 fixes it the problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum