Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Wicd treating WEP network like WPA
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Hamsterkill
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2006
Posts: 81

PostPosted: Fri Mar 26, 2010 1:14 pm    Post subject: [Solved] Wicd treating WEP network like WPA Reply with quote

Hey, I'm trying to use wicd-curses to connect to a WEP network. The network gets detected as WEP correctly in the UI and it sets the encryption method setting to WEP in the conf file. However, it also sets the enctype setting in the conf file to wpa, and from the log it appears to be trying to use my WEP hex key as a WPA PSK. Any ideas what I might be doing wrong?

Last edited by Hamsterkill on Mon Mar 29, 2010 2:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Mar 26, 2010 4:30 pm    Post subject: Reply with quote

Can you post this :

Code:

# iwlist scan
Back to top
View user's profile Send private message
Hamsterkill
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2006
Posts: 81

PostPosted: Fri Mar 26, 2010 7:22 pm    Post subject: Reply with quote

Unfortunately I can't very effectively right now since I can't get my touchpad to work right with gpm yet.

Is there something specific from the output I could post or do you need it all?
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Mar 26, 2010 8:34 pm    Post subject: Reply with quote

Hi, is you have the net, you can try this :

Code:

# emerge -av wgetpaste
# iwlist scan | wgetpaste


And post the url :P
Back to top
View user's profile Send private message
Hamsterkill
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2006
Posts: 81

PostPosted: Fri Mar 26, 2010 8:57 pm    Post subject: Reply with quote

Code:
wlan0     Scan completed :
          Cell 01 - Address: 00:1A:70:EE:9E:9C
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=54/70  Signal level=-56 dBm 
                    Encryption key:on
                    ESSID:"my_essid"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000011e8b18a840
                    Extra: Last beacon: 60ms ago
                    IE: Unknown: 00064C4C436E6574
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A1E181AFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D16060D0700000000000000000000000000000000000000
                    IE: Unknown: DD090010180208F4010000
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C331E181AFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C34060D0700000000000000000000000000000000000000
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Mar 26, 2010 9:00 pm    Post subject: Reply with quote

Since, I don't see any WPA version, can you post this just to be sure :

Code:

# echo "net-wireless/iw" ­­>> /etc/portage/package.keywords
# emerge -av net-wireless/iw
# iw dev wlan0 scan
Back to top
View user's profile Send private message
Hamsterkill
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2006
Posts: 81

PostPosted: Fri Mar 26, 2010 9:38 pm    Post subject: Reply with quote

It is a WEP network. I can connect to it on the command line using "iwconfig essid "my_essid" key myhexkey". It's just that wicd tries to treat it as WPA when it tries to connect.

Code:
BSS 00:1a:70:ee:9e:9c (on wlan0) -- associated
   TSF: 1233170022795 usec (14d, 06:32:50)
   freq: 2437
   beacon interval: 100
   capability: ESS Privacy ShortSlotTime (0x0411)
   signal: -55.00 dBm
   SSID: my_essid
   Supported rates: 1.0* 2.0* 5.5* 11.0* 18.0 24.0 36.0 54.0
   DS Parameter set: channel 6
   ERP: <no flags>
   Extended supported rates: 6.0 9.0 12.0 48.0
   WMM:   * Parameter version 1
      * BE: CW 15-1023, AIFSN 3
      * BK: CW 15-1023, AIFSN 7
      * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
      * VO: acm CW 3-7, AIFSN 2, TXOP 1504 usec
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Mar 27, 2010 12:10 am    Post subject: Reply with quote

Can you post this :

Code:

# equery files net-misc/wicd | wgetpaste


There a config file that save what WICD set.

Once we find that file, after that we will try to understand what is going on.
Back to top
View user's profile Send private message
Hamsterkill
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2006
Posts: 81

PostPosted: Sat Mar 27, 2010 12:30 am    Post subject: Reply with quote

Are you talking about wireless-settings.conf?

If so I'll get back to you on Monday. Already gone home for weekend.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Mar 27, 2010 2:16 am    Post subject: Reply with quote

Yes I think that's the one.

Post that file, maybe we will find something.
Back to top
View user's profile Send private message
Hamsterkill
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2006
Posts: 81

PostPosted: Mon Mar 29, 2010 2:17 pm    Post subject: Reply with quote

Nevermind. I'm just an idiot and didn't know the heading for the key in wicd-curses was a dropdown. Once I selected WEP hex for the key, all was fine. Thanks for the help.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Mar 30, 2010 1:33 am    Post subject: Reply with quote

Nice :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum