Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]netmount, ntpd & sshd balk - wlan0 config problem...
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Tue Mar 23, 2010 2:57 pm    Post subject: [Solved]netmount, ntpd & sshd balk - wlan0 config proble Reply with quote

Hi, all...

After changing to a new work environment, and a new protected wireless lan, my gentoo boot sequence shows several warnings and wlan0 fails to configure properly:
Code:

* Starting wlan0
*    Starting wpa_supplicant on wlan0 …
*    Starting wpa_cli on wlan0 …
*        Failed to configure wlan0 in the background                                                       !!

* WARNING:   netmount is scheduled to start when net.wlan0 has started.

* WARNING:   ntpd is scheduled to start when net.wlan0 has started.

* WARNING:   sshd is scheduled to start when net.wlan0 has started.


In spite of this, when I log in, following boot, I do have wlan connectivity:
Code:

ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          inet addr:172.16.31.106  Bcast:172.16.31.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1536 (1.5 KiB)  TX bytes:1066 (1.0 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-19-D2-85-9B-B2-00-00-00-00-00-00-00-00-00-00 
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Relevant snippet from dmesg shows:
Code:

Dmesg:
e1000e: Intel(R) PRO/1000 Network Driver - 1.0.2-k2
e1000e: Copyright (c) 1999-2008 Intel Corporation.
e1000e 0000:02:00.0: Disabling L1 ASPM
e1000e 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
e1000e 0000:02:00.0: pci_enable_pcie_error_reporting failed 0xffffffea
e1000e 0000:02:00.0: setting latency timer to 64
0000:02:00.0: 0000:02:00.0: Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
intelfb: Framebuffer driver for Intel(R) 830M/845G/852GM/855GM/865G/915G/915GM/945G/945GM/945GME/965G/965GM chipsets
intelfb: Version 0.9.6
intelfb 0000:00:02.0: power state changed by ACPI to D0
intelfb 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
intelfb: Cannot reserve FB region.
e1000e 0000:02:00.0: Warning: detected ASPM enabled in EEPROM
0000:02:00.0: eth0: (PCI Express:2.5GB/s:Width x1) 00:16:d3:3c:30:78
0000:02:00.0: eth0: Intel(R) PRO/1000 Network Connection
0000:02:00.0: eth0: MAC: 2, PHY: 2, PBA No: 005302-003
HDA Intel 0000:00:1b.0: PCI INT B -> GSI 17 (level, low) -> IRQ 17
hda_intel: probe_mask set to 0x1 for device 17aa:2010
HDA Intel 0000:00:1b.0: setting latency timer to 64
EXT3 FS on sda3, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on sda6, internal journal
EXT3-fs: mounted filesystem with writeback data mode.
XFS mounting filesystem sda5
Ending clean XFS mount for filesystem: sda5
Adding 506512k swap on /dev/sda2.  Priority:-1 extents:1 across:506512k
Clocksource tsc unstable (delta = -212100330 ns)
iwl3945 0000:03:00.0: firmware: requesting iwlwifi-3945-2.ucode
iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
wlan0: authenticate with AP 00:17:c5:5c:49:27
wlan0: authenticated
wlan0: associate with AP 00:17:c5:5c:49:27
wlan0: RX AssocResp from 00:17:c5:5c:49:27 (capab=0x11 status=0 aid=1)
wlan0: associated
cfg80211: Calling CRDA for country: US
[drm] Initialized drm 1.1.0 20060810

My wpa_supplicant.config:
Code:

ctrl_interface=/var/run/wpa_supplicant

update_config=0

eapol_version=1

ap_scan=1

fast_reauth=1





# Network Block Fields:



# Home WLAN

network={

        proto=WPA

        ssid="griswold"

        scan_ssid=0

        key_mgmt=WPA-PSK

        pairwise=TKIP

        group=TKIP

        psk="*************"

        priority=5

}






# Shared WEP key connection (no WPA, no IEEE 802.1X)

network={

        ssid="guenwald"

        key_mgmt=NONE

        wep_key0="************"

        wep_key1=0102030405

        wep_key2="1234567890123"

        wep_tx_keyidx=0

        priority=5

}






# This is a network block that connects to any unsecured access point.

# We give it a low priority so any defined blocks are preferred.



network={

        key_mgmt=NONE

        priority=-9999999

}


I'm ending up with the following deficiencies:
Code:

Runlevel: default
 cupsd                                                                                      [ started  ]
 dbus                                                                                       [ started  ]
 fcron                                                                                      [ started  ]
 hald                                                                                       [ started  ]
 local                                                                                      [ started  ]
 netmount                                                                                   [ stopped  ]
 ntp-client                                                                                 [ stopped  ]
 ntpd                                                                                       [ stopped  ]
 portmap                                                                                    [ started  ]
 postfix                                                                                    [ started  ]
 rsyncd                                                                                     [ started  ]
 sshd                                                                                       [ stopped  ]
 syslog-ng                                                                                  [ started  ]
 udev-postmount                                                                             [ started  ]
 wicd                                                                                       [ started  ]


Not sure what else to consider to sort this out... :?

Any help would be greatly appreciated!

Thanks!
_________________
"Primum non nocere" ---Galen


Last edited by cgmd on Wed Mar 31, 2010 10:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Mar 24, 2010 12:56 am    Post subject: Reply with quote

Hi, first can you post this :

Code:

# emerge --info
# rc-status
# cat /etc/conf.d/net
# cat /etc/wpa_supplicant/wpa_supplicant.conf
# ifconfig -a
# iwconfig
# iwlist scan
# dmesg | tail


Last edited by d2_racing on Wed Mar 24, 2010 1:10 am; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Mar 24, 2010 1:01 am    Post subject: Reply with quote

You will laugh, but right now with my Gentoo testing box with the kernel 2.6.33, I have a weird bug, my wireless is not working :P

So, I'm gonna debug myself while I'm debugging you :P
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Wed Mar 24, 2010 2:04 am    Post subject: Reply with quote

d2_racing wrote:
Hi, first can you post this :

Code:

# emerge --info
# rc-status
# cat /etc/conf.d/net
# cat /etc/wpa_supplicant/wpa_supplicant.conf
# ifconfig -a
# iwconfig
# iwlist scan
# dmesg | tail


I'll do all this tomorrow, when I'm back in range of the problematic wlan...

Thanks!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Mar 24, 2010 3:28 am    Post subject: Reply with quote

No problem, me too actually :P
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Wed Mar 24, 2010 10:24 pm    Post subject: Reply with quote

OK, here goes...

Emerge --sync:
Code:
Portage 2.1.7.17 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.31-gentoo-r6-i686-Intel-R-_Core-TM-_Duo_CPU_L2400_@_1.66GHz-with-gentoo-1.12.13
Timestamp of tree: Wed, 24 Mar 2010 07:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python:     2.6.5, 3.1.2
dev-python/pycrypto: 2.1.0_beta1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe"
DISTDIR="/home/portage-files/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.ISO-8859-1"
LC_ALL="en_US.ISO-8859-1"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j1"
PKGDIR="/home/portage-files/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acc acl acpi alsa apache2 avi berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dmi dri dts dvd dvdr dvdread eds emboss encode evo fam firefox flac foomaticdb fortran gdbm gif gpm gstreamer gtk hal iconv imlib ipv6 jpeg ldap libnotify mad madwifi mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls no-htdocs nptl nptlonly ogg oggvorbis opengl openmp osspng pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection samba scanner sdl session snmp spell spl ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb utf8 vorbis win32codecs wma wmf x264 x86 xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon tty" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa fbdev intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


rc-status:
Code:
Runlevel: default
 cupsd                                                                                             [ started  ]
 dbus                                                                                              [ started  ]
 fcron                                                                                             [ started  ]
 hald                                                                                              [ started  ]
 local                                                                                             [ started  ]
 netmount                                                                                          [ stopped  ]
 ntp-client                                                                                        [ stopped  ]
 ntpd                                                                                              [ stopped  ]
 portmap                                                                                           [ started  ]
 postfix                                                                                           [ started  ]
 rsyncd                                                                                            [ started  ]
 sshd                                                                                              [ stopped  ]
 syslog-ng                                                                                         [ started  ]
 udev-postmount                                                                                    [ started  ]
 wicd                                                                                              [ started  ]


/etc/conf.d/net:
Code:
/etc/conf.d/net
# Configuration of wired stuff

config_eth0=( "dhcp" )
dhcpcd_eth0="-t 10"




# Configuration of WiFi

modules=( "wpa_supplicant" )
wpa_supplicant_wlan0="-Dwext"
config_wlan0=( "dhcp" )
associate_timeout_wlan0=50


/etc/wpa_supplicant/wpa_supplicant.conf:
Code:

ctrl_interface=/var/run/wpa_supplicant
update_config=0
eapol_version=1
ap_scan=1
fast_reauth=1


# Network Block Fields:

# Home WLAN
network={
        proto=WPA
        ssid="griswold"
        scan_ssid=0
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        psk="*******"
        priority=5
}


# Simple case: WPA-PSK, PSK as an ASCII passphrase, allow all valid ciphers

network={
   ssid="gruenwald"
   psk="*******"
   priority=5
}


# Shared WEP key connection (no WPA, no IEEE 802.1X)
network={
        ssid="guenwald"
        key_mgmt=NONE
        wep_key0="***********"
        wep_key1=0102030405
        wep_key2="1234567890123"
        wep_tx_keyidx=0
        priority=5
}




# This is a network block that connects to any unsecured access point.
# We give it a low priority so any defined blocks are preferred.

network={
        key_mgmt=NONE
        priority=-9999999
}


ifconfig -a:
Code:

eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:200 (200.0 B)  TX bytes:200 (200.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          inet addr:172.16.31.106  Bcast:172.16.31.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6001 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5713 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5895762 (5.6 MiB)  TX bytes:1257893 (1.1 MiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-19-D2-85-9B-B2-00-00-00-00-00-00-00-00-00-00 
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)




iwconfig:
Code:

lo        no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"gruenwald" 
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:17:C5:5C:49:27   
          Bit Rate=12 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:6772-7565-6E77-616C-6432-3031-30
          Power Management:off
          Link Quality=65/70  Signal level=-45 dBm  Noise level=-127 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.


iwlist scan:
Code:

 iwlist scan
lo        Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:17:C5:5C:49:27
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=68/70  Signal level=-42 dBm 
                    Encryption key:on
                    ESSID:"gruenwald"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000015a40a0e7a
                    Extra: Last beacon: 631ms ago
                    IE: Unknown: 0009677275656E77616C64
                    IE: Unknown: 010882848B0C12961824
                    IE: Unknown: 030102
                    IE: Unknown: 0706555349010B1B
                    IE: Unknown: 200100
                    IE: Unknown: 2A0104
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101020003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C330C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 2D1A0C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3402001B00000000000000000000000000000000000000
                    IE: Unknown: 3D1602001B00000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0A00037F04010000000000
          Cell 02 - Address: 00:18:4D:00:BE:6C
                    Channel:3
                    Frequency:2.422 GHz (Channel 3)
                    Quality=26/70  Signal level=-84 dBm 
                    Encryption key:on
                    ESSID:"zehnder_br_conf"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000122c5b20185
                    Extra: Last beacon: 2714ms ago
                    IE: Unknown: 000F7A65686E6465725F62725F636F6E66
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030103
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A1E181AFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D16030D1200000000000000000000000000000000000000
                    IE: Unknown: 7F0101
                    IE: Unknown: DD090010180201F0010000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C331E181AFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C34030D1200000000000000000000000000000000000000

eth0      Interface doesn't support scanning.


dmesg | tail:
Code:

iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
wlan0: authenticate with AP 00:17:c5:5c:49:27
wlan0: authenticated
wlan0: associate with AP 00:17:c5:5c:49:27
wlan0: RX AssocResp from 00:17:c5:5c:49:27 (capab=0x11 status=0 aid=1)
wlan0: associated
cfg80211: Calling CRDA for country: US
[drm] Initialized drm 1.1.0 20060810
pci 0000:00:02.0: setting latency timer to 64
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0


I believe that's all requested...

Thanks!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Mar 25, 2010 12:51 am    Post subject: Reply with quote

First of all, you cannot have both the manual network way, I mean starting wpa_supplicant by hand and using at the same time wicd.

So, run this :

Code:

# rc-update del wicd
# rc-update del wicd boot


After that, reboot your box and post this :

Code:

# ifconfig -a
# iwconfig
# /etc/init.d/net.wlan0 start
# dmesg | tail
# wpa_cli status
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Thu Mar 25, 2010 4:29 pm    Post subject: Reply with quote

d2_racing wrote:
First of all, you cannot have both the manual network way, I mean starting wpa_supplicant by hand and using at the same time wicd.

So, run this :

Code:

# rc-update del wicd
# rc-update del wicd boot


After that, reboot your box and post this :

Code:

# ifconfig -a
# iwconfig
# /etc/init.d/net.wlan0 start
# dmesg | tail
# wpa_cli status


I unmerged wicd... to eliminate the warnings about the daemon not starting.

I now get:

Code:
# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-19-D2-85-9B-B2-00-00-00-00-00-00-00-00-00-00 
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Code:
# iwconfig
lo        no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.


Code:
# /etc/init.d/net.wlan0 start
 * WARNING:  net.wlan0 has already been started.


Code:
# dmesg | tail
EXT3-fs: mounted filesystem with writeback data mode.
XFS mounting filesystem sda5
Ending clean XFS mount for filesystem: sda5
Adding 506512k swap on /dev/sda2.  Priority:-1 extents:1 across:506512k
Clocksource tsc unstable (delta = -83824359 ns)
iwl3945 0000:03:00.0: firmware: requesting iwlwifi-3945-2.ucode
iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
[drm] Initialized drm 1.1.0 20060810
pci 0000:00:02.0: setting latency timer to 64
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0


Code:
# wpa_cli status
Selected interface 'wlan0'
wpa_state=SCANNING
 


Thanks!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Mar 25, 2010 5:29 pm    Post subject: Reply with quote

Ok, try this :

Code:

# /etc/init.d/net.wlan0 restart
# iwconfig
# ifconfig -a
# wpa_cli status
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Thu Mar 25, 2010 6:31 pm    Post subject: Reply with quote

d2_racing wrote:
Ok, try this :

Code:

# /etc/init.d/net.wlan0 restart
# iwconfig
# ifconfig -a
# wpa_cli status


I get:
Code:
/etc/init.d/net.wlan0 restart
 * Stopping wlan0
 *   Bringing down wlan0
 *     Shutting down wlan0 ...                                                        [ ok ]
 *     Stopping wpa_cli on wlan0 ...                                                  [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                                           [ ok ]
 * Starting wlan0
RTNETLINK answers: Unknown error 132
RTNETLINK answers: Unknown error 132
 *   Starting wpa_supplicant on wlan0 ...                                             [ ok ]
 *   Starting wpa_cli on wlan0 ...                                                    [ ok ]
 *     Failed to configure wlan0 in the background                                    [ !! ]


Code:
# iwconfig
lo        no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.


Code:
# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          inet addr:192.168.168.179  Bcast:192.168.168.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16002 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14832 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11788781 (11.2 MiB)  TX bytes:4021108 (3.8 MiB)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 B)  TX bytes:100 (100.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-19-D2-85-9B-B2-00-00-00-00-00-00-00-00-00-00 
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Code:
# wpa_cli status
Selected interface 'wlan0'
wpa_state=SCANNING

_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Mar 25, 2010 10:24 pm    Post subject: Reply with quote

Ok, after a reboot, post this :

Code:

# /etc/init.d/net.wlan0 restart
# iwconfig
# ifconfig -a
# wpa_cli status
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Fri Mar 26, 2010 1:53 am    Post subject: Reply with quote

d2_racing wrote:
Ok, after a reboot, post this :

Code:

# /etc/init.d/net.wlan0 restart
# iwconfig
# ifconfig -a
# wpa_cli status


OK...
Code:

# /etc/init.d/net.wlan0 restart
 * Stopping wlan0
 *   Bringing down wlan0
 *     Shutting down wlan0 ...                                            [ ok ]
 *     Stopping wpa_cli on wlan0 ...                                      [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                               [ ok ]
 * Starting wlan0
RTNETLINK answers: Unknown error 132
RTNETLINK answers: Unknown error 132
 *   Starting wpa_supplicant on wlan0 ...                                 [ ok ]
 *   Starting wpa_cli on wlan0 ...                                        [ ok ]
 *     Failed to configure wlan0 in the background                        [ !! ]


Code:

# iwconfig
lo        no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.


Code:

# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-19-D2-85-9B-B2-00-00-00-00-00-00-00-00-00-00 
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Code:

 # wpa_cli status
Selected interface 'wlan0'
wpa_state=SCANNING


What next??
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Mar 26, 2010 4:13 pm    Post subject: Reply with quote

Ok, can you try with the latest release of gentoo-sources 2.6.32.

And of course, after booting your new kernel, remerge iwl3945-ucode

After that, run this :

Code:

# rm /etc/udev/rules.d/70-persistent-net.rules
# reboot
# ifconfig -a
# iwconfig


There's something different on your box, because I don't have for a long time wmaster0 on my box, only wlan0 and it's working pretty well now.
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Fri Mar 26, 2010 5:00 pm    Post subject: Reply with quote

d2_racing wrote:
Ok, can you try with the latest release of gentoo-sources 2.6.32.

And of course, after booting your new kernel, remerge iwl3945-ucode

After that, run this :

Code:

# rm /etc/udev/rules.d/70-persistent-net.rules
# reboot
# ifconfig -a
# iwconfig


There's something different on your box, because I don't have for a long time wmaster0 on my box, only wlan0 and it's working pretty well now.

OK, I'll give that a try...

Thanks!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Sat Mar 27, 2010 3:49 pm    Post subject: Reply with quote

d2_racing wrote:
Ok, can you try with the latest release of gentoo-sources 2.6.32.

And of course, after booting your new kernel, remerge iwl3945-ucode

After that, run this :

Code:

# rm /etc/udev/rules.d/70-persistent-net.rules
# reboot
# ifconfig -a
# iwconfig


There's something different on your box, because I don't have for a long time wmaster0 on my box, only wlan0 and it's working pretty well now.


Ok... I upgraded to gentoo-sources 2.6.32-r2

I now get:
Code:

 # ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          inet addr:192.168.168.179  Bcast:192.168.168.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3305 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2767 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3813431 (3.6 MiB)  TX bytes:437794 (427.5 KiB)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 B)  TX bytes:100 (100.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Code:
# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11abg  Mode:Managed  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
eth0      no wireless extensions.


I'm really unsure of my wpa_supplicant.conf settings. Could they be the problem? :
Code:

ctrl_interface=/var/run/wpa_supplicant
update_config=0
eapol_version=1
ap_scan=1
fast_reauth=1


# Home WLAN
network={
        proto=WPA
        ssid="griswold"
        scan_ssid=0
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        psk="**********"
        priority=5
}

# New office LAN (problem):

# Shared WEP key connection (no WPA, no IEEE 802.1X)???
network={
        ssid="guenwald"
        key_mgmt=NONE
        wep_key0="*************"
        wep_key1=""
        wep_key2=""
        wep_tx_keyidx=0
        priority=5
}




# This is a network block that connects to any unsecured access point.
# We give it a low priority so any defined blocks are preferred.

network={
        key_mgmt=NONE
        priority=-9999999
}


Thanks!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Sat Mar 27, 2010 9:25 pm    Post subject: Reply with quote

I guess I should point out that this laptop does properly access the wlan which is located at my house:
Code:
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 B)  TX bytes:100 (100.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          inet addr:192.168.1.120  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12893 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9648 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:8306451 (7.9 MiB)  TX bytes:3337496 (3.1 MiB)



Code:

# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"griswold" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:18:39:E1:14:10   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=52/70  Signal level=-58 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.


Wouldn't this add strength to the argument that the configuration for accessing the wlan at my workplace, as it's set in wpa_supplicant.conf, is faulty and causing the problem?

Thanks!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun Mar 28, 2010 12:58 am    Post subject: Reply with quote

Indeed, can you try this little wpa_supplicant.conf when you are at work :

Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=0

network={
  ssid="guenwald"
  key_mgmt=NONE
  wep_key0="your_key_here"
  wep_tx_keyidx=0
  priority=5
}



For the record, can you post your key, maybe you don't need the "" if you pass the hexa key.

Code:

# ifconfig -a
# iwconfig
# /etc/init.d/net.wlan0 restart
# iwconfig
# wpa_cli status
# ping www.google.com
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Sun Mar 28, 2010 2:41 pm    Post subject: Reply with quote

d2_racing wrote:
Indeed, can you try this little wpa_supplicant.conf when you are at work :

Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=0

network={
  ssid="guenwald"
  key_mgmt=NONE
  wep_key0="your_key_here"
  wep_tx_keyidx=0
  priority=5
}



For the record, can you post your key, maybe you don't need the "" if you pass the hexa key.

Code:

# ifconfig -a
# iwconfig
# /etc/init.d/net.wlan0 restart
# iwconfig
# wpa_cli status
# ping www.google.com


Unfortunately, my home wlan seems to fail when using ap_scan=0. It does connect, however with:
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=1


For the record:
Code:

    wep_key0="gruenwald2010"


It's obviously not a hex key, but just a "pass phrase". It does require the use of "".

Before I removed wicd, it did, in fact, connect with my office wlan, but too late in the boot cycle. It was set to WEP2, and used the above pass phrase, when it was making its connection.

I'll re-try this when I return to the office... maybe later today.

Thanks!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun Mar 28, 2010 7:36 pm    Post subject: Reply with quote

WEP2, first time that I heard about that.

Are you sure that is not WPA2 ?

If so, we need to change your wpa_supplicant.conf
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Sun Mar 28, 2010 8:28 pm    Post subject: Reply with quote

d2_racing wrote:
WEP2, first time that I heard about that.

Are you sure that is not WPA2 ?

If so, we need to change your wpa_supplicant.conf

It's not wpa, I know it to be wep (shared).

Now, when I retry with your suggested wpa_supplicant settings, I get:
Code:
 # ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Code:
# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11abg  Mode:Managed  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
eth0      no wireless extensions.


Code:
 # /etc/init.d/net.wlan0 restart
 * Stopping wlan0
 *   Bringing down wlan0
 *     Shutting down wlan0 ...                                                                         [ ok ]
 *     Stopping wpa_cli on wlan0 ...                                                                   [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                                                            [ ok ]
 * Starting wlan0
RTNETLINK answers: Unknown error 132
RTNETLINK answers: Unknown error 132
 *   Starting wpa_supplicant on wlan0 ...                                                              [ ok ]
 *   Starting wpa_cli on wlan0 ...                                                                     [ ok ]
 *     Failed to configure wlan0 in the background                                                     [ !! ]


Code:
# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11abg  Mode:Managed  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
eth0      no wireless extensions.


Code:
 # wpa_cli status             
Selected interface 'wlan0'
wpa_state=SCANNING


Code:
 # ping www.google.com
ping: unknown host www.google.com


Unfortunately, still no wlan access... :(
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Sun Mar 28, 2010 8:41 pm    Post subject: Reply with quote

When I re-emerge wicd, it again connects using my passphrase, along with the setting manually set for WEP encription, not WEP shared encription.

I don't know what all this means... :?

Thanks!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Mon Mar 29, 2010 12:09 am    Post subject: Reply with quote

Ok, can you try with this little wpa_supplicant.conf :

Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
  ssid="guenwald"
  wep_key0="your_key_here"
  priority=5
}


Code:

# ifconfig -a
# iwconfig
# /etc/init.d/net.wlan0 restart
# iwconfig
# dmesg | tail
# wpa_cli status
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Tue Mar 30, 2010 3:10 pm    Post subject: Reply with quote

d2_racing wrote:
Ok, can you try with this little wpa_supplicant.conf :

Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
  ssid="guenwald"
  wep_key0="your_key_here"
  priority=5
}


Code:

# ifconfig -a
# iwconfig
# /etc/init.d/net.wlan0 restart
# iwconfig
# dmesg | tail
# wpa_cli status


Looking good, now!

Code:
# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:d3:3c:30:78 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:ee000000-ee020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 B)  TX bytes:100 (100.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:85:9b:b2 
          inet addr:172.16.31.106  Bcast:172.16.31.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2841 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2827 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3242218 (3.0 MiB)  TX bytes:533354 (520.8 KiB)



Code:
# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"gruenwald" 
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:17:C5:5C:49:27   
          Bit Rate=11 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:6772-7565-6E77-616C-6432-3031-30
          Power Management:off
          Link Quality=65/70  Signal level=-45 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Code:
# /etc/init.d/net.wlan0 restart
 * Unmounting network filesystems ...                                     [ ok ]
 * Stopping ntpd ...                                                      [ ok ]
 * Stopping sshd ...                                                      [ ok ]
 * Stopping wlan0
 *   Bringing down wlan0
 *     Stopping dhcpcd on wlan0 ...                                       [ ok ]
 *     Shutting down wlan0 ...                                            [ ok ]
 *     Stopping wpa_cli on wlan0 ...                                      [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                               [ ok ]
 * Starting wlan0
RTNETLINK answers: Unknown error 132
RTNETLINK answers: Unknown error 132
 *   Starting wpa_supplicant on wlan0 ...                                 [ ok ]
 *   Starting wpa_cli on wlan0 ...                                        [ ok ]
 *     wlan0 connected to "gruenwald" at 00:17:C5:5C:49:27
 *   wlan0 configured with address 172.16.31.106/24
 * Mounting network filesystems ...                                       [ ok ]
 * Setting clock via the NTP client 'ntpdate' ...                         [ ok ]
 * Starting ntpd ...                                                      [ ok ]
 * Starting sshd ...                                                      [ ok ]


Code:
# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"gruenwald" 
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:17:C5:5C:49:27   
          Bit Rate=36 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:6772-7565-6E77-616C-6432-3031-30
          Power Management:off
          Link Quality=66/70  Signal level=-44 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Code:
# dmesg | tail
wlan0: direct probe to AP 00:17:c5:5c:49:27 (try 2)
wlan0: direct probe to AP 00:17:c5:5c:49:27 (try 3)
wlan0: direct probe to AP 00:17:c5:5c:49:27 timed out
wlan0: direct probe to AP 00:17:c5:5c:49:27 (try 1)
wlan0: direct probe responded
wlan0: authenticate with AP 00:17:c5:5c:49:27 (try 1)
wlan0: authenticated
wlan0: associate with AP 00:17:c5:5c:49:27 (try 1)
wlan0: RX AssocResp from 00:17:c5:5c:49:27 (capab=0x11 status=0 aid=1)
wlan0: associated


Code:
# wpa_cli status
Selected interface 'wlan0'
bssid=00:17:c5:5c:49:27
ssid=gruenwald
id=1
pairwise_cipher=WEP-104
group_cipher=WEP-104
key_mgmt=NONE
wpa_state=COMPLETED
ip_address=172.16.31.106


Seems to be working! :D

Any thoughts about: RTNETLINK answers: Unknown error 132

Thanks for your help!!!
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Mar 30, 2010 9:23 pm    Post subject: Reply with quote

Good :P
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Mar 30, 2010 9:25 pm    Post subject: Reply with quote

I think it's because your rfkill switch is disabled...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum