Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cmake non ne vuole sapere di aggiornarsi con -avuDN world
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Thu Mar 18, 2010 9:06 pm    Post subject: cmake non ne vuole sapere di aggiornarsi con -avuDN world Reply with quote

allora il problema è il seguente:
dopo un pò di tempo ho deciso di aggiornare la mia gentoo con i classici comandi
Code:
emerge --sync
emerge -avuDN world

però arrivato all'aggiornamento del pacchetto cmake (che meli da come
Code:

[ebuild     UD] dev-util/cmake-2.6.4-r3 [2.8.1] USE="vim-syntax -emacs -qt4 (-ncurses%*)" 0 kB [0]

) mi da i seguenti errori che non capisco da dove escano
http://pastebin.com/jWZ5fUkd
Code:
KinG-InFeT ~ # emerge -avuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] dev-util/cmake-2.6.4-r3 [2.8.1] USE="vim-syntax -emacs -qt4 (-ncurses%*)" 0 kB [0]
[ebuild     U ] dev-libs/glib-2.22.4 [2.22.3] USE="fam -debug -doc -hardened (-selinux) -xattr" 0 kB [0]
[ebuild     U ] x11-misc/shared-mime-info-0.71 [0.70] 0 kB [0]
[ebuild     U ] dev-util/desktop-file-utils-0.16 [0.15] USE="-emacs" 0 kB [0]
[ebuild     U ] app-admin/conky-1.8.0_rc2 [1.7.2-r2] USE="X ncurses%* portmon truetype vim-syntax -apcupsd -audacious -curl -debug -eve -hddtemp -imlib -iostats -lua -lua-cairo -lua-imlib -math -moc -mpd -nano-syntax -nvidia -rss -thinkpad -weather-metar -weather-xoap -wifi (-alsa%*)" 0 kB [0]
[ebuild     U ] app-text/enchant-1.5.0 [1.4.2] USE="hunspell -aspell -zemberek" 0 kB [0]
[ebuild     U ] xfce-base/xfconf-4.7.2 [4.7.0] USE="perl -debug -profile" 0 kB [0]
[ebuild     U ] sys-auth/pambase-20100310 [20090620.1-r1] USE="consolekit cracklib sha512 -debug -gnome-keyring -mktemp -passwdqc (-selinux) -ssh" 0 kB [0]
[ebuild     U ] sys-apps/shadow-4.1.4.2-r3 [4.1.4.2-r2] USE="cracklib nls pam -audit (-selinux) -skey" 0 kB [0]
[ebuild     U ] net-misc/openssh-5.4_p1 [5.3_p1-r1] USE="X ldap pam tcpd -X509 -hpn -kerberos -libedit (-selinux) -skey -static (-pkcs11%) (-smartcard%)" 0 kB [0]
[ebuild     U ] x11-libs/gtk+-2.18.7-r1 [2.18.6] USE="cups jpeg jpeg2k tiff vim-syntax (-aqua) -debug -doc -test -xinerama" 0 kB [0]
[ebuild     U ] net-wireless/bluez-4.62 [4.39-r2] USE="alsa consolekit cups gstreamer usb -caps% -debug -old-daemons -pcmcia% -test-programs (-doc%)" 0 kB [0]
[ebuild     U ] app-text/ghostscript-gpl-8.71-r1 [8.70-r1] USE="X cairo cups gtk jpeg2k -bindist -djvu" LINGUAS="-ja -ko -zh_CN -zh_TW" 0 kB [0]
[ebuild     U ] media-sound/timidity++-2.13.2-r12 [2.13.2-r11] USE="X alsa flac gtk ncurses speex vorbis -ao -emacs -jack -motif -nas -oss -slang -tk" 0 kB [0]
[ebuild     U ] x11-libs/libsexy-0.1.11-r2 [0.1.11-r1] USE="-doc (-debug%)" 0 kB [0]
[ebuild     U ] app-arch/xarchiver-0.5.2-r1 [0.5.2] USE="-debug" 0 kB [0]
[ebuild     U ] www-plugins/adobe-flash-10.0.45.2 [10.0.42.34] USE="(-32bit*) (-64bit*) (-multilib)" 0 kB [0]
[ebuild     U ] x11-libs/wxGTK-2.8.10.1-r5 [2.8.10.1-r4] USE="X gstreamer opengl sdl -debug -doc -gnome -odbc -pch" 0 kB [0]
[ebuild   R   ] media-sound/moc-2.5.0_alpha4  USE="aac alsa flac mad sid sndfile speex timidity vorbis -curl -debug -ffmpeg -jack -libsamplerate -modplug -musepack% -oss -wavpack" 0 kB [0]
[ebuild     U ] net-analyzer/wireshark-1.2.6 [1.2.5] USE="caps gtk ipv6 pcap pcre zlib -adns -ares -gcrypt -geoip -gnutls -kerberos -lua -portaudio -profile (-selinux) -smi -threads" 0 kB [0]
[ebuild     U ] app-text/libspectre-0.2.4 [0.2.3] USE="-debug -doc -test" 0 kB [0]
[ebuild     U ] net-ftp/filezilla-3.3.2 [3.3.1] USE="dbus nls -test" 0 kB [0]
[ebuild     U ] net-analyzer/nmap-5.21 [5.10_beta1] USE="gtk ssl -lua" 0 kB [0]
[ebuild     U ] dev-vcs/git-1.7.0.2 [1.6.6.1] USE="blksha1 curl gtk iconv perl threads webdav -bash-completion -cgi -cvs -doc -emacs (-ppcsha1) -subversion -tk -xinetd" 0 kB [0]
[ebuild     U ] net-im/amsn-0.98.3 [0.98.1-r1] USE="-debug" 0 kB [0]
[ebuild     U ] app-portage/layman-1.3.2-r2 [1.3.0] USE="git mercurial%* subversion -bazaar% -cvs% -darcs% -test" 0 kB [0]
[ebuild     U ] xfce-base/exo-0.3.106 [0.3.105-r1] USE="libnotify python -debug -hal" 0 kB [0]
[ebuild     U ] mail-client/mozilla-thunderbird-3.0.3-r1 [3.0.1] USE="crypt dbus ldap startup-notification -bindist -custom-optimization -gnome -lightning -mozdom -system-sqlite% (-replytolist%)" LINGUAS="en it -af -be -bg% -ca -cs -da% -de -el -en_GB -en_US -es -es_AR -es_ES -eu -fi -fr -ga -ga_IE -he% -hu -ja -ko -lt -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt% -pt_BR -pt_PT% -ru -sk -sv -sv_SE -tr% -uk -zh% -zh_CN% -zh_TW% (-ar%) (-et%) (-fy%) (-fy_NL%) (-id%) (-is%) (-ro%) (-si%) (-ta%) (-ta_LK%)" 0 kB [0]
[ebuild     U ] x11-plugins/enigmail-1.0.1-r1 [1.0.0] USE="dbus startup-notification -custom-optimization -gnome -system-sqlite%" 0 kB [1=>0]
[ebuild     U ] media-sound/audacious-2.3_beta1 [2.2] USE="nls session (-altivec) -chardet -debug% -sse2 (-libsamplerate%)" 0 kB [0]
[ebuild     U ] media-plugins/audacious-plugins-2.3_beta1 [2.2-r2] USE="aac alsa cue flac ipv6 mp3 nls sdl sid sndfile vorbis -adplug (-aqua) -bs2b -cdda -debug% -esd -ffmpeg -fluidsynth -gnome -icecast -jack -lame -lirc -midi -mtp -oss -projectm -pulseaudio -sse2 -wavpack (-scrobbler%)" 0 kB [0]
[ebuild  N    ] app-text/poppler-0.12.4-r1  USE="abiword cairo jpeg jpeg2k lcms png utils xpdf-headers -cjk -debug -doc -exceptions -qt4" 0 kB [0]
[uninstall    ] app-text/poppler-utils-0.12.3  USE="abiword png"  [0]
[blocks b     ] app-text/poppler-utils ("app-text/poppler-utils" is blocking app-text/poppler-0.12.4-r1)
[uninstall    ] dev-libs/poppler-0.12.3  USE="abiword lcms poppler-data"  [0]
[blocks b     ] dev-libs/poppler ("dev-libs/poppler" is blocking app-text/poppler-0.12.4-r1)
[uninstall    ] dev-libs/poppler-glib-0.12.3  USE="cairo"  [0]
[blocks b     ] app-text/poppler ("app-text/poppler" is blocking app-text/poppler-utils-0.12.3, dev-libs/poppler-0.12.3, dev-libs/poppler-glib-0.12.3)
[blocks b     ] dev-libs/poppler-glib ("dev-libs/poppler-glib" is blocking app-text/poppler-0.12.4-r1)

Total: 32 packages (29 upgrades, 1 downgrade, 1 new, 1 reinstall, 3 uninstalls), Size of downloads: 0 kB
Conflict: 4 blocks
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/mozilla

!!! One or more updates have been skipped due to a dependency conflict:

net-misc/curl:0

  ('ebuild', '/', 'net-misc/curl-7.20.0-r1', 'merge') conflicts with
    >=net-misc/curl-7.19.7[openssl] required by ('installed', '/', 'net-im/centerim-4.22.9', 'nomerge')


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

dev-util/cmake:0



e alla fine :S

[100%] Built target documentation
>>> Source compiled.
>>> Test phase [not enabled]: dev-util/cmake-2.6.4-r3

>>> Install cmake-2.6.4-r3 into /var/tmp/portage/dev-util/cmake-2.6.4-r3/image/ category dev-util
>>> Working in BUILD_DIR: "/var/tmp/portage/dev-util/cmake-2.6.4-r3/work/cmake-2.6.4"
make -j2 install DESTDIR=/var/tmp/portage/dev-util/cmake-2.6.4-r3/image/
[ 14%] Built target cmsys
[ 14%] Built target cmcompress
[ 17%] Built target cmsysTestDynload
[ 27%] Built target cmtar
[ 34%] Built target cmsys_c
[ 34%] Built target cmsys
[ 44%] Built target cmsysTestsCxx
[ 44%] Built target cmtar
[ 44%] Built target cmcompress
[ 80%] Built target cmForm
[153%] Built target CMakeLib
[155%] Built target cmake
Built target CMakeLib
Built target cmsysTestProcess
Built target cmsysTestsC
Built target tartest
Built target CPackLib
Built target DumpDocumentation
Built target CTestLib
Built target ccmake
Built target cmake
Built target cpack
Built target ctest
Built target documentation
Install the project...
-- Install configuration: "Gentoo"
-- Installing: /var/tmp/portage/dev-util/cmake-2.6.4-r3/image/usr/share/cmake/include/cmCPluginAPI.h
-- Installing: /var/tmp/portage/dev-util/cmake-2.6.4-r3/image/usr/bin/ccmake
CMake Error at Source/cmake_install.cmake:41 (IF):
  if had incorrect arguments: EXISTS
  "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/bin/ccmake" AND NOT IS_SYMLINK
  "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/bin/ccmake" (Unknown arguments
  specified).
Call Stack (most recent call first):
  cmake_install.cmake:41 (INCLUDE)


make: *** [install] Error 1
 * ERROR: dev-util/cmake-2.6.4-r3 failed:
 *   Make install failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_install
 *   environment, line 3405:  Called cmake-utils_src_install
 *   environment, line  877:  Called _execute_optionaly 'src_install'
 *   environment, line  361:  Called enable_cmake-utils_src_install
 *   environment, line 1443:  Called die
 * The specific snippet of code:
 *       emake install DESTDIR="${D}" || die "Make install failed";
 *
 * If you need support, post the output of 'emerge --info =dev-util/cmake-2.6.4-r3',
 * the complete build log and the output of 'emerge -pqv =dev-util/cmake-2.6.4-r3'.
 * The complete build log is located at '/var/tmp/portage/dev-util/cmake-2.6.4-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/cmake-2.6.4-r3/temp/environment'.
 * S: '/var/tmp/portage/dev-util/cmake-2.6.4-r3/work/cmake-2.6.4'

>>> Failed to emerge dev-util/cmake-2.6.4-r3, Log file:

>>>  '/var/tmp/portage/dev-util/cmake-2.6.4-r3/temp/build.log'

 * Messages for package dev-util/cmake-2.6.4-r3:

 * ERROR: dev-util/cmake-2.6.4-r3 failed:
 *   Make install failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_install
 *   environment, line 3405:  Called cmake-utils_src_install
 *   environment, line  877:  Called _execute_optionaly 'src_install'
 *   environment, line  361:  Called enable_cmake-utils_src_install
 *   environment, line 1443:  Called die
 * The specific snippet of code:
 *       emake install DESTDIR="${D}" || die "Make install failed";
 *
 * If you need support, post the output of 'emerge --info =dev-util/cmake-2.6.4-r3',
 * the complete build log and the output of 'emerge -pqv =dev-util/cmake-2.6.4-r3'.
 * The complete build log is located at '/var/tmp/portage/dev-util/cmake-2.6.4-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/cmake-2.6.4-r3/temp/environment'.
 * S: '/var/tmp/portage/dev-util/cmake-2.6.4-r3/work/cmake-2.6.4'
KinG-InFeT ~ #


la prima parte riguarda proprio all'inizio dell'emerge dove seleziona i pacchetti da aggiornare e dopo cè la sfilza di errore:S

qualcuno mi saprebbe dare una risposta o meglio una soluzione al problema?
grazie

EDIT: cè anche un piccolo errore prima del yes or no dell'installazione
Code:
#
!!! One or more updates have been skipped due to a dependency conflict:
#
 
#
net-misc/curl:0
#
 
#
  ('ebuild', '/', 'net-misc/curl-7.20.0-r1', 'merge') conflicts with
#
    >=net-misc/curl-7.19.7[openssl] required by ('installed', '/', 'net-im/centerim-4.22.9', 'nomerge')
#
 
#
 
#
!!! The following update(s) have been skipped due to unsatisfied dependencies
#
!!! triggered by backtracking:
#
 
#
dev-util/cmake:0


cmq trovate tutto nel file :S
_________________
My Site => http://www.kinginfet.net/


Last edited by KinG-InFeT on Mon Mar 22, 2010 10:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Mar 19, 2010 8:42 am    Post subject: Reply with quote

Il primo è sicuramente un problema di dipendenze. Vedo che hai/avevi installato cmake-2.8.1 che è marchiato testing, come mai?

Per il secondo potresti provare con emerge -C cmake && emerge -1 cmake (dal log sembra che durante l'installazione uno dei file da sovrascrivere non sia un link simbolico e questo produca l'errore).
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Fri Mar 19, 2010 9:36 am    Post subject: Reply with quote

il fatto strano e ke io non ho mai installato cmake melo ha dato solo oa durante l'aggiornamento e se lo elimino melo da come pacchetto importante e per provare a bypassare il problema o fatto come mi hai detto te ...prima l'ho eliminato e poi l'ho provato a reinstallarlo con l'argomento -1 ma niente :S
sincerament e non ho mai trovato questi problemi durante l'aggiornamento...siccome non ho mai avuto cmake :S
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Mar 19, 2010 12:16 pm    Post subject: Reply with quote

L'avrai installato come dipendenza di qualcos'altro. Per verificare cosa lancia equery d cmake
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Fri Mar 19, 2010 1:37 pm    Post subject: Reply with quote

Code:
KinG-InFeT ~ # equery d cmake
 * These packages depend on cmake:
KinG-InFeT ~ #

non mi da niente :S
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Mar 19, 2010 2:54 pm    Post subject: Reply with quote

Com'è possibile? :lol:
Rimuovilo e lancia emerge -uDpvNt world (l'opzione t è quella importante) così vedi chi lo richiede.
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Fri Mar 19, 2010 3:52 pm    Post subject: Reply with quote

emerge -avuDN world --with-bdeps y

prova così, cmake dovrebbe essere una bdep :)
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Fri Mar 19, 2010 6:36 pm    Post subject: Reply with quote

niente da fare :( sempre lo stesso.....
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Fri Mar 19, 2010 9:47 pm    Post subject: Reply with quote

Scusa ma potresti editare il tuo primo post mettendo li dentro gli errori invece di metterci il link a pastebin ?
Grazie.
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Mar 20, 2010 11:57 am    Post subject: Reply with quote

Primo tentativo, visto che emerge vuole fare il downgrade di cmake, prova ad aggiungere la voce in package.keywords e a vedere se va meglio.

In alternativa
Code:
CMake Error at Source/cmake_install.cmake:41 (IF):
  if had incorrect arguments: EXISTS
  "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/bin/ccmake" AND NOT IS_SYMLINK
  "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/bin/ccmake" (Unknown arguments
  specified).

Questo è l'errore che leggo su pastebin, a questo punto proverei a suggerirti una soluzione "meno gentile" (a tuo rischio e pericolo):
Code:

quickpkg cmake
for i in `qlist cmake`; do rm -fr $i; done
emerge -1 cmake
Occhio agli accenti della seconda riga, sono quelli invertiti (AltGr+'); quel comando rimuove tutti i file installati da cmake per vedere se l'installazione successiva, non dovendo sovrascrivere nulla, riesca a concludere correttamente. Se proprio non funzionasse emerge -1K cmake dovrebbe ripristinare i file precedentemente salvati dal comando quickpkg.
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sat Mar 20, 2010 1:14 pm    Post subject: Reply with quote

riverdragon wrote:

Code:

quickpkg cmake
for i in `qlist cmake`; do rm -fr $i; done
emerge -1 cmake
Occhio agli accenti della seconda riga, sono quelli invertiti (AltGr+')

senza entrare nel merito della validità (non sto seguendo la discussione) il backtick (l'accento invertito) è deprecato in favore del più leggibile e facilmente indentabile $()
il tuo codice diventa quindi
Code:

quickpkg cmake
for i in $(qlist cmake); do rm -fr $i; done
emerge -1 cmake

_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Mar 20, 2010 4:53 pm    Post subject: Reply with quote

Kernel78 wrote:
senza entrare nel merito della validità (non sto seguendo la discussione) il backtick (l'accento invertito) è deprecato in favore del più leggibile e facilmente indentabile $()
Buono a sapersi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum