Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas con deps antiguas kdelibs 3.5 {SOLUCIONADO}
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Wed Mar 10, 2010 6:55 pm    Post subject: Problemas con deps antiguas kdelibs 3.5 {SOLUCIONADO} Reply with quote

Hola wenas, cuando hago un emerge --depclean me da este mensaje:

Calculating dependencies... done!
* Dependencies could not be completely resolved due to
* the following required packages not being installed:
*
* >=app-text/poppler-0.12.3-r3[lcms,qt4] pulled in by:
* kde-base/okular-4.3.4
*
* virtual/ghostscript pulled in by:
* kde-base/kdelibs-3.5.10-r6
*
* >=app-text/poppler-0.12.3-r3[utils] pulled in by:
* net-print/cups-1.4.2-r1
*
* >=virtual/perl-IO-Compress-Bzip2-2.015 pulled in by:
* perl-core/Archive-Tar-1.48
*
* >=app-text/poppler-0.12.3-r3[utils] pulled in by:
* app-misc/strigi-0.7.0
*
* >=virtual/perl-Compress-Zlib-2.015 pulled in by:
* perl-core/Archive-Tar-1.48
*
* Have you forgotten to run `emerge --update --newuse --deep world` prior
* to depclean? It may be necessary to manually uninstall packages that no longer
* exist in the portage tree since it may not be possible to satisfy their
* dependencies. Also, be aware of the --with-bdeps option that is documented
* in `man emerge`.

Soy muy novato y no entiendo bien el problema.
Alguien me puede orientar sobre que puedo hacer???

Gracias.


Last edited by el_miki on Tue Apr 20, 2010 9:27 am; edited 1 time in total
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1034
Location: La Plata, Argentina

PostPosted: Wed Mar 10, 2010 11:07 pm    Post subject: Reply with quote

hace un
Code:
emerge --update --newuse --deep world
y despues el depclean. eso es lo que te dice el mensaje...
_________________
el pelado de la gente
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Thu Mar 11, 2010 4:32 pm    Post subject: Reply with quote

Uffff

Es que no tengo actualizado las kde, y ese emerge se puede tirar la vida, jajaja.

De todas formas probaré.

Gracias.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1034
Location: La Plata, Argentina

PostPosted: Thu Mar 11, 2010 5:15 pm    Post subject: Reply with quote

simplemente enmascara lo que no quieras updatear y listo
_________________
el pelado de la gente
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Thu Mar 11, 2010 5:28 pm    Post subject: Reply with quote

Hola, es que soy mu novato, se puede enmascarar kde, entero?

como?

De todas formas tengo la sensacion de que algo necesita kdelibs 3.5 , como puedo saber que es para desinstalarlo?

Mcuhas gracias.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1034
Location: La Plata, Argentina

PostPosted: Fri Mar 12, 2010 1:08 am    Post subject: Reply with quote

todo kde se puede, pero es re engorroso.
tenes que hacer una cosa. chequea el fichero /var/lib/portage/world y fijate, ahi tenes todo lo que vos instalaste con portage.
tiene que bastar con enmascarar lo que tenes instalado. las dependencias se acomodan solas.
por ejemplo. yo tengo instalado esto de kde
Quote:
kde-base/ark
kde-base/dolphin
kde-base/gwenview
kde-base/kalarm
kde-base/kate
kde-base/kcalc
kde-base/kde-l10n
kde-base/kdebase-startkde
kde-base/kdm
kde-base/kget
kde-base/kmenuedit
kde-base/kmix
kde-base/kolourpaint
kde-base/kompare
kde-base/konsole
kde-base/okular

entonces deberia agregar en /etc/portage/package.mask lo siguiente
Quote:
>kde-base/ark-4.3.4
>kde-base/dolphin-4.3.4
>kde-base/gwenview-4.3.4
>kde-base/kalarm-4.3.4
....

con eso solo te instalara versiones de esos paquetes menores a 4.3.4. podes usar los signos >, <, >=, <=. y el paquete con categoria nombre y version. si pones kde-base/ark, sin signo ni version, te prohibira instalar ark en cualquiera de sus versiones.
una vez q enmascaras eso, hase el upgrade, y hace el depclean. este ultimo hacelo con mucho cuidado. a veces borra cosas y tenes que hacer malabares para recuperar el sistema
_________________
el pelado de la gente
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Sat Mar 13, 2010 9:05 am    Post subject: Reply with quote

Hola ye he ejecutado el comando

y ahora al terminar e hecho un sync y me dice:

!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
kde-base/kdelibs:3.5

!!! The following installed packages are masked:
- x11-libs/qt-3.3.8b-r2 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ben de Groot <yngwin@gentoo.org> (01 Mar 2010)
# Grand mask of qt:3 and remaining reverse dependencies
# pending removal on 21 Mar 2010 (bug 283429)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

He ejecutado emaint --check world y me dice que todo perfecto.

Y el emerge -- depclean me sigue diciendo algo parecido:

Calculating dependencies... done!
* Dependencies could not be completely resolved due to
* the following required packages not being installed:
*
* >=virtual/perl-IO-Compress-Bzip2-2.015 pulled in by:
* perl-core/Archive-Tar-1.48
*
* >=virtual/perl-Compress-Zlib-2.015 pulled in by:
* perl-core/Archive-Tar-1.48
*
* virtual/ghostscript pulled in by:
* kde-base/kdelibs-3.5.10-r6
*
* Have you forgotten to run `emerge --update --newuse --deep world` prior
* to depclean? It may be necessary to manually uninstall packages that no longer
* exist in the portage tree since it may not be possible to satisfy their
* dependencies. Also, be aware of the --with-bdeps option that is documented
* in `man emerge`.


Alguien me puede ayudar???

Gracias
Back to top
View user's profile Send private message
sasho23
Apprentice
Apprentice


Joined: 28 Dec 2005
Posts: 186
Location: Pamplona , Spain

PostPosted: Sat Mar 13, 2010 10:00 am    Post subject: Reply with quote

Hola, porque no pruebas el comando "pstree" eso te muestra el arbol del systema. De ahi deberias ver quien usa el kde3.
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Sat Mar 13, 2010 1:10 pm    Post subject: Reply with quote

Hola, Me da esto:

init─┬─acpid
├─6*[agetty]
├─cron
├─3*[dbus-daemon]
├─2*[dbus-launch]
├─hald───hald-runner─┬─hald-addon-inpu
│ └─hald-addon-stor
├─kaccess
├─kded4
├─kdeinit4─┬─firefox───19*[{firefox}]
│ ├─kio_trash
│ ├─klauncher
│ └─ksmserver─┬─kwin
│ └─{ksmserver}
├─kdm─┬─X
│ └─kdm───startkde───kwrapper4
├─kglobalaccel
├─klipper
├─kmix
├─knotify4───4*[{knotify4}]
├─konsole─┬─bash───su───bash───pstree
│ └─{konsole}
├─krunner
├─kxkb───{kxkb}
├─plasma-desktop
├─sshd
├─start_kdeinit
├─syslog-ng───syslog-ng
├─udevd
└─yakuake─┬─bash
└─{yakuake}

A mi no me da ninguna pista...

A alguien si?

Gracias.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1034
Location: La Plata, Argentina

PostPosted: Sat Mar 13, 2010 6:45 pm    Post subject: Reply with quote

pasa q me parece que hiciste un emerge --sync, y portage te borro los ebuilds viejos
Quote:
pelo@pelo-pc ~ $ ls /usr/portage/kde-base/kdebase-startkde/
ChangeLog files kdebase-startkde-4.3.4.ebuild kdebase-startkde-4.4.0.ebuild metadata.xml
Manifest kdebase-startkde-4.3.3-r1.ebuild kdebase-startkde-4.3.5.ebuild kdebase-startkde-4.4.1.ebuild

o sea, kde3 no esta mas en portage... vas a tener que hacerte tu arbol de portage (tu propio overlay) con kde3, o actualizar a kde4, ya que esos ebuilds no estan mas
_________________
el pelado de la gente
Back to top
View user's profile Send private message
sasho23
Apprentice
Apprentice


Joined: 28 Dec 2005
Posts: 186
Location: Pamplona , Spain

PostPosted: Sun Mar 14, 2010 9:56 am    Post subject: Reply with quote

el_miki wrote:
Hola, Me da esto:

init─┬─acpid
├─6*[agetty]
├─cron
├─3*[dbus-daemon]
├─2*[dbus-launch]
├─hald───hald-runner─┬─hald-addon-inpu
│ └─hald-addon-stor
├─kaccess
├─kded4
├─kdeinit4─┬─firefox───19*[{firefox}]
│ ├─kio_trash
│ ├─klauncher
│ └─ksmserver─┬─kwin
│ └─{ksmserver}
├─kdm─┬─X
│ └─kdm───startkde───kwrapper4
├─kglobalaccel
├─klipper
├─kmix
├─knotify4───4*[{knotify4}]
├─konsole─┬─bash───su───bash───pstree
│ └─{konsole}
├─krunner
├─kxkb───{kxkb}
├─plasma-desktop
├─sshd
├─start_kdeinit
├─syslog-ng───syslog-ng
├─udevd
└─yakuake─┬─bash
└─{yakuake}

A mi no me da ninguna pista...

A alguien si?

Gracias.


Pues vaya, a mi tampoco me da pistas. Yo tambien tuve ese problema hace tiempo y resulto que algun programa nesecitaba el kde3. Hay una forma de ver que programa es, yo diria que es una poco chapuza, pero funcionara. Hazte "emerge -C =kde-base/kdelibs-3.5" y luego al actualizar el sistema te volvera a pedir a instalarlo debido a las dependencias, pero eso si te dira cual programa lo nesecita. Entonces quitas el nesecitado ya te quedas con solo kde4. suerte!
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 303
Location: Argentina

PostPosted: Sun Mar 14, 2010 4:09 pm    Post subject: Reply with quote

Hola..
existe un comando para ver las dependencias... "equery depends <paquete> " tambien podes usar equery para ver las USE que tenes... "equery uses <paquete>"
yo ya no tengo mas kde-3 pero aca te dejo un ejemplo para que veas como es la salida...

Code:
M1530 upszot # equery depends kde-base/libknotificationitem:4.3
/usr/lib/portage/pym/portage/util/__init__.py:1121: DeprecationWarning: The 'myroot' parameter for portage.config.getvirtuals() is deprecated
  result = lazy_item.func(*pargs, **kwargs)
[ Searching for packages depending on kde-base/libknotificationitem:4.3... ]
kde-base/kdepimlibs-4.3.2 (!kdeprefix? >=kde-base/libknotificationitem-4.3.2[-kdeprefix])
                          (kdeprefix? >=kde-base/libknotificationitem-4.3.2:4.3[kdeprefix])

M1530 upszot # equery uses kde-base/libknotificationitem
/usr/lib/portage/pym/portage/util/__init__.py:1121: DeprecationWarning: The 'myroot' parameter for portage.config.getvirtuals() is deprecated
  result = lazy_item.func(*pargs, **kwargs)
[ Searching for packages matching kde-base/libknotificationitem... ]
[ Colour Code : set unset ]
[ Legend : Left column  (U) - USE flags from make.conf              ]
[        : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for kde-base/libknotificationitem-4.3.5 ]
 U I
 - - aqua           : Include support for the Aqua / Carbon GUI
 - - debug          : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
 - - kdeenablefinal : EXPERIMENTAL: KDE ebuilds will use the enable-final flag, yielding compilation speedups at the cost of heavy mem usage and potentially causing problems. We strongly discourage setting this
 - - kdeprefix      : Makes a KDE prefixed install into /usr/kde/${SLOT} if enabled or into /usr (FHS compatible) otherwise
M1530 upszot #
yo te recomendaria que uses eso, antes de hacer un "emerge -C " ya que de esa forma te podria dejar de andar algun programa que dependa de lo que desinstalas...

Te hago una consulta, tu intencion es pasarte a kde4 o quedarte con kde3?

si piensas quedarte con kde3, tal como te dijeron arriba vas a tener que hacer un overlay para poner los ebuilds pq el kde-3 ya no esta mas en portage...
mi recomendacion es que te pases a kde-4.... pero claro, desconosco si se elevan mucho los requerimentos de hardware...y si tu maquina lo tirara...

Edit: Me olvidaba de mencionarte algo que quisas te ayude tambien...
podes ver la lista de los paquetes que tenes instalados en tu sistema, (con su version y si estan maskeados o con ~) ejecutando
Quote:
M1530 upszot # equery list
/usr/lib/portage/pym/portage/util/__init__.py:1121: DeprecationWarning: The 'myroot' parameter for portage.config.getvirtuals() is deprecated
result = lazy_item.func(*pargs, **kwargs)
[ Searching for all packages in all categories among: ]
* installed packages
[I--] [ ] app-admin/conky-1.7.2-r2 (0)
[I--] [ ~] app-admin/eselect-1.2.10 (0)
[I--] [ ] app-admin/eselect-ctags-1.13 (0)
[I--] [ ] app-admin/eselect-esd-20060719 (0)
[I--] [ ] app-admin/eselect-fontconfig-1.0 (0)
[I--] [ ~] app-admin/eselect-opengl-1.1.1-r2 (0)
[I--] [ ~] app-admin/eselect-python-20091230 (0)
[I--] [M ] app-admin/eselect-ruby-20081227 (0)

Saludos.
_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy
Back to top
View user's profile Send private message
sasho23
Apprentice
Apprentice


Joined: 28 Dec 2005
Posts: 186
Location: Pamplona , Spain

PostPosted: Sun Mar 14, 2010 4:26 pm    Post subject: Reply with quote

La manera que te ofrece upszot es la forma correcta de hacerlo! De hecho me la apuntare para futuros problemas.
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Mon Mar 15, 2010 5:11 pm    Post subject: Reply with quote

Hola upszot, muchas gracias lo primerpo.

Una aclaración, tengo KDE 4.4.1 por eso quiero quitar de enmedio las kdelibs 3.5 Y no mantenerlas como dices.

He hecho lo del comando y no me encuentra nada que las use, mira:

Alucard el_miki # equery depends kde-base/kdelibs-3.5.10-r6
* These packages depend on kde-base/kdelibs-3.5.10-r6:
kde-base/attica-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/dolphin-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix,semantic-desktop?])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix,semantic-desktop?])
(!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/dragonplayer-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/drkonqi-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/gwenview-4.4.1-r1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix,semantic-desktop?])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix,semantic-desktop?])
(!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kappfinder-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kcalc-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kcheckpass-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kcminit-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kcmshell-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kcontrol-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kde-l10n-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-colorschemes-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-desktopthemes-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-emoticons-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-iconthemes-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-kscreensaver-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-sounds-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-styles-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-wallpapers-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeartwork-weatherwallpapers-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdebase-cursors-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdebase-data-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdebase-desktoptheme-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdebase-kioslaves-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
(!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix,bzip2?,lzma?])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix,bzip2?,lzma?])
kde-base/kdebase-menu-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdebase-menu-icons-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdebase-startkde-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdebase-wallpapers-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdebugdialog-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdepasswd-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdepimlibs-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdeplasma-addons-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix,semantic-desktop?])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix,semantic-desktop?])
(!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdesu-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdialog-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdm-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kdnssd-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix,zeroconf])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix,zeroconf])
(!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/keditbookmarks-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/keditfiletype-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kephal-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kfile-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kfind-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kfmclient-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kglobalaccel-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/khelpcenter-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/khotkeys-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kiconfinder-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kinfocenter-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kioclient-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/klipper-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kmenuedit-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kmimetypefinder-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kmix-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/knetattach-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/knewstuff-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/knotify-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/konqueror-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/konsole-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kopete-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kpasswdserver-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kquitapp-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kreadconfig-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/krosspython-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/krunner-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kscreensaver-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/ksmserver-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/ksplash-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kstart-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kstartupconfig-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kstyles-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/ksysguard-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/ksystraycmd-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/ktimezoned-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/ktraderclient-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kuiserver-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kurifilter-plugins-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kwalletd-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kwin-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kwrite-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/kwrited-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/libkonq-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/libkworkspace-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/libplasmaclock-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/libplasmagenericshell-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/libtaskmanager-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/nsplugins-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/okular-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/phonon-kde-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/plasma-apps-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/plasma-runtime-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/plasma-workspace-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix,semantic-desktop?])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix,semantic-desktop?])
(!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/powerdevil-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/pykde4-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix,opengl,semantic-desktop?])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix,opengl,semantic-desktop?])
(!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/qguiplatformplugin_kde-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/renamedlg-plugins-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/solid-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/solid-runtime-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/svgpart-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-base/systemsettings-4.4.1 (!kdeprefix ? >=kde-base/kdelibs-4.4.1[aqua=,-kdeprefix])
(kdeprefix ? >=kde-base/kdelibs-4.4.1:4.4[aqua=,kdeprefix])
kde-misc/yakuake-2.9.6 (>=kde-base/kdelibs-4.3)
media-sound/amarok-2.2.2.90 (>=kde-base/kdelibs-4.3[opengl?,semantic-desktop?])
(>=kde-base/kdelibs-4.3)
net-p2p/ktorrent-3.3.4 (>=kde-base/kdelibs-4.3)

Que me decis?

Gracias.
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 303
Location: Argentina

PostPosted: Wed Mar 17, 2010 4:32 am    Post subject: Reply with quote

el_miki wrote:
Hola upszot, muchas gracias lo primerpo.
Una aclaración, tengo KDE 4.4.1 por eso quiero quitar de enmedio las kdelibs 3.5 Y no mantenerlas como dices.
He hecho lo del comando y no me encuentra nada que las use, mira:
Que me decis?
Gracias.

Hola miki... perdona que no te pude contestar antes... bueno por lo que veo el paquete no tiene dependencias...por lo que lo podes quitar tranquilo...

proba de hacer un
Code:
emerge -CDp kde-base/kdelibs-3.5.10-r6
a ver que te quiere eliminar...
calculo que lo podes quitar tranquilo... yo las saque... el unico que lo usaba era el k3b que tenia instalada en otro slot la version vieja (que venia con kde3.5) pero con la ultima por mas de ser beta anda de lo mas bien asique la elimine...

con esto te podes dar cuenta facilmente si tenes aplicaciones instaladas en varios slots (duplicadas)
Code:
equery list -d


espero q te sea de ayuda...

saludos
_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Wed Mar 17, 2010 3:33 pm    Post subject: Reply with quote

Hola,

He probado:
Code:

Alucard el_miki # emerge -CDp kde-base/kdelibs-3.5.10-r6
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

>>> These are the packages that would be unmerged:

 kde-base/kdelibs
    selected: 3.5.10-r6
   protected: none
     omitted: 4.4.1-r1

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.


Por lo tanto he probado:
Code:

Alucard el_miki # emerge -pv --depclean  kde-base/kdelibs-3.5.10-r6
!!! 'kde-base/kdelibs-3.5.10-r6' is not a valid package atom.
!!! Please check ebuild(5) for full details.
Alucard el_miki # emerge -pv --depclean kde-base/kdelibs-3.5.10-r6
!!! 'kde-base/kdelibs-3.5.10-r6' is not a valid package atom.
!!! Please check ebuild(5) for full details.


Pues si que va a dar guerra este problema. La verdad es que ahora que recuerdo, la libreria la necesitaba k3b, pero ya lo quite!!!

Alguna idea¿

Gracias.
Back to top
View user's profile Send private message
lea0014
n00b
n00b


Joined: 09 Mar 2010
Posts: 24

PostPosted: Wed Mar 17, 2010 5:58 pm    Post subject: Reply with quote

Probá agregandole un '=' antes del nombre del paquete

emerge -pv --depclean =kde-base/kdelibs-3.5.10-r6
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 303
Location: Argentina

PostPosted: Wed Mar 17, 2010 8:29 pm    Post subject: Reply with quote

[quote="el_miki"]He probado:
Code:

Alucard el_miki # emerge -CDp kde-base/kdelibs-3.5.10-r6
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

hola... no soy muy bueno con el ingles... pero por lo que entiendo "<atom>" me da la impresion que se refiere a la exprecion atomica del paquete... con lo que entiendo seria sin poner el versionado....
el tema esta que al tener instalado kde 4.4.1 probablemente tengas tambien las kdelibs del 4... y no se con cual te va a querer hacer ese emerge prune....

pero bueno de todas formas como te dije mas arriba... ya que tu intencion es quedarte con la 4.4.1 y al no encontrar dependencias con equery depends .... (esto otro del emerge.. es como para hacer otro control mas a las cosas) yo te diria que ejecutes el emerge -C (sin -p) tranquilo y sin miedo....

Edit:
lea0014 wrote:
Probá agregandole un '=' antes del nombre del paquete

emerge -pv --depclean =kde-base/kdelibs-3.5.10-r6
Esto se puede hacer??.... no tengo a mano una maquina con gentoo para probarlo... esta noche lo voy a probar =)
_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy


Last edited by upszot on Thu Mar 18, 2010 1:04 am; edited 1 time in total
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 303
Location: Argentina

PostPosted: Thu Mar 18, 2010 1:03 am    Post subject: Reply with quote

hola...
probe eso de emerge -Dpv =paquere-version y va de lujo =))
aca hice una prueba con cualquier paquete...
Code:
M1530 upszot # emerge -Dpv =media-sound/amarok-2.2.2.90

These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild     UD] media-sound/amarok-2.2.2.90 [2.3.0] USE="daap mp3tunes mtp opengl semantic-desktop (-aqua) -cdda -debug -embedded -ipod (-kdeenablefinal) -lastfm" LINGUAS="es -bg -ca -cs -da -de -en_GB -et -eu -fi -fr -it -ja -km -nb -nds -nl -pa -pl -pt -pt_BR -ru -sl -sr -sr@latin -sv -th -tr -uk -wa -zh_TW" 0 kB

Total: 1 package (1 downgrade), Size of downloads: 0 kB
M1530 upszot #


bueno ya tengo intriga por saber como continua esto jeje...

saludos
_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Thu Mar 18, 2010 3:47 pm    Post subject: Reply with quote

Hola he probado:

Code:

Alucard el_miki # emerge -pv --depclean =kde-base/kdelibs-3.5.10-r6

Calculating dependencies... done!

>>> These are the packages that would be unmerged:                                                   
                                                                                                     
 kde-base/kdelibs
    selected: 3.5.10-r6
   protected: none
     omitted: 4.4.1-r1

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Packages installed:   708
Packages in world:    84
Packages in system:   50
Required packages:    707
Number to remove:     1



Despues he probado:

Code:

Alucard el_miki # emerge -Dpv =kde-base/kdelibs-3.5.10-r6

These are the packages that would be merged, in reverse order:

Calculating dependencies   * waiting for lock on /var/db/.pkg.portage_lockfile
 ...                                     [ ok ]
... done!

emerge: there are no ebuilds to satisfy "=kde-base/kdelibs-3.5.10-r6".


Joder yo flipo!!! A ver donde se ha metido el pakete!

GRacias.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3705

PostPosted: Thu Mar 18, 2010 3:55 pm    Post subject: Reply with quote

perdón si digo alguna chorrada, no he leído todo el hilo.

kde3 ya no está en el árbol oficial de gentoo asi que es normal que te diga que no puede actualizarlo a menos que uses el kde-sunset overlay este.
Pero si deberías ser capaz de desinstalarlo si es eso lo que pretendes, quiero decir, que te dice si ejecutas un emerge -Ca =kde-base/kdelibs-3.5.10-r6 p.ej. ?

saluetes
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 759

PostPosted: Thu Mar 18, 2010 4:10 pm    Post subject: Reply with quote

Si lo que quieres es desintalar kdelibs-3.5.10-r6 el comando que te dice gringo es correcto o si lo prefieres

emerge --depclean =kde-base/kdelibs-3.5.10-r6.

Lo que tu ejecutaste (Alucard el_miki # emerge -Dpv =kde-base/kdelibs-3.5.10-r6) sirve para actualizar (si es que es posible) exactamente ese paquete, versión y revisión (lo cual es siempre imposible) así como sus dependencias.
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Thu Mar 18, 2010 4:41 pm    Post subject: Reply with quote

gringo wrote:
perdón si digo alguna chorrada, no he leído todo el hilo.

kde3 ya no está en el árbol oficial de gentoo asi que es normal que te diga que no puede actualizarlo a menos que uses el kde-sunset overlay este.
Pero si deberías ser capaz de desinstalarlo si es eso lo que pretendes, quiero decir, que te dice si ejecutas un emerge -Ca =kde-base/kdelibs-3.5.10-r6 p.ej. ?

saluetes


Ummm pues SI, ya lo he desinstalado... que facil era. Nos hemos obcecado en hacer cosas raras, que no hemos hecho lo mas sencillo. Jajaaaa

Ahora solo espero que no me las vuevla a instalar al hacer un revdep-rebuild

Weno, ahora lo que me falta aclarar es esto otro qeu me dice:

!!! The following installed packages are masked:
- x11-libs/qt-3.3.8b-r2 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ben de Groot <yngwin@gentoo.org> (01 Mar 2010)
# Grand mask of qt:3 and remaining reverse dependencies
# pending removal on 21 Mar 2010 (bug 283429)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Que puedo hacer con ello???

Muchas gracias a todos.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3705

PostPosted: Thu Mar 18, 2010 4:51 pm    Post subject: Reply with quote

en teoría, un emerge -pv --depclean debería sacarte una lista de dependencias inútiles en tu sistema y una de ellas debería ser el qt3 que mencionas ahora que no tienes instalado kdelibs-3.5.x.
Si no es asi, simplemente emerge -Ca =x11-libs/qt-3.3.8b-r2, y listo.

Igual despues de esto te dice que tienes que volver a instalar este paquete lo que quiere decir que (aún) tienes paquetes que dependen de qt3, eso deberías poder solucionarlo mirando con un emerge -pN world los paquetes que aparezcan con un -qt3 en amarillo y recompilándolos.

saluetes
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 303
Location: Argentina

PostPosted: Thu Mar 18, 2010 7:33 pm    Post subject: Reply with quote

hablando de eso....

yo tengo "qt3" en /etc/make.conf en las use....
pero ya quiete tododo lo referente a kde3... estaba pensando... tengo esa use al dope no....

me pueden confirmar si es correcto quitarla de las use y hacer un "emerge -uD --newuse world"

saludos
_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy


Last edited by upszot on Tue Mar 23, 2010 2:39 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum