Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
¿ Xorg-Server ? (¡¡Solucionado!!)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Drake
n00b
n00b


Joined: 01 Oct 2007
Posts: 42

PostPosted: Thu Mar 18, 2010 11:01 pm    Post subject: Reply with quote

i92guboj wrote:
Drake wrote:
i92guboj wrote:
No parece que haya ningún error grave ahí. ¿Qué ocurre exactamente ahora al usar "startx" con el nuevo driver? X parece iniciar bien, quizás sea tu gestor de ventanas o escritorio es que tiene problemas ahora. ¿Puedes probar a usar un gestor de ventanas sencillo como fluxbox, openbox o algo similar?

no tengo niun escrtiorio estaba pensando en poner LXDE.. pero primero tenia que instalar la X..

Al momento teclear startx.. dice que no encuentro xterm xclock twn del xinitrc
y al final
waiting to x server to shutdown.


X por si mismo no es capaz de existir. Necesita que una aplicación cliente lo mantenga "vivo". Normalmente dicha aplicación es el gestor de ventanas, pero cualquier programa vale. Lo que sucede es que la sesión por defecto inicia twm, xterm y xclock. Si no se encuentra twm entonces X se ejecuta y a continuación muere. No es obligatorio tener twm instalado, pero si no lo tienes necesitas configurar X para iniciar algún otro WM o escritorio. X por si solo no sirve para nada.

osea no tengo pq instalar twm .. si voy a poner LXDE??
Back to top
View user's profile Send private message
Inodoro_Pereyra
Advocate
Advocate


Joined: 03 Nov 2006
Posts: 2630
Location: En la otra punta del cable

PostPosted: Fri Mar 19, 2010 1:19 am    Post subject: Reply with quote

No, no es necesario.
De hecho, TWM no sirve de mucho, no es mas que tres consolas, un reloj y ya... Bastante rudimentario (me ha sacado de apuros unas cuantas veces pero de ahí a ser necesario, no, para nada).

Salud!
_________________
Mi Blog.

Si no fuera por C, estaríamos escribiendo programas en BASI, PASAL y OBOL.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Fri Mar 19, 2010 7:55 am    Post subject: Reply with quote

Inodoro_Pereyra wrote:
No, no es necesario.
De hecho, TWM no sirve de mucho, no es mas que tres consolas, un reloj y ya... Bastante rudimentario (me ha sacado de apuros unas cuantas veces pero de ahí a ser necesario, no, para nada).

Salud!


Efectivamente no es necesario para nada. Solo puntualizar que las consolas y el reloj en realidad no tienen nada que ver con TWM, que es solo un gestor de ventanas muy sencillo. Es la sesión predefinida la que incluye esos añadido.

Saludos.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Inodoro_Pereyra
Advocate
Advocate


Joined: 03 Nov 2006
Posts: 2630
Location: En la otra punta del cable

PostPosted: Fri Mar 19, 2010 5:06 pm    Post subject: Reply with quote

Buen punto.

Salud!
_________________
Mi Blog.

Si no fuera por C, estaríamos escribiendo programas en BASI, PASAL y OBOL.
Back to top
View user's profile Send private message
Drake
n00b
n00b


Joined: 01 Oct 2007
Posts: 42

PostPosted: Mon Mar 22, 2010 6:00 am    Post subject: Reply with quote

Genial probare.. si me funciona LXDE ahora sin instalar TWM xclock etc..osea corriendo los driver de la envidia no deberia pq tener atado..

PD:Que sucede si instalao LXDE y en las USE no pongo LXDE ?? .. ahy manera que el emerge agregue las use automaticamente??
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Mon Mar 22, 2010 6:08 am    Post subject: Reply with quote

Drake wrote:
Genial probare.. si me funciona LXDE ahora sin instalar TWM xclock etc..osea corriendo los driver de la envidia no deberia pq tener atado..

PD:Que sucede si instalao LXDE y en las USE no pongo LXDE ?? .. ahy manera que el emerge agregue las use automaticamente??


No hay ningún ebuild que tenga un USE flag "lxde". En cuanto a lo de agregarlas automáticamente, no es posible. Al menos hasta que portage tenga la capacidad de leer nuestra mente o adivinar lo que pensamos. Existen utilidades para hacer más "fácil" la edición de USE flags, como ufed. Pero jamás las he usado así que no puedo comentar sobre sus capacidades concretas.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Drake
n00b
n00b


Joined: 01 Oct 2007
Posts: 42

PostPosted: Mon Mar 22, 2010 3:14 pm    Post subject: Reply with quote

Genial.. instale lxde y me funciono super bien..aunque como que me faltara algo :S .. lxde ocupa gtk enginer??daa... tp encuentro como cambiarle el idioma..
cuando trato de iniciar como usuario el lxde me dice xaith timeout in locking authority file //.Xauthority
//.serverauth.123337


Last edited by Drake on Mon Mar 22, 2010 3:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1034
Location: La Plata, Argentina

PostPosted: Mon Mar 22, 2010 3:47 pm    Post subject: Reply with quote

con generar las locales bbien, con locale-gen y poner en /etc/env.d/02locale lo siguiente
Code:
LANG="es_AR.UTF-8"
LC_COLLATE="C"

funciona perfectamente en español

claro esta que AR es xq soy argento...
_________________
el pelado de la gente
Back to top
View user's profile Send private message
Drake
n00b
n00b


Joined: 01 Oct 2007
Posts: 42

PostPosted: Mon Mar 22, 2010 3:52 pm    Post subject: Reply with quote

pelelademadera wrote:
con generar las locales bbien, con locale-gen y poner en /etc/env.d/02locale lo siguiente
Code:
LANG="es_AR.UTF-8"
LC_COLLATE="C"

funciona perfectamente en español

claro esta que AR es xq soy argento...

ya lo hice... y luego hice un locale-gen y no me paso nada..

tube que crear el archivo 02locale...
Code:
LANG="es_CL.UTF-8"
LC_COLLATE="C"


tendre que volver a instalar el LXDE ?
Back to top
View user's profile Send private message
Drake
n00b
n00b


Joined: 01 Oct 2007
Posts: 42

PostPosted: Mon Mar 22, 2010 4:06 pm    Post subject: Reply with quote

genial.. encontre lo del lenguaje.. http://www.gentoo.org/doc/es/guide-localization.xml?style=printable

ahora toy bsucando para que me inicie automaticamente el LXDE cuando encienda la torre..no lo encuentro..
el LXDE se me ve como corriendo una aplicacion de gtk en kde sin tener gtk-enginer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum