Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot install econnman from Enlightenment 18
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gelog
n00b
n00b


Joined: 01 Oct 2007
Posts: 20

PostPosted: Wed Feb 04, 2015 4:51 pm    Post subject: Cannot install econnman from Enlightenment 18 Reply with quote

Hello,

its too long i was not here. Just because my system did not surprise me.
I have a problem with installing econnman from E18.

Compiling :?: and installing were ok, but when i run econnman-bin i get next error:
Code:

Traceback (most recent call last):
  File "/usr/bin/econnman-bin", line 46, in <module>
    import elementary as elm
  File "/usr/lib64/python2.7/site-packages/elementary/__init__.py", line 19, in <module>
    import elementary.c_elementary
  File "elementary.c_elementary.pyx", line 1, in init elementary.c_elementary (./elementary/elementary.c_elementary.c:286539)
  File "/usr/lib64/python2.7/site-packages/evas/__init__.py", line 130, in <module>
    c_evas.init()
  File "evas.c_evas.pyx", line 287, in evas.c_evas.init (./evas/evas.c_evas.c:4342)
SystemError: Number of object callbacks changed from 32 to 35.



In system i have three python versions -> 2.7, 3.3, 3,4
Default for whole system was and is 2.7
Also before econnman i have installed python bindings, like python-e_dbus /version 1.7/, python-evas, python-elementary, as a dependences for econnman.
Everything is updated via git to newest.

Could somebody hint me what wrong with it ?
I would like to use this connection manager because it is part of E18.

Thank you
Bests,
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 406

PostPosted: Thu Feb 05, 2015 10:51 am    Post subject: Reply with quote

Heh... if you're using E18, then you should be using >=python-efl-1.10 and that packaged is not separated anymore like before.

Seems to be your issue here.

NOTE: There is such a package in my overlay... you may need to copy it to python-efl-1.10 or 1.11... 1.12 would be too new and would require EFL/ELM-1.12.

PS: So what is your EFL/ELM version then? You shoudl be using the same <major>.<minor> for both EFL/ELM and python bindings.

Else, use dhcpcd-ui... consult the wiki for more info about it. WM independent applet.
_________________
mkinitramfs-ll:(bar-)overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum