Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xmobar-darcs: emerge fallisce
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
formica
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2004
Posts: 113
Location: Messina (Sicily)

PostPosted: Fri Mar 12, 2010 12:56 am    Post subject: xmobar-darcs: emerge fallisce Reply with quote

Purtroppo sto sbattendo le corna xmobar-darcs (haskell-overlay)...
non ho veramente idea di cosa possa essere.
Anche xmobar dal portage classico fallisce miseramente!

Any idea?

Code:

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-misc/xmobar-darcs-0 from gentoo-haskell
 * checking ebuild checksums ;-) ...                                                                                                          [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                         [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                        [ ok ]
 * CPV:  x11-misc/xmobar-darcs-0
 * REPO: gentoo-haskell
 * USE:  elibc_glibc kernel_linux mail unicode userland_GNU x86 xft
>>> Unpacking source...
 * Fetching darcs repository http://code.haskell.org/xmobar into /usr/portage/distfiles/darcs-src...
/var/tmp/portage/x11-misc/xmobar-darcs-0/work /var/tmp/portage/x11-misc/xmobar-darcs-0/work
 * Running darcs pull --all --set-scripts-executable http://code.haskell.org/xmobar
Pulling from "http://code.haskell.org/xmobar"...               
No remote changes to pull in!
/var/tmp/portage/x11-misc/xmobar-darcs-0/work                 
 * Copying xmobar from /usr/portage/distfiles/darcs-src...
 * Darcs repository contents are now in /var/tmp/portage/x11-misc/xmobar-darcs-0/work/xmobar-darcs-0
>>> Source unpacked in /var/tmp/portage/x11-misc/xmobar-darcs-0/work
>>> Compiling source in /var/tmp/portage/x11-misc/xmobar-darcs-0/work/xmobar-darcs-0 ...
 * Using cabal-1.8.0.2.
[1 of 1] Compiling Main             ( /var/tmp/portage/x11-misc/xmobar-darcs-0/work/xmobar-darcs-0/Setup.lhs, /var/tmp/portage/x11-misc/xmobar-darcs-0/work/xmobar-darcs-0/Setup.o )
Linking setup ...
Configuring xmobar-0.10...
setup: At least the following dependencies are missing:
base ==4.*
 * ERROR: x11-misc/xmobar-darcs-0 failed:
 *   setup configure failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 1699:  Called cabal_src_compile
 *   environment, line  415:  Called cabal-configure
 *   environment, line  333:  Called die
 * The specific snippet of code:
 *       ./setup configure --ghc --prefix=/usr --with-compiler="$(ghc-getghc)" --with-hc-pkg="$(ghc-getghcpkg)" --prefix=/usr --libdir=/usr/$(get_libdir) --libsubdir=${P}/ghc-$(ghc-version) --datadir=/usr/share/ --datasubdir=${P}/ghc-$(ghc-version) ${cabalconf} ${CABAL_CONFIGURE_FLAGS} "$@" || die "setup configure failed"
 *
 * If you need support, post the output of 'emerge --info =x11-misc/xmobar-darcs-0',
 * the complete build log and the output of 'emerge -pqv =x11-misc/xmobar-darcs-0'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/haskell/eclass/haskell-cabal.eclass
 *   /usr/local/portage/layman/haskell/eclass/ghc-package.eclass
 * This ebuild is from an overlay named 'gentoo-haskell': '/usr/local/portage/layman/haskell/'
 * The complete build log is located at '/var/tmp/portage/x11-misc/xmobar-darcs-0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/xmobar-darcs-0/temp/environment'.
 * S: '/var/tmp/portage/x11-misc/xmobar-darcs-0/work/xmobar-darcs-0'

>>> Failed to emerge x11-misc/xmobar-darcs-0, Log file:

>>>  '/var/tmp/portage/x11-misc/xmobar-darcs-0/temp/build.log'

 * Messages for package x11-misc/xmobar-darcs-0:

 * ERROR: x11-misc/xmobar-darcs-0 failed:
 *   setup configure failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 1699:  Called cabal_src_compile
 *   environment, line  415:  Called cabal-configure
 *   environment, line  333:  Called die
 * The specific snippet of code:
 *       ./setup configure --ghc --prefix=/usr --with-compiler="$(ghc-getghc)" --with-hc-pkg="$(ghc-getghcpkg)" --prefix=/usr --libdir=/usr/$(get_libdir) --libsubdir=${P}/ghc-$(ghc-version) --datadir=/usr/share/ --datasubdir=${P}/ghc-$(ghc-version) ${cabalconf} ${CABAL_CONFIGURE_FLAGS} "$@" || die "setup configure failed"
 *
 * If you need support, post the output of 'emerge --info =x11-misc/xmobar-darcs-0',
 * the complete build log and the output of 'emerge -pqv =x11-misc/xmobar-darcs-0'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/haskell/eclass/haskell-cabal.eclass
 *   /usr/local/portage/layman/haskell/eclass/ghc-package.eclass
 * This ebuild is from an overlay named 'gentoo-haskell': '/usr/local/portage/layman/haskell/'
 * The complete build log is located at '/var/tmp/portage/x11-misc/xmobar-darcs-0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/xmobar-darcs-0/temp/environment'.
 * S: '/var/tmp/portage/x11-misc/xmobar-darcs-0/work/xmobar-darcs-0'
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Mar 12, 2010 3:10 pm    Post subject: Re: xmobar-darcs: emerge fallisce Reply with quote

formica wrote:
* Running darcs pull --all --set-scripts-executable http://code.haskell.org/xmobar
Pulling from "http://code.haskell.org/xmobar"...
No remote changes to pull in!
a naso sembra che debba scaricare da http://code.haskell.org/xmobar e non ci riesce, quindi la compilazione fallisce perché non c'è nulla da compilare.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
formica
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2004
Posts: 113
Location: Messina (Sicily)

PostPosted: Fri Mar 12, 2010 6:47 pm    Post subject: Reply with quote

Il messaggio dice che NON CI SONO cambiamenti remoti da "inserire"... insomma non mi pare sia quello il problema.
Boh, chi ci capisce è bravo.
Che fare?
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Mar 12, 2010 7:43 pm    Post subject: Reply with quote

Code:
Configuring xmobar-0.10...
setup: At least the following dependencies are missing:
base ==4.*

Direi che è più probabile che manchi qualche dipendenza, anche se di haskell conosco solamente il nome...
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
formica
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2004
Posts: 113
Location: Messina (Sicily)

PostPosted: Fri Mar 12, 2010 10:01 pm    Post subject: Reply with quote

Onip wrote:
Code:
Configuring xmobar-0.10...
setup: At least the following dependencies are missing:
base ==4.*

Direi che è più probabile che manchi qualche dipendenza, anche se di haskell conosco solamente il nome...


Lo credo anch'io... il problema è capire quale.
L'ultima riga è criptica... chi me la spiega? :D
Code:
base ==4.*
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Sat Mar 13, 2010 4:23 pm    Post subject: Reply with quote

Perchè non metti la versione in portage? La uso e funziona perfettamente, sicuramente posso darti un aiuto maggiore su quella (usavo anche io l'haskell overlay, ma recentemente l'ho completamente tolto) ;)
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
formica
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2004
Posts: 113
Location: Messina (Sicily)

PostPosted: Tue Mar 16, 2010 10:24 am    Post subject: Reply with quote

lavish wrote:
Perchè non metti la versione in portage? La uso e funziona perfettamente, sicuramente posso darti un aiuto maggiore su quella (usavo anche io l'haskell overlay, ma recentemente l'ho completamente tolto) ;)

Intanto grazie mille ;)

Sono passato all'overlay perchè usando il portage ufficiale ho problemi persino ad installare xmonad:

Code:

* xmonad-0.8.1.tar.gz RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * CPV:  x11-wm/xmonad-0.8.1
 * REPO: gentoo
 * USE:  elibc_glibc kernel_linux userland_GNU x86
>>> Unpacking source...
>>> Unpacking xmonad-0.8.1.tar.gz to /var/tmp/portage/x11-wm/xmonad-0.8.1/work
>>> Source unpacked in /var/tmp/portage/x11-wm/xmonad-0.8.1/work
>>> Compiling source in /var/tmp/portage/x11-wm/xmonad-0.8.1/work/xmonad-0.8.1 ...
 * Using cabal-1.8.0.2.
[1 of 1] Compiling Main             ( /var/tmp/portage/x11-wm/xmonad-0.8.1/work/xmonad-0.8.1/Setup.lhs, /var/tmp/portage/x11-wm/xmonad-0.8.1/work/xmonad-0.8.1/Setup.o )
Linking setup ...
Configuring xmonad-0.8.1...
Flags chosen: testing=False, small_base=True
Dependency X11 >=1.4.3: using X11-1.5.0.0
Dependency base ==3.*: using base-3.0.1.0
Dependency containers -any: using containers-0.1.0.1
Dependency directory -any: using directory-1.0.0.0
Dependency mtl -any: using mtl-1.1.0.0
Dependency process -any: using process-1.0.0.0
Dependency unix -any: using unix-2.3.0.0
Using Cabal-1.8.0.2 compiled by ghc-6.8
Using compiler: ghc-6.8.2
Using install prefix: /usr
Binaries installed in: /usr/bin
Libraries installed in: /usr/lib/xmonad-0.8.1/ghc-6.8.2
Private binaries installed in: /usr/libexec
Data files installed in: /usr/share/xmonad-0.8.1/ghc-6.8.2
Documentation installed in: /usr/share/doc/xmonad-0.8.1
No alex found
Using ar found on system at: /usr/bin/ar
No c2hs found
No cpphs found
No ffihugs found
Using gcc version 4.3.4 found on system at: /usr/bin/gcc
Using ghc version 6.8.2 given by user at: /usr/bin/ghc
Using ghc-pkg version 6.8.2 given by user at: /usr/bin/ghc-pkg
No greencard found
No haddock found
No happy found
No hmake found
Using hsc2hs version 0.66 found on system at: /usr/bin/hsc2hs
No hscolour found
No hugs found
No jhc found
Using ld found on system at: /usr/bin/ld
No lhc found
No lhc-pkg found
No nhc98 found
Using pkg-config version 0.23 found on system at: /usr/bin/pkg-config
Using ranlib found on system at: /usr/bin/ranlib
Using strip found on system at: /usr/bin/strip
Using tar found on system at: /bin/tar
Preprocessing library xmonad-0.8.1...
Preprocessing executables for xmonad-0.8.1...
Building xmonad-0.8.1...
[1 of 8] Compiling XMonad.StackSet  ( XMonad/StackSet.hs, dist/build/XMonad/StackSet.o )
[2 of 8] Compiling XMonad.Core      ( XMonad/Core.hs, dist/build/XMonad/Core.o )
[3 of 8] Compiling XMonad.Layout    ( XMonad/Layout.hs, dist/build/XMonad/Layout.o )
[4 of 8] Compiling XMonad.Operations ( XMonad/Operations.hs, dist/build/XMonad/Operations.o )
[5 of 8] Compiling XMonad.ManageHook ( XMonad/ManageHook.hs, dist/build/XMonad/ManageHook.o )
[6 of 8] Compiling XMonad.Config    ( XMonad/Config.hs, dist/build/XMonad/Config.o )
[7 of 8] Compiling XMonad.Main      ( dist/build/XMonad/Main.hs, dist/build/XMonad/Main.o )

XMonad/Main.hsc:303:21:
    Couldn't match expected type `KeyCode' against inferred type `Char'
      Expected type: KeyCode
      Inferred type: Char
    In the second argument of `(/=)', namely '\NUL'
    In the first argument of `when', namely `(kc /= '\NUL')'
 * ERROR: x11-wm/xmonad-0.8.1 failed:
 *   setup build failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3015:  Called haskell-cabal_src_compile
 *   environment, line 2366:  Called cabal_src_compile
 *   environment, line  545:  Called cabal-build
 *   environment, line  450:  Called die
 * The specific snippet of code:
 *       ./setup build || die "setup build failed"
 *
 * If you need support, post the output of 'emerge --info =x11-wm/xmonad-0.8.1',
 * the complete build log and the output of 'emerge -pqv =x11-wm/xmonad-0.8.1'.
 * The complete build log is located at '/var/tmp/portage/x11-wm/xmonad-0.8.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-wm/xmonad-0.8.1/temp/environment'.
 * S: '/var/tmp/portage/x11-wm/xmonad-0.8.1/work/xmonad-0.8.1'

>>> Failed to emerge x11-wm/xmonad-0.8.1, Log file:

>>>  '/var/tmp/portage/x11-wm/xmonad-0.8.1/temp/build.log'

 * Messages for package x11-wm/xmonad-0.8.1:

 * ERROR: x11-wm/xmonad-0.8.1 failed:
 *   setup build failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3015:  Called haskell-cabal_src_compile
 *   environment, line 2366:  Called cabal_src_compile
 *   environment, line  545:  Called cabal-build
 *   environment, line  450:  Called die
 * The specific snippet of code:
 *       ./setup build || die "setup build failed"
 *
 * If you need support, post the output of 'emerge --info =x11-wm/xmonad-0.8.1',
 * the complete build log and the output of 'emerge -pqv =x11-wm/xmonad-0.8.1'.
 * The complete build log is located at '/var/tmp/portage/x11-wm/xmonad-0.8.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-wm/xmonad-0.8.1/temp/environment'.
 * S: '/var/tmp/portage/x11-wm/xmonad-0.8.1/work/xmonad-0.8.1'

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
formica
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2004
Posts: 113
Location: Messina (Sicily)

PostPosted: Sat Mar 20, 2010 2:37 pm    Post subject: Reply with quote

Emerge continua a fallire. Da quanto ho capito c'è incompatibilità tra X.org 1.5 e Xmonad 0.9. Dovrei fare il downgrade di X.org.
Ho risolto con la versione 0.9.1 di Xmonad (che non è ancora in portage) installata tramite cabal-install (che è in portage).

Non metto il tag [RISOLTO] perchè l'incompatibilità permane.

Altri info su http://xmonad.org/intro.html

Saluti
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum