Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xdm/gdm login loops
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Ric95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2007
Posts: 94
Location: Alberta Can.

PostPosted: Thu Mar 11, 2010 3:14 am    Post subject: xdm/gdm login loops Reply with quote

When I try to login with xdm, the screen goes black for a few seconds then returns to the xdm login.
rc.conf has "XSESSION="Xfce4"
/etc/conf.d/xdm has "DISPLAYMANAGER="xdm"
What have I messed up this time ? :oops:
_________________
Corporations are not like people. They don't need rights as people do, they only need an even playing field on which to compete.


Last edited by Ric95 on Sat Mar 13, 2010 7:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Thu Mar 11, 2010 8:17 am    Post subject: Reply with quote

Can you post the output of:

ls -la /etc/X11/Sessions/

please?
Back to top
View user's profile Send private message
Ric95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2007
Posts: 94
Location: Alberta Can.

PostPosted: Thu Mar 11, 2010 1:20 pm    Post subject: Reply with quote

Code:
ric-desktop / # ls -la /etc/X11/Sessions/
total 16
drwxr-xr-x 2 root root 4096 2010-03-07 17:01 .
drwxr-xr-x 5 root root 4096 2010-03-08 00:45 ..
-rwxr-xr-x 1 root root   11 2010-03-07 17:01 Xfce4
-rwxr-xr-x 1 root root 2187 2010-03-06 17:23 Xsession

And Xfce4 only contains
Quote:
startxfce4

_________________
Corporations are not like people. They don't need rights as people do, they only need an even playing field on which to compete.
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Thu Mar 11, 2010 1:31 pm    Post subject: Reply with quote

Okay, try starting an X session, like so:

Press CTRL+ALT+F1 and login as root and then do:
Code:
killall -SIGKILL X
X


Now, switch to another console:

CTRL+ALT+F2 and login as the user you want to start Xfce4 with and then do:
Code:
DISPLAY=:0.0 xterm


Now, move to the X session:

CTRL+ALT+F7
Code:
startxfce4 > ~/xfce4errorlog 2> ~/xfce4errorlog


If it works, then I'm suprised :p . If it fails, please post ~/xfce4errorlog :) .[/profile]
Back to top
View user's profile Send private message
Ric95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2007
Posts: 94
Location: Alberta Can.

PostPosted: Sat Mar 13, 2010 5:09 pm    Post subject: Reply with quote

Sorry for the delay.
Quote:
Okay, try starting an X session, like so:
Press CTRL+ALT+F1 and login as root and then do:
Code:
killall -SIGKILL X
X
Now, switch to another console:
CTRL+ALT+F2 and login as the user you want to start Xfce4 with and then do:
Code:
DISPLAY=:0.0 xterm
Now, move to the X session:
CTRL+ALT+F7
Code:
startxfce4 > ~/xfce4errorlog 2> ~/xfce4errorlog

Thanks, I tried those steps, but it didn't help, and I couldn't find the xfce4errorlog.:(
So I tried installing gdm. it still loops back to the login screen with the error " session lasted less than 10 seconds, check configs" (or somthing like that)
I did fetch the error log from gdm:
Quote:

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.33-zen1 x86_64
Current Operating System: Linux localhost 2.6.33-zen1 #1 ZEN SMP Sun Mar 7 12:07:53 Local time zone must be set--see z x86_64
Build Date: 07 March 2010 04:04:11PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar 12 17:10:56 2010
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Mar 12 17:10:57 NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) Mar 12 17:10:57 NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) Mar 12 17:10:57 NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) Mar 12 17:10:57 NVIDIA(0): you continue to encounter problems, Please try
(EE) Mar 12 17:10:57 NVIDIA(0): reinstalling the NVIDIA driver.
expected keysym, got XF86TouchpadToggle: line 122 of inet
expected keysym, got XF86TouchpadToggle: line 122 of inet
expected keysym, got XF86TouchpadToggle: line 122 of inet
expected keysym, got XF86TouchpadToggle: line 122 of inet
expected keysym, got XF86TouchpadToggle: line 122 of inet
expected keysym, got XF86TouchpadToggle: line 122 of inet

This is frustrating. Before I installed xdm and gdm, I could log in from command line and xorg worked fine!, glx and all.
I suppose -C xdm wouldn't fix this ??
_________________
Corporations are not like people. They don't need rights as people do, they only need an even playing field on which to compete.
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sat Mar 13, 2010 5:25 pm    Post subject: Reply with quote

Ric95 wrote:
Sorry for the delay.
Quote:
Okay, try starting an X session, like so:
Press CTRL+ALT+F1 and login as root and then do:
Code:
killall -SIGKILL X
X
Now, switch to another console:
CTRL+ALT+F2 and login as the user you want to start Xfce4 with and then do:
Code:
DISPLAY=:0.0 xterm
Now, move to the X session:
CTRL+ALT+F7
Code:
startxfce4 > ~/xfce4errorlog 2> ~/xfce4errorlog


Where did things go wrong? Besides, looking at your xorg log *now*, it seems you have incorrect opengl settings.

eselect opengl list

eselect opengl set ...
Back to top
View user's profile Send private message
Ric95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2007
Posts: 94
Location: Alberta Can.

PostPosted: Sat Mar 13, 2010 6:10 pm    Post subject: Reply with quote

Quote:
looking at your xorg log *now*, it seems you have incorrect opengl settings.

Good thought.
opengl was set to xorg, I just tried changing it to nvidia, but no luck.
I did find that xfce4errorlog;
Quote:

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
No protocol specified
giving up.
xinit: Resource temporarily unavailable (errno 11): unable to connect to X se$
xinit: No such process (errno 3): Server error.

I don't think I did it right, I'll print it and try again.
_________________
Corporations are not like people. They don't need rights as people do, they only need an even playing field on which to compete.
Back to top
View user's profile Send private message
Ric95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2007
Posts: 94
Location: Alberta Can.

PostPosted: Sat Mar 13, 2010 6:33 pm    Post subject: Reply with quote

This is strange, I'll have to study this whole x thing.
Following your instructions, to here:
Quote:
startxfce4 > ~/xfce4errorlog 2> ~/xfce4errorlog
the desktop started!
With this errorlog:
Quote:
<stdin>:1:3: error: invalid preprocessing directive #Those
<stAgent pid 1854
xfdesktop[1875]: starting up

MCS->Xfconf settings migration complete

ocessing directive #Xft
<stdin>:4:3: error: invalid preprocessing directive #Xft

(xfce4-session:1862): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/security/EnableTcp" does not exist on channel "xfce4-session"

(xfce4-session:1862): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/compat/LaunchGNOME" does not exist on channel "xfce4-session"

(xfce4-session:1862): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/compat/LaunchKDE" does not exist on channel "xfce4-session"

(xfce4-session:1862): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/general/SessionName" does not exist on channel "xfce4-session"

(xfce4-session:1862): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/chooser/AlwaysDisplay" does not exist on channel "xfce4-session"
xfce4-settings-helper is already running

(xfwm4:1869): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/xfwm4/custom/override" does not exist on channel "xfce4-keyboard-shortcuts"

(xfwm4:1869): xfconf-WARNING **: Error check failed at IA__xfconf_channel_reset_property():694: Property "/xfwm4/custom" does not exist on channel "xfce4-keyboard-shortcuts"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/xinerama-stretch" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/style" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/icon-size" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/font-size" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/use-custom-font-size" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color-style" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color1" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color2" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/image-show" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/image-style" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/brightness" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/saturation" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/image-path" does not exist on channel "xfce4-desktop"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/KeyRepeat" does not exist on channel "keyboards"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/KeyRepeat/Delay" does not exist on channel "keyboards"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/KeyRepeat/Rate" does not exist on channel "keyboards"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/StickyKeys" does not exist on channel "accessibility"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/SlowKeys" does not exist on channel "accessibility"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/BounceKeys" does not exist on channel "accessibility"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/MouseKeys" does not exist on channel "accessibility"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-filesystem" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-home" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-trash" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-removable" does not exist on channel "xfce4-desktop"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/commands/custom/override" does not exist on channel "xfce4-keyboard-shortcuts"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at IA__xfconf_channel_reset_property():694: Property "/commands/custom" does not exist on channel "xfce4-keyboard-shortcuts"

(xfce4-settings-helper:1899): GLib-GObject-CRITICAL **: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed

(xfce4-settings-helper:1899): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/XkbDisable" does not exist on channel "keyboard-layout"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/NumScreens" does not exist on channel "displays"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/NumScreens" does not exist on channel "displays"

(xfce4-settings-helper:1899): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/general/workspace_names" does not exist on channel "xfwm4"
Can't run 'xinput' (No such file or directory); unable to migrate mouse settings at /usr/libexec/xfce4/xfconf-migration/xfconf-migration-4.6.pl line 434.

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-menu/show" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-menu/show-icons" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-icons" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-workspace-names" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-submenus" does not exist on channel "xfce4-desktop"

(xfdesktop:1875): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-sticky-once" does not exist on channel "xfce4-desktop"
xscreensaver: 11:23:01: SIGHUP received: restarting...
xscreensaver: 11:23:01: running as ric/users (1000/100)


(xfwm4:1869): libxfcegui4-WARNING **: ICE I/O Error

(xfwm4:1869): libxfcegui4-WARNING **: Disconnected from session manager.

(xfwm4:1869): xfconf-WARNING **: Error check failed at IA__xfconf_channel_has_property():609: Disconnection or out-of-memory

(xfwm4:1869): xfconf-WARNING **: Error check failed at xfconf_channel_set_internal():356: Disconnection or out-of-memory

[Those 2 lines duplicate about 15 times]
(xfce4-panel:1871): libxfcegui4-WARNING **: ICE I/O Error
onf_channel_set_internal():356: Disconnection or out-of-memory

(xfwm4:1869): xfconf-WARNING **: Error check failed at IA__xfconf_channel_has_property():609: Disconnection or out-of-memory

(xfwm4:1869): xfconf-WARNING **: Error check failed at xfconf_channel_set_internal():356: Disconnection or out-of-memory
**edit**[Those 2 lines duplicate about 30 times]

(xfwm4:1869): xfconf-WARNING **: Error check failed at IA__xfconf_channel_get_properties():738: Disconnection or out-of-memory
xfwm4: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
xscreensaver: 11:23:01: Can't open display: :0.0
xscreensaver: 11:23:01: running as ric/users (1000/100)

xscreensaver: 11:23:01: Errors at startup are usually authorization problems.
But you're not logging in as root (good!) so something
else must be wrong. Did you read the manual and the FAQ?

http://www.jwz.org/xscreensaver/faq.html
http://www.jwz.org/xscreensaver/man.html

The application 'xfce4-panel' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.

So I have a desktop, but xdm/gdm can't start it, and of course if I close xterm I lose it.
Progress though :)
Also, I suspect .xinit may be missing. Where would it be located on this setup?
_________________
Corporations are not like people. They don't need rights as people do, they only need an even playing field on which to compete.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7130
Location: almost Mile High in the USA

PostPosted: Mon Apr 28, 2014 2:19 am    Post subject: Reply with quote

I think this qualifies as necroing but I don't care...

I ran into the issue where trying to login to xfce4 via xdm would just hop back to the xdm login screen.

In ~/.xsession-errors, xfce4 indicated that it couldn't start because of duplicate authorization, or something to that extent (I forgot to write down the error before I solved it). I was setting .xsession with "startxfce4". Using .xsession set to another, non-dbus/ckit windowmanager like twm seemed to work fine.

The trick that did it for me, apparently, was that xdm needed to be emerged with USE=xdm-auth - at least when I re-emerged xdm it seems to let xdm start xfce4.

Hope this helps someone who sees this issue, or at least it's something to try.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum