Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas con deps antiguas kdelibs 3.5 {SOLUCIONADO}
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1230
Location: La Plata, Argentina

PostPosted: Fri Mar 19, 2010 1:11 am    Post subject: Reply with quote

equery depends x11-libs/qt-3 te dice lo que tenes que depende de ese paquete....
creo que pertenece a gentoolkit equery
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 306
Location: Argentina

PostPosted: Fri Mar 19, 2010 2:50 am    Post subject: Reply with quote

pelelademadera wrote:
equery depends x11-libs/qt-3 te dice lo que tenes que depende de ese paquete....
creo que pertenece a gentoolkit equery
... no ..veo que me entendiste mal...si es a mi a quien le contestaste =P
no me referia a qt3 como paquete sino a la USE qt3..
Quote:
M1530 upszot # cat /etc/make.conf
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="-O2 -march=i686 -pipe"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"

MAKEOPTS="-j3"

USE="ssl perl latin1 mysql -ipv6 logrotate samba
X acpi ssh kde gnome alsa java opengl -debug pulseaudio
qt3support accessibility glib etc wifi
dvd jpeg jpeg2k tiff gif xvid png mp3 mpeg win32codecs
"
y ahora que estoy frente a la maquina rectifico el nombre... (no era "qt3" sino "qt3support")
y repito la pregunta...

teniendo instalado y queriendo tener unicamente kde-4.4.1 y despues de haber desinstalado todo kde3.5 me da la impresion de que la USE "qt3support" la tengo al dope en el sistema... y me pregunto si la puedo quitar tranquilo o si es necesaria para algo de kde4?

saludos
_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1230
Location: La Plata, Argentina

PostPosted: Fri Mar 19, 2010 2:54 am    Post subject: Reply with quote

mira, kde es bastante macaco con las use... si lo compilaste, dejalo asi, xq despues te va a causar problemas en un futuro update....
no se bien para q sirve esa flag. pero cada vez q actualizas kde hay q quitarla y agregarla.... dependiendo de la version de kde... en fin. yo no tocaria mas nada
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 306
Location: Argentina

PostPosted: Fri Mar 19, 2010 3:15 am    Post subject: Reply with quote

Hola... que raro esto...
pelelademadera wrote:
pero cada vez q actualizas kde hay q quitarla y agregarla.... dependiendo de la version de kde...

yo tengo esa use desde kde3.5 y pase por kde4.2 , kde4.3 , kde4.3.5 y ahora 4.4.1 y nunca toque esa use... siempre la deje...

con respecto a que hace... esta aca...
Code:
qt3support    Enable the Qt3Support libraries for Qt4
tomado de http://www.gentoo.org/dyn/use-index.xml
pero bueno a mi esa descripcion no me dice mucho... quisas alguien mas experimentado pueda saber..

....a y a lo que me referia de quitarla era ...quitarla del /etc/make.conf y despues hacer un emerge -uDp --newuse world (sin la p) jeje asi recompilo todo el sistema....

pero bueno acabo de hacer la prueba por curiosidad y me encontre con esto...
Code:
M1530 upszot # emerge -uDp --newuse world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "~x11-libs/qt-core-4.6.2[-debug,-qt3support,-aqua]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-core-4.6.2-r1 (Change USE: -qt3support)
(dependency required by "x11-libs/qt-opengl-4.6.2" [ebuild])
(dependency required by "@world" [argument])
asique hay paquetes nuevos que la usan... (aunque no tengo ni idea de que hace...esa USE la puso un amigo cuando me inicio en gentoo el anio pasado)

saludos
_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Sun Mar 21, 2010 1:28 pm    Post subject: Reply with quote

Hola, ya quité tambien las qt3 y parece que todo vien, pero hago un revdep-rebuild y me falla al emerger:

Quote:

Alucard el_miki # revdep-rebuild
* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Found existing 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Found existing 2_ldpath.rr.
* Checking dynamic linking consistency
* Found existing 3_broken.rr.
* Assigning files to packages
* Found existing 4_raw.rr
* Cleaning list of packages to rebuild
* Found existing 4_pkgs.rr
* Assigning packages to ebuilds
* Found existing 4_ebuilds.rr
* Evaluating package order
* Found existing 5_order.rr
* Generated new 5_order.rr
* All prepared. Starting rebuild
emerge --oneshot --ask --verbose --tree dev-perl/DBD-mysql:0
..........

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild R ] dev-perl/DBD-mysql-4.01.3 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-perl/DBD-mysql-4.01.3
* DBD-mysql-4.013.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* CPV: dev-perl/DBD-mysql-4.01.3
* REPO: gentoo
* USE: elibc_glibc kernel_linux userland_GNU x86
sandbox:main signal SIGQUIT already had a handler ...

>>> Unpacking source...
>>> Unpacking DBD-mysql-4.013.tar.gz to /var/tmp/portage/dev-perl/DBD-mysql-4.01.3/work
>>> Source unpacked in /var/tmp/portage/dev-perl/DBD-mysql-4.01.3/work
sandbox:main signal SIGQUIT already had a handler ...

>>> Compiling source in /var/tmp/portage/dev-perl/DBD-mysql-4.01.3/work/DBD-mysql-4.013 ...
* Using ExtUtils::MakeMaker
Can't locate DBI/DBD.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.10.1/i686-linux /usr/lib/perl5/site_perl/5.10.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.10.1/i686-linux /usr/lib/perl5/vendor_perl/5.10.1 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.10.1/i686-linux /usr/lib/perl5/5.10.1 .) at Makefile.PL line 24.
* ERROR: dev-perl/DBD-mysql-4.01.3 failed:
* Unable to build! (are you using USE="build"?)
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 2851: Called perl-module_src_compile
* environment, line 2540: Called perl-module_src_prep
* environment, line 2612: Called die
* The specific snippet of code:
* perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor INSTALLMAN3DIR='none' DESTDIR="${D}" ${myconf} <<< "${pm_echovar}" || die "Unable to build! (are you using USE=\"build\"?)";
*
* If you need support, post the output of 'emerge --info =dev-perl/DBD-mysql-4.01.3',
* the complete build log and the output of 'emerge -pqv =dev-perl/DBD-mysql-4.01.3'.
* The complete build log is located at '/var/log/portage/dev-perl:DBD-mysql-4.01.3:20100321-132629.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-perl/DBD-mysql-4.01.3/temp/environment'.
* S: '/var/tmp/portage/dev-perl/DBD-mysql-4.01.3/work/DBD-mysql-4.013'
sandbox:main signal SIGQUIT already had a handler ...


>>> Failed to emerge dev-perl/DBD-mysql-4.01.3, Log file:

>>> '/var/log/portage/dev-perl:DBD-mysql-4.01.3:20100321-132629.log'

* Messages for package dev-perl/DBD-mysql-4.01.3:

* ERROR: dev-perl/DBD-mysql-4.01.3 failed:
* Unable to build! (are you using USE="build"?)
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 2851: Called perl-module_src_compile
* environment, line 2540: Called perl-module_src_prep
* environment, line 2612: Called die
* The specific snippet of code:
* perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor INSTALLMAN3DIR='none' DESTDIR="${D}" ${myconf} <<< "${pm_echovar}" || die "Unable to build! (are you using USE=\"build\"?)";
*
* If you need support, post the output of 'emerge --info =dev-perl/DBD-mysql-4.01.3',
* the complete build log and the output of 'emerge -pqv =dev-perl/DBD-mysql-4.01.3'.
* The complete build log is located at '/var/log/portage/dev-perl:DBD-mysql-4.01.3:20100321-132629.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-perl/DBD-mysql-4.01.3/temp/environment'.
* S: '/var/tmp/portage/dev-perl/DBD-mysql-4.01.3/work/DBD-mysql-4.013'
* revdep-rebuild failed to emerge all packages.
* you have the following choices:
* - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
* - Use /etc/portage/package.keywords to unmask a newer version of the package.
* (and remove 5_order.rr to be evaluated again)
* - Modify the above emerge command and run it manually.
* - Compile or unmerge unsatisfied packages manually,
* remove temporary files, and try again.
* (you can edit package/ebuild list first)
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr


Alguien me puede ayudar con este nuevo fallo???

GRacias.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1230
Location: La Plata, Argentina

PostPosted: Sun Mar 21, 2010 3:43 pm    Post subject: Reply with quote

si haces eso unicamente solo vas a quitar el soporte. tenes que hacer el emerge -DuNav luego el depclean y luego un revdep-rebuild
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
el_miki
Apprentice
Apprentice


Joined: 16 Mar 2006
Posts: 178
Location: Ciudad Real (Spain)

PostPosted: Mon Mar 22, 2010 7:09 pm    Post subject: Reply with quote

Hola, de mi problemilla con el emerge dev-perl/DBD-mysql-4.01.3

Nadie sabe nada?
Abro un post solo para eso?

Gracias.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum