Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PPP connection to three mobile, nothing accessible.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
sputnik_uk
n00b
n00b


Joined: 28 Feb 2007
Posts: 47

PostPosted: Sat Mar 06, 2010 4:12 pm    Post subject: PPP connection to three mobile, nothing accessible. Reply with quote

Hi again peeps.

I'm trying to connect to the internet via bluetooth on my mobile phone, using wvdial.

It connects but the only IP i can ping is my local address, all other IP addrresses cannot be reached, even those of the assigned DNS servers.

I called three and i should be able to use the phone as a dial up modem, nothing is blocked their end. I'm not using a firewall.

Do I need to add a default route?

Any ideas?

/etc/wvdial.conf:
Code:

[Dialer defaults]
Modem = /dev/rfcomm0

[Dialer three]

Init2 = ATZ
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = Analog Modem
ISDN = 0
Phone = *99\#
Modem = /dev/rfcomm0
username = username
Password = password
Dial Command = ATDT
Baud =466600
Init4 = AT+CGDCONT=1,"IP","three.co.uk"
rob@linux-g5a8:~>


Code:

linux-g5a8:/home/rob # wvdial three           
--> WvDial: Internet dialer version 1.60     
--> Cannot get information for serial port.   
--> Initializing modem.                       
--> Sending: ATZ                             
ATZ                                           
OK
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","three.co.uk"
AT+CGDCONT=1,"IP","three.co.uk"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sat Mar  6 16:05:57 2010
--> Pid of pppd: 8203
--> Using interface ppp0
--> local  IP address 10.19.41.23
--> remote IP address 10.6.6.6
--> primary   DNS address 172.31.140.69
--> secondary DNS address 172.30.140.69
--> Script /etc/ppp/ip-up run successful
--> Default route Ok.


netstat -rn
Code:

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.6.6.6        0.0.0.0         255.255.255.255 UH        0 0          0 ppp0
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
0.0.0.0         0.0.0.0         0.0.0.0         U         0 0          0 ppp0


Thanks.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46313
Location: 56N 3W

PostPosted: Sat Mar 06, 2010 6:19 pm    Post subject: Reply with quote

sputnik_uk,

Yep - your default route is wrong.

The last line
Code:
0.0.0.0         0.0.0.0         0.0.0.0         U         0 0          0 ppp0
should have 10.6.6.6 as the gateway, as thats your next hop towards the internet.

However, the first route should allow you to ping 10.6.6.6
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sputnik_uk
n00b
n00b


Joined: 28 Feb 2007
Posts: 47

PostPosted: Sat Mar 06, 2010 7:26 pm    Post subject: Reply with quote

Can't ping the gateway, guess access is blocked at 3's end. Will try on a windows machine later, grr
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum