Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge: problemi di conflitto [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat Feb 27, 2010 3:46 pm    Post subject: Emerge: problemi di conflitto [risolto] Reply with quote

Ho un problema con l'aggiornamento del sistema che dopo molti tentativi non sono ancora riuscito a risolvere.
Ho lanciato un
Code:
eix sync && emerge -NDuav world
e questo mi restituisce
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-core:4

  ('ebuild', '/', 'x11-libs/qt-core-4.6.2-r1', 'merge') pulled in by
    ~x11-libs/qt-core-4.6.2[-debug,-aqua] required by ('ebuild', '/', 'x11-libs/qt-test-4.6.2', 'merge')
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kdm-4.3.5', 'nomerge')
    x11-libs/qt-core required by world
    (and 9 more)

  ('installed', '/', 'x11-libs/qt-core-4.5.3-r2', 'nomerge') pulled in by
    ~x11-libs/qt-core-4.5.3[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.3', 'nomerge')
    ~x11-libs/qt-core-4.5.3[-debug] required by ('installed', '/', 'x11-libs/qt-dbus-4.5.3-r1', 'nomerge')
    x11-libs/qt-core required by world
    (and 2 more)


For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy ">=dev-libs/shared-desktop-ontologies-0.2" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/shared-desktop-ontologies-0.2 (masked by: ~x86 keyword)

(dependency required by "kde-base/kdelibs-4.4.0" [ebuild])
(dependency required by "world" [argument])


Ora in package.keywords ho smascherato diversi pacchetti che mi hanno portato alla situazione attuale; se non fosse che ogni pacchetto smascherato mi porta alla necessità di un nuovo smascheramento
Code:
x11-libs/qt-core ~x86
x11-libs/qt-webkit ~x86
x11-libs/qt-test ~x86


Ho provato a fare l'emerge dei singoli pacchetti ma nulla di fatto.


Last edited by mrl4n on Mon Mar 01, 2010 6:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sat Feb 27, 2010 4:38 pm    Post subject: Reply with quote

Devi assicurarti di aver smascherato tutti* i moduli delle qt. Il problema è che tutti i moduli devono avere la stessa versione.
Fallo e rilancia l'update del world come hai fatto prima.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat Feb 27, 2010 5:27 pm    Post subject: Reply with quote

Dubito che sia la strada giusta...ora mi ritrovo in package.keywords
Code:
x11-libs/qt-core ~x86
x11-libs/qt-webkit ~x86
x11-libs/qt-test ~x86
dev-libs/soprano ~x86
dev-libs/shared-desktop-ontologies ~x86
x11-libs/qt-qt3support ~x86
x11-libs/qt-gui ~x86
x11-libs/qt-sql ~x86
x11-libs/qt-script ~x86
x11-libs/qt-svg ~x86
x11-libs/qt-opengl ~x86


e al tentativo di fare l'emerge
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

x11-libs/qt-script:4

  ('ebuild', '/', 'x11-libs/qt-script-4.6.2', 'merge') pulled in by
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/kmag-4.3.5', 'nomerge')
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/libkonq-4.3.5', 'nomerge')
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/kdesu-4.3.5', 'nomerge') 
    (and 7 more)                                                                                   

  ('installed', '/', 'x11-libs/qt-script-4.5.3-r1', 'nomerge') pulled in by
    ~x11-libs/qt-script-4.5.3[-debug] required by ('installed', '/', 'x11-libs/qt-gui-4.5.3-r2', 'nomerge')                                                                                                   

x11-libs/qt-sql:4

  ('installed', '/', 'x11-libs/qt-sql-4.5.3', 'nomerge') pulled in by
    ~x11-libs/qt-sql-4.5.3[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.3', 'nomerge')                                                                                       

  ('ebuild', '/', 'x11-libs/qt-sql-4.6.2', 'merge') pulled in by
    ~x11-libs/qt-sql-4.6.2[qt3support,-debug,-aqua] required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.6.2', 'merge')                                                                                     
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kdepasswd-4.3.5', 'nomerge')                                                                                               
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/libkcddb-4.3.5', 'nomerge')                                                                                               
    (and 8 more)                                                                                       

x11-libs/qt-core:4

  ('ebuild', '/', 'x11-libs/qt-core-4.6.2-r1', 'merge') pulled in by
    ~x11-libs/qt-core-4.6.2[qt3support,-debug,-aqua] required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.6.2', 'merge')                                                                                     
    ~x11-libs/qt-core-4.6.2[-debug,-aqua] required by ('ebuild', '/', 'x11-libs/qt-script-4.6.2', 'merge')                                                                                                   
    x11-libs/qt-core required by world                                                                 
    (and 13 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-core-4.5.3-r2', 'nomerge') pulled in by
    ~x11-libs/qt-core-4.5.3[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.3', 'nomerge')                                                                                     
    ~x11-libs/qt-core-4.5.3[-debug] required by ('installed', '/', 'x11-libs/qt-script-4.5.3-r1', 'nomerge')                                                                                                 
    x11-libs/qt-core required by world                                                                 
    (and 3 more)                                                                                       

x11-libs/qt-gui:4

  ('installed', '/', 'x11-libs/qt-gui-4.5.3-r2', 'nomerge') pulled in by
    x11-libs/qt-gui required by world                                   
    ~x11-libs/qt-gui-4.5.3[qt3support] required by ('installed', '/', 'x11-libs/qt-core-4.5.3-r2', 'nomerge')                                                                                                 
    ~x11-libs/qt-gui-4.5.3[qt3support,accessibility,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.3', 'nomerge')                                                                         

  ('ebuild', '/', 'x11-libs/qt-gui-4.6.2', 'merge') pulled in by
    x11-libs/qt-gui required by world
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kcheckpass-4.3.5', 'nomerge')
    ~x11-libs/qt-gui-4.6.2[qt3support,accessibility,-debug,-aqua] required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.6.2', 'merge')
    (and 14 more)

x11-libs/qt-qt3support:4

  ('installed', '/', 'x11-libs/qt-qt3support-4.5.3', 'nomerge') pulled in by
    ~x11-libs/qt-qt3support-4.5.3[-debug] required by ('installed', '/', 'x11-libs/qt-gui-4.5.3-r2', 'nomerge')

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.6.2', 'merge') pulled in by
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/kdepasswd-4.3.5', 'nomerge')
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'app-cdr/k3b-1.70.0_beta1', 'nomerge')
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/libkonq-4.3.5', 'nomerge')
    (and 7 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously. You may want to try a larger value of the
--backtrack option, such as --backtrack=30, in order to see if that will
solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy ">=kde-base/kde-env-4.4.0[-kdeprefix,-aqua]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kde-env-4.4.0 (masked by: ~x86 keyword)

(dependency required by "kde-base/kdelibs-4.4.0" [ebuild])
(dependency required by "world" [argument])

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sat Feb 27, 2010 9:20 pm    Post subject: Reply with quote

Parti dai problemi piu semplici e assicurati di non averne piu:
Code:
...kde-base/kde-env-4.4.0 (masked by: ~x86 keyword) ...


Quando hai finito con tutti quelli, vedi se emerge riesce a creare tutto il grafico delle dipendenze in maniera giusta.
Per essere sicuri posta anche un "emerge --info" perché se hai una versione vecchia di portage questo non risolve questo tipo di blocchi in automatico.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat Feb 27, 2010 9:34 pm    Post subject: Reply with quote

Mi sta facendo smascherare il mondo...mi chiedo se sto facendo la cosa corretta.
Il mio emerge --info
Code:
# emerge --info
Portage 2.1.7.16 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r10 i686)
=================================================================                                   
System uname: Linux-2.6.31-gentoo-r10-i686-Intel-R-_Core-TM-2_Quad_CPU_Q8300_@_2.50GHz-with-gentoo-1.12.13                                                                                                   
Timestamp of tree: Sat, 27 Feb 2010 20:45:01 +0000                                                     
app-shells/bash:     4.0_p35                                                                           
dev-java/java-config: 2.1.10                                                                           
dev-lang/python:     2.6.4-r1                                                                         
dev-util/cmake:      2.6.4-r3                                                                         
sys-apps/baselayout: 1.12.13                                                                           
sys-apps/sandbox:    1.6-r2                                                                           
sys-devel/autoconf:  2.13, 2.63-r1                                                                     
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1                                               
sys-devel/binutils:  2.18-r3                                                                           
sys-devel/gcc:       4.3.4                                                                             
sys-devel/gcc-config: 1.4.1                                                                           
sys-devel/libtool:   2.2.6b                                                                           
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.inode.at/ "
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/dottout /usr/local/portage/mylocal"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aften alsa asf avi berkdb bluetooth branding bzip2 cairo cdda cdparanoia cdr cli consolekit cracklib crypt css cups cxx dbus dri dts dvd dvdr eds embedded emboss encode evo fam ffmpeg firefox flac fortran gdbm gif gphoto2 gpm gstreamer gtk hal iconv ipv6 jpeg kde lame ldap libnotify mad matroska mikmod mng modules mp3 mp4 mpeg msn mudflap mysql ncurses nls nptl nptlonly nsplugin odcb ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sasl scanner sdl session spell spl sql ssl startup-notification svg symlink sysfs tcpd thunar tiff timidity truetype unicode usb vorbis w32codecs webkit win32codecs x264 x86 xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="*" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sat Feb 27, 2010 11:28 pm    Post subject: Reply with quote

Se vuoi il sistema aggiornato con qt-4.6.2 e kde-4.4 è ovvio che li dovrai smascherare. Se ti rompi le scatole a farlo a mano c'è autounmask in portage.
Il portage che usi dovrebbe farcela credo....
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Feb 28, 2010 8:25 am    Post subject: Reply with quote

Io non ho mai capito perché, ma l'unico modo che ho trovato per risolvere questo problema (ad esempio per passare da qt-*-4.5.3 a qt-*-4.6.2) è stato quello di fare l'unmerge di tutti i pacchetti qt-* e installarli di nuovo.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sun Feb 28, 2010 8:57 am    Post subject: Reply with quote

Per cui, dopo aver smascherato "il mondo" devo mettermi a rimuoverlo, per poi aggiornarlo?
Giuro che questo meccanismo proprio non riesco a capirlo.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Feb 28, 2010 9:06 am    Post subject: Reply with quote

E non lo capisco nemmeno io infatti, solo che se voglio aggiornare qt, devo fare questa operazione. Più che "pericolosa" è noiosa. Infatti, dopo aver aggiunto i seguenti pacchetti in package.keywords, ad esempio:
Code:
=x11-libs/qt-qt3support-4.6.2
=x11-libs/qt-gui-4.6.2
=x11-libs/qt-script-4.6.2
=x11-libs/qt-svg-4.6.2
=x11-libs/qt-sql-4.6.2
=x11-libs/qt-test-4.6.2
=x11-libs/qt-core-4.6.2-r1
=x11-libs/qt-webkit-4.6.2
=x11-libs/qt-opengl-4.6.2
=x11-libs/qt-dbus-4.6.2
=x11-libs/qt-xmlpatterns-4.6.2
=x11-libs/qt-assistant-4.6.2
=x11-libs/qt-4.6.2
=x11-libs/qt-multimedia-4.6.2

Faccio:
Code:
emerge -Cav qt-gui qt-script qt-svg qt-sql qt-test qt-core qt-webkit qt-opengl qt-dbus qt-xmlpatterns qt-assistant qt qt-multimedia &&
emerge -av qt-gui qt-script qt-svg qt-sql qt-test qt-core qt-webkit qt-opengl qt-dbus qt-xmlpatterns qt-assistant qt qt-multimedia


Altrimenti le versioni più vecchie dei suddetti pacchetti mi bloccano l'aggiornamento a quelle più recenti. E questo mi è sempre successo.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sun Feb 28, 2010 9:12 am    Post subject: Reply with quote

Ho bisogno di un consiglio, perchè adesso sono ad un bivio, e non vorrei trovarmi con un sistema fortemente instabile; non sono ancora all'altezza di risolvermi tutti i problemi che mi si presentano e non voglio pesare sulle spalle del forum.
Pare che per proseguire devo aggiornare anche portage, nonostante vedo che oltre la mia versione, per ora, ne esiste solo un'altra
Code:
[I] sys-apps/portage
     Available versions:  [P]2.1.6.7 2.1.6.13 2.1.7.16 ~2.1.7.17 [M]~2.2_rc62 [M]~2.2_rc63 {build doc epydoc linguas_pl python3 selinux}
     Installed versions:  2.1.7.16(22:28:36 20/02/2010)(-build -doc -epydoc -linguas_pl -python3 -selinux)


Code:
!!! All ebuilds that could satisfy ">=dev-db/virtuoso-server-6.1.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-db/virtuoso-server-6.1.0 (masked by: EAPI 3)

The current version of portage supports EAPI '2'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

(dependency required by "dev-libs/soprano-2.4.0.1" [ebuild])
(dependency required by "world" [argument])
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Feb 28, 2010 9:34 am    Post subject: Reply with quote

Dunque, le versioni di portage 2.2_rc*, che personalmente uso da quando sono uscite e sono perfette, richiedono baselayout-2 e OpenRC.
C'è una guida nella documentazione ufficiale che spiega come fare e ti consiglio di seguirla.
Per sbloccare questa situazione credo proprio che tu debba passare a portage 2.2 (metti tranquillamente "=sys-apps/portage-2.2_rc*" in package.unmask e in package.keywords). Di sicuro con quella versione puoi installare quei pacchetti EAPI masked.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sun Feb 28, 2010 4:55 pm    Post subject: Reply with quote

...Un fallimento nel farlo produrrà un sistema non più avviabile...

Speriamo bene.
Grazie. :)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Feb 28, 2010 4:58 pm    Post subject: Reply with quote

Tranquillo, se non fai cavolate fila tutto liscio!
Io l'ho fatto su diversi PC e mai un problema.
Mi raccomando usa dispatch-conf a fine processo! Devi aggiornare tutti i files di configurazione.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sun Feb 28, 2010 8:22 pm    Post subject: Reply with quote

fbcyborg wrote:
Dunque, le versioni di portage 2.2_rc*, che personalmente uso da quando sono uscite e sono perfette, richiedono baselayout-2 e OpenRC.
C'è una guida nella documentazione ufficiale che spiega come fare e ti consiglio di seguirla.
Per sbloccare questa situazione credo proprio che tu debba passare a portage 2.2 (metti tranquillamente "=sys-apps/portage-2.2_rc*" in package.unmask e in package.keywords). Di sicuro con quella versione puoi installare quei pacchetti EAPI masked.


Non è così semplice...probabilmente per colpa mia.
Continuo a ricevere messaggi d'errore diversi senza riuscire a fare quell'aggiornamento
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Feb 28, 2010 8:49 pm    Post subject: Reply with quote

Forse se postassi qualche informazione in più sarebbe utile a tutti noi.
Ad esempio, a che punto sei, e che errore ti da?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sun Feb 28, 2010 8:58 pm    Post subject: Reply with quote

Il risultato dell'ultimo tentativo finisce così
Code:
Calculating dependencies |/usr/lib/portage/pym/portage/dep.py:931: DeprecationWarning: portage.dep.dep_getkey() is deprecated, use portage.dep.Atom.cp instead
  DeprecationWarning)
/usr/lib/portage/pym/portage/dep.py:695: DeprecationWarning: portage.dep.dep_getcpv() is deprecated, use portage.dep.Atom.cpv instead
  DeprecationWarning)
... done!

!!! All ebuilds that could satisfy ">=media-libs/libpng-1.2.42" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/libpng-1.4.0 (masked by: missing keyword)
- media-libs/libpng-1.2.42 (masked by: ~x86 keyword)

(dependency required by "app-text/ghostscript-gpl-8.71" [ebuild])
(dependency required by "net-print/foomatic-filters-3.0.20080507" [installed])
(dependency required by "world" [argument])

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


con package.keywords
Code:
kde-base/kdelibs ~x86
dev-libs/libattica ~x86
x11-libs/qt-core ~x86
x11-libs/qt-webkit ~x86
x11-libs/qt-test ~x86
dev-libs/soprano ~x86
dev-libs/shared-desktop-ontologies ~x86
x11-libs/qt-qt3support ~x86
x11-libs/qt-gui ~x86
x11-libs/qt-sql ~x86
x11-libs/qt-script ~x86
x11-libs/qt-svg ~x86
x11-libs/qt-opengl ~x86
kde-base/kde-env ~x86
x11-libs/qt-dbus ~x86
dev-db/virtuoso-server ~x86
app-text/ghostscript ~x86
sys-apps/baselayout ~x86
=sys-apps/portage-2.2_rc* ~x86
app-text/ghostscript-gpl ~x86
sys-apps/openrc ~x86
e package.unmask
Code:
=sys-apps/portage-2.2_rc*
sys-apps/openrc
=app-text/ghostscript-gpl-8.70
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Feb 28, 2010 9:19 pm    Post subject: Reply with quote

Ok, tu hai deciso di installare una versione testing di app-text/ghostscript-gpl ed altri pacchetti che richiedono (almeno) la versione 1.2.42 di libpng, quindi fai:
Code:
echo "=media-libs/libpng-1.2.42" >> /etc/portage/package.keywords

E ritenta l'emerge.
Hai un semplice problema di pacchetti mascherati.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Mon Mar 01, 2010 7:48 am    Post subject: Reply with quote

Pare non abbia riportato problemi gravi, il sistema si e riavviato.
Due cose minori; ogni lancio di aggiornamenti leggo come prima cosa il messaggio
Code:
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/portage/mylocal/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.

posso dargli un nome qualsiasi?
e l'orologio va un'ora avanti, il resto sembra funzionare correttamente.

A questo punto probabilmente sono arrivato al punto cruciale per cui all'aggiornamento ricevo un avviso di consistenti dimensioni
Code:
Total: 27 packages (17 upgrades, 8 new, 2 in new slots, 2 uninstalls), Size of downloads: 297,363 kB
Conflict: 28 blocks (4 unsatisfied)                                                                 

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'kde-base/libknotificationitem-4.3.5', 'nomerge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kmenuedit-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/thumbnailers-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/ksame-4.3.5', 'nomerge')
    (and 228 more)

  ('installed', '/', 'kde-base/libkworkspace-4.3.5', 'nomerge') pulled in by
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdebase-meta-4.3.5', 'nomerge')
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kwin-4.3.5-r1', 'nomerge')
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kget-4.3.5', 'nomerge')
    (and 9 more)

  ('installed', '/', 'kde-base/plasma-workspace-4.3.5', 'nomerge') pulled in by
    >=kde-base/plasma-workspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdeplasma-addons-4.3.5', 'nomerge')
    >=kde-base/plasma-workspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdebase-startkde-4.3.5', 'nomerge')
    >=kde-base/plasma-workspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdebase-meta-4.3.5', 'nomerge')
    (and 1 more)

  ('installed', '/', 'kde-base/kpilot-4.3.5', 'nomerge') pulled in by
    >=kde-base/kpilot-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdepim-meta-4.3.5', 'nomerge')

  ('ebuild', '/', 'kde-base/kdelibs-4.4.0', 'merge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/ksudoku-4.3.5', 'nomerge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/lskat-4.3.5', 'nomerge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kmix-4.3.5', 'nomerge')
    (and 240 more)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Mar 01, 2010 8:36 am    Post subject: Reply with quote

mrl4n wrote:
Pare non abbia riportato problemi gravi, il sistema si e riavviato.
Due cose minori; ogni lancio di aggiornamenti leggo come prima cosa il messaggio
Code:
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/portage/mylocal/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.

posso dargli un nome qualsiasi?
e l'orologio va un'ora avanti, il resto sembra funzionare correttamente.
OK, il primo problema lo risolvi così ad esempio:
Code:
echo "local-repo" >> /usr/local/portage/mylocal/profiles/repo_name

E sì, mettici il nome che vuoi.

Quello dell'orologio lo puoi risolvere in due modi: 1) riguarda la documentazione sulla localizzazione, 2) puoi usare ntp.
mrl4n wrote:


A questo punto probabilmente sono arrivato al punto cruciale per cui all'aggiornamento ricevo un avviso di consistenti dimensioni
Code:
Total: 27 packages (17 upgrades, 8 new, 2 in new slots, 2 uninstalls), Size of downloads: 297,363 kB
Conflict: 28 blocks (4 unsatisfied)                                                                 

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'kde-base/libknotificationitem-4.3.5', 'nomerge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kmenuedit-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/thumbnailers-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/ksame-4.3.5', 'nomerge')
    (and 228 more)

  ('installed', '/', 'kde-base/libkworkspace-4.3.5', 'nomerge') pulled in by
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdebase-meta-4.3.5', 'nomerge')
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kwin-4.3.5-r1', 'nomerge')
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kget-4.3.5', 'nomerge')
    (and 9 more)

  ('installed', '/', 'kde-base/plasma-workspace-4.3.5', 'nomerge') pulled in by
    >=kde-base/plasma-workspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdeplasma-addons-4.3.5', 'nomerge')
    >=kde-base/plasma-workspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdebase-startkde-4.3.5', 'nomerge')
    >=kde-base/plasma-workspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdebase-meta-4.3.5', 'nomerge')
    (and 1 more)

  ('installed', '/', 'kde-base/kpilot-4.3.5', 'nomerge') pulled in by
    >=kde-base/kpilot-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdepim-meta-4.3.5', 'nomerge')

  ('ebuild', '/', 'kde-base/kdelibs-4.4.0', 'merge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/ksudoku-4.3.5', 'nomerge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/lskat-4.3.5', 'nomerge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kmix-4.3.5', 'nomerge')
    (and 240 more)

Per questo problema invece io cercerei di non installare kdelibs-4.4.0.
Puoi farlo mascherando quel pacchetto in package.mask, ma te lo sconsiglio.
Probabilmente c'è qualche pacchetto che lo vuole. Per scoprire quale sia puoi usare un
Code:
emerge -uDNavt world

Dovresti scoprirlo con la struttura ad albero che ti viene mostrata.
A quel punto, fai il downgrade alla versione 4.3.5 del pacchetto che richiede kde-4.4.0 e tutto dovrebbe andare liscio.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Mon Mar 01, 2010 9:01 am    Post subject: Reply with quote

Ho verificato con
Code:
emerge -uDNavt world
e mi viene difficile utilizzare la soluzione che mi hai proposto, in quanto i pacchetti sono 4 e tutti e 4 già alla versione 4.3.5
Code:
[blocks B     ] kde-base/libkworkspace:4.3[-kdeprefix] ("kde-base/libkworkspace:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)                                                                         
[blocks B     ] kde-base/plasma-workspace:4.3[-kdeprefix] ("kde-base/plasma-workspace:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)                                                                   
[blocks B     ] kde-base/kpilot:4.3[-kdeprefix] ("kde-base/kpilot:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)                                                                                       
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)           
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Mar 01, 2010 9:07 am    Post subject: Reply with quote

Scusa ma kdelibs-4.4.0 è già installato?
Se sì, fai il downgrade alla versione 4.3.5. Poi vediamo quale pacchetto reclama la 4.4.0.
Code:
emerge -av =kde-base/kdelibs-4.3.5

_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Mon Mar 01, 2010 10:13 am    Post subject: Reply with quote

No, sono fermo alla versione 4.3.5
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Mar 01, 2010 10:14 am    Post subject: Reply with quote

E allora chi è il pacchetto che richiede questa 4.4.0? Dovresti vederlo dall'albero che ti genera il comando emerge -uDNavt world.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Mon Mar 01, 2010 10:30 am    Post subject: Reply with quote

Ti riporto esattamente quello che mi restituisce
Code:
emerge -uDNavt world


Code:
These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] app-portage/layman-1.2.3  USE="git subversion -test"
[ebuild     U ]  dev-util/subversion-1.6.9 [1.6.6] USE="berkdb dso kde%* nls perl python sasl webdav-neon -apache2 -bash-completion -ctypes-python -debug -doc -emacs -extras -gnome-keyring -java -ruby -test -vim-syntax -webdav-serf" 5,351 kB                                                                   
[ebuild     U ] net-print/hplip-3.10.2 [3.9.12-r1] USE="gtk hpcups libnotify qt4 scanner -doc -fax -hpijs -minimal -new-hpcups -parport -policykit -snmp -static-ppds -udev-acl" 20,944 kB                   
[nomerge      ] kde-base/kdelibs-4.4.0 [4.3.5] USE="acl alsa bzip2 fam handbook nls opengl semantic-desktop spell ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -mmx -openexr -policykit -sse -sse2 -test -zeroconf"                                     
[blocks b     ]  kde-base/kdelibs:4.3[-kdeprefix] ("kde-base/kdelibs:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)                                                                                     
[uninstall    ]   kde-base/kdelibs-4.3.5  USE="acl alsa bzip2 fam handbook nls opengl semantic-desktop spell ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -mmx -openexr -sse -sse2 -test -zeroconf"                                                     
[ebuild  NS   ] kde-base/kdelibs-4.4.0 [4.3.5] USE="acl alsa bzip2 fam handbook nls opengl semantic-desktop spell ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -mmx -openexr -policykit -sse -sse2 -test -zeroconf" 13,755 kB                           
[ebuild     U ]  dev-libs/soprano-2.4.0.1 [2.3.1-r1] USE="dbus raptor redland* virtuoso%* -clucene* -debug -doc -java*" 1,899 kB                                                                             
[ebuild  N    ]   dev-db/libiodbc-3.52.7  USE="gtk" 1,015 kB                                           
[nomerge      ] kde-base/kde-meta-4.3.5  USE="nls -accessibility (-aqua) (-kdeprefix)"                 
[nomerge      ]  kde-base/kdeutils-meta-4.3.5  USE="(-aqua) (-cups) -floppy (-kdeprefix) -lirc"       
[nomerge      ]   kde-base/superkaramba-4.3.5  USE="handbook python (-aqua) -debug (-kdeenablefinal) (-kdeprefix)"                                                                                           
[nomerge      ]    x11-libs/qt-qt3support-4.6.2 [4.5.3] USE="accessibility exceptions%* kde (-aqua) -debug -pch -phonon"                                                                                     
[blocks b     ]     <x11-libs/qt-webkit-4.6.2 ("<x11-libs/qt-webkit-4.6.2" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)                                                                     
[ebuild     U ]      x11-libs/qt-webkit-4.6.2 [4.5.3-r2] USE="exceptions%* kde (-aqua) -debug -pch" 156,838 kB                                                                                               
[nomerge      ] net-print/foomatic-filters-3.0.20080507  USE="cups"                                   
[ebuild     U ]  app-text/ghostscript-gpl-8.71 [8.64-r3] USE="X cairo cups gtk -bindist -djvu -jpeg2k (-cjk%)" LINGUAS="-ja% -ko% -zh_CN% -zh_TW%" 24,655 kB                                                 
[nomerge      ] x11-libs/qt-webkit-4.6.2 [4.5.3-r2] USE="exceptions%* kde (-aqua) -debug -pch"         
[ebuild  N    ]  x11-libs/qt-xmlpatterns-4.6.2  USE="(-aqua) -debug -pch" 0 kB                         
[nomerge      ] kde-base/kdelibs-4.4.0 [4.3.5] USE="acl alsa bzip2 fam handbook nls opengl semantic-desktop spell ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -mmx -openexr -policykit -sse -sse2 -test -zeroconf"                                     
[ebuild  N    ]  dev-libs/shared-desktop-ontologies-0.2  82 kB                                         
[ebuild  N    ]  dev-libs/libattica-0.1.1  USE="-debug" 29 kB                                         
[nomerge      ] kde-base/kde-meta-4.3.5  USE="nls -accessibility (-aqua) (-kdeprefix)"                 
[nomerge      ]  kde-base/kdewebdev-meta-4.3.5  USE="(-aqua) (-kdeprefix)"                             
[nomerge      ]   kde-base/kfilereplace-4.3.5  USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)"                                                                                                   
[nomerge      ]    x11-libs/qt-qt3support-4.6.2 [4.5.3] USE="accessibility exceptions%* kde (-aqua) -debug -pch -phonon"                                                                                     
[blocks b     ]     <x11-libs/qt-opengl-4.6.2 ("<x11-libs/qt-opengl-4.6.2" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)                                                                     
[ebuild     U ]      x11-libs/qt-opengl-4.6.2 [4.5.3-r1] USE="exceptions%* qt3support (-aqua) -debug -pch" 0 kB                                                                                               
[blocks b     ]       <x11-libs/qt-svg-4.6.2 ("<x11-libs/qt-svg-4.6.2" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)                                                                     
[ebuild     U ]        x11-libs/qt-svg-4.6.2 [4.5.3-r1] USE="exceptions%* iconv (-aqua) -debug -pch" 0 kB                                                                                                     
[blocks b     ]         <x11-libs/qt-test-4.6.2 ("<x11-libs/qt-test-4.6.2" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)                                                                   
[ebuild     U ]          x11-libs/qt-test-4.6.2 [4.5.3-r1] USE="exceptions%* iconv (-aqua) -debug -pch" 0 kB                                                                                                 
[blocks b     ]           <x11-libs/qt-qt3support-4.6.2 ("<x11-libs/qt-qt3support-4.6.2" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)                                                           
[ebuild     U ]            x11-libs/qt-qt3support-4.6.2 [4.5.3] USE="accessibility exceptions%* kde (-aqua) -debug -pch -phonon" 0 kB                                                                         
[blocks b     ]             <x11-libs/qt-gui-4.6.2 ("<x11-libs/qt-gui-4.6.2" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)                                                               
[ebuild     U ]              x11-libs/qt-gui-4.6.2 [4.5.3-r2] USE="accessibility cups dbus exceptions%* glib gtk mng qt3support tiff (-aqua) -debug -nas -nis -pch -raster -xinerama" 0 kB                   
[blocks b     ]               <x11-libs/qt-script-4.6.2 ("<x11-libs/qt-script-4.6.2" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-dbus-4.6.2)                                                           
[ebuild     U ]                x11-libs/qt-script-4.6.2 [4.5.3-r1] USE="exceptions%* iconv (-aqua) -debug -pch" 0 kB                                                                                         
[blocks b     ]                 <x11-libs/qt-sql-4.6.2 ("<x11-libs/qt-sql-4.6.2" is blocking x11-libs/qt-gui-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)                                                           
[ebuild     U ]                  x11-libs/qt-sql-4.6.2 [4.5.3] USE="exceptions%* iconv mysql qt3support sqlite (-aqua) -debug -firebird -odbc -pch -postgres" 0 kB                                           
[blocks b     ]                   <x11-libs/qt-dbus-4.6.2 ("<x11-libs/qt-dbus-4.6.2" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-script-4.6.2)                                                         
[ebuild     U ]                    x11-libs/qt-dbus-4.6.2 [4.5.3-r1] USE="exceptions%* (-aqua) -debug -pch" 0 kB                                                                                             
[ebuild     U ]                     x11-libs/qt-core-4.6.2-r1 [4.5.3-r2] USE="exceptions%* glib iconv qt3support ssl (-aqua) -debug -doc -optimized-qmake% -pch" 0 kB                                         
[nomerge      ] kde-base/kdelibs-4.4.0 [4.3.5] USE="acl alsa bzip2 fam handbook nls opengl semantic-desktop spell ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -mmx -openexr -policykit -sse -sse2 -test -zeroconf"                                     
[nomerge      ]  kde-base/kde-env-4.4.0 [4.3.5-r1] USE="(-aqua) (-kdeenablefinal) (-kdeprefix)"       
[blocks b     ]   kde-base/kde-env:4.3[-kdeprefix] ("kde-base/kde-env:4.3[-kdeprefix]" is blocking kde-base/kde-env-4.4.0)                                                                                   
[uninstall    ]    kde-base/kde-env-4.3.5-r1  USE="(-kdeenablefinal) (-kdeprefix)"                     
[ebuild  NS   ]  kde-base/kde-env-4.4.0 [4.3.5-r1] USE="(-aqua) (-kdeenablefinal) (-kdeprefix)" 0 kB   
[nomerge      ] dev-libs/soprano-2.4.0.1 [2.3.1-r1] USE="dbus raptor redland* virtuoso%* -clucene* -debug -doc -java*"                                                                                       
[ebuild  N    ]  dev-db/virtuoso-server-6.1.0  USE="ldap readline -kerberos -static-libs" 68,518 kB   
[nomerge      ] dev-util/subversion-1.6.9 [1.6.6] USE="berkdb dso kde%* nls perl python sasl webdav-neon -apache2 -bash-completion -ctypes-python -debug -doc -emacs -extras -gnome-keyring -java -ruby -test -vim-syntax -webdav-serf"                                                                             
[ebuild     U ]  net-misc/neon-0.29.3 [0.29.0] USE="nls ssl zlib -doc -expat -gnutls -kerberos -libproxy -pkcs11" LINGUAS="-cs -de -fr -ja -nn -pl -ru -tr -zh_CN" 861 kB                                     
[nomerge      ] dev-libs/soprano-2.4.0.1 [2.3.1-r1] USE="dbus raptor redland* virtuoso%* -clucene* -debug -doc -java*"                                                                                       
[ebuild  N    ]  dev-libs/redland-1.0.10-r1  USE="berkdb mysql ssl xml -iodbc -odbc -postgres -sqlite" 1,533 kB                                                                                               
[ebuild  N    ]   dev-libs/rasqal-0.9.17  USE="pcre xml -gmp -test" 1,233 kB                           
[nomerge      ] dev-db/virtuoso-server-6.1.0  USE="ldap readline -kerberos -static-libs"               
[ebuild  N    ]  dev-db/virtuoso-odbc-6.1.0  USE="-static-libs" 0 kB                                   
[nomerge      ] net-print/hplip-3.10.2 [3.9.12-r1] USE="gtk hpcups libnotify qt4 scanner -doc -fax -hpijs -minimal -new-hpcups -parport -policykit -snmp -static-ppds -udev-acl"                             
[nomerge      ]  media-gfx/xsane-0.996  USE="jpeg nls png tiff -gimp -lcms"                           
[ebuild     U ]   media-libs/tiff-3.9.2-r1 [3.9.2] USE="cxx jpeg zlib -jbig" 0 kB                     
[ebuild     U ]   media-libs/libpng-1.2.42 [1.2.40] 656 kB                                             
[blocks B     ] kde-base/libkworkspace:4.3[-kdeprefix] ("kde-base/libkworkspace:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)                                                                         
[blocks B     ] kde-base/plasma-workspace:4.3[-kdeprefix] ("kde-base/plasma-workspace:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)                                                                   
[blocks B     ] kde-base/kpilot:4.3[-kdeprefix] ("kde-base/kpilot:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)                                                                                       
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.0)                                                           

Total: 27 packages (17 upgrades, 8 new, 2 in new slots, 2 uninstalls), Size of downloads: 297,363 kB
Conflict: 15 blocks (4 unsatisfied)                                                                 

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'kde-base/libknotificationitem-4.3.5', 'nomerge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kmenuedit-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/thumbnailers-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/ksame-4.3.5', 'nomerge')
    (and 229 more)

  ('installed', '/', 'kde-base/libkworkspace-4.3.5', 'nomerge') pulled in by
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdebase-meta-4.3.5', 'nomerge')
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kwin-4.3.5-r1', 'nomerge')
    >=kde-base/libkworkspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kget-4.3.5', 'nomerge')
    (and 9 more)

  ('installed', '/', 'kde-base/plasma-workspace-4.3.5', 'nomerge') pulled in by
    >=kde-base/plasma-workspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdeplasma-addons-4.3.5', 'nomerge')
    >=kde-base/plasma-workspace-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdebase-startkde-4.3.5', 'nomerge')
    >=kde-base/plasma-workspace-4.3 required by ('installed', '/', 'kde-misc/gx-mail-notify-0.4.2', 'nomerge')
    (and 2 more)

  ('installed', '/', 'kde-base/kpilot-4.3.5', 'nomerge') pulled in by
    >=kde-base/kpilot-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kdepim-meta-4.3.5', 'nomerge')
    kde-base/kpilot required by @world

  ('ebuild', '/', 'kde-base/kdelibs-4.4.0', 'merge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/ksudoku-4.3.5', 'nomerge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/lskat-4.3.5', 'nomerge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kmix-4.3.5', 'nomerge')
    (and 240 more)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Mar 01, 2010 10:36 am    Post subject: Reply with quote

Effettivamente non è chiarissima la cosa..
Prova un:
Code:
equery d kde-base/kdelibs-4.4.0

_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum