Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Overlay] Installation de gnome-shell
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Mar 04, 2010 9:08 am    Post subject: Reply with quote

Quote:
J'ai vu pour le edit. J'ai un quad core donc j = 5

Que ton proc Quad core le supporte oui c'est une chose mais rien n'est garantie que du côté code il le supporte :wink: Souvent il y a des strip pour baisser la parallélisation voire les optimisations sur gcc et d'expérience tu verras que bien des pbs de compilations se règlent ainsi - en tout cas c'est une des étapes de qualification en cas de bug.

Fais déjà un #revdep-rebuild -piv pour voir si automake n'a pas besoin d'un coup de refresh et ensuite on vois

edit: que de fotes de tipaux aujoud'hui :/

Edit: Arf ! this is a really bug :lol:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Thu Mar 04, 2010 9:16 am    Post subject: Reply with quote

OK pour le j1. J'y penserais lors de la prochaine erreur de compil.

Pour pango, ça change rien (normal puisque ca plante avant le make)

La commande revdep-rebuild -piv se finit sur :
Quote:

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
[ 100% ]

* Dynamic linking on your system is consistent... All done.

Donc rien à signaler de ce coté.
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Mar 04, 2010 9:17 am    Post subject: Reply with quote

Regarde mon édit :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Thu Mar 04, 2010 9:21 am    Post subject: Reply with quote

Je viens de voir ton edit.

D'après le bug, ils ont ajoutés dev-util/gtk-doc-am comme dépendance.
Mais elle est déjà là dans la version de suka.
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Mar 04, 2010 9:23 am    Post subject: Reply with quote

Tu as la 1.26.0 moi j'en vois 2 de plus rien que dans l'arbre 8O
que donne le #emerge -pv pango
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Thu Mar 04, 2010 9:28 am    Post subject: Reply with quote

Dans l'arbre officiel, j'ai les versions 1.24.5-r1, 1.26.0, 1.26.1 et 1.26.2 de pango.
Par contre l'overlay de suka fournit la version 1.27.1. Donc c'est cette version que j'essaye d'installer (version requise par gnome-shell)

J'ai démasqué (et installé) la version 1.13 de gtk-doc-am et pango-1.27.1 est en cours de build.

Je te tiens au courant.
Back to top
View user's profile Send private message
mblnx
n00b
n00b


Joined: 04 Mar 2008
Posts: 11

PostPosted: Thu Mar 04, 2010 9:32 am    Post subject: Reply with quote

I can't help much more, but I am running gjs-0.4 and not gjs-0.5. It did failed to compile the first time but worked the second time I tried (dunno why).
One of the errors looked like automake syntax error maybe you gotta upgrade your automake? I had to put mine on 1.11.something

P.S.: you can safely use -j8 to compile stuff on quadcore, take 5 minutes to compile wine here (;
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Mar 04, 2010 9:35 am    Post subject: Reply with quote

déjà entre la 1.26.0 et la 1.26.1 -> tu as un bug réglé sur la parallélisation... (cf. this one)
Code:
< # $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.26.0.ebuild,v 1.5 2009/11/28 17:39:38 remi Exp $
---
> # $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.26.1.ebuild,v 1.1 2009/11/21 09:35:37 mrpouet Exp $
70,72d69
<       # Fix parallel build, bug 287825
<       epatch "${FILESDIR}/${PN}-1.26.0-fix-parallel-build.patch"

Pour ta dépendance à gnome-shell : qui le requiert exactement ? et es-tu sûr que c'est à >=pango-1.27.x
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Mar 04, 2010 9:49 am    Post subject: Reply with quote

mblnx wrote:
I can't help much more, but I am running gjs-0.4 and not gjs-0.5. It did failed to compile the first time but worked the second time I tried (dunno why).
One of the errors looked like automake syntax error maybe you gotta upgrade your automake? I had to put mine on 1.11.something
maybe but i'm not sure it's necessary to do that in first - which ebuild need it exactelly ?
mblnx wrote:

P.S.: you can safely use -j8 to compile stuff on quadcore, take 5 minutes to compile wine here (;

yes but... it depense on the code :wink: and many bugs and patchs refers to a too higher makeopts. I've just seen 2 bugs relative to this case on this topic so somethimes slower is better ^^

Edit: ooops ! dsl pour le post en trop j'ai râté l'édition du précédent
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Thu Mar 04, 2010 9:52 am    Post subject: Reply with quote

En fait, c'est pas gnome-shell qui dépends de pango mais mutter.

Dans le ebuild de mutter c'est écrit : >=x11-libs/pango-1.2[X]

Donc a priori, c'est pas nécessaire d'avoir la version 1.27.1 de pango.

Je viens de supprimer pango, son démasquage et lancer un revdep-rebuild. je pense que j'en ai pour des heures vu le nombre de programmes qui dépendent de pango.

mblnx wrote:
One of the errors looked like automake syntax error maybe you gotta upgrade your automake? I had to put mine on 1.11.something


An upgrade of gtk-doc-am solve my automake problem.

Edit : Par contre clutter avec le flag introspection dépend de >=x11-libs/pango-1.27.1[introspection]
Donc oui pango-1.27.1 est nécessaire.
Back to top
View user's profile Send private message
mblnx
n00b
n00b


Joined: 04 Mar 2008
Posts: 11

PostPosted: Thu Mar 04, 2010 10:02 am    Post subject: Reply with quote

gratz gronono (=

I think I had less problems doing this cause I unmasked every app inside gnome-2.28.2 and went solving every dep conflict
If this is of any use package.keywords/gnome-2.28.2

^^

It looks like i can't drag tabs from chromium to the desktop, it should create a new chromium windows with only one tab... but it crashes S=
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Mar 04, 2010 10:02 am    Post subject: Reply with quote

ok donc presque tout est réglé alors y'a plus qu'a attendre :)
wait & see

edit:
mblnx wrote:
It looks like i can't drag tabs from chromium to the desktop, it should create a new chromium windows with only one tab... but it crashes S=

koff koff ! Please a new post for these ! really too much for this one ! :lol:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
mblnx
n00b
n00b


Joined: 04 Mar 2008
Posts: 11

PostPosted: Thu Mar 04, 2010 10:13 am    Post subject: Reply with quote

boozo wrote:
ok donc presque tout est réglé alors y'a plus qu'a attendre :)
wait & see

edit:
mblnx wrote:
It looks like i can't drag tabs from chromium to the desktop, it should create a new chromium windows with only one tab... but it crashes S=

koff koff ! Please a new post for these ! really too much for this one ! :lol:


SSSS= I just said that cause this is the only bug I noticed after I updated to 2.28.2 =P
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Mar 04, 2010 10:28 am    Post subject: Reply with quote

/off oh ok I was afraid :P
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Fri Mar 05, 2010 11:11 am    Post subject: Reply with quote

Je vous donne des nouvelles.

J'ai eu une erreur de compilation sur mutter comme quoi il ne trouvait pas Gdk-2.0.gir. Un petit upgrade de gtk+ a résolu le problème.
Par contre l'upgrade de gtk+ vers la nouvelle version (supportant le flag introspection) a entrainé un upgrade de glib.

Au final j'ai pu installé gnome-shell (youpi !).

J'ai testé en lancer gnome-shell --replace dans un terminal (à partir de gnome)
=> L'affichage est corrompu. La console ne s'affiche plus, j'ai juste quelques lignes plus ou moins blanche là où devrait être la barre de titre.
=> Le menu est super lent. Lorsque je clique sur le menu Activities, il faut attendre 10-20 secondes avant d'avoir le résultat.

J'ai fait un deuxième test en lançant directement gnome-shell à partir du .xinitrc.
=> Je n'ai plus mon superbe wallpaper :( mais un fond bleu
=> Lorsque je clique sur le menu, c'est super lent.
=> Si j'ouvre un terminal, j'ai un rectangle bleu qui apparait en relief. Mais il reste vide (pas de zone texte).

Pour information, j'ai une ATI Radeon HD 4870 (R700) avec les pilotes libres et le support DRI activé.

Donc pour l'instant ce n'est pas encore utilisable. Il faudrait peut-être que je teste avec le pilote graphique proprio.

En tout cas merci beaucoup à boozo et à mblnx.

Pour ceux qui veulent essayer, j'ai écrit un fichier texte au fur et à mesure de mon install sur les paquets à démasquer (fichier fourni sans garantie).
Back to top
View user's profile Send private message
NEOxAKIRA
Guru
Guru


Joined: 20 May 2007
Posts: 302
Location: France

PostPosted: Sun Apr 10, 2011 1:26 pm    Post subject: Reply with quote

moi quand je lance gnome-shell --replace
j'ai X qui redémarre...

et pour le lancer depuis slim c'est bien cette commande : exec ck-launch-session gnome-session ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum