Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Athlon Kernel & NVdriver & Alsa
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
CHerzog
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2002
Posts: 108
Location: Germany

PostPosted: Mon Jul 15, 2002 12:03 pm    Post subject: Athlon Kernel & NVdriver & Alsa Reply with quote

Hi,

ich versuche nun seit einigen Tagen den NVdriver und Alsa (snd_via8233) am laufen zu bekommen. Ich habe allerdings immer Probleme, sobald ich die Athlon Option im Kernel aktiviere. Ich habe schon sicher 20x den Kernel mit verschiedenen Einstellungen probiert, jedoch nichts passendes gefunden. Gibt es da irgendetwas wichtiges zu beachten?

Ich kompiliere mit dem neuesten GCC.

Gibt es bei den flags in der make.conf eine gute, schnelle und sichere Einstellung, die ich nehmen kann? Sicher im Sinne von stabil. Es gibt ja auch in diesem Forum einige Beispiele, die mir aber nicht bei meinem Problem geholfen haben.

Danke

Christian
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Mon Jul 15, 2002 1:09 pm    Post subject: Reply with quote

Vielleicht wäre es mal interessant welchen Fehler du bekommst.
Gehen die Module nicht oder verweigert er die komplette Kompilierung..
Back to top
View user's profile Send private message
CHerzog
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2002
Posts: 108
Location: Germany

PostPosted: Tue Jul 16, 2002 8:01 am    Post subject: Athlon etc Reply with quote

Ich habe mir gestern noch mal die Athlon-XP stage3-Version gezogen und noch mal begonnen. Jetzt scheint es beides zu funktionieren. Zumindest funktioniert MP3 und NVdriver wurde korrekt als Modul geladen. Ausser XFree86 habe ich es auch noch nicht weiter geschafft, um zu sehen, ob die Grafik auch funktioniert.

Allerdings habe ich bisher noch nicht mehr geschafft (muss auch mal arbeiten ;-))

Ich melde mich wenn Probleme kommen.

Danke

Christian
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Tue Jul 16, 2002 1:05 pm    Post subject: Reply with quote

Welchen Kernel hast Du da versucht zu kompilieren? Das würde mich brennend interssieren, da ich es bislang nicht geschafft habe, den 2.4.19-gentoo-r7 ohne SMP Support zu kompilieren. Ich habe nämlich genau dasselbe Setting: Athlon, Nvidia und Alsa:

Code:


/usr/src/linux-2.4.19-gentoo-r7/include/linux/timer.h:30: warning: this is the location of the previous definition
In file included from /usr/src/linux-2.4.19-gentoo-r7/include/linux/interrupt.h:45,
                 from ksyms.c:21:
/usr/src/linux-2.4.19-gentoo-r7/include/asm/hardirq.h:37: warning: `synchronize_irq' redefined
/usr/src/linux-2.4.19-gentoo-r7/include/linux/modules/i386_ksyms.ver:98: warning: this is the location of the previous definition
In file included from ksyms.c:17:
/usr/src/linux-2.4.19-gentoo-r7/include/linux/kernel_stat.h: In function `kstat_irqs':
/usr/src/linux-2.4.19-gentoo-r7/include/linux/kernel_stat.h:46: `smp_num_cpus' undeclared (first use in this function)
/usr/src/linux-2.4.19-gentoo-r7/include/linux/kernel_stat.h:46: (Each undeclared identifier is reported only once
/usr/src/linux-2.4.19-gentoo-r7/include/linux/kernel_stat.h:46: for each function it appears in.)
make[2]: *** [ksyms.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.19-gentoo-r7/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.19-gentoo-r7/kernel'
make: *** [_dir_kernel] Error 2
bash-2.05a#




Das die nvidia Treiber bei mir nur ohne SMP laufen ist der Kernel im Moment für mich nutzlos und ich muss beim -r5 bleiben.
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
atze
n00b
n00b


Joined: 14 Jul 2002
Posts: 55

PostPosted: Wed Jul 17, 2002 10:09 am    Post subject: Reply with quote

Ich habe genau die selbe zusammenstellung Athlon XP NVidia und ALSA! Bei mir funktioierte(!) der NV-Kernel bereit. Leider funktioniert das nach mehrfacher neukompilierung wegen PPPOE und ALSA nicht mehr :(

Ich habe jedoch im Gegensatz zu meiner vorherigen Einstellungen MTR( hieß das so? ) im Kernel eingeschaltet und agp... ausgeschaltet! Danach gings nicht mehr, mein System ist sogar baden gegangen ... :( etz mach ich's von vorn! :)

Bei mir war aber ALSA der Grund warum ich so oft neukompilieren musste! Der hat mir, auch nach "emerge" von ALSA, keine Module angeboten, die ich "modproben" könnte.
Back to top
View user's profile Send private message
ypok
n00b
n00b


Joined: 31 May 2002
Posts: 14
Location: switzerland

PostPosted: Wed Jul 17, 2002 6:15 pm    Post subject: Reply with quote

ich habe keine probleme mit 2.4.19-gentoo-r7 mit alsa (snd-via686) und den nvidia modulen, benutze gcc 3.1
Back to top
View user's profile Send private message
CHerzog
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2002
Posts: 108
Location: Germany

PostPosted: Thu Jul 18, 2002 11:35 am    Post subject: Reply with quote

Also ich taste mich da jetzt immer weiter durch. habe mittlerweile (da ich andere Module nach und nach einspiele, und andere Optionen ausprobiere) den Kernel schon öfter kompiliert. Ich bekomme dann auch schnell mal Probleme. Wenn ich aber ein 'emerge NVdriver alsa-driver' (wie hießen die NVModule noch gleich, bin grad nicht an dem Rechner) mache funktioniert das alles wieder. Die Module werden bei Modul_install anscheinend rausgeschmissen (obwohl ich dachte, das das nur ein clean macht, vielleicht liest ja hier jemand mit, der mir das mal kurz erläutern kann).

Na ja - also nach Kernel kompilieren ein emerge, dann funktioniert es bei mir (GCC3.1 Kernel 2.4.19r7)

HTH Christian
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Fri Jul 19, 2002 7:38 am    Post subject: Reply with quote

Nach jedem Neukompilieren des Kernels muss emerge nvidia-driver und emerge alsa-driver ausgeführt werden, da diese einige Module zum Kernel hinzufügen.

@ypok: Hast Du SMP im Kernel so belassen oder rausgenommen?
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum