Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[GENTOO-OVH] Problème mise à jour Gentoo ()
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Tinkite
n00b
n00b


Joined: 23 Feb 2010
Posts: 8

PostPosted: Tue Feb 23, 2010 3:58 pm    Post subject: [GENTOO-OVH] Problème mise à jour Gentoo () Reply with quote

EN: Hello and thanks you for help me,
FR:Bonjour à tous et merci par avance de votre aide,

EN: I want to update my release because it's very old, I have some problems to update this release.
FR:Voilà mon problème j'ai un serveur dédié chez ovh que j'ai depuis cet été et je voudrais mettre à jour cette version car j'ai lu qu'elle est était bourré de failles et parce que je voudrais pouvoir installer les MAJ des différents logiciels qu'il y a sur la distribribution (php, MySQL, red5, apache, perl, python, ffmpeg).

EN : Information about kernel version
FR:Les infos concernant la version du kernel
Code:

# uname -r
2.6.27.10-grsec-xxxx-grs-ipv4-64

EN: Theses command I have already try to resolve my problem.
FR :Voilà les commandes que j'ai déjà effectués pour essayer de résoudre mes problèmes:
Code:

#emerge eselect //installer le tool eselect
# eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/10.0 *
  [2]   default/linux/amd64/10.0/desktop
  [3]   default/linux/amd64/10.0/developer
  [4]   default/linux/amd64/10.0/no-multilib
  [5]   default/linux/amd64/10.0/server
  [6]   hardened/linux/amd64/10.0
  [7]   hardened/linux/amd64/10.0/no-multilib
  [8]   selinux/2007.0/amd64
  [9]   selinux/2007.0/amd64/hardened
  [10]  selinux/v2refpolicy/amd64
  [11]  selinux/v2refpolicy/amd64/desktop
  [12]  selinux/v2refpolicy/amd64/developer
  [13]  selinux/v2refpolicy/amd64/hardened
  [14]  selinux/v2refpolicy/amd64/server
# eselect profile set 1
#emerge --fetchonly sys-apps/portage
Calculating dependencies... done!

>>> Emerging (1 of 2) dev-lang/python-2.5.4-r4 to /
 * Python-2.5.4.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * python-gentoo-patches-2.5.4-r3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking Python-2.5.4.tar.bz2 ;-) ...                                  [ ok ]
 * checking python-gentoo-patches-2.5.4-r3.tar.bz2 ;-) ...                [ ok ]

>>> Emerging (2 of 2) sys-apps/portage-2.1.6.13 to /
 * portage-2.1.6.13.patch.bz2 RMD160 SHA1 SHA256 size ;-) ...             [ ok ]
 * portage-2.1.6.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                  [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking portage-2.1.6.tar.bz2 ;-) ...                                 [ ok ]
 * checking portage-2.1.6.13.patch.bz2 ;-) ...                            [ ok ]



EN: Problems were occurred when I try to update system
FR:Les problèmes surviennent quand j'essaye de mettre à jour :
Code:

#emerge --sync

Number of files: 135920
Number of files transferred: 38
Total file size: 183362421 bytes
Total transferred file size: 461813 bytes
Literal data: 461813 bytes
Matched data: 0 bytes
File list size: 3371790
File list generation time: 8.717 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 38950
Total bytes received: 3874004

sent 38950 bytes  received 3874004 bytes  289848.44 bytes/sec
total size is 183362421  speedup is 46.86

>>> Updating Portage cache:   51%
Invalid ebuild name: /usr/portage/games-rpg/eschalon-book-1-demo/eschalon-book-1-demo-105.ebuild                                                            100%
 * IMPORTANT: 2 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * An update to portage is available. It is _highly_ recommended
 * that you update portage now, before any other packages are updated.

 * To update portage, run 'emerge portage' now.
#emerge portage
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 2) dev-lang/python-2.5.4-r4 to /
 * Python-2.5.4.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * python-gentoo-patches-2.5.4-r3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking Python-2.5.4.tar.bz2 ;-) ...                                  [ ok ]
 * checking python-gentoo-patches-2.5.4-r3.tar.bz2 ;-) ...                [ ok ]
 * "bsddb" module is out-of-date and no longer maintained inside dev-lang/python. It has
 * been additionally removed in Python 3. You should use external, still maintained "bsddb3"
 * module provided by dev-python/bsddb3 which supports both Python 2 and Python 3.
 * It is highly recommended to additionally install Python 3, but without configuring Python wrapper to use Python 3.
 *
 * ERROR: dev-lang/python-2.5.4-r4 failed.
 * Call stack:
 *                ebuild.sh, line 1717:  Called dyn_setup
 *                ebuild.sh, line  768:  Called qa_call 'pkg_setup'
 *                ebuild.sh, line   44:  Called pkg_setup
 *   python-2.5.4-r4.ebuild, line   68:  Called built_with_use 'sys-devel/gcc' 'libffi'
 *            eutils.eclass, line 1847:  Called die
 * The specific snippet of code:
 *                                      die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   sys-devel/gcc-3.4.5 does not actually support the libffi USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-lang/python-2.5.4-r4/temp/build.log'.
 *

 * Messages for package dev-lang/python-2.5.4-r4:

 *
 * ERROR: dev-lang/python-2.5.4-r4 failed.
 * Call stack:
 *                ebuild.sh, line 1717:  Called dyn_setup
 *                ebuild.sh, line  768:  Called qa_call 'pkg_setup'
 *                ebuild.sh, line   44:  Called pkg_setup
 *   python-2.5.4-r4.ebuild, line   68:  Called built_with_use 'sys-devel/gcc' 'libffi'
 *            eutils.eclass, line 1847:  Called die
 * The specific snippet of code:
 *                                      die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   sys-devel/gcc-3.4.5 does not actually support the libffi USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-lang/python-2.5.4-r4/temp/build.log'.
 *
 * It is highly recommended to additionally install Python 3, but without configuring Python wrapper to use Python 3.
 * "bsddb" module is out-of-date and no longer maintained inside dev-lang/python. It has
 * been additionally removed in Python 3. You should use external, still maintained "bsddb3"
 * module provided by dev-python/bsddb3 which supports both Python 2 and Python 3.

EN : Two problems with emerge --sync who stop update at 51% and emerge oportage who meet problem with python.
FR :Voilà donc deux problèmes se présentent pour emerge --sync update du portage s'arrête à 51%
et un second avec emerge portage qui semble rencontré des problèmes avec python mais bon moi ça m'aide.

EN: I hope I took all informations for understand my problem. Thanks you !
FR:J'espère que j'ai mis toute les informations qu'il faut pour comprendre mon problème sinon hésitez pas.
Merci.


Last edited by Tinkite on Wed Feb 24, 2010 8:55 pm; edited 3 times in total
Back to top
View user's profile Send private message
nikaya
Veteran
Veteran


Joined: 13 May 2006
Posts: 1471
Location: Germany

PostPosted: Tue Feb 23, 2010 4:27 pm    Post subject: Reply with quote

Please post your problem at the french section of the forum:
https://forums.gentoo.org/viewforum-f-35.html

or describe it in english language.
_________________
Notes on Dhamma
How to waste your time: look for an explanation of consciousness, ask to know what feeling is. (Nanavira Thera)
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Feb 23, 2010 4:43 pm    Post subject: Reply with quote

Salut, ouf tu vas avoir du plaisir :P

Peux-tu poster ceci :

Code:

# emerge --info
# cat /etc/make.conf
# rc-update show
# gcc-config -l
Back to top
View user's profile Send private message
Tinkite
n00b
n00b


Joined: 23 Feb 2010
Posts: 8

PostPosted: Tue Feb 23, 2010 4:59 pm    Post subject: Reply with quote

EN : Ok have fun :)
FR :Ok va pour le plaisir alors :)

EN : Commands asked :
FR:Voilà les commandes demandées :
Code:

 #emerge --info
 Portage 2.1.3.19 (default/linux/amd64/10.0, gcc-3.4.5, glibc-2.3.6-r3, 2.6.27.10-grsec-xxxx-grs-ipv4-64 x86_64)
=================================================================
System uname: 2.6.27.10-grsec-xxxx-grs-ipv4-64 x86_64 Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz
Timestamp of tree: Tue, 23 Feb 2010 15:30:01 +0000
app-shells/bash:     3.2_p17
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.11.14-r8
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1, 1.10.2
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc:       3.4.5
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/local/apache/conf /usr/local/lib/php4 /usr/local/lib/php5 /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=nocona"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ ftp://mirrors.linuxant.fr/distfiles.gentoo.org/ http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR@euro"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-ovh"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 mmx modules mudflap multilib ncurses netboot nls nptlonly openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl sysfs tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa via vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


# cat /etc/make.conf
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -pipe -march=nocona"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ ftp://mirrors.linuxant.fr/distfiles.gentoo.org/ http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/"
USE="-X mmx multilib netboot sse sse2 -gtk -sdl -xpm -curl -nptl"
PORTDIR_OVERLAY="/usr/local/portage-ovh"
FEATURES="-sandbox"
PORTAGE_BINHOST="ftp://ftp.ovh.net/made-in-ovh/release/binhost/2.14-2.15/64"
CONFIG_PROTECT="/usr/local/apache/conf /usr/local/lib/php5 /usr/local/lib/php4"
SOURCE="/usr/portage/local/layman/make.conf"

# rc-update show
              apache |      default
            bootmisc | boot
             checkfs | boot
           checkroot | boot
               clamd |      default
               clock | boot
            collectd |      default
         consolefont | boot
     courier-authlib |
       courier-imapd |      default
   courier-imapd-ssl |
       courier-pop3d |
   courier-pop3d-ssl |
         crypto-loop |
          domainname | boot
                 gpm |
             hddtemp |
              hdparm |
            hostname | boot
               httpd |
           ip6tables |
            iptables |
             keymaps | boot
               local |      default nonetwork
          localmount | boot
     mit-krb5kadmind |
         mit-krb5kdc |
             modules | boot
               mysql |      default
        mysqlmanager |
               named |      default
            net.eth0 |      default
            net.eth1 |      default
              net.lo | boot
            netmount |      default
                 nfs |
            nfsmount |
                nscd |
             numlock |
          open-iscsi |
             portmap |
             proftpd |      default
               qmail |      default
               quota |      default
           rmnologin | boot
              rsyncd |
               slapd |
              slurpd |
              smartd |
               spamd |      default
           sqwebmail |      default
                sshd |      default
           syslog-ng |      default
             urandom | boot
          vixie-cron |      default
            watchdog |      default
              webmin |      default

# gcc-config -l
 [1] x86_64-pc-linux-gnu-3.4.5 *
 [2] x86_64-pc-linux-gnu-3.4.5-hardened
 [3] x86_64-pc-linux-gnu-3.4.5-hardenednopie
 [4] x86_64-pc-linux-gnu-3.4.5-hardenednopiessp
 [5] x86_64-pc-linux-gnu-3.4.5-hardenednossp

Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Feb 24, 2010 3:10 am    Post subject: Reply with quote

Peux-tu poster ceci :

Code:

# emerge -pv gcc


Tu as une vieille version de GCC, Python, je sais pas trop comment te faire updater le tout...
Back to top
View user's profile Send private message
Tinkite
n00b
n00b


Joined: 23 Feb 2010
Posts: 8

PostPosted: Wed Feb 24, 2010 6:31 pm    Post subject: Reply with quote

FR:Voilà la commande que tu m'as demandé j'espère que sa aidera parce que je bloque vraiment, merci.
EN: Command ask :[/code]
Code:

 # emerge -pv gcc

These are the packages that would be merged, in order:

Calculating dependencies /
!!! All ebuilds that could satisfy ">=sys-libs/glibc-2.8" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/glibc-2.8_p20080602-r1 (masked by: package.mask)
- sys-libs/glibc-2.9_p20081201-r2 (masked by: package.mask)
- sys-libs/glibc-2.9_p20081201-r3 (masked by: package.mask, ~amd64 keyword)
- sys-libs/glibc-2.10.1 (masked by: package.mask, ~amd64 keyword)
- sys-libs/glibc-2.10.1-r1 (masked by: package.mask)
- sys-libs/glibc-2.11 (masked by: package.mask, ~amd64 keyword)
- sys-libs/glibc-2.11-r1 (masked by: package.mask, ~amd64 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "sys-devel/gcc-4.3.4" [ebuild])

Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Wed Feb 24, 2010 6:49 pm    Post subject: Reply with quote

Des paquets sont masqués :

1. regarder ce que contient /etc/portage/package.mask
2. Synchroniser l'arbre de portage
3. Mettre à jour ton "profile"

http://www.gentoo.org/doc/fr/handbook/handbook-x86.xml?full=1#book_part1_chap6
Back to top
View user's profile Send private message
Tinkite
n00b
n00b


Joined: 23 Feb 2010
Posts: 8

PostPosted: Wed Feb 24, 2010 7:42 pm    Post subject: Reply with quote

Ok donc je supprime ces lignes du fichier et je lance les commandes de mise a jour de portage. Mais si c'est dans ce fichier c'est pas que ovh ne souhaite pas que l'on fasse des mises à jours ?

Voici ce que donnne la commande :
Code:

 # vim /etc/portage/package.mask
www-servers/apache
dev-lang/php
net-mail/qmail-autoresponder
sys-process/daemontools
net-mail/ezmlm
net-mail/ezmlm-idx
net-mail/fastforward
mail-mta/qmail
net-mail/qmailadmin
net-mail/qmailanalog
sys-apps/ucspi-tcp
net-mail/vpopmail
>sys-libs/glibc-2.4
net-www/apache
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Feb 24, 2010 8:43 pm    Post subject: Reply with quote

Salut,

pourrais-tu mettre ton titre en conformité stp ?

Pour quelle raison ces paquets sont-ils masqués ? Je pense que ces modifications spécifiques à OVH foutent plus le bronx qu'autre chose...
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Tinkite
n00b
n00b


Joined: 23 Feb 2010
Posts: 8

PostPosted: Wed Feb 24, 2010 8:56 pm    Post subject: Reply with quote

Bonjour,

Voilà je viens de le mettre en conformité. Tu crois donc que je peux supprimer ces lignes sans crainte ?
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Feb 24, 2010 9:02 pm    Post subject: Reply with quote

Peut-être d'abord demander à OVH la raison du masquage de ces paquets, on sait jamais.
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Tinkite
n00b
n00b


Joined: 23 Feb 2010
Posts: 8

PostPosted: Wed Feb 24, 2010 9:10 pm    Post subject: Reply with quote

Oui je vais faire ça, sinon si je supprime cela tout doit se télécharger normalement et se mettre à jour ?
Je vous tiens au courant sur ce que me dira le service technique ovh.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Feb 25, 2010 3:39 am    Post subject: Reply with quote

En changeant de profile, je pense que tu vas pouvoir faire quelques maj.
Back to top
View user's profile Send private message
Tinkite
n00b
n00b


Joined: 23 Feb 2010
Posts: 8

PostPosted: Mon Mar 01, 2010 6:08 pm    Post subject: Reply with quote

Salut,

D'après OVH ce n'est pas possible de faire de mise à jour, la solution qu'ils m'ont proposé est de mettre une version nu d'une distribution linux. Donc c'est pas terrible, quelqu'un connaît-il de bon tutoriel sur le net pour installer un serveur web (apache,mail,ftp,ssh ...) parce que je ne suis pas spécialisé mais j'ai des bases sur les environnements linux.
Merci à vous,
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Mar 02, 2010 2:28 am    Post subject: Reply with quote

C'est poche de la part de OVH, je sais que certains utilise Debian dans ce genre de situation, par contre je ne suis pas expert dans ce domaine.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7896
Location: ~Brussels - Belgique

PostPosted: Tue Mar 02, 2010 6:36 am    Post subject: Reply with quote

Non, ce que OVH dit, c'est qu'ils ne supportent pas Gentoo, excepté leur version patchée et antédiluvienne.

Si tu ne t'y connais pas en sécurité, installe une distribution bien gérée par OVH (debian, ubuntu), sinon tu risques d'avoir une Gentoo alléchante comme un pot à miel pour les hackers...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Mar 02, 2010 6:48 pm    Post subject: Reply with quote

En effet, un serveur pas patché sur le net, c'est vraiment magique pour un hacker :P
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Tue Mar 02, 2010 8:09 pm    Post subject: Reply with quote

XavierMiller wrote:
Si tu ne t'y connais pas en sécurité, installe une distribution bien gérée par OVH (debian, ubuntu), sinon tu risques d'avoir une Gentoo alléchante comme un pot à miel pour les hackers...


ça laisse sous entendre que l'on peut hacker facilement gnu/linux si il n'est pas installé et configuré par des pros ... On est pas obligé d'être un expert en sécu pour installer et utiliser une gentoo sur le www car le système est déjà assez sécure . Les logiciels ftp (vsftpd par ex), postfix, ssh, apache, etc ... sont facilement configurable pour avoir une bonne sécu ... Et hack pas qui veut ...

Perso, j'ai un rps chez ovh que j'ai installé moi-même avec un serveur web, une messagerie postfix mysql, un serveur ftp, et bien sur un accès ssh avec un fichier correctement configuré et je n'ai pas eu de soucis jusqu'a maintenant ... On trouve des bon conseils et tutos sur le web pour bien configurer ces logiciels mais bien sur personne n'est l'abri d'une attaque et je sais que je n'ai pas sécurisé comme un parano. La secu est une remise en question permanente ...
_________________
Get Up and Go !
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7896
Location: ~Brussels - Belgique

PostPosted: Tue Mar 02, 2010 8:56 pm    Post subject: Reply with quote

Oui, comme tu dis : il faut bien se documenter, bien configurer tout cela.

Et mettre à jour automatiquement.

J'ai une connaissance qui a un Ubuntu chez OVH, option "sécurité maximale". OVH s'occupe de patcher en permanence son serveur.
Avec Gentoo, il faut le faire soi-même, lire les alertes de sécurité et en permanence colmater les brèches.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum