Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kernel]impossible de monter clé usb vfat (RESOLU)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
julienlfr
n00b
n00b


Joined: 22 Oct 2009
Posts: 12
Location: Paris

PostPosted: Mon Feb 08, 2010 11:52 am    Post subject: [kernel]impossible de monter clé usb vfat (RESOLU) Reply with quote

Bonjour,

Aprés avoir modifier mon kernel (pour virer tout ce qui ne sert pas) il m'est impossible de monter ma clé usb qui est en FAT32

Voici le message d'erreur :

Code:
mount : type erroné de syst .de fichiers, option erronée, super bloc
        erroné sur /dev/sdb1, codepage ou aide manquante ou autre erreur
       Dans quelques cas certaines informations sont utiles dans syslog - essayez
       dmesg | tail  ou quelque chose du genre


voici ce que me donne le dmesg.

Code:
usb 2-3: new high speed USB device using ehci_hcd and address 4
ehci_hcd 0000:00:1d.7: port 3 high speed
ehci_hcd 0000:00:1d.7: GetStatus port 3 status 001005 POWER sig=se0 PE CONNECT
usb 2-3: default language 0x0409
usb 2-3: udev 4, busnum 2, minor = 131
usb 2-3: New USB device found, idVendor=0951, idProduct=1624
usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-3: Product: DataTraveler G2
usb 2-3: Manufacturer: Kingston
usb 2-3: SerialNumber: 000AEBFFB402A99125210264
usb 2-3: uevent
usb 2-3: usb_probe_device
usb 2-3: configuration #1 chosen from 1 choice
usb 2-3: adding 2-3:1.0 (config #1, interface 0)
usb 2-3:1.0: uevent
usb-storage 2-3:1.0: usb_probe_interface
usb-storage 2-3:1.0: usb_probe_interface - got id
usb-storage: USB Mass Storage device detected
usb 2-3: uevent
usb-storage: -- associate_dev
usb-storage: Vendor: 0x0951, Product: 0x1624, Revision: 0x0200
usb-storage: Interface Subclass: 0x06, Protocol: 0x50
usb-storage: Transport: Bulk
usb-storage: Protocol: Transparent SCSI
scsi7 : SCSI emulation for USB Mass Storage devices
usb-storage: *** thread sleeping.
drivers/usb/core/inode.c: creating file '004'
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
usb 2-3: uevent


Si quelqu'un a une idée de ce que j'ai pu virer dans le kernel qui me donne cette erreur.

mount:

Code:
/dev/sda6 on / type ext3 (rw,noatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
udev on /dev type tmpfs (rw,nosuid,relatime,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85


Voici mon lspci:

Code:
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation G98M [Quadro NVS 160M] (rev a1)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
03:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
0c:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100


ainsi que mon .config.

(je pastebin vu la taille ^^)

http://pastebin.com/m798e25e2

Merci d'avance pour l'aide apporter.

Bonne journée
_________________
emerge -avq life


Last edited by julienlfr on Thu Feb 11, 2010 3:36 pm; edited 2 times in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7901
Location: ~Brussels - Belgique

PostPosted: Mon Feb 08, 2010 12:48 pm    Post subject: Reply with quote

Salut,

Qu'as-tu enlevé ? remets-en donc un petit peu ;)
Que dit dmesg lors de l'insertion de la clef ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
julienlfr
n00b
n00b


Joined: 22 Oct 2009
Posts: 12
Location: Paris

PostPosted: Mon Feb 08, 2010 1:37 pm    Post subject: Reply with quote

Pour le dmesg c'était ceci.

Quote:
voici ce que me donne le dmesg.

Code:

usb 2-3: new high speed USB device using ehci_hcd and address 4
ehci_hcd 0000:00:1d.7: port 3 high speed
ehci_hcd 0000:00:1d.7: GetStatus port 3 status 001005 POWER sig=se0 PE CONNECT
usb 2-3: default language 0x0409
usb 2-3: udev 4, busnum 2, minor = 131
usb 2-3: New USB device found, idVendor=0951, idProduct=1624
usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-3: Product: DataTraveler G2
usb 2-3: Manufacturer: Kingston
usb 2-3: SerialNumber: 000AEBFFB402A99125210264
usb 2-3: uevent
usb 2-3: usb_probe_device
usb 2-3: configuration #1 chosen from 1 choice
usb 2-3: adding 2-3:1.0 (config #1, interface 0)
usb 2-3:1.0: uevent
usb-storage 2-3:1.0: usb_probe_interface
usb-storage 2-3:1.0: usb_probe_interface - got id
usb-storage: USB Mass Storage device detected
usb 2-3: uevent
usb-storage: -- associate_dev
usb-storage: Vendor: 0x0951, Product: 0x1624, Revision: 0x0200
usb-storage: Interface Subclass: 0x06, Protocol: 0x50
usb-storage: Transport: Bulk
usb-storage: Protocol: Transparent SCSI
scsi7 : SCSI emulation for USB Mass Storage devices
usb-storage: *** thread sleeping.
drivers/usb/core/inode.c: creating file '004'
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
usb 2-3: uevent


malgrés ravoir regardé du coté des périph sur mon kernel toujours rien je séche quelque peu :s
_________________
emerge -avq life
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7901
Location: ~Brussels - Belgique

PostPosted: Mon Feb 08, 2010 1:38 pm    Post subject: Reply with quote

OK, la clef est bien reconnue. Vérifie que tu as bien les modules associés à FAT32.

Question idiote : comment as-tu compilé le kernel ? As-tu bien fait un "make modules_install" ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
julienlfr
n00b
n00b


Joined: 22 Oct 2009
Posts: 12
Location: Paris

PostPosted: Mon Feb 08, 2010 1:54 pm    Post subject: Reply with quote

je compile avec Genkernel il me semble qu'il effectue la bzImage et les modules

(vfat est en dur je recompile en module des fois que ..)
_________________
emerge -avq life
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7901
Location: ~Brussels - Belgique

PostPosted: Mon Feb 08, 2010 2:04 pm    Post subject: Reply with quote

Vérifie aussi les options "NLS".

En gros, mets un maximum de filesystems en module, comme ça tu seras tranquille.

A moins d'avoir un réel besoin de réduire la place, tel un système embarqué, je préfère compiler trop de modules que trop peu. Ca peut dépanner le jour où je dois connecter mon système à un nouveau matériel (pour dépanner par exemple).
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
julienlfr
n00b
n00b


Joined: 22 Oct 2009
Posts: 12
Location: Paris

PostPosted: Mon Feb 08, 2010 2:24 pm    Post subject: Reply with quote

Impeccable c'était bien les NLS j'ai remis ceux que j'avais viré en module et ça refonctionne.

Merci beaucoup Xavier :)
_________________
emerge -avq life
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7901
Location: ~Brussels - Belgique

PostPosted: Mon Feb 08, 2010 3:01 pm    Post subject: Reply with quote

De rien ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Feb 09, 2010 11:39 pm    Post subject: Reply with quote

J'arrive un peu tard, mais peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum