Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
RT2860 - Crashes on bringing up interace ra0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
dahranis
Apprentice
Apprentice


Joined: 20 Jan 2006
Posts: 166

PostPosted: Fri Feb 19, 2010 1:50 pm    Post subject: RT2860 - Crashes on bringing up interace ra0 Reply with quote

Hey, I recently bought the edimax ew-7728in (rt2860), using the staged drivers in 2.6.30-r6 gentoo-sources and the system crashes when it brings up the card; and I can't access anything else from there. If I remove the card everythings fine, i've googled and found a few problems with the card/driver but none similar to what I'm experiencing.
Does anybody know of anything that I can do? I've tried reverting back to an older kernel (using the ralink drivers) and it's the same problem.
Back to top
View user's profile Send private message
Hupf
Tux's lil' helper
Tux's lil' helper


Joined: 11 Sep 2005
Posts: 112
Location: Germany

PostPosted: Fri Feb 19, 2010 2:05 pm    Post subject: Reply with quote

I haven't come to test the functionality yet, but with a 2.6.32 kernel (zen-sources, shouldn't matter) the status LED on my notebook blinks happily when bringing up the network scripts - without crashing anything.
I'll report back in a few days after trying to actually connect to my WLAN - if the kernel upgrade alone doesn't work for you.
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sat Feb 20, 2010 5:40 pm    Post subject: Reply with quote

To confirm, for me my rt2860 works reliably in 2.6.32. Altough, I have seen patches floating around that make the non-staging driver for rt2860 work reliably as well for 2.6.33.
Back to top
View user's profile Send private message
dahranis
Apprentice
Apprentice


Joined: 20 Jan 2006
Posts: 166

PostPosted: Sun Feb 21, 2010 4:39 pm    Post subject: Reply with quote

upgraded to the 2.6.32 (gentoo-sources) and the same problem is occurring. i believe there is a kernel panic whenifconfig brings up the device (device changed to wlan0)

This problem has occurred with kernel 2.6.30-r4 (gentoo-sources) using the january 2010 ralink driver and with the staged 2.6.31-r6 kernel.
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Feb 21, 2010 4:45 pm    Post subject: Reply with quote

Try upgrading to a git kernel, that one has some patches that made the by the rt2860 driver supported chipsets 'usable' according to the author. You need to use the rt2x00 drivers *not* staging/rt2860.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum