Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help printing to Windows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Itserpol
n00b
n00b


Joined: 23 Jan 2010
Posts: 22

PostPosted: Mon Feb 08, 2010 2:19 am    Post subject: Help printing to Windows Reply with quote

I've been trying to figure out how to print to an Epson Stylus CX8400 connected to a Windows XP machine on my LAN, mostly following this guide:

http://en.opensuse.org/Print_to_Windows_printer

When I tried printing a test page from http://localhost:631/printers/, it displayed an error "/etc/cups/interfaces/EPSON failed". What does this mean?

Also, in case I'm going about this the wrong way, I've included every step I can remember taking:

Code:

#Installing cups and samba
$ emerge cups
$ emerge samba
$ /etc/init.d/cupsd start
$ /etc/init.d/samba start
$ rc-update add cupsd default
$ rc-update add samba default

#Installing gutenprint drivers
$ emerge gutenprint

#Adding Windows XP hostname to /etc/hosts
$ nano /etc/hosts
192.168.0.102    hostname

#Adding printer to /etc/cups/printers.conf
$ nano /etc/cups/printers.conf
<DefaultPrinter EPSON>
Info Epson printer
Location hostname
DeviceURI smb://user:passwd@WORKGROUP/hostname/EPSON

#Restarting cups
$ /etc/init.d/cupsd restart

#Creating Samba configuration file
$ nano /etc/samba/smb.conf
[global]
printing = cups
printcap name = cups
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7635
Location: Goose Creek SC

PostPosted: Mon Feb 08, 2010 4:07 am    Post subject: Reply with quote

Code:
http://localhost:631
add printer
name printer ; continue
Device : Windows printer via Samba ; continue
Device URI : smb://name of server with printer attached/name of printer share ; continue
Make/Manufacturer for  : Epson ; continue
Model/Driver for  : Epson Stylus CX8400 ; add printer
Back to top
View user's profile Send private message
Itserpol
n00b
n00b


Joined: 23 Jan 2010
Posts: 22

PostPosted: Mon Feb 08, 2010 5:11 am    Post subject: Reply with quote

Oh I see now, I needed to install gutenprint before I added the printer. Last time I tried
Code:

Make/Manufacturer for  : Epson ; continue
Model/Driver for  : Epson Stylus CX8400 ; add printer

there wasn't any CX8400 driver in the menu.

Anyway, I set it up and there's still some problem. The test page causes the printer to feed one blank page and then keep printing over the same two lines on the next one. The only way to stop it is to cancel the job from the XP machine. Also, the cups printers page displays "Can not get the ticket cache for root".
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7635
Location: Goose Creek SC

PostPosted: Mon Feb 08, 2010 5:58 am    Post subject: Reply with quote

are there spaces or odd characters in the names of the printer, server, or printer share if so recommend not using them. May fix "Can not get the ticket cache for root" per one googled source.

http://localhost:631 Set Printer Options may allow fixing "The test page causes the printer to feed one blank page and then keep printing over the same two lines on the next one."

have you emerged ghostscript and foomatic; may help.
Back to top
View user's profile Send private message
Itserpol
n00b
n00b


Joined: 23 Jan 2010
Posts: 22

PostPosted: Mon Feb 08, 2010 3:53 pm    Post subject: Reply with quote

No, there aren't any spaces or other odd characters in any of the printer or server names. And I'm not sure what you mean by "per one googled source".

I changed the media size (A4 -> Letter) and color model (RGB -> CMY) in the printer options, and emerged ghostscript-gpl and foomatic-filters, but nothing's changed.

I half thought I should maybe wait to see if the test page would finish, but it's using up a LOT of black ink.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7635
Location: Goose Creek SC

PostPosted: Mon Feb 08, 2010 6:40 pm    Post subject: Reply with quote

you might try repeating
Code:
emerge cups
now that all possible support apps are present and then remove and reinstall the printer via localhost:631

google found a lot of instances of the ticket problem but the only fellow claiming a solution cited "white spaces in printer tags"

Doomed?
You may get limited capability by using "wrong" driver.
Back to top
View user's profile Send private message
Itserpol
n00b
n00b


Joined: 23 Jan 2010
Posts: 22

PostPosted: Sun Feb 21, 2010 3:08 pm    Post subject: Reply with quote

I set up the printer to use the CX3810 driver and the test page finally printed, except that the colors are all offset so that I get multiple cyan, magenta, and yellow images.

Reading the link you provided, I get the idea that this just isn't a good printer for Linux and I won't get it to work better than this. Thankfully, I never need to do very much printing, so I'll just do it from my Windows drive I guess.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum