Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-sunset support (KDE-3.5.x) thread.<my issue resolved>
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 222
Location: Clarkston, Michigan

PostPosted: Tue Jun 01, 2010 7:00 am    Post subject: Reply with quote

Hi,

akode will not build. I lost the exact error message as I got fed up with it and hacked around it, but, at first, during make it complained of a missing libakode.so. After some digging I discovered that file was linked to a libakode.so.2.0.0 which didn't exist. Out of curiosity I moved a local copy of that .so into the temp library folder to see what would happen, and the compilation made it to the install stage, but then complained about more missing .so files, and I can only conclude that the ebuild was not doing any linking. Like I said I've worked around it, I disabled the arts use flag for the time being as I've got 427 more packages to update and don't have time to deal with this right now. Does anyone else run into this issue?
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 222
Location: Clarkston, Michigan

PostPosted: Fri Jun 04, 2010 5:24 pm    Post subject: Reply with quote

Another user fixed a very similar error with Amarok 1.4 by masking ">=sys-devel/autoconf-2.64". I will try this and report back. Also, does KDE 3.5 require GCC 4.2 or earlier? Trying to emerge many KDE 3.5 packages makes them die complaining of libstdc++ lacking "GLIBCXX_3.4.11" unless I use GCC 4.2. Is there anyway around this?
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5894
Location: Pomona, California.

PostPosted: Fri Jun 04, 2010 9:51 pm    Post subject: Reply with quote

I use gcc-4.3.2, and have been for some time. How often do you sync?

Cheers,
Pappy
_________________
SITE LIST:
Main: http://www.kernel-seeds.org
Mirror: http://kernel-seeds.grytpype-thynne.org/
Mirror 2: http://kernel-seeds.gentoostudio.org/
Mirror 3: http://www.elilabs.com/~pappy/
Mirror 4: http://62.3.120.142/~seeds/
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 222
Location: Clarkston, Michigan

PostPosted: Fri Jun 04, 2010 11:19 pm    Post subject: Reply with quote

pappy_mcfae wrote:
I use gcc-4.3.2, and have been for some time. How often do you sync?

Cheers,
Pappy
I switched to 4.4 myself. My system did in fact go un-updated for several months, but I thought the error message translated to simply "your libstdc++ is too new for this package". Apparently I was wrong, because after wiping out 3.5, running emerge -uDN world && emerge -e world, and then emerging 3.5 again, and 75/250 packages have emerged without incident, so I must have spoken too soon. Will report back if any errors pop up.
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5894
Location: Pomona, California.

PostPosted: Sat Jun 05, 2010 6:33 am    Post subject: Reply with quote

KDE-3.5 is a lovely thing...and I'm glad that there are people working on it to keep it current, or as close as possible. Hurray for kde-sunset...now if I could figure out why I can't upload to the kde-sunset git.

Cheers,
Pappy
_________________
SITE LIST:
Main: http://www.kernel-seeds.org
Mirror: http://kernel-seeds.grytpype-thynne.org/
Mirror 2: http://kernel-seeds.gentoostudio.org/
Mirror 3: http://www.elilabs.com/~pappy/
Mirror 4: http://62.3.120.142/~seeds/
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Sat Jun 05, 2010 11:12 am    Post subject: Reply with quote

For the record, KDE 3.5.x in kde-sunset is fine with GCC 4.4.x simply because it was also fine when it was in Portage. The first version of GCC that's *not* tested with KDE 3.5.x ebuilds is 4.5.x, and it will most likely cause build-time problems, ones that are rather easy to fix.
Back to top
View user's profile Send private message
jesnow
Guru
Guru


Joined: 26 Apr 2006
Posts: 449

PostPosted: Thu Dec 09, 2010 10:50 pm    Post subject: Reply with quote

What about Trinity? I'm still soldiering along with kde-sunset on 2 machines, but Trinity looks like it has rapidly improved 3.5 to the point where I wish I had it. Has anybody got it working? I'm not afraid to try to compile it, but I've never written an ebuild, so I'm no help there.

I saw some chatter some time ago about kde-sunset and trinity being combined, but i don't know where that went. I saw some posts along the lines of "it would be a good idea" and there's been nothing since.

Has anybody heard anything?

jon
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5894
Location: Pomona, California.

PostPosted: Sun Dec 19, 2010 8:51 pm    Post subject: Reply with quote

Soldiering on? hehehe.

I have KDE-3 on two machines, and I swear by it. I finally bit the bullet and went for KDE-4.5 on another machine. All I can say is the updated apps work better with Xfce4 as the actual Manager. Plasma makes me gag. No Desktop, indeed!

The only truly good thing I've seen out of the KDE-4 update was that they finally got konqueror to update dynamically, like Thunar. Other than that, in the words of Miwwicent, the Swobovian Wabbit, "Feh!"

Cheers,
Pappy
_________________
SITE LIST:
Main: http://www.kernel-seeds.org
Mirror: http://kernel-seeds.grytpype-thynne.org/
Mirror 2: http://kernel-seeds.gentoostudio.org/
Mirror 3: http://www.elilabs.com/~pappy/
Mirror 4: http://62.3.120.142/~seeds/
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5894
Location: Pomona, California.

PostPosted: Sun Dec 19, 2010 8:55 pm    Post subject: Reply with quote

And apparently, Trinity is still in development. Here is their web page for more details.

Cheers,
Pappy
_________________
SITE LIST:
Main: http://www.kernel-seeds.org
Mirror: http://kernel-seeds.grytpype-thynne.org/
Mirror 2: http://kernel-seeds.gentoostudio.org/
Mirror 3: http://www.elilabs.com/~pappy/
Mirror 4: http://62.3.120.142/~seeds/
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5894
Location: Pomona, California.

PostPosted: Sun Dec 19, 2010 9:01 pm    Post subject: Reply with quote

Xaero wrote:
I switched to 4.4 myself.


I finally bit the bullet and went up to 4.4.4-r2. I'm actually still in process on this machine, my file server, and the web server. Core-too is done. Apparently, this is a good thing as the kernel initialization time for this machine is back down in the three second range. That makes me happy

Cheers,
Pappy
_________________
SITE LIST:
Main: http://www.kernel-seeds.org
Mirror: http://kernel-seeds.grytpype-thynne.org/
Mirror 2: http://kernel-seeds.gentoostudio.org/
Mirror 3: http://www.elilabs.com/~pappy/
Mirror 4: http://62.3.120.142/~seeds/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum