Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Errore grub
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
devi
n00b
n00b


Joined: 05 Feb 2010
Posts: 57

PostPosted: Fri Feb 05, 2010 3:29 pm    Post subject: [RISOLTO] Errore grub Reply with quote

Allora seguendo la guida di gentoo per gli amd64 sono riuscito ad installare gentoo solo che mi sono piantato su grub dato che quando riavvio mi esce l'errore
Code:
Error 15: file not found...
.
Ho organizzato gentoo in questo modo:
Code:
swap /dev/sda6
boot /dev/sda7
root /dev/sda8
ed ho installato grub con i comandi
Code:
find /boot/grub/stage1
root (hd0,6)
setup (hd0)
quit
Il mio grub.conf è questo:
Code:
# This is a sample grub.conf for use with Genkernel, per the Gentoo handbook
# http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap2
# If you are not using Genkernel and you need help creating this file, you
# should consult the handbook. Alternatively, consult the grub.conf.sample that
# is included with the Grub documentation.

default 0
timeout 30
#splashimage=(hd0,0)/boot/grub/splash.xpm.gz

#title Gentoo Linux 2.6.24-r5
#root (hd0,0)
#kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 real_root=/dev/sda3
#initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5

# vim:ft=conf:
default 0
timeout 30
splashimage=(hd0,6)/boot/grub/splash.xpm.gz

title Gentoo Linux 2.6.31-r6
root (hd0,6)
kernel (hd0,6)/boot/kernel-genkernel-amd64-2.6.31-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda8
initrd (hd0,6)/boot/initramfs-genkernel-amd64-2.6.31-gentoo-r6
boot

title Sabayon Linux (kernel-genkernel-x86_64-2.6.31-sabayon)
root (hd0,5)
kernel (hd0,5)/boot/kernel-genkernel-x86_64-2.6.31-sabayon root=/dev/ram0 ramdisk=8192 real_root=/dev/sda6 dolvm init=/linuxrc splash=silent,theme:sabayon vga=791 console=tty1 quiet resume=swap:/dev/sda7 real_resume=/dev/sda7
initrd (hd0,5)/boot/initramfs-genkernel-x86_64-2.6.31-sabayon
boot

# Solo nel caso si desideri il dual-boot
title Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1

Per risolvere il problema ho seguito questa guida http://www.gentoo.org/doc/it/grub-error-guide.xml ma non riesco a venirne a capo...
Mi potreste dare qualche consiglio utile perchè sono entrato nel pallone?[/u]


Last edited by devi on Thu Feb 11, 2010 12:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Fri Feb 05, 2010 6:53 pm    Post subject: Reply with quote

innanzitutto noto che sei nuovo quindi benvenuto :wink:

Per quanto riguarda quell'errore di grub, come puoi ben vedere qui può dipendere dalla mancata presenza del file che hai specificato;
quindi o non trova il kernel che hai compilato (perchè manca nel percorso che hai indicato) oppure se hai sbagliato a scrivere in menu.lst di conseguenza non trova il kernel perchè non esiste

Soluzione: verificare che in /boot ci sia immagine e initrd e/o cercare di non sbagliare a scrivere in menu.lst.
A tal proposito ti consiglio di dare nomi brevi ai kernel che hai creato
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
devi
n00b
n00b


Joined: 05 Feb 2010
Posts: 57

PostPosted: Sat Feb 06, 2010 9:50 am    Post subject: Reply with quote

Ti ringrazio per il benvenuto. Avevi ragione su grub: ho risolto perchè non mi ero accorto che i link erano sbagliati comunaque ce l'ho fatta! Ho installato gentoo amd64. Solo che la distro è... a riga di comando! Manca l'ambiente grafico: X, gnome, gdm.. E mò che faccio?
Come devo installarli? Lo so che lo devo fare tramite emerge ma mi potete dare una dritta sui flag di USE perchè mi sono un po' incartato per favore?
La documentazione di gentoo consiglia di usare USE="X gdm gnome hal" solo che mi dà delle dipendenze non soddisfatte. Come devo fare? Siccome scrivo da win appena posso cerco di postare i messaggi che mi escono
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sat Feb 06, 2010 6:21 pm    Post subject: Reply with quote

mi sa tanto che ti sei impastato sul gravoso problema: tra cups e gtk chi installo prima che vogliono installarsi a vicenda? il problema deriva dal fatto che alcuni programmi hanno delle dipendenze incrociate, se installi gnome di solito devi smazzartene un paio.
Io ti consiglierei: come prima cosa leggi bene quello che ti sputa emerge:
nel caso ipotetico che ti dica che che le "dipendenze sono insoddisfatte", preferirei dire hai delle dipendenze circolari, di solito la soluzione arriva dal disabilitare alcune USE FLAG (o tutte) e poi dare una seconda passata. quindi nell'ipotetico esempio di prima:
Code:
USE="-*" emerge cups
emerge gnome
emerge -uDN world

potrebbe risolvere il problema.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Feb 06, 2010 8:12 pm    Post subject: Reply with quote

pardon ma prima devi seguire la guida per installare Xorg (e non dovresti incontrare nessun tipo di problema) dopodicchè pensi al DE/WM
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
devi
n00b
n00b


Joined: 05 Feb 2010
Posts: 57

PostPosted: Wed Feb 10, 2010 4:33 pm    Post subject: Reply with quote

ago88 wrote:
pardon ma prima devi seguire la guida per installare Xorg (e non dovresti incontrare nessun tipo di problema) dopodicchè pensi al DE/WM

Mi sa proprio che farò così! ;)
Grazie per i consigli, rimanete sintonizzati perchè vi farò sapere. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum