Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev and baselayout conflict..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
dirtbag
Guru
Guru


Joined: 18 Feb 2003
Posts: 508
Location: NC

PostPosted: Thu Feb 04, 2010 3:45 am    Post subject: udev and baselayout conflict.. Reply with quote

Im seeing this on 2 of my gentoo boxen..

badman jason # /etc/init.d/udev restart
* Service udev starting
The udev init-script is written for baselayout-2!
Please do not use it with baselayout-1!.
* ERROR: udev failed to start
badman jason #
Code:

emerge -s udev baselayout sez

*  sys-fs/udev
      Latest version available: 146-r1
      Latest version installed: 146-r1

*  sys-apps/baselayout
      Latest version available: 1.12.13
      Latest version installed: 1.12.13
      Size of files: 263 kB


not sure how this got screwed up.

-db
Back to top
View user's profile Send private message
MotivatedTea
Apprentice
Apprentice


Joined: 06 Nov 2006
Posts: 269
Location: Toronto, Canada

PostPosted: Thu Feb 04, 2010 4:46 am    Post subject: Reply with quote

I think you don't need to run "/etc/init.d/udev" unless you're using baselayout-2, which you're not. So, use rc-update to remove udev from the scripts that are auto-started. (I've got a baselayout-1 system that does not have udev in the rc-started scripts, and it works fine. I've also got a baselayout-2 system on which udev is definitely required.)
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Thu Feb 04, 2010 5:08 am    Post subject: Reply with quote

Me too:
    on baselayout-1 box
    Code:
    # rc-update show | grep udev
    #
    Code:
    # qlist -Iv udev baselayout
    sys-apps/baselayout-1.12.13
    sys-fs/udev-146-r1


    on baselayout-2 box
    Code:
    # rc-update show | grep udev
               udev-mount |                           sysinit
           udev-postmount | boot
                udev-save |                  shutdown
                    udevd |                           sysinit
    Code:
    # qlist -Iv udev baselayout
    sys-apps/baselayout-2.1.6
    sys-fs/udev-146-r2


:?: Why do you want to restart udev?
Back to top
View user's profile Send private message
dirtbag
Guru
Guru


Joined: 18 Feb 2003
Posts: 508
Location: NC

PostPosted: Thu Feb 04, 2010 3:12 pm    Post subject: Reply with quote

well ill be damned.. heh udev is NOT set to be started in my init scripts.. ok so nevermind .. :oops:
I was trying to restart udev thinking that it would solve my problems with my usb scanner being seen on the wrong usb bus..


https://forums.gentoo.org/viewtopic-t-813965-highlight-.html

-db
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum